Você está na página 1de 69

UNIVERSIDADE TECNOLGICA FEDERAL DO PARAN

DEPARTAMENTO ACADMICO DE ELETRNICA


CURSO SUPERIOR DE TECNOLOGIA EM SISTEMAS DE TELECOMUNICAES









LEANDRO HAMANN JUNIOR








ESTUDO E SIMULAO DE REDE MPLS








TRABALHO DE CONCLUSO DE CURSO









CURITIBA
2011
2
LEANDRO HAMANN JUNIOR



















ESTUDO E SIMULAO DE REDE MPLS



















Trabalho apresentado disciplina de
Trabalho de Diplomao como
requisito parcial obteno do ttulo de
Tecnlogo, do Curso Superior de
Tecnologia em Sistemas de
Telecomunicaes do Departamento
Acadmico de Eletrnica DAELN - da
Universidade Tecnolgica Federal do
Paran - UTFPR.

Orientador: Prof. Dr. Augusto Foronda









CURITIBA
2011
3
LEANDRO HAMANN JUNIOR


ESTUDO E SIMULAO DE REDE MPLS



Este trabalho de concluso de curso foi apresentado no dia 29 de novembro de 2011, como
requisito parcial para obteno do ttulo de Tecnlogo em Sistemas de Telecomunicaes,
outorgado pela Universidade Tecnolgica Federal do Paran. O aluno foi argudo pela Banca
Examinadora composta pelos professores abaixo assinados. Aps deliberao, a Banca
Examinadora considerou o trabalho aprovado.



______________________________
Prof. M. Sc. Csar Janeczko
Coordenador de Curso
Departamento Acadmico de Eletrnica



______________________________
Prof. Dr. Dcio Estevo do Nascimento
Responsvel pela Atividade de Trabalho de Concluso de Curso
Departamento Acadmico de Eletrnica


BANCA EXAMINADORA







______________________________
Prof. Dr. Augusto Foronda
Orientador





__________________________________
Prof. Dr. Kleber Kendy Hirokawa Nabas





______________________________
Prof. Me. Alexandre Jorge Miziara



A folha de Aprovao assinada encontra-se na Coordenao do Curso

4

















































s pessoas que sempre me apoiaram para chegar at este momento.
5
AGRADECIMENTOS

A Deus, primeiramente.
Gostaria de agradecer a toda minha famlia, principalmente aos meus pais
Leandro Hamann e Marlene Cordeiro Hamann, e minhas irms Helosa Hamann e
Dbora Beatriz Hamann. As primeiras pessoas com que comecei a aprender os mais
variados assuntos no comeo da vida.
Agradeo a oportunidade de ter conseguido estudar na Universidade
Tecnolgica Federal do Paran, e a todos os colaborados que fazem parte desta
instituio.
Agradeo o convvio social com os colegas e amigos dentro da universidade,
no s os da turma, mas aos de outros cursos tambm. Fonte de ensinamentos
imensurveis.
Agradeo a todos os professores do departamento de eletrnica que
apoiaram o meu crescimento social e intelectual, nas reas mais diversas, no s
em tecnologia.
Agradeo especialmente dedicao do professor orientador Augusto
Foronda, pela pacincia e incentivo na orientao deste projeto. Agradeo tambm a
toda a banca avaliadora que fez com que meu conhecimento fosse amadurecido.
6































possvel reconhecer a utilidade de uma ideia sem, contudo,
compreender como us-la adequadamente (GOETHE apud FILHO;
SILVA, 2000).
7
RESUMO

JUNIOR, Leandro Hamann. Estudo e simulao de rede MPLS. 2011. 69 f.
Trabalho de Concluso de Curso (Curso Superior em Tecnologia em Sistemas de
Telecomunicaes), Departamento Acadmico de Eletrnica, Universidade
Tecnolgica Federal do Paran. Curitiba, 2011.


Esta pesquisa apresenta a simulao de uma rede MPLS. importante ressaltar
que qualquer rede ou sistema pode ser simulado antes de se efetivar a implantao
dos sistemas ou dispositivos. O foco deste trabalho est no estudo dos principais
conceitos da tecnologia MPLS e a simulao de implantao em dispositivos reais,
validando as informaes atravs de simulador. A simulao utilizada faz referncia
ao estudo realizado, demonstrando as caractersticas e recursos disponveis em
software de simulao baseado em dispositivos que realmente so utilizados em
redes de longa distncia. Aqui ser demonstrada a simulao do comportamento do
MPLS. A concentrao do projeto esta relacionado com o modelo conceitual, com a
arquitetura do MPLS. Alm de servios como a VPN, engenharia de trfego e
qualidade de servio. A metodologia composta por levantamento bibliogrfico e
sntese de informaes. A rede simulada teve o resultado esperado, funcionou
conforme caractersticas do levantamento bibliogrfico.


Palavras-chave: MPLS. Simulao. Comutao de rtulos.

8
ABSTRACT

JUNIOR, Leandro Hamann. Study and simulation of MPLS. 2011. 69 f.
Trabalho de Concluso de Curso (Curso Superior em Tecnologia em Sistemas de
Telecomunicaes), Departamento Acadmico de Eletrnica, Universidade
Tecnolgica Federal do Paran. Curitiba, 2011.


This research presents the simulation of an MPLS network. Note that any network or
system can be simulated prior to the effective implementation of systems or devices.
The focus of this work is the study of the major concepts of MPLS technology and
simulation deployment to real devices, validating the information through the
simulator. The simulation used refers to the study, demonstrating the features and
resources available in simulation software-based devices that actually are used in
wide area networks. Here is shown the simulation of MPLS. The concentration of the
project is related to the conceptual model, the architecture of MPLS. In addition to
services such as VPN, traffic engineering and quality-of-service. The methodology
consists of literature review and synthesis of information. The simulated network had
the expected result, characteristics of the work as literature.


Key-words: MPLS. Simulation. Label switch.
9
LISTA DE FIGURAS

Figura 1 - Tipos populares de conexo Wan .............................................................20
Figura 2 - Rede Frame Relay ............................................................................................20
Figura 3 - Rede ATM do ncleo de um Backbone de Internet .........................................21
Figura 4 - Utilizao dos dispositivos CSU/DSU .......................................................25
Figura 5 - Rede de Longa Distancia e Roteadores ......................................................26
Figura 6 - Cisco 7200 Series ...........................................................................................27
Figura 7 - HP A-Msr50 Series .....................................................................................27
Figura 8 - Hub and Spoke ........................................................................................................29
Figura 9 - Malha parcial .............................................................................................................29
Figura 10 - Malha completa ................................................................................................29
Figura 11 - Redundante Hub and Spoke ...............................................................................30
Figura 12 - Rede MPLS .....................32
Figura 13 - Comutao de Rtulos ............................32
Figura 14 - Arquitetura do LSR ..................................................................................................35
Figura 15 - Roteadores MPLS ...................................................................................................36
Figura 16 - Cabealho MPLS .....................................................................................................37
Figura 17 - Pilha MPLS ................................................................................................................38
Figura 18 - Exemplo de LFIB ......................................................................................................40
Figura 19 - Distribuio de Rtulos ...........................................................................................40
Figura 20 - Sada do comando show IP cef detail ................................................................43
Figura 21 - Verificao da configurao do MPLS .....................................................................44
Figura 22 - Configurao da MTU na interface Gigabit ......................................................45
Figura 23 - Verificao de vizinhana ..................................................................................45
Figura 24 - Servios MPLS .........................................................................................................46
Figura 25 - Janela do Simulador com Rede Simples ..........................................................49
Figura 26 - Topologia proposta para estudo ...........................................................................50
Figura 27 - Tabela de roteamento PE1 ...................................................................................52
Figura 28 - Status das interfaces utilizadas ..........................................................................52
Figura 29 - Teste de ping nas interfaces de PE1 Redundncia .....................................53
Figura 30 - LFIB Reflexo da tabela de roteamento ...........................................................55
Figura 31 - LIB (Base de Informao de Rtulo) ..................................................................55
Figura 32 - FIB (Base de Informao de Encaminhamento) ..............................................56
Figura 33 - Vizinhos que participam do MPLS .......................................................................56
Figura 34 - Rtulo esttico ..........................................................................................................57
Figura 35 - Outros comandos do MPLS .................................................................................58
Figura 36 - Analise atravs do Wireshark ...............................................................................59
10
LISTA DE SIGLAS

ATM - Asynchronous Transfer Mode
BGP Border Gateway Protocol
CE Customer Equipment
CEF Cisco Express Forwarding
CPE Customer Premises Equipment
CPU Central Processing United
CSU/DSU Channel Service Unit / Data Service Unit
DCE Data Communications Equipment
DTE Data Terminal Equipment
EGP - Exterior Gateway Protocol
EIGRP Enhanced Interior Gateway Routing Protocol
FEC Forwarding Equivalence Class
FIB Forwarding Base Information
GNS3 - Graphical Network Simulator 3
IETF - Internet Engineering Task Force
IGP - Internet Gateway Protocol
IOS - Internet Operational System
IP - Internet Protocol
IPSEC - Internet Protocol Security
IS-IS - Intermediate System to Intermediate System
ISDN - Integrated Services Digital Network
ITU - International Telecommunication Union
Kbps - Kilobit per Second
LDP - Label Distribution Label
LIB - Label Information Base
LFIB Label Forwarding Information Base
LSH - Label Switch Hop
LSP - Label Switch Path
LSR - Label Switch Router
Mbps - Megabit per Second
MPLS - Multiprotocol Label Switch
MTU Maximum Transmission Unit
OSI - Open System Interconnect
OSPF - Open Shortest Path First
PE Provider Edge
QOS - Quality of Service
RFC - Request for Comments
RSVP Resource Reservation Protocol
SLA Services Level Agreement
SLR - Switch Label Router
TCP Transmission Control Protocol
TDP - Tag Distribution Protocol
TE - Traffic Engineer
TTL - Time to Live
UDP User Datagram Protocol
VOIP - Voice over Internet Protocol
VPN - Virtual Private Network
WAN - Wide Area Network
11
SUMRIO

CAPTULO 1 ........................................................................................................................... 13
INTRODUO........................................................................................................................ 13
1.1 PROBLEMA ...................................................................................................................... 14
1.2 JUSTIFICATIVA............................................................................................................... 15
1.3 OBJETIVOS....................................................................................................................... 15
1.3.1 Objetivo Geral ................................................................................................................. 15
1.3.2 Objetivos Especficos ...................................................................................................... 16
1.4 MTODOS DE PESQUISA .............................................................................................. 16
CAPTULO 2 ........................................................................................................................... 17
2.1 TIPOS DE CONEXES WAN.......................................................................................... 17
2.2 TECNOLOGIAS DE COMUTAO POR PACOTE...................................................... 18
2.2.1 Frame Relay..................................................................................................................... 18
2.2.2 ATM................................................................................................................................ 19
2.2.3 A Tecnologia MPLS........................................................................................................ 20
2.2.3.1 Redes Convergentes ..................................................................................................... 20
2.2.3.2 Segurana em MPLS.................................................................................................... 21
2.2.3.3 Benefcios do MPLS..................................................................................................... 21
2.2.3.4 Simulador ..................................................................................................................... 22
2.3 EQUIPAMENTOS DE REDES DE LONGA DISTNCIA............................................. 22
2.3.1 CSU/DSU modem........................................................................................................... 23
2.3.2 Roteador .......................................................................................................................... 23
2.4 MODELOS DE ROTEADORES....................................................................................... 24
2.4.1 Equipamentos Cisco ........................................................................................................ 24
2.4.2 Equipamentos 3COM...................................................................................................... 25
CAPTULO 3 ........................................................................................................................... 26
3 MPLS (MULTIPROTOCOL LABEL SWITCH) .............................................................. 26
3.1 MODELO CONCEITUAL DO MPLS ........................................................................... 26
3.1.1 Conexes tradicionais de redes de longa distncia....................................................... 26
3.1.2 Terminologia MPLS..................................................................................................... 28
3.1.3 Caractersticas do MPLS.............................................................................................. 29
3.1.4 - Conceitos MPLS ........................................................................................................... 30
3.1.5 Mecanismos de comutao do roteador........................................................................ 31
3.1.6 - Comutao padro do protocolo de Internet ................................................................. 31
12
3.1.7 Comutao do CEF (Encaminhamento Rpido da Cisco)............................................ 32
3.2 ARQUITETURA DO MPLS .......................................................................................... 32
3.2.1 Componentes MPLS..................................................................................................... 32
3.2.2 Rtulo MPLS................................................................................................................ 34
3.2.2.1 Estrutura do rtulo MPLS ......................................................................................... 35
3.2.3 Pilhas de rtulos ........................................................................................................... 35
3.2.3 Quadro MPLS............................................................................................................... 36
3.2.4 Roteador de comutao de rtulos................................................................................ 36
3.2.5 LIB, LFIB e FIB........................................................................................................... 37
3.2.6 Distribuio de rtulos.................................................................................................. 38
3.3 CONFIGURAO DO MEIO MPLS............................................................................ 39
3.3.1 Configurao do CEF................................................................................................... 39
3.3.2 Configurao dos quadros MPLS nas interfaces.......................................................... 41
3.3.3 Configurao do tamanho MTU................................................................................... 42
3.4 SERVIOS MPLS .......................................................................................................... 44
3.4.1 Engenharia de Trfego.................................................................................................. 44
3.4.2 Segurana ..................................................................................................................... 45
3.4.3 Qualidade de Servio.................................................................................................... 45
3.4.4 Futuro do MPLS........................................................................................................... 45
4 SIMULAO DA REDE MPLS (MULTIPROTOCOL LABEL SWITCH) ................... 46
4.1 SIMULADOR DE REDES GNS3 (SIMULADOR GRFICO DE REDE)................... 46
4.2 TOPOLOGIA E IMPLEMENTAO........................................................................... 48
4.2.1 - Configuraes bsicas................................................................................................... 49
4.2.2 - Configuraes MPLS.................................................................................................... 51
4.3 RESULTADOS ............................................................................................................... 56
5 - CONCLUSO .................................................................................................................... 58
REFERNCIAS ....................................................................................................................... 60
APENDICE A Configurao dos roteadores ........................................................................ 63
13

CAPTULO 1

INTRODUO


A Internet surgiu em 1969, nos Estados Unidos. O objetivo principal dos
militares era construir uma rede descentralizada e que possibilitasse a troca de
informao entre os rgos do governo americano (SEI, 1997). Entretanto, nos anos
90, a Internet no ficou restrita s aos interesses educacionais e cientficos. Logo
comeou a ser observada a potencialidade econmica que a Internet poderia tornar-
se.
Com a liberao da Internet para uso comercial, o trfego aumentou
rapidamente e manter o Quality of Service (QoS) era muito difcil. Com isso, novas
tecnologias utilizadas na Internet foram sendo implementadas e passando por
mudanas aos longos dos anos, de modo a atender cada vez melhor as
expectativas de seus usurios.
As tecnologias de telecomunicaes esto em constante evoluo e cada vez
mais se necessita de servios mais rpidos. O Multiprotocol Label Switching (MPLS)
uma tecnologia que utiliza rtulos para o roteamento e no a verificao de
cabealhos Internet Protocol (IP) como acontece com alguns protocolos. Existem
outras tecnologias como o Asynchronous Transfer Mode (ATM) que tambm oferece
uma melhora considervel em redes de comutao de pacotes. Entretanto, o mais
interessante sobre o MPLS que ele aplicado sobre o IP (INCIO, 2002).
O MPLS foi desenvolvido para resolver o problema de altos fluxos de redes
ATM sobre IP. Hoje esta tecnologia utilizada em muitas operadoras para promover
uma melhor prestao de servios. Estes servios podem ser utilizados em
conexes nacionais e internacionais (PRETO, 2008).
O MPLS o resultado de inmeros esforos, que a indstria realizou no fim
da dcada de 90, para melhorar a velocidade entre roteadores IP, adotando o
conceito de rtulo de tamanho fixo (KUROSE; ROSS, 2006). Para os autores, o
objetivo da tecnologia aumentar a infraestrutura de repasse de datagramas IP com
14
base em rtulos de tamanhos fixos, em vez de endereos de destino IP. A
caracterstica marcante desta tcnica o uso de endereamento e roteamento IP.
Muitos equipamentos existentes no mercado possuem suporte para este tipo
de aplicao. As primeiras empresas que comearam a desenvolver este tipo de
tecnologia para atender a demanda do mercado antes da tecnologia ser padronizada
pela Internet Engineering Task Force (IETF) foram o IP Switching da Ipslon e o Tag
Swithing da Cisco (STALLING, 2001).
O objetivo deste trabalho fazer um estudo sobre a tecnologia nos servios
de rede e apresentar uma simulao de uma rede MPLS mostrando como os
recursos desta tecnologia podem ser usados.
Este projeto ser desenvolvido em sua maior parte atravs de levantamento
bibliogrfico presente nos veculos de comunicao como livros, Internet e atravs
do simulador GNS3. Isso necessrio, pois existem vrios textos que exemplificam
a tecnologia, mostrando as suas aplicaes, tendncias, servios e seu futuro com
relao s tecnologias como a Internet, Voice over IP (VoIP), Vdeo Conferncia,
entre outros recursos.


1.1 PROBLEMA


O MPLS uma tecnologia que esta sendo muito utilizada em vrias empresas
de diversos segmentos. Antes de sua implantao prtica dentro de uma
organizao, necessrio testar a soluo, atravs de um cenrio prximo ao da
empresa, em laboratrio. Este artifcio de testar uma tecnologia, antes de implantar
em uma organizao pode mostrar os problemas que poderiam vir a acontecer,
visando a no prejudicar a linha produo de uma empresa.
Por isso, este trabalho apresentar uma anlise do MPLS atravs de
simulao, com o intuito de verificar problemas que podem vir a desencadear na sua
implantao. A simulao importante porque visa a reduo de problemas, antes
da soluo ser implantada dentro de uma organizao.
O que se pretende fazer neste projeto uma analise da teoria sobre o MPLS
e verificar sua funcionalidade atravs de simulao no GNS3. Tambm sero
verificados prs e contra da tecnologia na simulao que ser aplicada. Este tipo de
15
estudo se faz necessrio, pois a tecnologia MPLS uma tendncia que est
ocorrendo em grande escala e que poder contribuir na utilizao de muitos outros
servios que esto ligados ao protocolo IP, melhorando o desempenho da rede.


1.2 JUSTIFICATIVA


O MPLS uma tecnologia muito utilizada em sistemas de telecomunicaes,
visando atender de maneira eficaz os servios prestados por operadoras que
disponibilizam este tipo de servios sobre o protocolo IP.
O estudo do MPLS est ligado diretamente com o curso de Tecnologia em
Sistemas de Telecomunicaes, pois uma das caractersticas do MPLS a
utilizao de grandes redes e de uma certeza de disponibilidade de seus servios.
Um dos fatores de motivao para a execuo deste projeto poder simular o
funcionamento da tecnologia em uma rede, prximo ao cenrio da empresa, antes
de sua implantao, prevendo desta maneira qualquer imprevisto que possa vir a
acontecer no momento em que a tecnologia entrar em funcionamento.
Uma caracterstica muito interessante sobre o MPLS que ele est
substituindo tecnologias como o Frame Relay e o ATM. Estas j conectaram
empresas atravs de servios das operadoras, mas esto perdendo o lugar para a
utilizao do MPLS. Isto se deve aos grandes esforos que a tecnologia sofreu nos
ltimos anos, no intuito de garantir qualidade no trfego de comutao de pacotes.


1.3 OBJETIVOS


1.3.1 Objetivo Geral


Descrever e simular o funcionamento de uma rede com a utilizao da
tecnologia MPLS em dispositivos Cisco.

16

1.3.2 Objetivos Especficos


- Caracterizar a tecnologia MPLS;
- Classificar quais as vantagens e desvantagens da tecnologia MPLS;
- Aplicar os conhecimentos tericos na simulao da rede MPLS;
- Descrever os resultados que aparecero na simulao da rede MPLS.


1.4 MTODOS DE PESQUISA


O projeto proposto ser realizado atravs de levantamento bibliogrfico, com
auxlio da Internet e de livros. Poder ser usado tambm o auxlio de fruns de
discusso sobre o tema.
O projeto seguir as seguintes etapas para sua realizao -
- Levantamento bibliogrfico;
- Descrio sucinta de tecnologias anteriores ao MPLS;
- Descrio das caractersticas do MPLS;
- Simulao de uma rede utilizando o MPLS;
- Apresentao dos resultados.







17
CAPTULO 2


A tecnologia proposta para ser estudada uma das mais novas em redes
WAN. Entretanto, antes de estud-la faz-se necessrio entender as tecnologias que
surgiram antes do MPLS e depois entender porque esta tecnologia foi desenvolvida
e aceita em redes de longas distncias.


2.1 TIPOS DE CONEXES WAN


Existem trs tipos de conexes de redes WAN de acordo com (FELIPPETTI,
2008):
- Linhas alugadas ou privadas: este tipo de conexo chamado de conexo
dedicada ou ponto a ponto. So usadas linhas seriais sncronas. Permite a
comunicao sem interrupo entre redes que precisam receber o sinal de
sincronismo, sem precisar ativar ou autenticar antes da transmisso de dados.
- Comutao de circuito: pode-se comparar este tipo de conexo como uma
chamada telefnica, pois nenhuma informao, antes de ser estabelecida uma
conexo, pode ser transmitida. Requer baixa largura de banda, utilizando modems
comuns e Integrated Services Digital Network (ISDN).
- Comutao de pacotes: este tipo de conexo permite compartilhar a largura
de banda com outros usurios. Compara-se a uma linha telefnica comunitria.
Entretanto, se a utilizao da rede for constante, convm o aluguel de uma linha
privada. Algum exemplos deste tipo de tecnologias so: Frame-Relay, X25, ATM e
MPLS. Nestas redes as velocidades podem variar entre 56 Kbps a 2Mbps. Na figura
1 so mostradas alguns tipo de conexes mais comuns.



18

Figura 1 - Tipos Populares de Conexo WAN
Fonte: Adaptado de Felippetti (2008)


2.2 TECNOLOGIAS DE COMUTAO POR PACOTE

2.2.1 Frame Relay


O Frame Relay uma tecnologia de comutao de pacotes que surgiu nos
anos 90. um protocolo de alto desempenho. Ele foi criado com algumas
referncias da tecnologia X.25. O overhead reduzido. As velocidades podem variar
entre 64 Kbps a 2048 Kbps. Este protocolo possui alocao dinmica de banda e
controle de congestionamento de dados (FELIPPETTI, 2008).
O Frame Relay se tornou uma tecnologia mais atraente, do que as antigas
linhas alugadas. Em vez de pagar para todos os circuitos alugados. Este tipo de
rede permite criar circuitos virtuais dentro da rede de um provedor de Frame Relay
(BONEY, 2005). uma tecnologia que permite a configurao de largura de banda
para cada interligao. A linha alugada conecta o dispositivo do usurio final com o
provedor desta tecnologia. A figura 2 mostra uma rede Frame Relay.


Figura 2 Rede Frame Relay
Fonte: Odom 2 (2006).
19

2.2.2 ATM


O Modo de Transferncia Assncrona (ATM) foi criado para o trfego sensvel
ao tempo, disponibilizando ao mesmo tempo transmisso de voz, vdeo e dados. O
ATM utiliza clulas que so fixadas em 53 bytes ao invs de pacotes. Hoje ainda se
executa Frame Relay sobre ATM (LAMMLE, 2008).
Conforme descrio de Kurose e Ross (2006), os padres ATM comearam a
ser desenvolvidos na dcada de 80, cujos objetivos era a transmisso de dados em
tempo real. Desenvolvida pela Unio Internacional de Telecomunicaes (ITU) em
2004. A rede ATM utilizada em redes de telefonia e redes Protocolo de Internet
(IP), a tecnologia utilizada para conectar roteadores.
Entre as principais caractersticas do ATM incluem o servio de taxa
constante, varivel, disponvel e no especificada de bits. Funciona atravs de
comutao de pacotes (KUROSE e ROSS, 2006).
A tecnologia ATM tambm pode prover conectividade entre dispositivos IP,
conforme a figura 3.


Figura 3 - Rede ATM no Ncleo de um Backbone de Internet
Fonte: Kurose; Ross (2006)





20

2.2.3 A Tecnologia MPLS


O MPLS uma tecnologia de comutao. Assim como existe a comutao
ATM (Modo de Transferncia Assncrona) e a comutao IP. O MPLS, que tambm
chamado de comutao por rtulos, esta outra forma de comutar pacotes
(PRETO, 2008).
De acordo com Cisco 1 (2008), o MPLS uma tecnologia de
encaminhamento de pacotes que utiliza rtulos para decidir como os dados sero
encaminhados. Com o MPLS, a anlise no cabealho da camada de rede feito
apenas uma vez, quando o pacote entra no domnio MPLS.
A tecnologia MPLS pode ser aplicada em qualquer protocolo da camada 3
(camada de rede do modelo OSI), e apresenta benefcios para os seguintes
servios: Rede Virtual Privada, Engenharia de Trfego e Qualidade de Servio.
O IETF desenvolveu uma arquitetura designada MPLS e se encontra descrita
em vrios documentos (RUELA, 2005).
Antes da tecnologia ter sido padronizada pela IETF, tanto o IP Switching da
Ipslon como o Tag Switching da Cisco, iniciaram esforos independentes pela
padronizao de suas arquiteturas (VILARINHO, 2010). Segundo ele foi criado um
grupo de trabalho para lidar com todas as tecnologias sendo desenvolvidas para se
garantir a interoperabilidade. Deste grupo de trabalho nasceu o MPLS.


2.2.3.1 Redes Convergentes


O MPLS uma tecnologia que tende a ser cada vez mais utilizada em redes
de grande desempenho, devida a sua alta velocidade. Hoje o que observamos
uma grande variedade de servios que esto disponveis sobre o protocolo IP com
larguras de banda flexveis.
De acordo com a revista Teletime (2010), a soluo permite desempenhos
elevados das redes ao lidarem com trfegos de dados em situaes crticas, como
21
falhas e gargalos, e assegura transmisses com menores nveis de perdas e
atrasos.
Alm de uma demanda cada vez maior de velocidade da Internet para a
utilizao para pesquisa e uso de interatividade na rede, ser necessria uma
tecnologia que torne a TV por IP um sistema mais atraente e que no aconteam
falhas neste tipo de servio. Este apenas um dos servios que precisa de um bom
desempenho de rede.


2.2.3.2 Segurana em MPLS


A tecnologia MPLS no utiliza qualquer tipo de criptografia para os dados que
circulam via Internet, se a empresa que contratou o servio quiser distribuir
informaes que exijam confidencialidade, o MPLS no a opo mais indicada
(BARA, 2008). Nesse caso pode se utilizar uma VPN, que um recurso de
segurana sobre a tecnologia MPLS.
Tecnologias como a MPLS tambm so utilizadas para a integrao de
informaes em uma empresa que possui vrias filiais em diferentes locais, dentro
de um mesmo pas, ou a mbito internacional. Por isso a segurana se faz
necessria, quando se utiliza este tipo de tecnologia.
Se utilizada corretamente, a tecnologia MPLS, em alguns casos at
combinada com outras tecnologias como o Segurana do Protocolo de Internet
(IPSec), pode atender perfeitamente todas as necessidades de comunicao da
empresa sem comprometer a confidencialidade e a integridade do dados que nela
trafegam (BARA, 2008).


2.2.3.3 Benefcios do MPLS


O MPLS uma tecnologia que tem muito a oferecer para o sucesso agregado
s funcionalidades de outras tecnologias. Tendo uma viso positiva da rede e da
tecnologia faz-se necessrio o comentrio dos seus benefcios.
22
Uma das principais vantagens do MPLS que ele a base do padro para a
tecnologia de comutao por rtulo, o que resulta em um ambiente aberto com
vrios fabricantes produzindo equipamentos interoperveis (INCIO, 2002). Com a
competio, os produtos so encontrados com preos mais baixos e so conduzidos
a uma maior inovao.
Segundo Incio (2002), algumas das vantagens de se utilizar a tecnologia
MPLS seria: roteamento explcito, redes privadas virtuais, suporte a mltiplos
protocolos e a mltiplos links, facilidade de evoluo, roteamento inter-domnio e
suporte a todos os tipos de trfegos.


2.2.3.4 Simulador


Para a execuo deste trabalho ser utilizado um software para a simulao
de uma pequena rede, para demonstrar o funcionamento da rede MPLS. O software
escolhido o GNS3 com o Sistema Operacional de Internet (IOS) da Cisco, do
roteador 7200.
O GNS3 um simulador grfico de rede que permite a emulao de redes
complexas. Este programa cria um ambiente virtual no computador, com a utilizao
do Cisco IOS, de maneira que a tecnologia MPLS possa ser testada em laboratrio
(FUSZNER, 2008).
Este tipo de software usado no s para simular o estudo de uma rede, mas
sim para projetar redes reais. So muito utilizados por profissionais da rea de
comunicaes para a aplicao de projetos.


2.3 EQUIPAMENTOS DE REDES DE LONGA DISTNCIA


Este estudo tambm necessrio para entender como a conexo entre os
dispositivos em uma rede de longa distncia. Muitas vezes, nos deparamos com
dispositivos finais, entretanto h muitos outros dispositivos que no so comentados.
Abaixo esto descritos dois dispositivos destas redes.
23

2.3.1 CSU/DSU modem


A Unidade de Servio de Canal / Unidade de Servio de Dados CSU/DSU
um dispositivo com interface digital, dividido entre dispositivos Equipamento de
Comunicao de Dados (DCE) e Equipamento de Terminao de Dados (DTE). Os
equipamentos DCE geram sincronismo para os equipamentos dos clientes, podem
ser equipamentos em laboratrios ou a prpria operadora de telefonia. Os
dispositivos DTE recebem o sincronismo para funcionar (PAQUET, 2003).
De acordo com descrio de Odom 1 (2003), algumas interfaces seriais dos
dispositivos mais novos j possuem uma CSU/DSU integrada, o que no possuem,
precisam de cabos especiais para interconectar os dispositivos. O autor ainda relata
que, ao se fazer um laboratrio de estudo no necessrio ter um equipamento
CSU/DSU, basta ter dois roteadores e os cabos especficos para criar este tipo de
cenrio. Um dos roteadores dever criar o sincronismo para os roteadores se
comunicarem. A figura 4 demonstra que a operadora faz o sincronismo.


Figura 4 - Utilizao dos Dispositivos CSU/DSU
Fonte: Certification Resources (2011).


2.3.2 Roteador


O roteador um dispositivo, que fornece portas de interface de acesso de
redes interconectadas e de longas distncias, podem ser utilizado na conexo com
redes de operadoras. Podem estar conectadas s interfaces serias ou outras, como
modems ou dispositivos CSU/DSU (CCNA EXPLORATION 4.0, 2007).
24
Tambm existem roteadores especficos que residem no interior de uma rede
de longa distncia, chamados de roteadores centrais. Suportam vrias interfaces de
telecomunicao de altas velocidades, encaminham pacotes IP em altas velocidades
e suportam diversos protocolos de roteamento (CCNA EXPLORATION 4.0, 2007). A
figura 5 mostra trs roteadores em uma topologia de rede.


Figura 5 Rede de Longa Distancia e Roteadores
Fonte: Autoria prpria


2.4 MODELOS DE ROTEADORES


Existem vrios modelos e marcas de equipamento que podem ser utilizados
em redes de longa distncia. Nesta etapa do projeto pretende-se mostrar alguns
destes equipamentos e quais podem ser utilizados em uma rede MPLS. Apesar do
baseamento deste projeto estar relacionado com equipamentos Cisco, ser
comentado sobre outros dispositivos que podem ser utilizados em redes reais.
Existem trs marcas de roteadores que se destacam no mercado, entre elas
podem ser citados Cisco, Nortel e 3com (HP).


2.4.1 Equipamentos Cisco


A Cisco System possui um enorme portflio para atender diversas demandas
e funcionalidades de aplicaes em diversos tipo de redes, alm de garantir
desempenho e proteo. A empresa divide os equipamentos em diversas categorias
para utilizaes adequadas. Entre elas so citadas: roteadores para filiais,
25
plataforma de interconexo da central de dados, roteadores moveis para a Internet,
roteadores de ncleo para provedores de servio, roteadores de borda para
provedores de servios, roteadores para pequenas empresas e roteadores de
agregao de redes de longa distncia e borda para Internet (CISCO 2, 2011).
Conforme descrito no site da Cisco 2 (2011), todos os dispositivos que
possuem o sistema operacional com a release 12.1 ou superior incluem a tecnologia
MPLS. Se os dispositivos estiverem com o sistema presente podero utilizar os
recursos da tecnologia como engenharia de trfego, garantir a largura de banda,
redimensionamento rpido, utilizao de VPN MPLS e classe de capacidade de
servio. Abaixo, figura 6, exposto um roteador da Cisco.


Figura 6 - Cisco 7200 Series
Fonte: Cisco 2 (2011).


2.4.2 Equipamentos 3COM


Seus equipamentos oferecem um robusto conjunto de opes de
conectividade em rede, recursos de fcil utilizao como VPN e segurana global
flexvel, modular para pequenas e mdias empresas (3COM, 2011).
Entre os modelos que podem ser usados para configurao em redes MPLS
so o HP A6600 Router Series, HP A8800 Router Series, HP A-MSR50 Series, A-
MSR20 Series, HP A-MSR20-1x Series, A-MSR30 Series e A-MSR900 Series. A
figura 7 mostra um exemplo.

Figura 7 - HP A-MSR50 Series
Fonte: 3com (2011).
26
CAPTULO 3


3 MPLS (MULTIPROTOCOL LABEL SWITCH)


Neste captulo ser demonstrado o estudo sobre o MPLS. Aqui sero
divididos em sub-captulos para a melhor explanao do estudo realizado.
O MPLS evoluiu de vrios esforos que foram realizados pela indstria, do
meio ao final dos anos 1990, visando aperfeioar a velocidade de distribuio dos
roteadores IP, adotando um novo conceito de redes, um rtulo de tamanho fixo
(KUROSE; ROSS, 2006).
Esta tcnica, no pretende eliminar a utilizao do IP, pois trabalha utilizando
o endereamento e o roteamento deste protocolo. Os Esforos realizados pela
Internet Engineering Task Force (IETF) para o desenvolvimento da tecnologia MPLS
tambm podem ser encontrados nos Request for Comments (RFCs) 3031 e 3032.


3.1 MODELO CONCEITUAL DO MPLS

3.1.1 Conexes tradicionais de redes de longa distncia


Redes de longas distncias tradicionais normalmente existem em arquiteturas
limitadas baseando no tamanho da empresa e no oramento de largura de banda
entre esses lugares (MORGAN; LOVERING, 2008). As arquiteturas mais comuns
so:
- Hub and Spoke: Este tipo de arquitetura a tradicional topologia em estrela
em redes locais, onde existe um concentrador, em que os outros passam
informaes atravs dele. A figura 8 mostra um exemplo de Hub and Spoke.
27

Figura 8 - Hub and Spoke
Fonte: Morgan; Lovering (2008).


- Malha Parcial: Este tipo de arquitetura apresenta algumas redundncias
para garantir o funcionamento da rede. A figura 9 mostra uma rede com malha
parcial.


Figura 9 - Malha Parcial
Fonte: Morgan; Lovering (2008).

- Malha Completa: Neste tipo de arquitetura cada equipamento est ligado
diretamente aos outros. Conforme mostrado na figura 10.


Figura 10 - Malha Completa
Fonte: Morgan; Lovering (2008).

- Redundante Hub and Spoke: Neste tipo de arquitetura tambm h uma
concentrador principal, entretanto, h mais ligaes para garantir que a rede
continue funcionando, quando houver algum problema na topologia de rede. A figura
11 mostra um exemplo deste tipo de rede.

28

Figura 11 - Redundante Hub and Spoke
Fonte: Morgan; Lovering (2008).

3.1.2 Terminologia MPLS


Para estudar a tecnologia MPLS necessrio conhecer alguns termos
definidos pela RFC 3031. Abaixo esto algumas terminologias (MORGAN;
LOVERING, 2008).
- Rtulo (Label): um identificador de comprimento fixo, usado para
identificao de redes, em um grupo compartilhado de destino comum.
- Pilha de Rtulo (Label Stack): um conjunto de rtulos que est presente no
cabealho do pacote, onde cada rtulo independente um do outro.
- Troca de Rtulos (Label Swap): a operao bsica de encaminhamento,
onde procurado um rtulo de entrada para determinar sua sada. Tambm
considerado importante o encapsulamento, porta, e outros dados para a troca de
informaes.
- Salto de Comutao do Rtulo (Label-Swiched Hop LSH): o salto entre
dois ns MPLS, onde o encaminhamento feito usando rtulos.
- Caminho de comutao do Rtulo (Label Switched Path LSP): o caminho
atravs de um ou mais dispositivos, em um nvel de hierarquia.
- Roteador de Comutao de Rtulos (Label Switching Router LSR): um
n MPLS que capaz de encaminhar pacotes rotulados.
- Domnio MPLS: um conjunto de equipamentos capaz de realizar
roteamento e encaminhamento MPLS. Geralmente, os equipamentos esto no
mesmo domnio administrativo.
- N de Borda MPLS: um n MPLS que conecta a outros dispositivos fora
do domnio MPLS.
- Sada no N MPLS: um ponto da borda MPLS, que controla o trfego
deixando o domnio MPLS.
29
- Entrada no N MPLS: um ponto da borda MPLS, que controla o trfego de
entrada do domnio MPLS.
- Rtulo MPLS: o rtulo presente no cabealho do pacote e que contm as
informaes do MPLS para a rede.
- N MPLS: um controlador de protocolos MPLS, onde opera um ou mais
protocolos de roteamento, capaz de encaminhar pacotes com base em rtulos.

3.1.3 Caractersticas do MPLS


Algumas caractersticas sobre o comutador de rtulos multiprotocolos
(MORGAN; LOVERING, 2008).
- um mecanismo de comutao de pacotes, atravs da anlise de rtulos;
- Os rtulos possuem informaes necessrias para realizar o
encaminhamento de pacotes;
- No realizam as pesquisas dos cabealhos da camada de rede, em outras
palavras, o protocolo de Internet;
- Os rtulos substituem o protocolo de Internet, em relao a operaes de
roteamento tradicionais;
- Independente do protocolo de rede utilizado, o trabalho do roteador enviar
os pacotes ao roteador de prximo salto, em um processo de alta velocidade e
tecnologia;
- Em MPLS, h apenas um exame do pacote e a atribuio de uma
Encaminhamento de Classe de Equivalncia (FEC);
- Nas redes MPLS, apenas os roteadores de comutao de rtulos de borda
executam a pesquisa na tabela de roteamento, isso faz com que o atraso no
caminho da rede seja menor;
- O uso da tecnologia MPLS em prestadoras de servios oferecido atravs
de Redes Privadas Virtuais (VPN) para garantir um transporte seguro e confivel.
Dentro das operadoras, existem rotas especificas entre o provedor e a empresa. Na
figura 12 mostrado as rotas que cada roteador sabe do dispositivo adjacente.

30

Figura 12 - Rede MPLS
Fonte: Kurose; Ross (2006).


3.1.4 - Conceitos MPLS


Conforme j descrito anteriormente, o MPLS analisa os rtulos, ao invs dos
protocolos de camada de rede. Desta maneira o rtulo de um pacote de sada
verificado e comparado com um rtulo do banco de dados. Com a informao
encontrada, um novo rtulo anexado ao pacote e transmitido para a interface de
destino (MORGAN; LOVERING, 2008). A figura 13 exibe o caminho atravs de
rtulos.


Figura 13 - Comutao de Rtulos
Fonte: Morgan; Lovering (2008).

Na figura acima, os roteadores core descritos como A e B so chamados de
Roteadores de Comutao de Rtulos (LSRs). Os roteadores A e B no participam
da consulta tabela de roteamento, o roteador que executa esse processo o
roteador de borda. A deciso de encaminhamento realizada atravs dos rtulos.
s vezes, um LSR anterior ao roteador de borda poder aparecer antes de enviar o
pacote o destino final (MORGAN; LOVERING, 2008).
31


3.1.5 Mecanismos de comutao do roteador


O mecanismo de comutao MPLS fornecido pelos sistemas de Internet da
Cisco, atravs do recurso CEF. Este recurso passou por evoluo e esta descrita
abaixo (MORGAN; LOVERING, 2008).
- Cada pacote processado antes do encaminhamento, pela tabela de
roteamento. Este um processo lento;
- Destinos so armazenados na memria e usados para encaminhar pacotes,
fazendo com que a comutao seja mais rpida, principalmente se existir outros
endereos de roteamento parecidos;
- utilizada a Base de Informao de Encaminhamento (FIB) para operar em
altas velocidades na camada de rede.


3.1.6 - Comutao padro do protocolo de Internet


O processo de roteamento bastante simples, necessitando no mnimo de
dois tipos de protocolos, para um mesmo domnio, um Protocolo de Entrada Interior
(IGP). Para se comunicar com sistemas externos, preciso um Protocolo de Entrada
Exterior (EGP). s vezes, necessrio o uso de um protocolo de borda, para haver
comunicao entre sistemas de domnios diferentes (MORGAN; LOVERING, 2008).
Estes tipos de protocolos verificam na tabela de roteamento se h uma rota
para o destino, alm de verificar entre esses caminhos, o melhor, com uma distncia
menor ou custo reduzido.
O processo de roteamento IP (protocolo Internet) funciona da seguinte
maneira: existem dois cabealhos para que a operao acontea, o cabealho da
camada de enlace e o cabealho do pacote IP. Quando um pacote precisa ser
comutado, verificado no cabealho IP qual o endereo de destino, se estiver
diretamente conectado no roteador o pacote transferido para a interface de
destino, desencapsulado, e verificado o endereo fsico de destino. Entretanto, pode
32
no estar diretamente conectado, sendo assim, preciso verificar se h alguma
informao na tabela de roteamento indicando se existe uma rota para a rede
especificada, se houver o pacote ser enviado para o destino, aps chegar na rede
de destino verificado se o endereo fsico corresponde ao do cabealho da
camada de enlace. O roteamento acontece verificando-se os endereos da camada
de rede e de enlace de dados.


3.1.7 Comutao do CEF (Encaminhamento Rpido da Cisco)


O CEF uma tecnologia que utiliza o FIB. O FIB uma imagem da tabela de
roteamento do protocolo de Internet, nele est a informao de prximo salto, com
base nas informaes de endereo do protocolo de Internet. Quando h alguma
mudana na tabela de roteamento, o FIB atualizado com a ajuda de um protocolo
de roteamento, seja o protocolo estado de conexo ou vetor de distancia (MORGAN;
LOVERING, 2008).
O CEF mantm uma tabela de adjacncia, pois o FIB no armazena
informaes de interface de sada e encapsulamento de camada de enlace. As
tabelas de adjacncias so atualizadas quando h alguma modificao na topologia
de rede. O CEF pode ser executado em modo distribudo, fornecendo um ambiente
de comutao mais rpido e eficiente.


3.2 ARQUITETURA DO MPLS

3.2.1 Componentes MPLS


A arquitetura subjacente da tecnologia MPLS foi separada em dois
mecanismos tradicionais de roteamento (MORGAN; LOVERING, 2008).
Plano de Controle: mantm o roteamento e troca informaes de rtulos entre
os dispositivos adjacentes.
33
Plano de Dados: tambm conhecido como plano de encaminhamento,
direciona as informaes com base nos endereos ou rtulos de destino.
A figura 14 mostra detalhadamente como esto divididos os dois planos.


Figura 14 - Arquitetura do LSR
Fonte: Odom 1 (2006).

O plano de controle trabalha com as complexidades de roteamento em geral.
Incluindo os protocolos Abra o Caminho Mais Curto Primeiro (OSPF), Protocolo de
Gateway Interior Aprimorado (EIRGP), Sistema Intermedirio para Sistema
Intermedirio (IS-IS), Protocolo de Gateway de Borda (BGP), entre outros protocolos
utilizados.
Alm dos protocolos de roteamento tradicionais, existem rtulos equivalentes
baseados em protocolo de roteamento. O Protocolo de Distribuio de Etiqueta
(TDP) e o Protocolo de Distribuio de Rtulo (LDP), este protocolo proprietrio da
Cisco. Outro protocolo presente na tecnologia o Protocolo de Reserva de Recurso
(RSVP), utilizado no mecanismo de engenharia de trfego do MPLS, este permite a
reserva da largura de banda (MORGAN; LOVERING, 2008).
O plano de dados utilizado para o trfego de encaminhamento, com base
nas informaes do protocolo de roteamento ou LDP. A Base de Informao de
Encaminhamento de Rtulos (LFIB) criada atravs das informaes dos protocolos
LDP, BGP e RSVP, e utilizado para armazenar e enviar pacotes para o destino.


34
3.2.2 Rtulo MPLS


Os rtulos contidos no MPLS tm a funo de separar as operaes de
encaminhamento da camada de rede de destinos e informaes contidas nos
cabealhos dos pacotes (MORGAN; LOVERING, 2008). Quando associado um
rtulo a uma FEC as informaes de encaminhamento tornam-se altamente
eficientes.
A FEC um grupo de pacotes IP que pode corresponder a uma rede IP de
destino ou qualquer classe de trfego que o LSR considera significativo. Os trfegos
podem ser classificados com nveis de servio (SLA). Os SLAs podem ser
negociados com as operadoras de telefonia (MORGAN; LOVERING, 2008).
Os rtulos so adicionados aos pacotes por LSRs de borda, tambm o
provedor do roteador de borda (PE) o LSR que adiciona o rtulo. Os roteadores
(PE) esto ligados diretamente aos roteadores dos clientes de borda (CE), que
geralmente so equipamentos de instalao do cliente (CPE). Todo caminho de
ingresso para a sada PE conhecido como o rtulo ligado ao caminho (LSP)
(MORGAN; LOVERING, 2008).
Os pacotes so classificados de acordo com as diversas FECs contidas no
mecanismo de rtulos MPLS, sem a necessidade de examinar o cabealho da
camada de rede. O rtulo colocado entre os cabealhos da camada de enlace e
camada de rede, formando o quadro MPLS. A figura 15 mostra os roteadores no
domnio MPLS.


Figura 15 - Roteadores MPLS
Fonte: Morgan; Lovering (2008).



35
3.2.2.1 Estrutura do rtulo MPLS


O cabealho MPLS formado por quatro bytes e est localizado antes do
cabealho IP. O rtulo do MPLS formado por um campo de 20 bits. (ODOM;
HEALY; METHA, 2008). A figura 16 mostra como dividido o cabealho MPLS.


Figura 16 - Cabealho MPLS
Fonte: Odom; Healy; Metha (2008).

- Rtulo (20 bits): Identifica o espao de caminho de comutao do rtulo;
- Classe de Servio (3 bits): usado para qualidade de servio, este pequeno
campo utilizado para propsitos experimentais;
- Pilha (1 bit): sinalizador, que quando esta em 1, significa que o rtulo esta
imediatamente precedendo um cabealho IP;
- Tempo de Vida (8 bits): Usado para os mesmo propsitos do cabealho IP,
sendo um deles, evitar loop de roteamento.


3.2.3 Pilhas de rtulos


As pilhas de rtulos podem ser comparadas como o encapsulamento IP
dentro do IP, existem dois cabealhos, mas apenas o primeiro utilizado para tomar
as decises de roteamento (MORGAN; LOVERING, 2008). possvel encontrar
alguns cenrios que utilizam vrios rtulos para um processo particular, estes
cenrios esto disponveis em servios MPLS.
- Redes Privadas Virtuais (VPN) sobre o MPLS;
- Engenharia de Trafego (TE) sobre o MPLS;
- VPN sobre MPLS com TE.



36
A figura 17 mostra as pilhas de rtulos no cabealho MPLS.

Figura 17 - Pilha MPLS
Fonte: Morgan; lovering (2008).


Se os rtulos se tornarem obsoletos, eles sero removidos do cabealho. O
processamento de rtulos sempre baseado no rtulo superior. Cada um dos
rtulos tem uma denominao, o inferior o rtulo de nvel 1, o segundo de nvel 2,
e assim por diante. O pacote sem rtulo possui uma profundidade zero.


3.2.3 Quadro MPLS


O quadro MPLS utilizado para descrever que tipo de encapsulamento ser
utilizado nas interfaces que esto sendo usadas para a comunicao dos roteadores
(MORGAN; LOVERING, 2008). Se a interface de sada est habilitada com MPLS, o
roteador dever colocar o rtulo e encapsular de acordo com a estrutura da camada
de enlace. O roteador tambm especifica o tipo do protocolo de roteamento,
conforme est configurado e encontra seus vizinhos.


3.2.4 Roteador de comutao de rtulos


Os LSRs devem ser capazes funcionar com os planos de controle e controle
de dados. O LSR mantm a tabela de roteamento para garantir que o FIB esteja
atualizado com as informaes de rtulos atualizados. O LDP responsvel por
distribuir os rtulos e preencher o LFIB no plano de dados (MORGAN; LOVERING,
2008).
De acordo com MORGAN e LOVERING (2008), alguns cenrios so
possveis para a deciso do LSR de borda.
37
- Um pacote recebido pode ser enviado como pacote IP normal para um
endereo de destino. Sendo assim, a interface de sada no est habilitada com o
MPLS;
- Um pacote recebido pode ser enviado como um pacote MPLS para um
endereo de destino. Sendo Assim, a interface de sada est habilitada com o
MPLS;
- Um pacote recebido encaminhado com base apenas no rtulo. O rtulo
analisado na LFIB para o pacote ser enviado para o prximo salto;
- O LFIB mostra que o LSR de borda a sada do MPLS de borda. Sendo
assim, o pacote rotulado encaminhado normalmente.




3.2.5 LIB, LFIB e FIB


O MPLS precisa do protocolo de roteamento subjacente para coletar
informaes e construir a LFIB, a tabela de roteamento por rtulos. Os rtulos so
compartilhados pelos protocolos de distribuio, entretanto a informao
construda com base na tabela de roteamento IP. Se a rede IP apresentar
problemas, o MPLS tambm ter problemas (MORGAN; LOVERING, 2008).
Com a convergncia de rede atravs dos protocolos de roteamento IP, cada
LSR atribui rtulos para os destinos. Os rtulos atribudos so armazenados em uma
base de informaes de rtulos (LIB). Depois da atribuio de rtulos, o LSR
anuncia seus rtulos aos roteadores vizinhos na rede. Estes anncios so
armazenados na FIB e no LFIB. Cada LSR ter sua LIB, LFIB e FIB de acordo com
os rtulos recebidos.
O LIB parte do plano de controle e mantm o mapeamento entre o prefixo
IP e o rtulo atribudo. O LFIB faz parte do plano de dados e fornece informaes
para o encaminhamento de pacotes rotulados com base nas informaes dos
protocolos de roteamento (MORGAN; LOVERING, 2008). A figura 18 mostra as
informaes que formam a LFIB.

38

Figura 18 - Exemplo de LFIB
Fonte: Morgan; Lovering (2008).

3.2.6 Distribuio de rtulos


O MPLS no adiciona overhead na comunicao adicional entre os
roteadores. So usados recursos significativos para a propagao de prefixos de
rotas e a manuteno da LIB e LFIB, juntamente com a tabela de adjacncia
(MORGAN; LOVERING, 2008).
A distribuio de rtulos realizada pelo LDP. O MPLS admite duas formas
de propagar informaes em sua arquitetura: utilizar as funcionalidades dos
protocolos existentes e criar novos protocolos tarefa de troca de rtulos. O LDP
est implementado no plano de controle e os rtulos de troca esto armazenados na
LIB.
A deciso de distribuir um rtulo especial a uma FEC feito pelo LSR em
cada salto ao longo do caminho. No trfego MPLS, os rtulos so propagados nos
dois sentidos. A distribuio de rtulos pode acontecer de duas maneiras:
atualizaes no solicitadas e atualizaes por demanda. Abaixo mostrada a
utilizao do LDP para atualizao dos rtulos, figura 19.


Figura 19 - Distribuio de Rtulos
Fonte: Morgan; Lovering (2008).


Assim como ocorre nas tabelas de roteamento, o LFIB tambm consegue
formar uma estrutura para saber qual o roteador de prximo salto. Este detalhe
39
visto na figura acima, pode ser notado que cada roteador sabe qual o prximo
roteador que tem que enviar os pacotes, isto , se estiver configurado corretamente.

3.3 CONFIGURAO DO MEIO MPLS


Esta etapa do projeto descreve um pouco sobre a configurao do MPLS com
referncia aos equipamentos da Cisco.
A configurao bsica do MPLS relativamente simples. normalmente
ativada nas interfaces. O Processo para habilitar o MPLS consiste em apenas trs
passos: habilitar o CEF, habilitar o MPLS nas interfaces conectadas a rede e
configurar o MTU (Unidade Mxima de Transmisso) (MORGAN e LOVERING,
2008).

3.3.1 Configurao do CEF

O encaminhamento rpido da Cisco (CEF) um mecanismo que fornece
rapidez e eficincia. O CEF uma tecnologia avanada de comutao da camada
trs, que otimiza desempenho e estabilidade em grandes redes, atravs de trfego
dinmico. O CEF utiliza menos a Unidade Central de Processamento (CPU) para os
processos de troca ou comutao rpida, disponibilizando mais tempo aos servios
e aplicaes (MORGAN; LOVERING, 2008).
O CEF pode ser executado de dois modos: No modo central, em que um
processo CEF est sendo executado no roteador ou, no modo distribudo, o CEF
projetado para ser executado em roteadores de alto nvel. Isto permite um
percentual de comutao mais rpida se as interfaces de origem e destino estiverem
no mesmo roteador, devido ao cache de comutao (MORGAN; LOVERING, 2008).
A FIB uma cpia da tabela de roteamento. A FIB e as tabelas de adjacncia
so base operacional para a CEF, e so utilizadas para tomar decises de
comutao de destino IP. A tabela de adjacncia mantem os dados de informaes
de camada de enlace de dados, evitando os processos desta camada (MORGAN;
LOVERING, 2008).
40
O CEF ativado no prompt de comando de configurao global do roteador,
em alguns verses do Sistema Operacional de Internet (IOS) j est ativado por
padro do sistema. Mas pode ser ativado com o seguinte comando:
- Nome do roteador (config)#ip cef
Tambm possvel ativar o modo distribudo, o que ajuda no processamento
das rotas para lidar com a comutao, atravs do comando:
- Nome do roteador (config) # ip cef distributed
Outra opo possvel configurar o CEF em uma interface especifica, usando
o seguinte comando:
- Nome do roteador (config - if) # ip route-cache cef
Para desativar o CEF onde no necessrio, basta colocar (no) antes dos
comandos descritos anteriormente.
Existem trs outras opes de configuraes para o CEF:
- Balanceamento de carga: pode ser configurado por destino ou por pacote
para o balanceamento de carga;
- Contador de rede: autoriza a coleta de estatsticas de trfego, como pacotes
e bytes;
- Comutao distribuda de tneis: est ativado automaticamente no CEF, o
que permite a comutao de tneis.
Para verificar se as configuraes no equipamento esto certas, necessria
a utilizao de um dos dois comandos abaixo, o segundo comando exibe um resumo
das informaes da FIB:
- Nome do roteador #show ip cef; ou
- Nome do roteador #show ip cef detail.
Os dois comandos acima no so suficientes para verificar se a rede esta em
perfeito funcionamento. Para isso existem outros comandos que permitem a
atualizao das informaes de rtulos no roteador para a verificao de
convergncia da rede:
- Nome do roteador # clear adjacency;
- Nome do roteador # clear ip cef inconsistency;
- Nome do roteador # clear cef interface.
Para o monitoramento em tempo real possvel utilizao de outros dois
comandos:
- Nome do roteador # debug ip cef;
41
- Nome do roteador # debug ip cef events.
A figura 20 mostra a sada do comando show ip cef detail.

Figura 20 - Sada do Comando show ip cef detail
Fonte: Morgan; Lovering (2008).

3.3.2 Configurao dos quadros MPLS nas interfaces


A prxima etapa da configurao esta relacionada com a configurao das
interfaces que esto sendo utilizadas na rede. Nesta etapa necessrio configurar
um protocolo para a distribuio de rtulos. Em alguns ambientes utilizado o TDP
(Protocolo de Distribuio de Rtulos). Entretanto, na maioria das implementaes
utilizado o LDP (Protocolo de Distribuio de Rtulos), que um mecanismo
padronizado para troca de rtulos, de propriedade da Cisco (MORGAN; LOVERING,
2008).
O MPLS ativado em um roteador atravs do comando abaixo. Deve ser
ativado em todos os roteadores da rede:
- Nome do roteador (config) # mpls ip
Em roteadores Cisco, o comando mpls ip j esta ativado por padro,
entretanto possvel desativar com (no) antes do comando mpls ip. Aps ter
configurado o MPLS na interface, os protocolos de distribuio tambm devem ser
configurados. Pode ser usado um dos protocolos ou os dois atravs dos comandos
abaixo:
- Nome do roteador (config - if) # mpls label protocol both (para usar os dois);
- Nome do roteador (config - if) # mpls label protocol lpd (padro);
- Nome do roteador (config - if) # mpls label protocol tdp.
42
O LPD conforme dito, deve ser configurado na interface. Em verses antigas
do IOS da Cisco aparecer o comando tag-switching, como protocolo de rtulos para
o MPLS. Nos sistemas IOS mais novos, a partir do lanamento da verso 12.4(3) o
LDP definido como padro (MORGAN; LOVERING, 2008).
Os protocolos TDP e LDP possuem diferenas com relao as portas que
utilizam na camada de transporte. O TDP utiliza a porta UDP 646 e o LDP utiliza a
porta TCP 711. Caso o comando mpls ip no esteja configurado na interface, no
haver adjacncia na rede e a comunicao no ocorrer por MPLS. Caso um
ambiente MPLS com equipamentos diferentes, este tipo de cenrio o mais ideal
(MORGAN; LOVERING, 2008). A figura 21 mostra as configuraes que devem
estar presentes em uma rede MPLS.


Figura 21 - Verificao da Configurao do MPLS
Fonte: Morgan; Lovering (2008).


3.3.3 Configurao do tamanho MTU


A ltima parte da configurao do quadro MPLS a definio do tamanho da
MTU. Este considerado um problema em configurao de MPLS e pode ter efeitos
de longo alcance em ambiente de rea local (MORGAN; LOVERING, 2008).
Tipicamente este problema acontece em interfaces LAN, em que o tamanho
est em torno de 1500 bytes. J a interface utilizada em longa distancia possuem
tamanhos de MTU maior a capacidade de se ajustar automaticamente. O tamanho
da MTU leva em conta o comprimento do rtulo utilizado, no caso 4 bytes. Pode ser
utilizado uma MTU de 1504 bytes para um nico rtulo (MORGAN; LOVERING,
2008).
43
Quando alguns servios como o Engenharia de Trfego e VPN, sobre o
MPLS estiverem funcionando necessrio aumentar o tamanho da MTU, este
tamanho pode ser de 1512 bytes. A alterao da MTU acontece na interface com a
utilizao do comando:
- Nome do roteador (config if) # mpls mtu 1512
O comando define um tamanho de MTU especifico para a comutao de
pacote, ao invs de definir para todos os tipos de trfegos. O intervalo do tamanho
da MTU pode variar entre 64 a 65535 bytes (MORGAN; LOVERING, 2008). Na
figura 22 mostrada a configurao da MTU.


Figura 22 - Configurao da MTU na interface gigabit
Fonte: Morgan; Lovering (2008).

Uma configurao importante para verificar se a configurao do MPLS esta
correta e utilizar o comando debug mpls ldp bindings, para visualizar as trocas de
rtulos com relao a atualizao FIB em tempo real. Outro comando interessante
o show mpls ldp neighbor para a verificao de dispositivos conectados diretamente
e que estejam funcionando com o protocolo LDP. A figura 23 detalha quem so os
dispositivos vizinhos em uma rede MPLS.


Figura 23 - Verificao de Vizinhana
Fonte: Morgan; Lovering (2008).



44
3.4 SERVIOS MPLS

A arquitetura MPLS pode ser integrada a diversos tipos de servios em uma
rede. O potencial do MPLS so as outras aplicaes que so possveis de
implementao, como o trfego de engenharia e redes privadas virtuais (ODOM 2,
2006). A figura 24 mostra alguns dos servios MPLS realizados pelo painel de
controle.


Figura 24 - Servios MPLS
Fonte: Odom 2 (2006).


3.4.1 Engenharia de Trfego


Engenharia de trafego o processo de roteamento do trfego de dados para
equilibrar a carga entre os links, roteadores e switches, e aplicado em redes que
possuem vrios caminhos. Engenharia de trfego deve ser capaz de garantir a
demanda de vrias classes de servios diferentes (MORROW; SAYEED, 2006).
Razes para implantar a engenharia de trfego:
- Quando h mudanas nos padres de trfego, para evitar
congestionamento;
- Comercio eletrnico, grandes eventos esportivos, entre outros;
- Melhor utilizao da largura de banda;
- Ajudar na rota em que no seja a melhor opo;
- Garantia de largura de banda ponto-a-ponto;
45
- Planejamento do trfego para melhor a disponibilidade total da rede.

3.4.2 Segurana


A segurana em redes MPLS esta ligada diretamente redes em que esto
configuradas com VPN. As VPNs so utilizadas em meio a Internet, entretanto, so
configuradas de maneira que um cliente no tenha conhecimento de outro cliente
diferente, a no ser que seja uma rede avanada da organizao. Sobre as redes
virtuais j foi explicado um pouco nos captulos anteriores.


3.4.3 Qualidade de Servio

Para qualidade de servio, o modelo de servios integrados especifica duas
classes de servios: Carga controlada e servio garantido. Utiliza o protocolo de
reservas de recursos (RSVP) para a sinalizao dos servios (MORROW e
SAYEED, 2006).
O servio garantido possibilita que aplicaes com requisitos rigorosos para a
largura de banda atribuda e atraso de pacotes. garantido que os pacotes sero
entregues em um determinado momento. J a reserva de recursos feito no sentido
inverso com o receptor especificando o nvel de servio desejado.

3.4.4 Futuro do MPLS

O IP MPLS ser um componente importantssimo para as futuras arquiteturas
de voz, vdeo e servios de dados mveis. Este um recurso que prestadores de
servios vo oferecer para as redes de prxima gerao.
Os pacotes MPLS podem ser executados em mais de uma camada de enlace
de dados e os quadros podem ser executados atravs de pacotes IP. Pode ser visto
que o MPLS no se encaixa no modelo OSI (YATER REKHTER; apud MORROW;
SAYEED, 2006)
Outro fator importante que o MPLS pode fazer integrar redes IP e pticas e
trazer um melhor provisionamento nos circuitos de camada fsica.
46

4 SIMULAO DA REDE MPLS (MULTIPROTOCOL LABEL SWITCH)


A ltima parte deste projeto esta destinada implantao de uma rede para a
simulao do MPLS. Nesta simulao ser verificada toda a configurao de todos
os roteadores envolvidos na rede. Ser verificada a convergncia de rede e se o
protocolo MPLS corresponde conforme foi estudado. Seguido dos trs passos para
configurao dos dispositivos. Depois disso, sero verificados alguns testes de
recursos com o MPLS.


4.1 SIMULADOR DE REDES GNS3 (SIMULADOR GRFICO DE REDE)


O GNS3 um simulador grfico de redes, que permite a emulao de redes
complexas. Assim como possvel fazer um ambiente virtual com softwares de
computadores em outros programas de emulao. O GNS3 emula os sistemas
Operacionais de Internet da Cisco (FUZSNER, 2008).
O GNS3 permite a emulao do Cisco IOS em plataformas Windows ou
Linux. Existem inmeros simuladores de redes, entretanto esto limitados com
relao aos recursos que podem oferecer. O GNS3 permite a configurao do MPLS
para a simulao de uma rede, seja ela simples ou complexa. Dependendo apenas
da capacidade do hardware onde est sendo configurado para a simulao.
A rede simulada tambm pode ser verificada com um analisador de rede, para
verificar se os pacotes esto sendo encaminhados entre a rede. O interessante
que o GNS3 pode utilizar recursos do analisador Wireshark. O analisador consegue
fazer um detalhamento dos recursos que esto sendo utilizados na rede WAN
simulada. Na figura 25 mostrada a janela do simulador de rede.

47

Figura 25 - Janela do Simulador com Rede Simples
Fonte: Autoria prpria.


Na figura mostrada acima, interessante observar alguns recursos que esto
disponveis no simulador GNS3:
- tipo de dispositivos e seus respectivos IOS;
- diversos tipos de cabeamento so disponveis;
- diversos protocolos de enlace so disponveis;
- Verificao do detalhamento, das interfaces interconectadas no lado direito;
- Configurao do dispositivo como se estivesse conectado por console;
- H outros recursos especficos do software que no sero citados, pois so
mais complexos e no so relevantes ao projeto.





48
4.2 TOPOLOGIA E IMPLEMENTAO


A simulao de rede para o estudo do MPLS se baseia na topologia abaixo.
Ela apresenta sete roteadores, conforme sua identificao e descrio de cada um
deles. Os CEs so roteadores de borda do cliente, os PEs so os roteadores de
borda com o provedor e os Ps so os roteadores da operadora. Na figura 26
mostrada a topologia que ser utilizada na simulao.

Figura 26 - Topologia Proposta para Estudo
Fonte: Autoria prpria.

Para comear com a implantao, foi definido o quadro de endereamento da
rede entre todos os roteadores da topologia. O Quadro proporciona uma melhor
visualizao da disposio dos endereos utilizados em cada uma das interfaces.
Roteador Serial 1/0 Serial 1/1 Serial 1/2
CE A1 172.16.253.1/30
PE1 172.16.253.2/30 172.16.253.5/30 172.16.253.9/30
P1 172.16.253.6/30 172.16.253.13/30
P2 172.16.253.10/30 172.16.253.17/30
P3 172.16.253.18/30 172.16.253.21/30
PE 2 172.16.253.14/30 172.16.253.22/30 172.16.253.25/30
CE A2 172.16.253.26/30
Quadro 1 Endereamento dos dispositivos
Fonte: Autoria prpria.

49


A prxima etapa do projeto a configurao de todos os roteadores dividindo
as etapas, para explicar o que acontece em cada uma delas.


4.2.1 - Configuraes bsicas


A primeira etapa fazer uma configurao bsica em cada um dos
roteadores. A configurao do PE1 mostrada como exemplo e todos os outros
roteadores seguem o mesmo padro de configurao.

Current configuration - 1667 bytes
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption

hostname PE1

boot-start-marker
boot-end-marker

enable secret 5 $1$UZlj$paaNERckhH7zDPb65bFQv1

no aaa new-model

ip cef

interface FastEthernet0/0
no ip address
shutdown
duplex half

interface Serial1/0
description PE1 -> CE_A1
bandwidth 128000
ip address 172.16.253.2 255.255.255.252
serial restart-delay 0

interface Serial1/1
description PE1 -> P1
bandwidth 128
ip address 172.16.253.5 255.255.255.252
serial restart-delay 0
clock rate 128000

interface Serial1/2
description PE1 -> P2
bandwidth 128
ip address 172.16.253.9 255.255.255.252
serial restart-delay 0

router ospf 10
router-id 2.2.2.2
log-adjacency-changes
network 172.16.253.0 0.0.0.3 area 10
network 172.16.253.4 0.0.0.3 area 10
network 172.16.253.8 0.0.0.3 area 10

no ip http server
no ip http secure-server

control-plane

gatekeeper
shutdown

line con 0
exec-timeout 60 0
password 5 $1$UZlj$paaNERckhH7zDPb65bFQv1
logging synchronous
login
stopbits 1
line aux 0
exec-timeout 60 0
password 5 $1$UZlj$paaNERckhH7zDPb65bFQv1
logging synchronous
login
stopbits 1
line vty 0 4
exec-timeout 60 0
password 5 $1$UZlj$paaNERckhH7zDPb65bFQv1
logging synchronous
login
end

Na configurao pode ser observada a definio de um nome para
identificao do roteador, ativada a criptografia para todas as senhas, so
configuradas as interfaces utilizadas com endereos e parmetros necessrios para
a comunicao entre os roteadores, utilizado o protocolo OSPF como protocolo de
50
roteamento IP, e por ltimo observada a configurao das portas de comunicao
de configurao do roteador.
Outra caracterstica importante aproveitando as configuraes do roteador
PE1 a tabela de roteamento, onde so mostrados todos os caminhos possveis
para chegar at o roteador CE_A2. A figura 27 mostra a tabela de roteamento de
PE1.


Figura 27 - Tabela DE Roteamento PE1
Fonte: Autoria prpria.

Outra configurao importante a ser verificada antes de continuar com a
configurao observar o status de cada porta que est sendo utilizada. Na figura
28 possvel analisar as condies de cada interface.


Figura 28 - Status das Interfaces Utilizadas
Fonte: Autoria prpria.

Um teste simples para se certificar de que est tento comunicao entre as
extremidades da rede realizar um teste de ping. Este teste mostra se o protocolo
51
de roteamento est criando caminhos nas tabelas de roteamento dos roteadores.
Isso importante, porque a tabela de roteamento ser utilizada no processo do
MPLS.
Abaixo mostrado que o caminho do roteador PE2 at PE1 est sendo
realizado, e que h redundncia na rede. A redundncia importante e funciona
como fator de segurana, caso algum dos links estiver fora por alguma
eventualidade, a outra extremidade assume todo o trfego sem causar srios
problemas na rede. A figura 29 mostra que possvel realizar teste de ping entre
dispositivos.


Figura 29 - Teste de ping nas Interfaces de PE1 Redundncia
Fonte: Autoria prpria.

4.2.2 - Configuraes MPLS

Aps a configurao bsica dos roteadores e a verificao dos status de cada
porta utilizada e a convergncia da rede, podemos continuar a configurao e aplicar
o MPLS para a realizao de seu estudo.
A seguir mostrada a configurao do roteador PE1 que faz parte do domnio
MPLS:








52
PE1#sh run
Building configuration...

Current configuration - 1814 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$UZlj$paaNERckhH7zDPb65bFQv1
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description PE1 -> CE_A1
bandwidth 128000
ip address 172.16.253.2 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
!
interface Serial1/1
description PE1 -> P1
bandwidth 128
ip address 172.16.253.5 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
clock rate 128000
!
interface Serial1/2
description PE1 -> P2
bandwidth 128
ip address 172.16.253.9 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
router-id 2.2.2.2
log-adjacency-changes
network 172.16.253.0 0.0.0.3 area 10
network 172.16.253.4 0.0.0.3 area 10
network 172.16.253.8 0.0.0.3 area 10
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 60 0
password tccutfpr
logging synchronous
login
stopbits 1
line aux 0
exec-timeout 60 0
password tccutfpr
logging synchronous
login
stopbits 1
line vty 0 4
exec-timeout 60 0
password tccutfpr
logging synchronous
login
!
!
end

53

Com esta configurao realizada em todos os roteadores que fazem parte do
domnio MPLS (PE1, P1, P2, P3 e PE2), pode ser observada algumas informaes
conforme j foram vistas anteriormente.
A primeira configurao a ser mostrada a LFIB (Base de Informao de
Encaminhamento de Rtulos), ela demonstra a tabela de rtulos com base das
informaes da tabela de roteamento, conforme figura 30.

Figura 30 - LFIB Reflexo da Tabela de Roteamento
Fonte: Autoria prpria.



O LIB mantm o mapeamento entre o prefixo IP e o rtulo atribudo, caso
alguma rota seja mudada na topologia, o LIB atualizado primeiramente, e depois
contribui para a formao do LFIB. Todo este processo ocorre aps a convergncia
da rede atravs do protocolo de roteamento ativo. Abaixo, na figura 31, mostrado
um exemplo do FIB e seu comando para a verificao.


Figura 31 - LIB (Base de Informao de Rtulo)
Fonte: Autoria prpria.
54
importante verificar as trocas de rtulos com relao a atualizao da FIB
em tempo real, abaixo mostrado os detalhes e o comando para esta verificao.
Na figura 32 mostrado um detalhamento das informaes da FIB.

Figura 32 - FIB (Base de Informao de Encaminhamento)
Fonte: Autoria prpria.

Quando feita uma configurao MPLS importante levar em considerao
quais interfaces esto sendo utilizadas no processo. Por mais que tenha sido
configurado por algum administrador, este no se lembrar de todas as interfaces
que participam do processo, pois nesse tipo de configurao no h a necessidade
de sempre ficar reconfigurando as interfaces. A seguir mostrado o comando
utilizado e a sada do comando utilizado mostrando as informaes necessrias das
interfaces que esto configuradas com o protocolo LDP, figura 33.


Figura 33 - Vizinhos que Participam do MPLS
Fonte: Autoria prpria

55
Outro detalhe importante a ser levado em considerao em ambiente MPLS
a atribuio dos rtulos em cada interface que est sendo utilizada. Neste ambiente
de laboratrio no fica difcil deixar que o sistema se encarregue de distribuir os
rtulos de acordo com seu padro de configurao. Entretanto, em redes reais, se
isso acontecer, a administrao tornar-se- difcil de ser realizada. Para colocar um
rtulo de maneira esttica, utilize o comando conforme mostrado na figura 34.


Figura 34 - Rtulo Esttico
Fonte: Autoria prpria.


Nas configuraes realizadas foram utilizados comando que colocassem o
MPLS em funcionamento, entretanto existem outros comando para melhorar o seu
funcionamento. H comandos que so utilizados no modo de configurao global, ou
nas configuraes das interfaces. Segue alguns comandos que esto presentes no
IOS do roteador 7200, conforme mostra a figura 35.


Figura 35 - Outros Comandos do MPLS
Fonte: Autoria prpria.


56
4.3 RESULTADOS
Os resultados que foram obtidos foram satisfatrios, pois esta foi uma simples
simulao do MPLS em sua utilizao em laboratrio. A seguir segue a descrio de
alguns resultados.
- A caracterstica do LFIB conforme descrito por vrios autores foi confirmada,
ela um reflexo da tabela de roteamento;
- Na simulao foi possvel mostrar que cada interface possui seu prprio
rtulo, e que este divulgado aos outros roteadores pela LFIB;
- No decorrer do projeto foi demonstrado que simples a configurao do
MPLS e que condiz com que os autores dizem para se configurar o protocolo;
- Na simulao, alguns momentos alguns pacotes de ping foram perdidos.
Foi notado que isso acontecia devido ao processamento do computador. Dessa
forma, mostra-nos que em um meio por onde o protocolo estiver atuando poder
sofrer algumas alteraes em alguns momentos. Entretanto, as operadoras devem
mantem a qualidade de servio que est sendo prestado aos seus clientes;
- No projeto, foi descrita algumas maneiras de verificar se a rede convergiu e
se o MPLS est realmente em funcionamento;
- Com o auxilio do programa Wireshark foi possvel analisar algumas
caractersticas do MPLS, entre a ligao do roteador PE1 e P2 que esto no domnio
MPLS, conforme figura 36.


Figura 36 - Analise atravs do Wireshark
Fonte: Autoria prpria.

57
- Pode ser notado que os roteadores citados trocam mensagem hello
atravs dos protocolos LDP e OSPF;
- Pode ser observado que o rtulo da interface conectada ao roteador PE1
17;
- Pode ser observada a porta que o LDP utiliza (646);
- Pode ser observada a identificao do roteador de comutao de rtulos
(LSR).
Podem ser feitas outras analises atravs da figura, entretanto as informaes
bsicas sobre o MPLS j foram citadas.


58

5 - CONCLUSO

A execuo deste projeto foi de grande importncia no amadurecimento do
conhecimento sobre a tecnologia MPLS. Atravs dele, foi possvel fazer um breve
estudo e a analise da utilizao do MPLS e porque ele est substituindo outros
protocolos de redes WAN.
Com a evoluo do desenvolvimento do deste projeto, foi possvel fazer uma
sntese das principais caractersticas do MPLS e sua utilizao com outros
protocolos, que apesar de no utilizar o protocolo de internet diretamente, necessita
de alguns recursos dele para seu funcionamento.
O estudo realizado mostrou de maneira ampla, devido ao nvel de
conhecimento que foi exigido para sua realizao e simulao. Pois a configurao
de roteadores realizada por profissionais de operadoras que comercializam este
tipo de servios de redes WAN.
O desafio deste projeto foi mostrar de uma maneira simples, as
caractersticas do MPLS e seu funcionamento simulado em laboratrio, antes de ser
aplicado em um local para real funcionamento.
Por meio deste estudo, foi possvel verificar que o MPLS est substituindo
protocolos WAN como as tecnologias Frame Relay e ATM. Estes dois realizam a
comutao na camada de enlace, onde o Protocolo de Internet gerava srios
problemas de escalabilidade.
Com a utilizao dos protocolos de roteamento da camada de rede sendo
simples e bem definidos, onde as tabelas so criadas automaticamente. Seria de
interesse integrar um protocolo que utilizasse o protocolo de internet ao invs de
sobrep-lo. E foi exatamente isso que aconteceu, a indstria utilizou os recursos do
ATM para criar o MPLS.
O MPLS multiprotocolo, o que quer dizer que se adapta a qualquer
protocolo da camada de rede. Utiliza as informaes necessrias para encaminhar
pacotes por redes, atravs de rtulos simples de complemento fixo.
O MPLS um protocolo que oferece vrias vantagens em sua utilizao,
sendo os mais citados at mesmo pelos autores a Engenharia de Trfego e o QoS.
Alm de oferecer segurana atravs de recursos como a utilizao de VPNs.
59
A utilizao do MPLS uma das tecnologias que mais ser usada no futuro
no to distante, e substituir as tecnologias que lhe deram origem. Muitas
empresas j utilizam a tecnologia para muitos servios IP, entre eles podem ser
citados os servios VoIP e Imagens.
Este projeto mostrou de maneira simples, sem se aprofundar nas
caractersticas do MPLS, entretanto h alguns estudos que podem ser realizados
futuramente verificando profundamente os servios que esta tecnologia pode
oferecer. H muitas caractersticas a serem analisadas em Engenharia de Trfego,
Qualidade de Servio, Redes Virtuais Privadas (VPNs) entre outros servios que
no foram citados para no deixar este trabalho muito extenso.
Contudo, pode-se dizer que o MPLS uma tecnologia que est apenas no
seu comeo de utilizao e que ser muito til em outras tecnologias que dependem
do protocolo IP para funcionar e que precisaram se comunicar atravs de rede de
longas distancia.
60
REFERNCIAS

3COM. Equipamentos - roteadores. Disponvel em: <www.3com.com.br>. Acesso
em: 8 jun. 2011.


BARA, Joo Pedro Filho. As Redes MPLS so Seguras? Julho 2008. Disponvel
em:<http://www.itweb.com.br/voce_informa/interna.asp?cod=1235>. Acesso em: 12
set. 2010.


BONEY, James. Cisco IOS in a Nutshell. 2. Ed. United States of America - OReilly,
2005. 796 p.


CCNA EXPLORATION 4.0. San Francisco, USA. 2007. Manual de certificao.


CERTIFICATION RESOURCES. Termos que comeam com C. Disponvel em:
<http://www.mcmcse.com/glossary/c.shtml>. Acesso em: 11 jun. 2011.


CISCO 1. MPLS FAQ para Iniciantes. Setembro 2008. Disponvel em:
<http://www.cisco.com/en/US/tech/tk436/tk428/technologies_q_and_a_item09186a0
0800949e5.shtml>. Acesso em: 15 nov. 2010.


CISCO 2. Compare produtos e solues. Disponvel em:
<http://www.cisco.com/web/BR/produtos/routers_comparison.html>. Acesso em: 8 de
jun. 2011


FELIPPETTI, Marco Aurlio. CCNA 4.1 - Guia completo de estudo. Florianpolis -
Visual Books, 2008. 480 p.


FILHO, Benigno Barreto; SILVA, Claudio Xavier. Matemtica Aula por aula. So
Paulo, SP: Editora FTD AS, 2000, 310.


FUSZNER, Mike. GNS3 Graphical Network Simulator. Disponvel em -
<http://iweb.dl.sourceforge.net/project/gns-3/GNS3/0.5/GNS3-0.5-tutorial.pdf>
Acesso em 15 nov. 2010.


INCIO, Fabricio Couto. MPLS Multiprotocol Label Switching. Disponvel em:
<http://www.gta.ufrj.br/grad/02_1/mpls/apres.html>. Acesso em: 15 nov. 2010.


61
KUROSE, James F.; ROSS, Keith W. Redes de computadores e a internet: uma
abordagem top-down. 3. ed. So Paulo, SP: Pearson Addison-Wesley, 2006. xx, 634
p.


LAMMLE, Todd. CCNA - Cisco Certified Network Associate Fast pass. 3. ed.
Indianapolis: Wiley, 2008. 507 p.


MORGAN, Brian; LOVERING, Neil. CCNP ISCW: Official Exam Certification Guide.
Indianapolis, USA - Cisco Press, 2008. 682 p.


MORROW, Monique; SAYEED, Azhar. MPLS and Next-Generation Networks:
Foundations for NGN and Enterprise Virtualization. Indianapolis, USA: Cisco Press,
2006. 422 p.


ODOM 1, Wendell. Guia de certificao do exame: Cisco CCNA. 3. ed. rev. Rio de
Janeiro - Alta Books, c2003. 738 p.


ODOM 2, Wendell. CCIE Routing and Switching Official Exam certification
Guide. 2. ed. Indianapolis, USA: Cisco Press, 2006. 1097 p.


ODOM, Wendell; HEALY, Rus; MEHTA, Naren. CCIE Routing and Switching:
Exam Certification Guide. Indianapolis, USA - Cisco Press, 2008. 1217 p.


PAQUET, Catherine. Construindo redes Cisco de acesso remoto. So Paulo, SP:
Pearson Education do Brasil, 2003. xxiv, 590 p.


PRETO, Gerson. Rede MPLS, Tecnologias e Tendncias de Evolues
Tecnolgicas. Novembro 2008. Disponvel em:
<http://www.lume.ufrgs.br/bitstream/handle/10183/15971/000695253.pdf?sequence=1>.
Acesso em: 15 nov. 2010.


RUELA, Jos. MPLS - Multiprotocol Label Switching. 2005. Disponvel em:
<http://paginas.fe.up.pt/~jruela/Apontamentos/MPLS.pdf> Acesso em: 15 nov 2010.


SEI - Sistema de Ensino Integrado. So Paulo - Pronal, 1997.


STALLING, William. The Internet Protocol Journal. September 2001. Disponvel
em: <http://www.cisco.com/web/about/ac123/ac147/archived_issues/ipj_4-3/ipj_4-
3.pdf> Acesso em: 10 de Nov. 2010.
62


TELETIME. MPLS e IMS - Esse o caminho. Edio 132, ano 13, Maio 2010.
Disponvel em <http://www.teletime.com.br/5/2010/mpls-e-ims-esse-e-o-
caminho/tt/189069/revista.aspx>. Acesso em 15 nov. 2010.


VILARINHO, Claudio. MPLS (Multiprotocol Label Switching). Maio 2010.
Disponvel em: <http://blogdovilarinho.blogspot.com/2010/05/mpls-multiprotocol-
label-switching.html>. Acesso em:15 nov. 2010.
63
APENDICE A Configurao dos roteadores


Configurao roteador CE_A1
Current configuration - 1568 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CE_A1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$WEbu$7fyYX0P4bHTmByqGbcsW41
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
!
!
!
!!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description CE_A1 -> PE1
bandwidth 128
ip address 172.16.253.1 255.255.255.252
serial restart-delay 0
clock rate 128000
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
router-id 1.1.1.1
log-adjacency-changes
network 172.16.253.0 0.0.0.3 area 10
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
banner motd ^Codt $
ACESSO RESTRITO!
CAIA FORA!
$
^C
!
line con 0
exec-timeout 60 0
password 7 111D1A0602060D1C16
logging synchronous
login
stopbits 1
line aux 0
exec-timeout 60 0
password 7 111D1A0602060D1C16
logging synchronous
login
stopbits 1
line vty 0 4
exec-timeout 60 0
password 7 111D1A0602060D1C16
logging synchronous
login
!
!
end

64

Configurao do roteador PE1
Current configuration - 1814 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$UZlj$paaNERckhH7zDPb65bFQv1
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description PE1 -> CE_A1
bandwidth 128000
ip address 172.16.253.2 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
!
interface Serial1/1
description PE1 -> P1
bandwidth 128
ip address 172.16.253.5 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
clock rate 128000
!
interface Serial1/2
description PE1 -> P2
bandwidth 128
ip address 172.16.253.9 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
router-id 2.2.2.2
log-adjacency-changes
network 172.16.253.0 0.0.0.3 area 10
network 172.16.253.4 0.0.0.3 area 10
network 172.16.253.8 0.0.0.3 area 10
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 60 0
password tccutfpr
logging synchronous
login
stopbits 1
line aux 0
exec-timeout 60 0
password tccutfpr
logging synchronous
login
stopbits 1
line vty 0 4
exec-timeout 60 0
password tccutfpr
logging synchronous
login
!
!
end
65

Configurao do roteador P1
Current configuration - 1756 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname P1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$1Jsa$HWeQYvVxmRPlb8Bnj.MQn.
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description P1 -> PE1
bandwidth 128
ip address 172.16.253.6 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
!
interface Serial1/1
description P1 -> PE2
bandwidth 128
ip address 172.16.253.13 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
clock rate 128000
!
interface Serial1/2
no ip address
shutdown
mpls ip
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
router-id 3.3.3.3
log-adjacency-changes
network 172.16.253.4 0.0.0.3 area 10
network 172.16.253.12 0.0.0.3 area 10
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
banner motd ^C
ACESSO RESTRITO!
CAIA FORA!
^C
!
line con 0
exec-timeout 60 0
password 7 00101005114F0D161D
logging synchronous
login
stopbits 1
line aux 0
exec-timeout 60 0
password 7 00101005114F0D161D
logging synchronous
login
stopbits 1
line vty 0 4
exec-timeout 60 0
password 7 00101005114F0D161D
logging synchronous
login
!
!
end
66

Configurao do roteador P2
Current configuration - 1746 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname P2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$A7Bh$icO/7eKvpZXenvjX15Lu81
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description P2 -> P3
bandwidth 128
ip address 172.16.253.10 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
clock rate 128000
!
interface Serial1/1
description P2 -> P3
bandwidth 128
ip address 172.16.253.17 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
router-id 4.4.4.4
log-adjacency-changes
network 172.16.253.8 0.0.0.3 area 10
network 172.16.253.16 0.0.0.3 area 10
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
banner motd ^C
ACESSO RESTRITO!
CAIA FORA!
^C
!
line con 0
exec-timeout 60 0
password 7 120D0614071F0A1438
logging synchronous
login
stopbits 1
line aux 0
exec-timeout 60 0
password 7 120D0614071F0A1438
logging synchronous
login
stopbits 1
line vty 0 4
exec-timeout 60 0
password 7 120D0614071F0A1438
logging synchronous
login
!
!
end
67

Configurao do roteador P3
Current configuration - 1718 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Og4f$6Jc1qHa83XmvwsaB8HthD1
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description P3 -> P2
bandwidth 128
ip address 172.16.253.18 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
clock rate 128000
!
interface Serial1/1
description P3 -> PE2
bandwidth 128000
ip address 172.16.253.21 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
router-id 5.5.5.5
log-adjacency-changes
network 172.16.253.16 0.0.0.3 area 10
network 172.16.253.20 0.0.0.3 area 10
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
banner motd ^C
ACESSO RESTRITO!
CAIA FORA!
^C
!
line con 0
exec-timeout 60 0
password tccutfpr
logging synchronous
login
stopbits 1
line aux 0
exec-timeout 60 0
password tccutfpr
logging synchronous
login
stopbits 1
line vty 0 4
exec-timeout 60 0
password tccutfpr
logging synchronous
login
!
!
end
68

Configurao do roteador PE2
Current configuration - 1802 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$YEVh$BLYQ47DSvUyv/T.vU9B281
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description PE2 -> P1
bandwidth 128
ip address 172.16.253.14 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
no fair-queue
!
interface Serial1/1
description PE2 -> P3
bandwidth 128
ip address 172.16.253.22 255.255.255.252
mpls label protocol ldp
mpls ip
mpls mtu 1512
serial restart-delay 0
clock rate 128000
!
interface Serial1/2
description PE2 -> CE_A2
bandwidth 128
ip address 172.16.253.25 255.255.255.252
serial restart-delay 0
clock rate 128000
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
router-id 6.6.6.6
log-adjacency-changes
network 172.16.253.12 0.0.0.3 area 10
network 172.16.253.20 0.0.0.3 area 10
network 172.16.253.24 0.0.0.3 area 10
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 60 0
password tccutfpr
logging synchronous
login
stopbits 1
line aux 0
exec-timeout 60 0
password tccutfpr
logging synchronous
login
stopbits 1
line vty 0 4
exec-timeout 60 0
password tccutfpr
logging synchronous
login
!
!
end
69

Configurao do roteador CE_A2
Current configuration - 1497 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE_A2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Zo2M$sdo/JBy2oz6Vs2MwtoLo01
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 172.16.253.26 255.255.255.252
serial restart-delay 0
no fair-queue
!
interface Serial1/1
description CE_A2 -> PE2
bandwidth 128
ip address 172.16.253.26 255.255.255.252
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
router-id 7.7.7.7
log-adjacency-changes
network 172.16.253.24 0.0.0.3 area 10
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 60 0
password tccutfpr
logging synchronous
login
stopbits 1
line aux 0
exec-timeout 60 0
password tccutfpr
logging synchronous
login
stopbits 1
line vty 0 4
exec-timeout 60 0
password tccutfpr
logging synchronous
login
!
!
end