Você está na página 1de 20

5/8/2014 teleco.com.

br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 1/20
Seo: Tutoriais Banda Larga


Redes MPLS II: Modelo Conceitual 2 BGP/MPLS VPN

Esta seo continua a apresentao iniciada no tutorial parte I das experincias e implementaes que
foram realizadas, recorrendo o emulador GNS3, com o objetivo de estudar algumas caractersticas
fundamentais do MPLS e VPN camada 3 em MPLS.

A fim de facilitar o entendimento, a topologia proposta para anlise do trabalho ser novamente
apresentada conforme foi montada, atravs da ilustrao da figura 1:

Figura 1: Captura da topologia MPLS no GNS3
Fonte: Elaborao do autor, 2010

No cenrio acima, os roteadores usados para simular os equipamentos de ncleo Ps foram o Cisco
7200 com a verso de IOS c7200-jk9s-mz.124-13b.bin. Para os equipamentos PEs foram usados o
modelo Cisco 3725 com a verso de IOS c3725-adventerprisek9-mz.124-15.T5.bin. E para os
equipamentos de acesso ao cliente CEs o modelo Cisco 2691 com a verso de IOS c2691-
adventerprisek9_ivs-mz.124-9.T7.bin. A escolha das verses IOS usadas para formar a topologia foi
outro fator importante. Cada verso possui caractersticas e funcionalidades diferentes, com suporte a
um conjunto especfico de protocolos.

A escolha dos protocolos envolvidos na topologia, como protocolo de encapsulamento, de roteamento,
tneis tambm foi outro fator determinante. O objetivo foi montar toda a rede usando apenas protocolos
no proprietrios, ou seja, a mesma topologia poder ser implementada com roteadores de outros
fabricantes.

J os computadores emulados com o programa Virtual Box, foram usados uma imagem do sistema
operacional Ubuntu verso 10.4 para simular uma operao, gerando trfego pela rede MPLS de um
ponto a outro da rede. E a captura das informaes foi recorrida ao Wireshark em cada ponto ligado a
um par de roteadores.

Em todas as experincias descritas em cada tpico, foram usados os mesmo endereos de IP das
interfaces. Os testes e anlises sero de maneira separada e sequenciada.

Configurao do BGP/MPLS VPN

Nesse tpico ser abordada a constituio de VPNs camada 3 com suporte no MPLS. As configuraes a
seguir so referentes aos roteadores PEs e CEs conforme visto na Figura 20: Captura da topologia
MPLS no GNS3 da seo Modelo Conceitual 1 MPLS com OSPF do tutorial parte I. Da mesma
forma que no caso anterior relatado no tutorial parte I, as configuraes foram realizadas com a ajuda do
emulador GNS3, dando continuidade ao que j foi implementado.

Figura 2: Captura da topologia BGP/MPLS VPN em anlise do GNS3
Fonte: Elaborao do autor, 2010

As configuraes nessa seo restringem-se somente aos roteadores PEs e CEs, os roteadores de
ncleo Ps no precisaro sofrer qualquer alterao no que j foi implementado, j que sua participao
nesse caso prover o transporte dos pacotes rotulados no MPLS. O procedimento de configurao ser
mostrado somente nos roteadores CE1 e PE1, tendo em vista que as configuraes nos roteadores PE2,
CE2, CE3 e CE4, mudaram somente parmetros de endereamento IP conforme as tabelas 4 e 5, como
tambm hostname, senhas, e descriptions.

ROTEADORES SERIAL 0/0 SERIAL 0/1
Portugus
English
Espaol
Home Comentrios Em Debate Tutoriais Imprensa RH Guia de Sites Calendrio Quem Somos Glossrio Digite a palavra OK News Cadastre seu email OK
5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 2/20
PE1 172.16.1.1/30 172.16.1.1/30
PE2 172.16.2.1/30 172.16.2.1/30
Tabela 1: Relao de endereo IP/interface dos roteadores PEs
Fonte: Elaborao do autor, 2010


ROTEADORES SERIAL0/0 FASTEHERNET0/0
CE1 172.16.1.2/30 192.168.1.1/24
CE2 172.16.2.2/30 192.168.2.1/24
CE3 172.16.1.2/30 192.168.1.1/24
CE4 172.16.2.2/30 192.168.2.1/24
Tabela 2: Relao de endereo IP/interface dos roteadores CEs
Fonte: Elaborao do autor, 2010

As configuraes realizadas no PE1 seguem a seguinte sequncia:
Configurao da VRF VPN_A;
Configurao da VRF VPN_B;
Configurao de IP e protocolo para ativao de VPN_A na serial0/0;
Configurao de IP e protocolo para ativao de VPN_B na serial0/1;
Configurao do roteamento BGP;
Configurao do vizinho (loopback do roteador PE2) no BGP;
Configurao do BGP/MPLS VPN IPv4;
Configurao da VRF VPN_A no BGP/VPN;
Configurao da VRF VPN_B no BGP/VPN;
Configurao do roteamento esttico para cada VRF.

Na sequncia dos quadros 1, 2 e 3, pode-se observar que o endereamento IP das VPNs so iguais, e
um no interferir no outro, devido ao comando ip vrf forward vinculado a cada interface de sada para os
roteadores CEs. Em condies normais, sem o uso desse comando, o equipamento acusaria que um
mesmo endereo IP j esta em uso em outra interface no equipamento, recusando o comando ip address
com endereo IP na mesma faixa. Com o uso das VRFs, uma tabela de roteamento virtual montada
para cada uma das VRFs, dando total independncia da tabela de roteamento global do roteador. No
quadro 1 mostra a sequncia de comandos necessria para disponibilizar o recurso de VPN em MPLS
para os roteadores CEs. Em seguida nos quadros 2 e 3, exibido como ficou as configuraes no PE1 e
PE, omitindo alguns comandos que por padro j vem configurado.


ROUTER_PE_1> enable
ROUTER_PE_1# configure terminal
ROUTER_PE_1(config)# ip vrf VPN_A
ROUTER_PE_1(config-vrf)# rd 100:110
ROUTER_PE_1(config-vrf)# route-target export 100:110
ROUTER_PE_1(config-vrf)# route-target import 100:110
ROUTER_PE_1(config-vrf)# ip vrf VPN_B
ROUTER_PE_1(config-vrf)# rd 100:120
ROUTER_PE_1(config-vrf)# route-target export 100:120
ROUTER_PE_1(config-vrf)# route-target import 100:120
ROUTER_PE_1(config-vrf)# interface serial0/0
ROUTER_PE_1(config-if)# description ## ACESSO CE1 ##
ROUTER_PE_1(config-if)# ip vrf forwarding VPN_A
ROUTER_PE_1(config-if)# ip address 172.16.1.1 255.255.255.252
ROUTER_PE_1(config-if)# encapsulation PPP
ROUTER_PE_1(config-if)# no shutdown
ROUTER_PE_1(config-if)# interface serial0/1
ROUTER_PE_1(config-if)# description ## ACESSO CE2 ##
ROUTER_PE_1(config-if)# ip vrf forwarding VPN_B
ROUTER_PE_1(config-if)# ip address 172.16.1.1 255.255.255.252
ROUTER_PE_1(config-if)# encapsulation PPP
ROUTER_PE_1(config-if)# no shutdown
ROUTER_PE_1(config-if)# router bgp 100
ROUTER_PE_1(config-router)# neighbor 220.110.90.2 remote-as 100
ROUTER_PE_1(config-router)# neighbor 220.110.90.2 update-source Loopback0
ROUTER_PE_1(config-router)# neighbor 220.110.90.2 next-hop-self
ROUTER_PE_1(config-router)# no auto-summary
ROUTER_PE_1(config-router)# no synchronization
ROUTER_PE_1(config-router)# address-family ipv4
ROUTER_PE_1(config-router-af)# neighbor 220.110.90.2 activate
ROUTER_PE_1(config-router-af)# neighbor 220.110.90.2 send-community both
ROUTER_PE_1(config-router-af)# exit-address-family
ROUTER_PE_1(config-router)# address-family ipv4 vrf VPN_A
ROUTER_PE_1(config-router-af)# redistribute connected
ROUTER_PE_1(config-router-af)# redistribute static
ROUTER_PE_1(config-router-af)# no synchronization
ROUTER_PE_1(config-router-af)# exit-address-family
ROUTER_PE_1(config-router-af)# exit-address-family
ROUTER_PE_1(config-router)# address-family ipv4 vrf VPN_B
ROUTER_PE_1(config-router-af)# redistribute connected
ROUTER_PE_1(config-router-af)# redistribute static
ROUTER_PE_1(config-router-af)# no synchronization
ROUTER_PE_1(config-router-af)# exit-address-family
ROUTER_PE_1(config-router)# exit
ROUTER_PE_1(config)# ip route vrf VPN_A 192.168.1.0 255.255.255.0 172.16.1.2
ROUTER_PE_1(config)# ip route vrf VPN_B 192.168.1.0 255.255.255.0 172.16.1.2


Quadro 1: Configurao de VPN MPLS no PE1
5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 3/20
Fonte: Elaborao do autor, 2010


ROUTER_PE_1#show running-config
!
ip vrf VPN_A
rd 100:110
route-target export 100:110
route-target import 100:110
!
ip vrf VPN_B
rd 100:120
route-target export 100:120
route-target import 100:120
!
interface Loopback0
ip address 220.110.90.1 255.255.255.255
!
interface FastEthernet0/0
description ## ACESSO P2 ##
ip address 220.110.90.10 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
!
interface Serial0/0
description ## ACESSO CE1 ##
ip vrf forwarding VPN_A
ip address 172.16.1.1 255.255.255.252
encapsulation ppp
clock rate 128000
!
interface FastEthernet0/1
description ## ACESSO P1 ##
ip address 220.110.90.14 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
!
interface Serial0/1
description ## ACESSO CE3 ##
ip vrf forwarding VPN_B
ip address 172.16.1.1 255.255.255.252
encapsulation ppp
clock rate 128000
!


Quadro 2.a: Verificao das configuraes do roteador PE1 (parte inicial)
Fonte: Elaborao do autor, 2010


!
router ospf 1
log-adjacency-changes
network 220.110.90.1 0.0.0.0 area 0
network 220.110.90.10 0.0.0.0 area 0
network 220.110.90.14 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 220.110.90.2 remote-as 100
neighbor 220.110.90.2 update-source Loopback0
neighbor 220.110.90.2 next-hop-self
no auto-summary
!
address-family vpnv4
neighbor 220.110.90.2 activate
neighbor 220.110.90.2 send-community both
exit-address-family
!
address-family ipv4 vrf VPN_B
redistribute connected
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf VPN_A
redistribute connected
redistribute static
no synchronization
exit-address-family
!
ip forward-protocol nd
ip route vrf VPN_A 192.168.1.0 255.255.255.0 172.16.1.2
ip route vrf VPN_B 192.168.1.0 255.255.255.0 172.16.1.2
!
5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 4/20

Quadro 2.b: Verificao das configuraes do roteador PE1 (parte final)
Fonte: Elaborao do autor, 2010



ROUTER_PE_2#show running-config
!
ip vrf VPN_A
rd 100:110
route-target export 100:110
route-target import 100:110
!
ip vrf VPN_B
rd 100:120
route-target export 100:120
route-target import 100:120
!
interface Loopback0
ip address 220.110.90.2 255.255.255.255
!
interface FastEthernet0/0
description ## ACESSO P2 ##
ip address 220.110.90.18 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
!
interface Serial0/0
description ## ACESSO CE2 ##
ip vrf forwarding VPN_A
ip address 172.16.2.1 255.255.255.252
encapsulation ppp
clock rate 128000
!
interface FastEthernet0/1
description ## ACESSO P1 ##
ip address 220.110.90.22 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
!
interface Serial0/1
description ## ACESSO CE4 ##
ip vrf forwarding VPN_B
ip address 172.16.2.1 255.255.255.252
encapsulation ppp
clock rate 128000
!

Quadro 3.a: Verificao das configuraes do roteador PE2 (parte inicial)


!
router ospf 1
log-adjacency-changes
network 220.110.90.2 0.0.0.0 area 0
network 220.110.90.18 0.0.0.0 area 0
network 220.110.90.22 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 220.110.90.1 remote-as 100
neighbor 220.110.90.1 update-source Loopback0
neighbor 220.110.90.1 next-hop-self
no auto-summary
!
address-family vpnv4
neighbor 220.110.90.1 activate
neighbor 220.110.90.1 send-community both
exit-address-family
!
address-family ipv4 vrf VPN_B
redistribute connected
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf VPN_A
redistribute connected
redistribute static
no synchronization
exit-address-family
!
ip forward-protocol nd
ip route vrf VPN_A 192.168.2.0 255.255.255.0 172.16.2.2
ip route vrf VPN_B 192.168.2.0 255.255.255.0 172.16.2.2
5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 5/20
!

Quadro 3.b: Verificao das configuraes do roteador PE2 (parte final)
Fonte: Elaborao do autor, 2010

Nos quadros 2 e 3, verificou-se como ficou as configuraes dos roteadores PE1 e PE2. Essas
configuraes garantem o acesso isolado dos roteadores CEs, onde o CE1 e CE2 fazem parte da VPN_A
e o CE3 e CE4 da VPN_B. Foi observado tambm que tanto a VPN_A quanto a VPN_B possuem as
mesmas caractersticas. Elas no precisariam necessariamente ser configuradas com as faixas IPs iguais,
mas foram configurados dessa maneira com a inteno de mostrar como uma rede no sobrepe outra.
No quadro 4 o mesmo procedimento foi realizado com os roteadores CEs.


Router>enable
Router# configure terminal
Router(config)#enable secret Ce1!+mp*
Router(config)#hostname ROUTER_CE_1
ROUTER_CE_1(config)# interface serial0/0
ROUTER_CE_1(config-if)# description ## ACESSO PE1 ##
ROUTER_CE_1(config-if)# ip address 172.16.1.2 255.255.255.252
ROUTER_CE_1(config-if)# encapsulation ppp
ROUTER_CE_1(config-if)# bandwidth 128
ROUTER_CE_1(config-if)# no shutdown
ROUTER_CE_1(config-if)# interface fastethernet0/0
ROUTER_CE_1(config-if)# description ## REDE LOCAL ##
ROUTER_CE_1(config-if)# ip address 192.168.1.1 255.255.255.0
ROUTER_CE_1(config-if)# no shutdown
ROUTER_CE_1(config-if)# ip dhcp pool host1
ROUTER_CE_1(dhcp-config)# network 192.168.1.0 255.255.255.0
ROUTER_CE_1(dhcp-config)# default-router 192.168.1.1 255.255.255.0
ROUTER_CE_1(dhcp-config)# exit
ROUTER_CE_1(config)# ip route 0.0.0.0 0.0.0.0 172.16.1.1

Quadro 4: Configuraes do CE1
Fonte: Elaborao do autor, 2010

Na configurao do roteador CE1 seguiu a seguinte sequncia:
Configurao de IP e protocolo para ativao da interface serial0/0;
Configurao de IP para ativao da interface fastehernet0/0;
Configurao do protocolo DHCP;
Configurao da rota esttica.

Foi adotado o DHCP (Dynamic Host Configuration Protocol), para dar mais comodidade ao usurio final,
j que esse protocolo proporciona a distribuio dinmica de IPs para a rede, nesse. A mesma
configurao foi inserida nos demais roteadores CEs, mudando apenas os parmetros de
endereamento IP nas interfaces, rotas e no DHCP, conforme a tabela 5. Nos quadros 5, 6, 7 e 8
verificou-se como ficaram as configuraes nos CEs.


ROUTER_CE_1#show running-config
!
hostname ROUTER_CE_1
!
ip dhcp pool rede_local
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
description ## REDE LOCAL ##
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
description ## ACESSO PE1 ##
bandwidth 128
ip address 172.16.1.2 255.255.255.252
encapsulation ppp
!
ip route 0.0.0.0 0.0.0.0 172.16.1.1
!
d

Quadro 5: Verificao das configuraes do CE1
Fonte: Elaborao do autor, 2010



ROUTER_CE_2#show running-config
!
ip dhcp pool rede_local
network 192.168.2.0 255.255.255.0
default-router 192.268.2.1 255.255.255.0
!
interface FastEthernet0/0
description ## REDE LOCAL ##
ip address 192.168.2.1 255.255.255.0
duplex auto
5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 6/20
speed auto
!
interface Serial0/0
description ## ACESSO PE2 ##
bandwidth 128
ip address 172.16.2.2 255.255.255.252
encapsulation ppp
!
ip route 0.0.0.0 0.0.0.0 172.16.2.1
!

Quadro 6: Verificao das configuraes do CE2
Fonte: Elaborao do autor, 2010



ROUTER_CE_3#show running-config
!
ip dhcp pool rede_local
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
description ## REDE LOCAL ##
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
description ## ACESSO PE1 ##
bandwidth 128
ip address 172.16.1.2 255.255.255.252
encapsulation ppp
!
ip route 0.0.0.0 0.0.0.0 172.16.1.1
!


Quadro 7: Verificao das configuraes do CE3
Fonte: Elaborao do autor, 2010



ROUTER_CE_4#show running-config
!
ip dhcp pool rede_local
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0
description ## REDE LOCAL ##
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
description ## ACESSO PE2 ##
bandwidth 128
ip address 172.16.2.2 255.255.255.252
encapsulation ppp
!
ip route 0.0.0.0 0.0.0.0 172.16.2.1
!

Quadro 8: Verificao das configuraes do CE4
Fonte: Elaborao do autor, 2010

Como na seo anterior, algumas configuraes foram omitidas pelo fato de j virem configuradas por
padro nos equipamentos. Foi exibido o que de fato necessrio para o funcionamento.

Testes e Anlise do BGP/MPLS VPNs

Com os roteadores PEs e CEs devidamente configurados, o prximo passo foi verificar o funcionamento
e parmetros relevantes quanto ao funcionamento das VPNs em redes MPLS. Primeiro foi verificado as
informaes sobre o roteamento nos roteadores PE1 e PE2. No quadro 9 segue as informaes obtidas
com a sada do comando show ip router no roteador PE1.


ROUTER_PE_1#show ip route
-- Omitido --
Gateway of last resort is not set

220.110.90.0/24 is variably subnetted, 8 subnets, 2 masks
C 220.110.90.8/30 is directly connected, FastEthernet0/0
C 220.110.90.12/30 is directly connected, FastEthernet0/1
C 220.110.90.1/32 is directly connected, Loopback0
O 220.110.90.2/32 [110/3] via 220.110.90.13, 08:20:46, FastEthernet0/1
[110/3] via 220.110.90.9, 08:21:17, FastEthernet0/0
O 220.110.90.3/32 [110/2] via 220.110.90.13, 08:20:46, FastEthernet0/1
O 220.110.90.4/32 [110/2] via 220.110.90.9, 08:21:17, FastEthernet0/0
5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 7/20
O 220.110.90.16/30 [110/2] via 220.110.90.9, 08:21:17, FastEthernet0/0
O 220.110.90.20/30 [110/2] via 220.110.90.13, 08:20:46, FastEthernet0/1

Quadro 9: Verificao da tabela de roteamento do PE1
Fonte: Elaborao do autor, 2010

Observou-se na sada do comando show ip route, que na tabela de roteamento consta apenas os
endereos IPs globais, usados para a comunicao entre os roteadores Ps e PEs. Informaes sobre os
endereos de IPs usados nas VPNs no so apresentados na sada desse comando. Isso acontece
devido a capacidade que o VRF tem em isolar o roteamento usado nas VPNs, dos demais roteamentos
do equipamento. Na sada do comando show ip router vrf VPN_A e show ip router VPN_B, essa histria
muda, apresentando uma nova tabela de roteamento para cada VFR designada conforme os quadros 10
e 11.


ROUTER_PE_1#show ip route vrf VPN_A
-- Omitido --
Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
B 172.16.2.2/32 [200/0] via 220.110.90.2, 08:26:54
C 172.16.1.0/30 is directly connected, Serial0/0
B 172.16.2.0/30 [200/0] via 220.110.90.2, 08:26:54
C 172.16.1.2/32 is directly connected, Serial0/0
S 192.168.1.0/24 [1/0] via 172.16.1.2
B 192.168.2.0/24 [200/0] via 220.110.90.2, 08:26:54

Quadro 10: Verificao da tabela de roteamento da vrf VPN_A no PE1
Fonte: Elaborao do autor, 2010



ROUTER_PE_1#show ip route vrf VPN_B
-- Omitido --
Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
B 172.16.2.2/32 [200/0] via 220.110.90.2, 08:30:01
C 172.16.1.0/30 is directly connected, Serial0/1
B 172.16.2.0/30 [200/0] via 220.110.90.2, 08:30:01
C 172.16.1.2/32 is directly connected, Serial0/1
S 192.168.1.0/24 [1/0] via 172.16.1.2
B 192.168.2.0/24 [200/0] via 220.110.90.2, 08:30:01

Quadro 11: Verificao da tabela de roteamento da vrf VPN_B no PE1
Fonte: Elaborao do autor, 2010

As linhas que precedem com B indica que para chegar nessa rede ser preciso passar pelo BGP. O S
so as rotas estticas usadas para o roteamento com os CEs, e o C como j foi visto, so as redes
diretamente conectadas as interfaces. Informaes sobre o roteamento das VPNs pode ser obtido
atravs do comando show ip bgp vpnv4 all, conforme mostrado no quadro abaixo.



ROUTER_PE_1#show ip bgp vpnv4 all
BGP table version is 25, local router ID is 220.110.90.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:110 (default for vrf VPN_A)
*> 172.16.1.0/30 0.0.0.0 0 32768 ?
*> 172.16.1.2/32 0.0.0.0 0 32768 ?
*>i172.16.2.0/30 220.110.90.2 0 100 0 ?
*>i172.16.2.2/32 220.110.90.2 0 100 0 ?
*> 192.168.1.0 172.16.1.2 0 32768 ?
*>i192.168.2.0 220.110.90.2 0 100 0 ?
Route Distinguisher: 100:120 (default for vrf VPN_B)
*> 172.16.1.0/30 0.0.0.0 0 32768 ?
*> 172.16.1.2/32 0.0.0.0 0 32768 ?
*>i172.16.2.0/30 220.110.90.2 0 100 0 ?
*>i172.16.2.2/32 220.110.90.2 0 100 0 ?
*> 192.168.1.0 172.16.1.2 0 32768 ?
*>i192.168.2.0 220.110.90.2 0 100 0 ?


Quadro 12: Verificao da tabela de roteamento VPNv4 do BGP no PE1
Fonte: Elaborao do autor, 2010

Nas informaes mostradas no quadro 12, possvel ver todas as sadas das VRFs no BGP, como
tambm a redistribuio para as rotas estticas usadas paca a comunicao fim a fim dos CEs. Pode-se
ver tambm que as redes que no contm a sigla i de internal, so os IPs referentes aos endereo de
WAN e LAN dos roteadores CE1 e CE3, que no esto configuradas nos equipamentos PEs, e sim
previstas no roteamento esttico. No roteador PE2 o mesmo ocorre s que referentes aos endereos de
WAN e LAN dos roteadores CE2 e CE4, conforme o quadro 13.


ROUTER_PE_2#show ip bgp vpnv4 all
5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 8/20
BGP table version is 25, local router ID is 220.110.90.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:110 (default for vrf VPN_A)
*>i172.16.1.0/30 220.110.90.1 0 100 0 ?
*>i172.16.1.2/32 220.110.90.1 0 100 0 ?
*> 172.16.2.0/30 0.0.0.0 0 32768 ?
*> 172.16.2.2/32 0.0.0.0 0 32768 ?
*>i192.168.1.0 220.110.90.1 0 100 0 ?
*> 192.168.2.0 172.16.2.2 0 32768 ?
Route Distinguisher: 100:120 (default for vrf VPN_B)
*>i172.16.1.0/30 220.110.90.1 0 100 0 ?
*>i172.16.1.2/32 220.110.90.1 0 100 0 ?
*> 172.16.2.0/30 0.0.0.0 0 32768 ?
*> 172.16.2.2/32 0.0.0.0 0 32768 ?
*>i192.168.1.0 220.110.90.1 0 100 0 ?
*> 192.168.2.0 172.16.2.2 0 32768 ?

Quadro 13: Verificao da tabela de roteamento VPNv4 do BGP no PE2
Fonte: Elaborao do autor, 2010

Da mesma forma que o roteador no consegue visualizar os IPs das VPNs na sua tabela de roteamento
principal, tambm no conseguir receber respostada dos pacotes emitidos diretamente para esses IPs,
conforme teste abaixo.


ROUTER_PE_1#ping 172.16.1.1 repeat 50

Type escape sequence to abort.
Sending 50, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
..................................................
Success rate is 0 percent (0/50)


Quadro 14: Teste com pacotes ICMP para o ip da VPN_A do PE1
Fonte: Elaborao do autor, 2010

No quadro 14 pode-se observar que apesar do endereo IP 172.16.1.1 estar configurado na interface
serial0/0 do prprio roteador PE1, foram disparados 50 pacotes ICMP com 100% de perda. Isso mostra
que as redes das VRFs esto de fato isoladas do restante das redes. Para o PE1 poder realizar esse
teste, o comando ping precisa fazer uma chamada na VRF correspondente a rede. Abaixo o comando
usado para esse teste.


ROUTER_PE_1#ping vrf VPN_A 172.16.1.1 repeat 50

Type escape sequence to abort.
Sending 50, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (50/50), round-trip min/avg/max = 4/25/76 ms


Quadro 15: Teste com pacotes ICMP para o IP da VPN_A do PE1
Fonte: Elaborao do autor, 2010

Outro fator importante a ser analisado foi a tabela de encaminhamento dos rtulos MPLS. Como agora
novas redes foram atribudas aos roteadores PEs, a tabela MPLS sofreu alteraes conforme a sada do
comando show mpls forwarding-table, verificado nos dois roteadores PEs.


ROUTER_PE_1#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 220.110.90.4/32 0 Fa0/0 220.110.90.9
17 Pop tag 220.110.90.3/32 0 Fa0/1 220.110.90.13
18 19 220.110.90.2/32 0 Fa0/1 220.110.90.13
17 220.110.90.2/32 0 Fa0/0 220.110.90.9
19 Pop tag 220.110.90.16/30 0 Fa0/0 220.110.90.9
20 Pop tag 220.110.90.20/30 0 Fa0/1 220.110.90.13
21 Aggregate 172.16.1.0/30[V] 0
22 Untagged 172.16.1.2/32[V] 0 Se0/0 point2point
23 Untagged 192.168.1.0/24[V] 0 Se0/0 point2point
24 Aggregate 172.16.1.0/30[V] 0
25 Untagged 172.16.1.2/32[V] 0 Se0/1 point2point
26 Untagged 192.168.1.0/24[V] 0 Se0/1 point2point

Quadro 16: Sada do comando show mpls forwarding-table do PE1
Fonte: Elaborao do autor, 2010

Conforme as informaes mostradas no quadro 16, a tabela de encaminhamento dos rtulos MPLS
sofreu alteraes quando comparada ao quadro 12 da seo Modelo Conceitual 1 MPLS com OSPF
do tutorial parte I. Para cada rede associada a uma VRFs, foi adicionado um novo rtulo. Observado
tambm que, mesmo contendo endereos IPs iguais, o mecanismo de encaminhamento MPLS tratar de
maneira diferenciada cada rede, tendo como base a associao das VRFs em cada interface. O
parmetro Aggregate significa que para esse prefixo, o rtulo ser removido do pacote, e ento ser feito
uma consulta na tabela de roteamento (nesse caso a tabela de roteamento da VRF). J o Untagged,
indica que o rtulo ser removido e encaminhado para o prximo salto. Os endereos 172.16.1.2/32 e
5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 9/20
192.168.1.0/24, pertencem a roteadores CEs, no farem parte da rede MPLS, portanto no participaram
do processo LDP do MPLS.

Da mesma forma como foi mostrado no quadro 16, no quadro 17 as mesmas informaes foram
coletadas s que desta vez no ilustrando a sada no roteador PE2.


ROUTER_PE_2#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 220.110.90.4/32 0 Fa0/0 220.110.90.17
17 Pop tag 220.110.90.3/32 0 Fa0/1 220.110.90.21
18 18 220.110.90.1/32 0 Fa0/1 220.110.90.21
16 220.110.90.1/32 0 Fa0/0 220.110.90.17
19 Pop tag 220.110.90.8/30 0 Fa0/0 220.110.90.17
20 Pop tag 220.110.90.12/30 0 Fa0/1 220.110.90.21
21 Aggregate 172.16.2.0/30[V] 0
22 Untagged 172.16.2.2/32[V] 0 Se0/0 point2point
23 Untagged 192.168.2.0/24[V] 0 Se0/0 point2point
24 Aggregate 172.16.2.0/30[V] 0
25 Untagged 172.16.2.2/32[V] 0 Se0/1 point2point
26 Untagged 192.168.2.0/24[V] 0 Se0/1 point2point

Quadro 17: Sada do comando show mpls forwarding-table do PE2
Fonte: Elaborao do autor, 2010

Depois de verificar o funcionamento da arquitetura BGP/VPN MPLS nos roteadores PEs, verificou-se
tambm o funcionamento entre os roteadores CEs. No quadro 18 mostra o resultado dos testes
realizados com pacotes ICMP disparados do roteador CE1 para o endereo da interface FastEthernet0/0
do CE2, testando a conectividade da VPN_A, e entre CE3 e CE4 testando a conectividade da VPN_B
mostrados no quadro 19.


ROUTER_CE_1#ping 192.168.2.1 repeat 500

Type escape sequence to abort.
Sending 500, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!
Success rate is 100 percent (500/500), round-trip min/avg/max = 4/16/68 ms


Quadro 18: Teste com pacotes ICMP entre o CE1 e CE2
Fonte: Elaborao do autor, 2010



ROUTER_CE_3#ping 192.168.2.1 repeat 500

Type escape sequence to abort.
Sending 500, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!
Success rate is 100 percent (500/500), round-trip min/avg/max = 4/17/92 ms


Quadro 19: Teste com pacotes ICMP entre os roteadores CE3 e CE4
Fonte: Elaborao do autor, 2010

De acordo com os resultados verificados nos quadros 18 e 19, constatou-se que tanto a conectividade
da VPN_A quando da VPN_B est em perfeito funcionamento. Outro fator importante analisado tambm
foi o caminho percorrido entre CE1 e CE2 atravs do comando traceroute, conforme o quadro abaixo.


ROUTER_CE_1#traceroute 192.168.2.1

Type escape sequence to abort.
Tracing the route to 192.168.2.1

1 172.16.1.1 20 msec 12 msec 8 msec
2 220.110.90.13 36 msec 24 msec 16 msec
3 172.16.2.1 12 msec 8 msec 12 msec
4 172.16.2.2 16 msec 32 msec *

Quadro 20: Verificao do caminho entre o CE1 e CE2
Fonte: Elaborao do autor, 2010

5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 10/20
Verificou-se no quadro 20 que o caminho percorrido entre os roteadores CE1 e CE2, conectados na
VPNA : CE1PE1 P1 PE2 CE2.

Apesar do IP pblico 220.110.90.13 referente ao roteador P1 aparecer no caminho percorrido at o CE2,
no possvel pingar nesse equipamento conforme mostrado no quadro 21.


ROUTER_CE_1#ping 220.110.90.13 repeat 50

Type escape sequence to abort.
Sending 50, 100-byte ICMP Echos to 220.110.90.13, timeout is 2 seconds:
U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.U.
Success rate is 0 percent (0/50)

Quadro 21: Verificao do caminho entre o CE1 e CE2
Fonte: Elaborao do autor, 2010

O retorno U significa nesse caso, que os pacotes esto sendo transmitidos do roteador CE1, porm o
roteador P1 no tem uma entrada na tabela de roteamento para retornar o pacote. Isso mostra que a
conexo da VPN de fato est isolada.

Sabendo-se que o caminho percorrido CE1PE1 P1 PE2 CE2, foi verificado como os protocolos
de roteamento fazem a convergncia de rota em caso de falhas.

No exemplo apresentado no quadro 22 foi provocado uma falha no P1 , colocando em shutdown a
interface FastEthernet1/1 que da acesso ao PE1, logo aps disparar os pacotes do CE1 para o C2.
Segue o teste abaixo:


ROUTER_CE_1#ping 192.168.2.1 repeat 500

Type escape sequence to abort.
Sending 500, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!...!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!
Success rate is 99 percent (497/500), round-trip min/avg/max = 1/17/60 ms

Quadro 22: Teste com pacotes ICMP entre o CE1 e CE2
Fonte: Elaborao do autor, 2010



ROUTER_P_1> enable
ROUTER_P_1# configure-terminal
ROUTER_P_1(config)# interface fastEthernet 1/1
ROUTER_P_1(config-if)# shutdown
ROUTER_P_1(config-if)#
*Nov 1 03:54:42.498: %OSPF-5-ADJCHG: Process 1, Nbr 220.110.90.1 on
FastEthernet1/1 from FULL to DOWN, Neighbor Down: Interface down or detached
*Nov 1 03:54:42.518: %LDP-5-NBRCHG: LDP Neighbor 220.110.90.1:0 (1) is
DOWN (Interface not operational)
*Nov 1 03:54:44.474: %LINK-5-CHANGED: Interface FastEthernet1/1, changed
state to administratively down
*Nov 1 03:54:44.478: %ENTITY_ALARM-6-INFO: ASSERT INFO Fa1/1 Physical
Port Administrative State Down
*Nov 1 03:54:45.474: %LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet1/1, changed state to down

Quadro 23: Provocamento de falha na interface FastEhernet1/1 P1
Fonte: Elaborao do autor, 2010



ROUTER_CE_1#traceroute 192.168.2.1

Type escape sequence to abort.
Tracing the route to 192.168.2.1

1 172.16.1.1 12 msec 16 msec 4 msec
2 220.110.90.9 12 msec 16 msec 16 msec
3 172.16.2.1 8 msec 32 msec 72 msec
4 172.16.2.2 16 msec 28 msec *

Quadro 24: Verificao do caminho entre o CE1 e CE2 aps falha provocado no P1
Fonte: Elaborao do autor, 2010

Pode-se observar que a topologia proposta para analise, configurada com os protocolos de roteamento
OSPF (para comunicao da nuvem pblica) e BGP (para comunicao das VPNs em nuvem privada),
reagiu com rapidez falha. No quadro 21, observou-se que apenas 3 pacotes foram perdidos dos 500
disparados, isso devido ao poder de convergncia que o protocolo OSPF oferece. Posteriormente no
quadro 24 foi realizado novamente o comando traceroute, e mostrou que a converso da rota para o IP
220.110.90.9 do roteador P2, foi realizado com sucesso, traando a rota CE1PE1 P2 PE2 CE2.

5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 11/20
Testes com Virtual Box

Os testes realizados nesse tpico tiveram um ponto de vista do usurio final. Para esse teste foi recorrido
ao Virtual Box. O sistema operacional virtualizado foi Ubuntu 10.4 nos computadores C1 e C2 aos
roteadores CE1 e CE2, realizando testes e gerando trfego atravs da rede. O protocolo usado para
esse fim foi o FTP (File Transfer Protocol).

O FTP um dos protocolos mais usados para transferncia de arquivos na rede. Para melhor ilustrar o
processo de login e transferncia do arquivo, o servio HTTP (Hypertext Transfer Protocol) tambm foi
usado. O HTTP usado para comunicao de sites. Todos os dois servios foram disponibilizados no
computador C2 conectado a interface FastEthernet0/0 do roteador CE2.

As figuras 3 e 4 mostram como ficaram as configuraes de endereamento IP dos computadores C1 e
C2. Na figura 5 foi realizado teste de conectividade, onde foram disparados 20 pacotes ICMP do C1 para
o C2, e na figura 6 disparados do C2 para o C1. J nas figuras 7 e 8, foi mostrado o caminho percorrido
pelo pacote para chegar de um ponto a outro na rede.

E por fim nas figuras 9, 10 e 11, exibem respectivamente o processo de login no servidor FTP do
computador C2, selecionamento do arquivo a ser transferido e a transferncia do arquivo.

Figura 3: Verificao das configuraes de endereo IP no C1
Fonte: Elaborao do autor, 2010


Figura 4: Verificao das configuraes de endereo IP no C2
Fonte: Elaborao do autor, 2010


5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 12/20
Figura 5: Teste de conectividade com pacote ICMP entre C1 e C2
Fonte: Elaborao do autor, 2010


Figura 6: Teste de conectividade com pacote ICMP entre C2 e C1
Fonte: Elaborao do autor, 2010


5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 13/20
Figura 7: Caminho percorrido entre C1 e C2
Fonte: Elaborao do autor, 2010


Figura 8: Caminho percorrido entre C2 e C1
Fonte: Elaborao do autor, 2010


5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 14/20
Figura 9: C1 efetuando login FTP no C2
Fonte: Elaborao do autor, 2010


Figura 10: Selecionamento do arquivo para transferncia
Fonte: Elaborao do autor, 2010


5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 15/20
Figura 11: Transferindo arquivo do C2 para C1
Fonte: Elaborao do autor, 2010

Aps a realizao de todos os teste entre roteadores Ps, PEs e CEs na topologia proposta, nesse tpico
pode-se observar que da mesma forma os computadores C1 e C2, ligados respectivamente nos
roteadores CE1 e CE2, comunicaram-se de um ponto a outro da rede sem problemas. As informaes
trafegadas na rede foram coletadas com o Wireshark para anlise no prximo tpico.

Anlises com o Wireshark

Com base nas informaes extradas nos tpicos anteriores referentes ao BGP/MPLS VPN, foram
analisadas alguns pacotes relevantes ao tema. A seguir foram capturados alguns pacotes recorrendo ao
Wireshark.

Figura 12: Captura dos pacotes BGP entre o n P1 e PE1
Fonte: Elaborao do autor, 2010

Na figura 12, observou-se que logo aps o estabelecimento do OSPF, os pacotes BGP comeam a ser
enviados na rede com o finalidade de encontrar vizinhos. No pacote 129, pode verificar que trata-se de
uma mensagem OPEN, usado para iniciar uma sesso BGP. Em destaque, no cabealho MPLS o campo
Label j est rotulado com o valor 20. Assim como no OSPF e LDP, a identificao do BGP tambm
associada ao endereo IP da interface loopback, nesse caso 220.110.90.1.

Logo abaixo em destaque, dentro do campo Capabilities Advertisement, a extenso Multiprotocol do
protocolo BGP j aparece agregado a mensagem. Dentro desse campo onde so transportadas
informaes de VPN IPv4 address-family , visto com mais detalhes na figura 13.

5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 16/20
Figura 13: Captura do pacote BGP entre o n P1 e PE1
Fonte: Elaborao do autor, 2010

O pacote 170 mostrado na figura 13 trata de uma mensagem tipo UPDATE. Nesse pacote a extenso
Multiprotocol do BGP aparece com mais detalhes. O atributo MP_REACH_NLRI, contm todas as
informaes referentes VPN_A do roteador PE1. Sabe-se disso pela identificao do RD com os
valores 100:110 . Na configurao dos roteadores PE1 e PE2 esses valores so associados a uma vrf
(com o comando ip vrf VPN_A). Observou-se tambm que para cada prefixo de endereo IP foi atribuda
a um rtulo diferente, conforme j visto anteriormente no quadro 15.

Figura 14: Captura do pacote BGP entre o n P1 e PE1
Fonte: Elaborao do autor, 2010

J no pacote 171 da figura 14, observou-se na mensagem UPDATE que tambm possuiu informaes
sobre a extenso Multiprotocol do BGP, s que agora referente ao encaminhamento da VPN_B,
constatada pela identificao do RD 100:120. Da mesma forma como aconteceu com a VPN_A, na
VPN_B foram atribudos diferentes valores de rtulos para cada prefixo de endereo IP. Assim, cada
pacote destinado esses endereos da VPN_B (neste caso), recebero uma etiqueta, otimizando o
trfego durante a passagem na rede. Nas figuras abaixo segue exemplos da marcao em diferentes
tipos de trfego.

5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 17/20
Figura 15: Captura do pacote ICMP entre o n P1 e PE1
Fonte: Elaborao do autor, 2010

Como exemplo do trfego entre host host, temos o a captura do pacote 231. Esse pacote do tipo
ICMP, usado para testar a conectividade da rede. Foram aproveitados os testes do tpico anterior, para
coletar informaes relevantes ao funcionamento da BGP/MPLS VPN. Pode-se observar que o pacote
ICMP foi rotulado com o valor 23 com destino ao endereo 192.168.1.2. Com base na figura 12, conclui-
se que de fato esse pacote est sendo encaminhado VPN_A, j que a RD 100:110 est vinculada a vrf
VPN_A do roteador PE1.

Figura 16: Captura do pacote FTP entre o n P1 e PE1
Fonte: Elaborao do autor, 2010

No pacote 499 da figura 16, o destino e o rtulo so os mesmo do exemplo anterior, com a diferena que
agora trata-se de um pacote FTP. Como ilustrado no teste de transferncia da figura 10, o computador
CE1 fez uma solicitao para transferir um determinado arquivo. Conforme observado acima, o sentido
do trfego C2 para C1, de acordo com a captura no campo Source e Destination.



5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 18/20
5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 19/20
5/8/2014 teleco.com.br
http://www.teleco.com.br/tutoriais/tutorialmplscam2/pagina_2.asp 20/20
2014 Teleco Aspectos Legais :: Privacidade :: Nossa Proposta :: Fale Conosco :: Anuncie no Teleco