Você está na página 1de 9

Algoritmos - 2 Lista de Algoritmos ( Repetio)

I Ler 300 nmeros e mostrar a mdias dos nmeros maiores ou iguais a 1000 e menores que 2000.
II - Ler vrios nmeros e mostrar a mdias dos nmeros maiores ou iguais a 1000 e menores que 2000. Parar de ler
quando um nmero negativo for digitado. Usar a estrutura enquanto.
III - Ler vrios nmeros e mostrar a mdias dos nmeros maiores ou iguais a 1000 e menores que 2000. Parar de ler
quando um nmero negativo for digitado. Usar a estrutura repita.
IV Ler a quantidade de camisas, calas e pares de meias que vrios clientes levam para uma lavanderia. Para cada
conjunto de valores lidos, calcular quanto cada cliente deve pagar. Parar de ler quando todos os trs itens tiverem
quantidade zero. Ao final da leitura, indicar, quantas camisas, calas e pares de meia foram levados at a lavanderia. A
lavagem de camisas custa R$ 8,5 por unidade, a lavagem de calas custa R$ 12,00 por unidade e os pares de meia custam
R$ 2,00. Usar a estrutura enquanto.
V Ler a quantidade de camisas, calas e pares de meias que vrios clientes levam para uma lavanderia. Para cada
conjunto de valores lidos, calcular quanto cada cliente deve pagar. Parar de ler quando todos os trs itens tiverem
quantidade zero ou negativa. Ao final da leitura, indicar, quantas camisas, calas e pares de meia foram levados at a
lavanderia. A lavagem de camisas custa R$ 8,5 por unidade, a lavagem de calas custa R$ 12,00 por unidade e os pares de
meia custam R$ 2,00. custam Usar a estrutura repita.
VI Ler a idade e o salrio de 1340 pessoas. Ao final, mostrar quantas pessoas tem mais de 30 anos e mostrar tambm
quantas pessoas tem mais de 50 anos e ganham entre R$ 4000 e R$ 6000.
VII Ler a idade e o salrio para vrias pessoas. Ao final, mostrar quantas pessoas tem mais de 30 anos e mostrar
tambm quantas pessoas tem mais de 50 anos e ganham entre R$ 4000 e R$ 6000. Parar de ler quando uma idade
negativa ou 0 for digitada. Usar a estrutura enquanto.
VIII Ler a idade e o salrio para vrias pessoas. Ao final, mostrar quantas pessoas tem mais de 30 anos e mostrar
tambm quantas pessoas tem mais de 50 anos e ganham entre R$ 4000 e R$ 6000. Parar de ler quando uma idade
negativa ou 0 for digitada. Usar a estrutura repita.
IX Perguntar para 1600 pessoas se elas possuem animais de estimao. Ao final, mostrar ( na forma de percentual )
quantas possuem e quantas no possuem animais de estimao.

1 de 9

Algoritmos - 2 Lista de Algoritmos ( Repetio)

Respostas

( verso preliminar )

I Ler 300 nmeros e mostrar a mdias dos nmeros maiores ou iguais a 1000 e menores que 2000.
R:
incio.

inteiro : contador, numero, soma, qtd;


real : media ;
soma 0;

qtd 0;

para contador de 1 at 300 passo +1 faa


imprima ( "Informe um numero:");
leia ( numero );
se ( numero >= 1000 e numero < 2000 )
ento
soma soma + numero;
qtd qtd + 1;
fim_se;
fim_para;
media soma / qtd ;
imprima ( "Media: ", media );
fim.

II - Ler vrios nmeros e mostrar a mdias dos nmeros maiores ou iguais a 1000 e menores que 2000. Parar de ler
quando um nmero negativo for digitado. Usar a estrutura enquanto.
R:
incio.

inteiro : contador, numero, soma, qtd;


real : media ;
soma 0;

qtd 0;

enquanto ( numero >= 0 ) faa


imprima ( "Informe um numero:");
leia ( numero );
se ( numero >= 1000 e numero < 2000 )
ento
soma soma + numero;
qtd qtd + 1;
fim_se;
fim_enquanto;
media soma / qtd ;
imprima ( "Media: ", media );
fim.

2 de 9

Algoritmos - 2 Lista de Algoritmos ( Repetio)

III - Ler vrios nmeros e mostrar a mdias dos nmeros maiores ou iguais a 1000 e menores que 2000. Parar de ler
quando um nmero negativo for digitado. Usar a estrutura repita.
R: incio.
inteiro : contador, numero, soma, qtd;
real : media ;
soma 0;

qtd 0;

repita
imprima ( "Informe um numero:");
leia ( numero );
se ( numero >= 1000 e numero < 2000 )
ento
soma soma + numero;
qtd qtd + 1;
fim_se;
at ( numero < 0 );
media soma / qtd ;
imprima ( "Media: ", media );
fim.

3 de 9

Algoritmos - 2 Lista de Algoritmos ( Repetio)

IV Ler a quantidade de camisas, calas e pares de meias que vrios clientes levam para uma lavanderia. Para cada
conjunto de valores lidos, calcular quanto cada cliente deve pagar. Parar de ler quando todos os trs itens tiverem
quantidade zero ou negativa. Ao final da leitura, indicar, quantas camisas, calas e pares de meia foram levados at a
lavanderia. A lavagem de camisas custa R$ 8,5 por unidade, a lavagem de calas custa R$ 12,00 por unidade e os pares de
meia custam R$ 2,00. Usar a estrutura enquanto.
R:
incio.

inteiro : qtd_camisas, qtd_calcas, qte_meias, total_camisas, total_calcas, total_meias;


real : total_a_pagar;
qtd_camisas 0; qtd_calcas 0; qte_meias 0 ;
total_camisas 0; total_calcas 0; total_meias 0;
enquanto ( qtd_camisas 0 e qtd_calcas 0 e qte_meias 0 ) faa
imprima ( "Informe a quantidade de camisas:");
leia ( qtd_camisas );
imprima ( "Informe a quantidade de calas:");
leia ( qtd_calcas );
imprima ( "Informe a quantidade de pares de meias:");
leia ( qtd_meias );
total_a_pagar qtd_camisas x 8,5 + qtd_calcas x 12,0 + qte_meias x 2,0 ;
total_camisas total_camisas + qtd_camisas ;
total_calcas total_calcas + qtd_calcas;
total_meias total_meias + qtd_meias;
fim_enquanto;
imprima ( "Total de camisas do dia: ", total_camisas );
imprima ( "Total de calas do dia: ", total_calcas );
imprima ( "Total de pares de meias do dia: ", total_meias );
fim.

4 de 9

Algoritmos - 2 Lista de Algoritmos ( Repetio)

V Ler a quantidade de camisas, calas e pares de meias que vrios clientes levam para uma lavanderia. Para cada
conjunto de valores lidos, calcular quanto cada cliente deve pagar. Parar de ler quando todos os trs itens tiverem
quantidade zero. Ao final da leitura, indicar, quantas camisas, calas e pares de meia foram levados at a lavanderia. A
lavagem de camisas custa R$ 8,5 por unidade, a lavagem de calas custa R$ 12,00 por unidade e os pares de meia custam
R$ 2,00. custam Usar a estrutura repita.
R:
incio.
inteiro : qtd_camisas, qtd_calcas, qte_meias, total_camisas, total_calcas, total_meias;
real : total_a_pagar;
qtd_camisas 0; qtd_calcas 0; qte_meias 0 ;
total_camisas 0; total_calcas 0; total_meias 0;
repita
imprima ( "Informe a quantidade de camisas:");
leia ( qtd_camisas );
imprima ( "Informe a quantidade de calas:");
leia ( qtd_calcas );
imprima ( "Informe a quantidade de pares de meias:");
leia ( qtd_meias );
total_a_pagar qtd_camisas x 8,5 + qtd_calcas x 12,0 + qte_meias x 2,0 ;
total_camisas total_camisas + qtd_camisas ;
total_calcas total_calcas + qtd_calcas;
total_meias total_meias + qtd_meias;
at ( qtd_camisas < 0 e qtd_calcas < 0 e qte_meias < 0 ) ;
imprima ( "Total de camisas do dia: ", total_camisas );
imprima ( "Total de calas do dia: ", total_calcas );
imprima ( "Total de pares de meias do dia: ", total_meias );
fim.

5 de 9

Algoritmos - 2 Lista de Algoritmos ( Repetio)

VI Ler a idade e o salrio de 1340 pessoas. Ao final, mostrar quantas pessoas tem mais de 30 anos e mostrar tambm
quantas pessoas tem mais de 50 anos e ganham entre R$ 4000 e R$ 6000.
R:
incio.

inteiro : contador, idade, qtd_pessoas_mais_30_anos,


qtd_pessoas_mais_50_e_salario_entre_4e5000;
real : salario ;
qtd_pessoas_mais_30_anos 0;
qtd_pessoas_mais_50_e_salario_entre_4e5000 0;
para contador de 1 at 1340 passo +1 faa
imprima ( "Informe a idade:");
leia ( idade );
imprima ( "Informe o salario:");
leia ( salario );
se ( idade > 30 )
ento
qtd_pessoas_mais_30_anos qtd_pessoas_mais_30_anos + 1;
fim_se;
se ( idade > 50 e salario > 4000 e salario < 5000 )
ento
qtd_pessoas_mais_50_e_salario_entre_4e5000
qtd_pessoas_mais_50_e_salario_entre_4e5000 + 1;
fim_se;
fim_para;
imprima ( "Qte de pessoas com mais de 50 anos: ", qtd_pessoas_mais_30_anos );
imprima ( "Qte de pessoas com idade superior a 50 e com salario entre R$ 4000 e 5000: ",
qtd_pessoas_mais_50_e_salario_entre_4e5000 );
fim.

6 de 9

Algoritmos - 2 Lista de Algoritmos ( Repetio)

VII Ler a idade e o salrio para vrias pessoas. Ao final, mostrar quantas pessoas tem mais de 30 anos e mostrar
tambm quantas pessoas tem mais de 50 anos e ganham entre R$ 4000 e R$ 6000. Parar de ler quando uma idade
negativa ou 0 for digitada. Usar a estrutura enquanto.
R:
incio.

inteiro : contador, idade, qtd_pessoas_mais_30_anos,


qtd_pessoas_mais_50_e_salario_entre_4e5000;
real : salario ;
qtd_pessoas_mais_30_anos 0;
qtd_pessoas_mais_50_e_salario_entre_4e5000 0;
enquanto ( idade > 0 ) faa
imprima ( "Informe a idade:");
leia ( idade );
imprima ( "Informe o salario:");
leia ( salario );
se ( idade > 30 )
ento
qtd_pessoas_mais_30_anos qtd_pessoas_mais_30_anos + 1;
fim_se;
se ( idade > 50 e salario > 4000 e salario < 5000 )
ento
qtd_pessoas_mais_50_e_salario_entre_4e5000
qtd_pessoas_mais_50_e_salario_entre_4e5000 + 1;
fim_se;
fim_enquanto;
imprima ( "Qte de pessoas com mais de 50 anos: ", qtd_pessoas_mais_30_anos );
imprima ( "Qte de pessoas com idade superior a 50 e com salario entre R$ 4000 e 5000: ",
qtd_pessoas_mais_50_e_salario_entre_4e5000 );
fim.

7 de 9

Algoritmos - 2 Lista de Algoritmos ( Repetio)

VIII Ler a idade e o salrio para vrias pessoas. Ao final, mostrar quantas pessoas tem mais de 30 anos e mostrar
tambm quantas pessoas tem mais de 50 anos e ganham entre R$ 4000 e R$ 6000. Parar de ler quando uma idade
negativa ou 0 for digitada. Usar a estrutura repita.
R:
incio.

inteiro : contador, idade, qtd_pessoas_mais_30_anos,


qtd_pessoas_mais_50_e_salario_entre_4e5000;
real : salario ;
qtd_pessoas_mais_30_anos 0;
qtd_pessoas_mais_50_e_salario_entre_4e5000 0;
repita
imprima ( "Informe a idade:");
leia ( idade );
imprima ( "Informe o salario:");
leia ( salario );
se ( idade > 30 )
ento
qtd_pessoas_mais_30_anos qtd_pessoas_mais_30_anos + 1;
fim_se;
se ( idade > 50 e salario > 4000 e salario < 5000 )
ento
qtd_pessoas_mais_50_e_salario_entre_4e5000
qtd_pessoas_mais_50_e_salario_entre_4e5000 + 1;
fim_se;
at ( idade <= 0 );
imprima ( "Qte de pessoas com mais de 50 anos: ", qtd_pessoas_mais_30_anos );
imprima ( "Qte de pessoas com idade superior a 50 e com salario entre R$ 4000 e 5000: ",
qtd_pessoas_mais_50_e_salario_entre_4e5000 );
fim.

8 de 9

Algoritmos - 2 Lista de Algoritmos ( Repetio)

IX Perguntar para 1600 pessoas se elas possuem animais de estimao. Ao final, mostrar ( na forma de percentual )
quantas possuem e quantas no possuem animais de estimao.
R:
incio.

inteiro : contador, possui_animal_de_estimacao, nao_possui_animal_de_estimacao;


caractere : possui_animal;
possui_animal_de_estimacao 0;
nao_possui_animal_de_estimacao 0;
para contador de 1 at 300 passo +1 faa
imprima ( "Voc possui animal de estimao ( sim ou no:");
leia ( possui_animal );
se ( possui_animal = "sim" )
ento
possui_animal_de_estimacao possui_animal_de_estimacao + 1;
seno
nao_possui_animal_de_estimacao nao_possui_animal_de_estimacao + 1;
fim_se;
fim_para;
imprima ( "Quantidade de pessoas que possuem animais de estimao: ", possui_animal_de_estimacao );
imprima ( "Quantidade de pessoas que no possuem animais de estimao: ",
nao_possui_animal_de_estimacao);
fim.

9 de 9