Você está na página 1de 5

Bacharelado em Cincia e Tecnologia

BC0505 Processamento da Informao


ATIVIDADE PRTICA
Vetores Unidimensionais
Coloque suas respostas nesse arquivo .DOC conforme solicitado em cada enunciado.
Ao final, faa o Upload desse arquivo .DOC no TIDIA, na ATIVIDADE especificada pelo
professor. Enquanto voc no clicar em ENVIAR, poder salvar e voltar "mais tarde"
para modificar o seu arquivo.
Exerccio 1
1. Escreva um algoritmo que Leia 10 valores inteiros e armazene-os em um Vetor. Aps a digitao do
ltimo valor, imprima os elementos pares.
OBS: OBRIGATRIO O USO DO COMANDO DE VETORES E LAOS
PARTE I - ALGORITMO: PORTUGOL
programa
// Ricardo.borges@aluno.ufabc.edu.br
// le vetor e escreve os elemntos pares
//ativ 21 da semana 7
funcao inicio()
inteiro v[10]
para ( inteiro i=0; i<10; i=i++){
leia (v[i])
}
para ( inteiro i=1; i<10; i=i+2){
escreva(v[i]," " )
}
}
}

PARTE II - PROGRAMA EM
JAVA

O PROGRAMA EM JAVA SER SUBMETIDO EM OUTRA ATIVIDADE ATRAVS DO BOCA

Exerccio 2
2. Escreva um algoritmo que Leia 15 nomes de pessoas e armazene-os em um Vetor. Aps a digitao
do ltimo nome, imprima-os na sequncia contrria.
OBS: OBRIGATRIO O USO DO COMANDO DE VETORES E LAOS
PARTE I - ALGORITMO: PORTUGOL
programa
//Ricardo.borges@aluno.ufabc.e
du.br
// le vetor e escreve os elemntos
pares
//ativ 22 da semana 7
funcao inicio()
cadeia n[15]
escreva ( " escreva 15 nome
de pessoas seguidos por enter " )
para ( inteiro i=0; i<15; i=i++)
{
leia (n[i])
}
escreva ( " ========= de
tras para a frente =====\n")
para ( inteiro i=0; i<15; i=i++){
escreva(n[14-i]," \n" )
}
}
}

PARTE II - PROGRAMA EM JAVA


O PROGRAMA EM JAVA SER SUBMETIDO EM OUTRA ATIVIDADE ATRAVS DO BOCA

Exerccio 3

3. Escreva um algoritmo que leia 8 elementos em um vetor inteiro A. Construa um outro vetor B, de
mesma dimenso de A, com seus elementos sendo a multiplicao do elemento correspondente de A
por 3. Mostre os elementos de B.
OBS: OBRIGATRIO O USO DO COMANDO DE VETORES E LAOS
PARTE I - ALGORITMO: PORTUGOL
programa
// Ricardo.borges@aluno.ufabc.edu.br
// le vetor e escreve os elementos pares
//ativ 23 da semana 7
funcao inicio()
inteiro A[8],B[8]
escreva ( " entre 8 inteiros
seguidos por enter " )
para ( inteiro i=0; i<8; i=i+
+){
leia (A[i])
}
para ( inteiro i=0; i<8; i=i+
+){
B[i]=A[i]*3
}
escreva ( " =========
escrev B[i]=A[i] multiplicado por
3 =====\n")
para ( inteiro i=0; i<8; i=i+
+){
escreva(B[i]," \n" )
}
}
}

PARTE II - PROGRAMA EM JAVA


O PROGRAMA EM JAVA SER SUBMETIDO EM OUTRA ATIVIDADE ATRAVS DO BOCA

Exerccio 4
4. Leia 20 elementos em um vetor A e construa o vetor B com elementos de A, porm invertidos, ou
seja, o primeiro elemento de A passa a ser o ltimo elemento de B, e assim por diante. Mostre os 2
vetores , o maior elemento do vetor A e o menor elemento do vator B.
OBS: OBRIGATRIO O USO DO COMANDO DE VETORES E LAOS
PARTE I - ALGORITMO: PORTUGOL
programa
// Ricardo.borges@aluno.ufabc.edu.br
// le vetor e escreve os elementos pares
//ativ Exerc 4 da semana 7
funcao inicio()
inteiro A[20],B[20]
inteiro maior=-9999, menor=99999 ,iMaior=0,iMenor=0
escreva ( " entre 20 inteiros seguidos por enter " )
para ( inteiro i=0; i<20; i=i++){
leia (A[i])
}
para ( inteiro i=0; i<20; i=i++){
B[19-i]=A[i]
}
escreva ( " ========= escrever A[i] e depois B[i] =====\n")
para ( inteiro i=0; i<20; i=i++){
escreva(A[i]," ")
}
escreva(" \n" )
para ( inteiro i=0; i<20; i=i++){
escreva(B[i]," " )
}
escreva(" \n" )
// achar o maior varrendo o vetor salvando o maior e seu indice
para ( inteiro i=0; i<20; i=i++){
se (A[i]>maior) {
maior =A[i]
iMaior=i
}
}
escreva(" O maior elemento do vetor :",maior ," que fica na posia : " , iMaior, "\n" )
// achar o menor varrendo o vetor salvando o maior e seu indice
para ( inteiro i=0; i<20; i=i++){
se (A[i]<menor) {
menor =A[i]
iMenor=i
}
}
escreva(" O menor elemento do vetor :",menor ," que fica na posia : " , iMenor,
"\n" )
}

PARTE II PROGRAMA
EM JAVA
O PROGRAMA
EM JAVA
SER
SUBMETIDO
EM OUTRA
ATIVIDADE
ATRAVS DO
BOCA