Você está na página 1de 9

Frame Relay Lab: Physical Interfaces, Point-to-point

Ethernet 0
172.25.10.1/24

S0/DTE
172.25.1.1
RouterA

DLCI=100

S0
DCE

S1
DCE

Frame Relay Switch


(Router)
PVC

Router A (DTE)
version 12.0
!
hostname RouterA
!
interface Serial0
ip address 172.25.1.1 255.255.255.0
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface FastEthernet0
ip address 172.25.10.1 255.255.255.0
no keepalive
!
router rip
network 172.25.0.0

Router B (DTE)
version 12.0
!
hostname RouterB
!
interface Serial0
ip address 172.25.1.2 255.255.255.0
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface FastEthernet0
ip address 172.25.20.1 255.255.255.0
no keepalive
!
router rip
network 172.25.0.0

S0/DTE
172.25.1.2
DLCI=101

RouterB

Ethernet 0
172.25.20.1/24

Frame Relay Switch (DCE)


Current configuration:
!
hostname FrameSwitch
!
frame-relay switching
!
interface Serial0
no ip address
encapsulation frame-relay
clockrate 56000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 100 interface Serial1 101
interface Serial1
no ip address
encapsulation frame-relay
clockrate 56000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 101 interface Serial0 100

Notes:
1. A router is not normally used as a Frame Relay switch. This feature is typically sued
in test and demonstration situations.
2. Loopback interface can be used to simulate actual physical interfaces.
3. The Frame Relay switch is acting as the DCE device, which would be a normal
situation.

Lab 1: Inverse ARP

Save running-configs to startup-configs


Reboot Frame Relay switch
After Frame Relay switch has rebooted, reboot RouterA and RouterB

Monitoring and Testing the Configuration


On the Frame Relay Switch, perform the following commands:
1. Router# show frame-relay route
FrameSwitch#show frame-relay route
Input Intf
Input Dlci
Output Intf
Serial0
100
Serial1
Serial1
101
Serial0

Output Dlci
101
100

Status
active
active

At your appropriate router, RouterA or RouterB, perform the following commands:


1. Router# show inter s 0

What is the encapsulation?


What is the LMI type and other LMI information?
Is the router DTE or DCE?

RouterA#show inter s 0
Serial0 is up, line protocol is up
Hardware is PowerQUICC Serial
Internet address is 172.25.1.1/24
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY, loopback not set
Keepalive set (10 sec)
LMI enq sent 132, LMI stat recvd 132, LMI upd recvd 0, DTE LMI up
LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE
Broadcast queue 0/64, broadcasts sent/dropped 93/0, interface
broadcasts 49
(Partial Output)

2. Router# show frame-relay map

What IP address is it showing and how did it get it?


What is it dynamic and not static? (Inverse ARP!)

RouterA#show frame-relay map


Serial0 (up): ip 172.25.1.2 dlci 100(0x64,0x1840), dynamic,
broadcast,, status defined, active

3. Router# show frame-relay pvc


What is the DLCI number and why?
What is the PVC status?
What other information is it giving you?
RouterA#show frame-relay pvc
PVC Statistics for interface Serial0 (Frame Relay DTE)

Local
Switched
Unused

Active
1
0
0

Inactive
0
0
0

Deleted
0
0
0

Static
0
0
0

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =


Serial0
input pkts 130
output pkts 127
in bytes 22121
out bytes 21802
dropped pkts 0
in FECN pkts 0
in BECN pkts 0
out FECN pkts 0
out BECN pkts 0
in DE pkts 0
out DE pkts 0
out bcast pkts 107
out bcast bytes 19722
pvc create time 00:25:50, last time pvc status changed 00:25:40

4. Router# show ip route


What is the routing table showing you?
Does it show both the directly connected and the remote Loopback networks?
RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP,
Gateway of last resort is not set

R
C
C

172.25.0.0/24 is subnetted, 3 subnets


172.25.20.0 [120/1] via 172.25.1.2, 00:00:16, Serial0
172.25.1.0 is directly connected, Serial0
172.25.10.0 is directly connected, FastEthernet0

5. Router# ping remote-router-ip-address


Can you ping the remote routers serial interface? (Yes)
Can you ping the remote routers loopback interface? (Yes)
6. Router# show frame-relay lmi
What is the LMI type?
RouterA#show frame-relay lmi
LMI Statistics for interface Serial0 (Frame Relay DTE) LMI TYPE = ANSI
Invalid Unnumbered info 0
Invalid Prot Disc 0
Invalid dummy Call Ref 0
Invalid Msg Type 0
Invalid Status Message 0
Invalid Lock Shift 0
Invalid Information ID 0
Invalid Report IE Len 0
Invalid Report Request 0
Invalid Keep IE Len 0
Num Status Enq. Sent 180
Num Status msgs Rcvd 180
Num Update Status Rcvd 0
Num Status Timeouts 0

LAB 2: Frame-Relay Map Statements (No Inverse ARP)


We will now disable inverse-arp on the routers and replace the inverse-arp process with
frame-relay map statements. Remember, you can either one of these, but not both!
(Note: There are times when this will work, but unexpected results may occur. See my
presentation on Frame Relay configurations to understand why.)
Removing Inverse-ARP and Configuring Frame-Relay map statements
1. At both routers, RouterA and RouterB, do:
Router(config)# inter s 0
Router(config-if)# no frame-relay inverse-arp
<- Disables inverse-arp
Router(config-if)# shutdown
<- Wait about 30 seconds.
Router(config-if)# no shutdown

2. Perform the following commands and examine the results:


Router# show inter s 0 (No change)
Router# show frame-relay map (No results)
Router# show frame-relay pvc (DLCI Usage = Unused)
Router# clear ip route *
Router# show ip route (Will only see directly connected networks)
Router# ping remote-router-ip-addresses (Cannot ping remote interfaces)

3. Lets replace inverse-arp with frame-relay map statements:


At RouterA:
RouterA(config)# inter s 0
RouterA(config-if)# frame-relay map ip 172.25.1.2 100
What is the 172.25.1.2 and the 100?
At RouterB:
RouterB(config)# inter s 0
RouterB(config-if)# frame-relay map ip 172.25.1.1 101
What is the 172.25.1.1 and the 101?

Monitoring and Testing the Configuration


At your appropriate router, RouterA or RouterB, perform the following commands:

1. Why did you use the ip address and DLCI number as given in the previous step?

2. Router# show frame-relay map


What IP address is it showing?
What is it dynamic and not static?
RouterA#show frame-relay map
Serial0 (up): ip 172.25.1.2 dlci 100(0x64,0x1840), static,
CISCO, status defined, active

3. Router# show frame-relay pvc (DLCI Usage = Local)

4. Router# show ip route


What is the routing table showing you?
Does it show the remote Ethernet networks? Why not?
RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP,
Gateway of last resort is not set

C
C

172.25.0.0/24 is subnetted, 2 subnets


172.25.1.0 is directly connected, Serial0
172.25.10.0 is directly connected, FastEthernet0

5.. Router# ping remote-router-ip-address


Can you ping the remote routers serial interface? (Yes)
Can you ping the remote routers Ethernet interface? (No)
What is the problem?
6. Solution: RIP uses broadcasts to exchange routing tables. Change the frame-relay
map statesments to the following:
At RouterA:
RouterA(config)# inter s 0
RouterA(config-if)# frame-relay map ip 172.25.1.2 100 broadcast
At RouterB:
RouterB(config)# inter s 0
RouterB(config-if)# frame-relay map ip 172.25.1.1 101 broadcast
6

7. Note: To clear and update the DLCIs and the routing tables:
shutdown the serial interfaces
no shutdown the serial interfaces
clear the routing tables: clear ip route *
If that doesnt work, save your running-configs and reboot RouterA and RouterB
8. Now look at the routing tables:
RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP,
Gateway of last resort is not set

R
C
C

172.25.0.0/24 is subnetted, 3 subnets


172.25.20.0 [120/1] via 172.25.1.2, 00:00:02, Serial0
172.25.1.0 is directly connected, Serial0
172.25.10.0 is directly connected, FastEthernet0

9. Notice the new information in the frame-relay map:


RouterA#show frame-relay map
Serial0 (up): ip 172.25.1.2 dlci 100(0x64,0x1840), static,
broadcast,
CISCO, status defined, active

10. Can you ping all interfaces? (Yes!)


RouterA#ping 172.25.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.25.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/64/64 ms
RouterA#ping 172.25.20.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.25.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/64/68 ms

11. Note: Look at the running-config: Even if you did not use the command, no framerelay inverse-arp , when you use the frame-relay map statements, inverse-arp is
automatically disabled and the command no frame-relay inverse-arp is automatically
put into the running config!
interface Serial0
ip address 172.25.1.1 255.255.255.0
encapsulation frame-relay
frame-relay lmi-type ansi
frame-relay map ip 172.25.1.2 100 broadcast
no frame-relay inverse-arp
(Happens automatically when frame-relay map statement is used.
7

LAB 3: Configuring LMI Autosense (No frame-relay lmi-type)


We will remove the command, frame-relay lmi-type ansiand see what happens. (Note:
You must be running Cisco IOS version 11.2 or higher.) This lab may be done using
inverse-arp, as in Lab 1, or with frame-relay map statements, as in Lab 2.

Removing the LMI


1. To remove the lmi-type, at both routers, RouterA and Router B, the command is:
Router(config-if)# shutdown
Router(config-if)# no frame-relay lmi-type ansi
Router(config-if)# no shutdown
The interface should now be configured as:
RouterA Example:
interface Serial0
ip address 172.25.1.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.25.1.2 100 broadcast
no frame-relay inverse-arp

2. Lets see the LMI Autosense in action:


Router# debug frame-relay lmi
3. Turn the interface back on, and LMI Autosense will begin!
Router(config-if)# shutdown (wait until the interface shuts down)
Router(config-if)# no shutdown

4. After a couple of minutes, turn of debug with:


Router# undebug all

Monitoring and Testing the Configuration


1. Router# show frame-relay lmi

What is the LMI type? How did it get it? (Using the autosense feature.)

RouterA#show frame-relay lmi


LMI Statistics for interface Serial0 (Frame Relay DTE) LMI TYPE = ANSI
Invalid Unnumbered info 0
Invalid Prot Disc 0
Invalid dummy Call Ref 0
Invalid Msg Type 0
Invalid Status Message 0
Invalid Lock Shift 0
Invalid Information ID 0
Invalid Report IE Len 0
Invalid Report Request 0
Invalid Keep IE Len 0
Num Status Enq. Sent 199
Num Status msgs Rcvd 198
Num Update Status Rcvd 0
Num Status Timeouts 3

2. Is everything else working?


Note: All of the following commands should show normal working results.
Router# show inter s 0
Router# show frame-relay map
Router# show frame-relay pvc
Router# show ip route
Router# ping remote-router-ip-addresses

Você também pode gostar