Você está na página 1de 56

CENTRO FEDERAL DE EDUCAO TECNOLGICA DO PARAN.

KLEBER NABAS
kleber@cefetpr.br
AUGUSTO FORONDA
foronda@cefetpr.br

NDICE

Roteadores...............................................................................................................3
Roteadores Internos E Externos..............................................................................4
Roteador Cisco Configurao...............................................................................5
Configurando Uma Interface Serial Sncrona...........................................................7
Configurando Uma Porta Ethernet...........................................................................7
Configurando Tabela De Rotas................................................................................8
Visualizando Configuraes.....................................................................................8
Usando O Show In <Sx>........................................................................................10
Usando O Show Ip Route.......................................................................................11
Dicas Da Serial.......................................................................................................12
Parmetros Informativos........................................................................................13
Tipo De Encapsulamento.......................................................................................13
Tempo Em Que Est Contando Erros....................................................................13
Sinais Na Interface.................................................................................................14
Identificando Problemas.........................................................................................14
Comandos teis.....................................................................................................16
Comandos Do Roteador Cisco...............................................................................17
Password................................................................................................................19
Nome Do Roteador.................................................................................................20
Habilitar Interface....................................................................................................20
Roteamento.............................................................................................................21
Configurando Protocolos.........................................................................................22
Configurando Um Ip................................................................................................22
Resumo De Comandos...........................................................................................23
Frame-Relay Em Roteador Cisco...........................................................................25
Dlci..........................................................................................................................26
Arp Inverso..............................................................................................................26
Sub-Interfaces.........................................................................................................27
Ligando Ao Igx 8400..............................................................................................28
Recomendaes De Segurana Para Roteadores Cisco.......................................30
Filtros Em Roteadores Cisco...................................................................................35
Tecnologias ............................................................................................................37
Protocolo Ppp (Protocolo Ppp (Point-To-Point Protocol)........................................37
Frame Relay........................................................................................................40
"High-Level Data Link Control" (Hdlc).....................................................................44
Protocolo X.25.......................................................................................................50
Modem Digitel Dt64mi............................................................................................55

Roteadores
So equipamentos utilizados para interconexo de duas redes que utilizam
a mesma camada de transporte, porm possuem camadas de rede diferentes.O
roteador funciona, normalmente como o principal componente de uma rede
corporativa ou de um backbone de internet. Assim como as pontes, roteadores
tambm agem como filtros, porm agora trabalhando no nvel logo acima (nvel de
rede) do que as bridges atuam (nvel de enlace). Roteadores so na verdade
dispositivos que estabelecem uma conexo entre as redes. Responsveis por
saber como toda a rede est conectada e como transmitir informaes de uma
parte da rede para outra. Em poucas palavras eles evitam que os "hosts" percam
tempo assimilando conhecimentos sobre a rede. Estes roteadores podem estar
conectados a duas ou mais redes.
Roteadores filtram trfego baseado nos campos de endereamento
contidos dentro do cabealho do protocolo de rede. Subcampos destes endereos
identificam o segmento da LAN onde esto localizadas a estao origem e destino.
Protocolos em que os campos de endereamento no possuem subcampos
identificadores da localizao da estao destino no podem ser roteados,
podendo, porm, ter seus pacotes filtrados por pontes. Um exemplo disto o
protocolo NetBIOS, j que em seu cabealho existem apenas informaes dos
nomes das estaes e no sua localizao. Nestes casos, a fim de repassar
pacotes, o roteador freqentemente usado como uma ponte.
Alm da forma de filtrar o trfego, roteadores tambm diferem das pontes
pelo controle do congestionamento, por filtrar quadros de broadcast e pela
determinao da melhor rota na rede visando minimizar seu trfego (a melhora no
uso dos links tambm oferecida pelas pontes com roteamento na origem, porm
de forma muito menos eficiente que pelos roteadores).
As pontes assumem que o nodo destino de um quadro atingvel
diretamente, sem nodos intermedirios, uma vez que o nvel de enlace no tem
conhecimento de inter-redes, ou de roteamento atravs de redes locais conectadas

em srie. Assim, as pontes no oferecem a possibilidade de isolar nodos entre


grupos lgicos, que seria bastante til em situaes como aquelas onde
mensagens broadcast so destinadas apenas a alguns nodos especficos.
J os roteadores oferecem muito mais flexibilidade no trfego do fluxo. Redes
facilmente podem ser divididas em grupos lgicos distintos, utilizando para isso
convenes de endereamento como no TCP/IP
Roteadores Internos e Externos
Existem duas opes de roteadores que so usados no mercado com as
seguintes caractersticas:
Roteadores internos
So

aqueles

formados

pela

combinao

de

placa

de

comunicao

sncrona/assncrona, PC, placa Ethernet e SW de roteamento carregado ou bult-in


no S.O do PC. Trata-se de uma soluo fcil e baixo custo. Porm existe
dependncia com as caractersticas tcnicas do servidor em que reside: tipo de
bus e sistema operacional. Se um desses dois componentes mudam (digamos
voc muda o servidor de Intel para PA RISC), ento todo investimento do roteador
interno (HW + SW) perdido.
Roteadores externos
So aqueles formados por HW e SW dedicados ao roteamento, estando
concentrados em uma "caixa" externa. Por ter funes exclusivamente voltadas ao
roteamento, sua performance atinge ndices superiores, justificando at um custo
ligeiramente maior que a dos roteadores internos. O produto nesse caso
independente da arquitetura de HW /SW do servidor, pois tipicamente estamos
falando de ligao ao servidor via Ethernet e host do TCP/IP, ou outro protocolo de
comunicao.

Roteador Cisco - Configurao

Implantao:
Itens bsicos:
Tipo de Interface: depender do meio de comunicao escolhido.
Tipo de encapsulamento: depender dos roteadores disponveis em cada
ponta.
Endereamento IP e tabelas de rotas: dependero da rede e dos
padres adotados.
Modos de configurao:
Existem dois modos de operaes diferentes:
User EXEC Mode: Neste modo no possvel visualizar a operao e
nem alter-la, mas esto disponveis vrios comandos que permitem verificar o
funcionamento do roteador.
Priviliged EXEC Mode: Neste modo permitido adicionar ou alterar as
configuraes.
O Roteador Cisco pode ser acessado por telnet, desde que este esteja
acessvel na rede ou por console. No caso deste ser acessado por console, os
parmetros so: 9600 8 N 1, ou seja, velocidade de 9600 bps, 8 bits, 1 Stop bit e
sem paridade.
Podem ser configuradas senhas diferentes para acesso ao console,
porta auxiliar, ao terminal via telnet e ao modo privilegiado (enable). Passa-se para
o modo privilegiado atravs do comando enable, depois do qual ser solicitada
uma outra senha.

Algumas dicas
Para configurar o roteador deve-se entrar no modo de configurao, com o
comando conf term, para finalizar a configurao, usa-se ctrl + z e logo em
seguida para gravar a configurao usa-se o comando wr (ou copy running-config
startup-config).

Exemplo da conexo de duas redes usando roteadores

Router A

Router B
Figura 1

Configurando uma interface serial sncrona

Router# conf term


router(config)#in s<minha serial >
router(config-if)#description <descrio do Link>
router(config-if)#ip address x.x.x.x m.m.m.m
router(config-if)#encapsulation <ppp ou hdlc>
router(config-if)#^z
router#wr

Definir:
x.x.x.x endereo IP (exemplo: 10.0.0.2)
m.m.m.m mscara (exemplo: 255.0.0.0)
Algo que deve-se prestar ateno que o encapsulamento deve ser o
mesmo nos dois roteadores.

Assim, quando tivermos Cisco nas duas pontas

podemos usar HDLC, caso contrrio, com o PPP sempre ser possvel configurar.
Configurando uma porta Ethernet
Router# conf term
router(config)#ip address x.x.x.x m.m.m.m
router(config-if)#^z
router#wr
Definir:
x.x.x.x endereo IP (exemplo: 200.100.50.1)
m.m.m.m mscara (exemplo: 255.255.255.0)
Configurando Tabela de rotas
Exemplo para o Router A:
Router# conf term
router(config)#ip address x.x.x.x m.m.m.m y.y.y.y
router(config-if)#^z
router#wr
Definir:
x.x.x.x rede (O endereo de rede ethernet do destino - exemplo:
192.168.17.0)
m.m.m.m mscara (exemplo: 255.255.255.0)
7

y.y.y.y destino (pode ser um n IP ou uma interface serial do destino exemplo: 10.0.0.1 ou s0).

Visualizando configuraes
Usando o show conf:
Esse comando permite visualizar as configuraes atuais do roteador.

A configurao no roteador ficar assim:

cisco>enable
Password:
cisco#sh conf
Using 577 out of 32762 bytes
!
version 11.2
!
hostname cisco
!
enable secret 5 $1$qxqA$ky/STYP6vmW7YOx3BQkWV0
enable password cisco1
!
ip subnet-zero
!
interface Ethernet0
ip address 200.100.50.1 255.255.255.0
!
interface Serial0
8

description ppp
ip address 10.0.0.2 255.0.0.0
no ip mroute-cache
encapsulation ppp
no ip route-cache
!
interface Serial1
no ip address
shutdown
!
router igrp 1
network 172.16.0.0
!
ip classless
ip route 192.168.17.0 255.255.255.0 10.0.0.1
snmp-server community public RO
!
line con 0
line 1 16
flowcontrol hardware
line aux 0
line vty 0 4
password cisco
login
!
end

Usando o show in <sx>


Esse comando permite visualizar as configuraes da interface serial
A visualizao ficar assim:

cisco#sh in s0
Serial0 is up, line protocol is up
Hardware is HD64570
Description: ppp
Internet address is 10.0.0.2/8
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Open
Open: IPCP, CDP
Last input 00:00:04, output 00:00:04, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/64/0 (size/threshold/drops)
Conversations 0/1 (active/max active)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1732 packets input, 110993 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants
26 input errors, 26 CRC, 1 frame, 0 overrun, 0 ignored, 14 abort
2222 packets output, 106522 bytes, 0 underruns
0 output errors, 0 collisions, 98 interface resets
0 output buffer failures, 0 output buffers swapped out
DCD=up DSR=up DTR=up RTS=up CTS=up

Usando o show ip route

Router1>sh ip route
Codes:

C connected, S static, I IGRP, R RIP, M mobile, B BGP


10

D EIGRP, EX EIGRP external, O OSPF, IA OSPF inter area


E1 OSPF external typ 1, E2 OSPF external type 2, E EGP
I IS-IS, L1 IS-IS level-1, L2 IS-IS level-2, * - candidate defaut
Gatteway of last resort is 200.17.210.80 to network 0.0.0.0
R

10.0.0.0 [120/2] via 192.168.4.170, 00:00:23, serial1


[120/2] via 192.168.4.42, 00:00:20, serial0

200.17.210.0 is directly connected, Ethernet0


44.0.0.0 255.255.255.252 is subnetted, 1 subnets

44.174.10.0 is directly connected, serial0


192.168.4.0 255.255.255.252 is subnetted, 2 subnets

192.168.4.0 is directly connected, serial0

192.168.4.168 is directly connected, serial1

200.238.129.0 is directly connected, serial0

S*

0.0.0.0 0.0.0.0 [1/0] via 200.17.210.80

ATENTAR rota default, se os caminhos esto certos.

Dicas da serial
Status da interface:
Serial0 is up, line protocol is up
Se a serial0 is down, no est conseguindo receber sinal do modem ou
est sem portadora.
Se serial0 is administratively down, foi desabilitada por configurao
(shutdown).

11

Se protocol is down, no est conseguindo se comunicar com a outra


ponta e as causas podem ser diversas: problemas no circuito de dados (taxa de
erros, falha em algum ponto do caminho), encapsulamento errado, interface
desabilitada na outra ponta.
Se protocol is up (looped), o circuito est em loop em algum ponto.
Configurao do endereo IP:
Internet address is 10.0.0.2/8

Parmetros informativos:
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
BW Velocidade do circuito somente informativo, no influencia.
rely Confiabilidade da linha, deve ser sempre 255/255, diferente disso
indica que h taxa de erros no circuito de dados.
Load Carga de utilizao do link (sada)
Tipo de encapsulamento:
Encapsulation PPP, loopback not set, keepalive set (10 sec)
Tempo em que est contando erros:
Last clearing of "show interface" counters never
Quando o router religado aparece como acima, caso contrrio mostra o
tempo.

12

Mdia de 5 minutos de trfego:


5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
Erros que ocorreram:
26 input errors, 26 CRC, 1 frame, 0 overrun, 0 ignored, 14 abort
2222 packets output, 106522 bytes, 0 underruns
0 output errors, 0 collisions, 98 interface resets
Sinais na interface:
DCD=up DSR=up DTR=up RTS=up CTS=up

Identificando problemas

Um circuito de dados pode ser interrompido por vrios motivos. Os


roteadores cisco tem disponveis algumas ferramentas que auxiliam a identificar
estes problemas e assim dar mais agilidade na soluo do mesmo.
O circuito pode ser interrompido por uma manuteno eventual, rudo na
linha, problema em um modem no meio do caminho, configurao errada, interface
incompatvel, etc. Veremos a seguir como o roteador pode auxilia-lo a identificar
estes problemas.
Primeiro Passo: como est o roteador?
Verificar: status da interface, erros, carga, sinais, loop.

13

De acordo como o que for mostrado no show interface podemos identificar algumas
falhas:
Serial down no est recebendo sinal do modem.
Erros de CRC.
Circuito muito carregado provoca lentido, dificuldade de acesso.
Os sinais devem estar todos UP.
Protocol looped o circuito est em loop. Pode ser testado loop em pontos
do circuito que o roteador ser capaz de perceber.
Segundo Passo: anlise dos resultados
Pode ser problema: no circuito de dados, de configurao ou de roteamento.
Problemas de circuito:
Serial down sem portadora, cabo mal conectado, no consegue pegar os
sinais do modem.
Algum sinal down problemas de configurao do modem, falha no
modem.
Erros de CRC rudo, mal contato.
Rely baixo taxa de erros no circuito.
No pega loop em algum ponto provvel defeito no ponto em que o loop
no detectado.
Problemas de configurao:
Se serial up, protocol down, sinais OK, sem erros, identificando loop
Verificar encapsulamento.
Se serial up, protocol up, no chegando no prximo roteador. Verificar
configurao do endereo IP.

14

Problemas de roteamento:
Interface OK, sinais OK, no consegue chegar a lugar nenhum Usar o comando
show ip route.
Alguns backbones usam endereos reservados no roteveis na interfaces
seriais, ser possvel chegar somente at o prximo roteador.
Quando uma interface numerada, a rede ou subrede da qual ela faz
parta dever ser imediatamente identificada pelo roteador e criada uma rota
diretamente conectada. Deve-se verificar se esta rota existe e est com a
mscara correta.
Quando um pacote chega no roteador a tabela de rotas consultada, se o
destino se encontra na tabela de rotas, esta rota usada. Caso contrrio, deve ser
usada a rota default, certificar-se que esta rota existe e est correta.
Rotas erradas certifique-se que no existam.
IP Classless Quando o roteador possui uma rota para uma subrede no
envia os pacotes com destino outra subrede para a rota default, a no ser que o
comando ip classless esteja habilitado.

Comandos teis

Router>show process cpu Mostra a utilizao da cpu do roteador e os


processos que esto rodando com a sua respectiva partio.
Router>show version Mostra a verso do sistema operacional, as
interfaces que o equipamento possui, uptime, memria, entre outros.
Router#clear counter

<sx/ethx> Zera os contadores de erros na

interface especificada.
15

Router#conf term
Router(config)#in xxxx
Router(config-if)#shutdown
Router(config-if)#no shutdown Como um reset da interface.
Router>ping <nmero-ip> Envia um pacote e espera a resposta. Se
tiver resposta existe comunicao entre as partes.
Router>traceroute <nmero-ip> Mostra o caminho que o pacote segue,
ou seja, mostra os endereos dos roteadores que o pacote trafega.

Comandos do Roteador Cisco


Alguns comandos de configurao do roteador.
Help
O comando help nos roteadores cisco so "pedidos", pelo caractere (?).
por exemplo:
Router# cl?
clear

clock

Router# clock ?
set

Set time and date

Vizualizao de configuraes
Para podermos visualizar as configuraes, podemos usar os comandos:
- SHOW RUNNING-CONFIG
Mostra a configurao do arquivo corrente.
- SHOW STARTUP-CONFIG
Mostra as configuraes que esto armazenadas na NVRAM.

16

Cpia de configuraes
Para copiar configuraes de um local p/ outro:
- COPY RUNNING STARTUP
Copia o contedo do RUNNING-CONFIG para STARTUP-CONFIG
- COPY STARTUP RUNNING
Copia o contedo do STARTUP-CONFIG para RUNNING-CONFIG
SHOW INTERFACE
Quando queremos verificar se uma porta est UP, e as configuraes esto
corretas, usamos este comando, ex.:
- show interface type number
Router# show int serial 1
Serial is up, line protocol is up, Hardware is MK5025
Como voc pode ver no exemplo a Serial est UP e o Protocolo tambm.
Mas as vezes podem ocorrer alguns erros, vou disponibilizar uma tabela que
mostra mais ou menos o que pode ser:
Serial

Line protocol

Operacional

UP

UP

Problema de

UP

down

down

down

down

down

Conexo
Problema de
interface
desabilit.
administrati.

17

PASSWORD
Vamos falar agora sobre password nos roteadores cisco, falaremos sobre, pelo
acesso local e remoto (telnet).

A password padro que eu conheo que vem

habilitada nos roteadores cisco enable/cisco.

Pode ter certeza que voc

encontrar um router assim um dia. Bom mas o acesso por telnet, no mudaria
muita coisa, do que o acesso normal, ambos seguem os dois exemplos abaixo:
telnet --> "enable" --> Router# config_term
Router (confi)# line vty 0 4
Router (config-line)# enable password h4x0r
Explicando a parte acima, estamos dando um telnet no router, usando a
password padro, e em seguida mudando o password do "root", por h4x0r. Sendo
assim, o administrador s poder reativar as configuraes, resetando o IOS.
Agora por acesso local mais simples:
"enable" --> Router (config)# enable password h4x0r
Router (config)# service password-encryption
Como voc deve ter observado, foi usado o comando "service passwordencryption", que seria para aplicar criptografia na password!
Nome do Roteador
Para voc mudar o nome do roteador simples, veja o exemplo abaixo:
Router>
Router> enable
Password>
Router#
Router# config terminal

18

Router (config)# hostname "TankDS"


TankDS (config)# exit
TankDS#
Simples no? Para maiores informaes no se esquea de consultar o help (?)!
Habilitar Interface
Para podermos habilitar uma interface. (para maiores informaes
consulte o help(?)).
Router (config)# int e0
Router (config-if)# no shutdown

Roteamento
Ao meu conhecimento existem 3 forma de roteamento, so elas: Rotas
Estticas, Rotas default e Roteamento Dinmico. Veremos um pouco sobre cada
uma.
- Rotas Estticas
So definidas manualmente, ex:
Router# config terminal
Router (config)# ip route rede mask gateway distncia
- Rotas Default
Definidas manualmente como sendo o caminho a ser tomada quando no h rota
conhecida para o destino.
- Roteamento Dinmico

19

O roteador aprende o caminho para o destino atravs de updates


peridicas nas tabelas de outros roteadores.
Protocolos de Roteamento Dinmicos
Os Protocolos de Roteamento Dinmicos so os protocolos nos quais o
roteador cisco pode trabalhar, so: DISTACE-VECTORS, LINK-STATE e HIBRIDO.
Vamos ver um pouco sobre eles.
- DISTANCE-VECTORS
- RIP (V1 e V2) (30 seg)
- IGRP (cisco) (90 seg)
- IPX RIP
Consome:
-

Menos CPU.

Menos Memria

Possuem tempo fixo

Tempo de convergncia alto

- LINK-STATE
- OSPF --> IP
- NLSP --> IPX
Consome:
-

Mais CPU

tempo baixo de convergncia

HIBRIDO
- EIGRP --> CISCO
No tem tempo fixo
Configurando Protocolos

20

Os comandos bsicos para configurar o protocolo so:


Router>
Router> enable
Password>
Router#
Router# config terminal
Router (config)# router protocol
Router (config-router)# network network-number
Router (config-router)# redistribute static
onde estatic seria o nome do protocolo ex.: RIP.
Configurando um IP
Chegamos na parte de comandos para configurar o IP no roteador. Temos dois
mtodos de configurao de IP's.
- Interface Configuration
Configura o endereo IP e a Mscara.
- Global Configuration
Define as rotas estticas ou
Seleciona o protocolo de roteamento.
especifica as redes.
- Configurando o endereo IP na interface
Router(config-if)# ip address ip-addres subnet-mask
- Rota Esttica
Router(config)# ip route network [mask] {address|interface} [distance]

21

- Protocolo de Roteamento
Router(config)# router protocol
- Especificando as Redes
Router(config-router)# network network-number

Resumo de comandos

sh conf

configuraes gravadas no roteador "hd"

sh cdp neighbors
sh runn

configuraes que esto apenas na memria

"ram"
sh ver

informaes do SO

sh <serial>

ex. sh s7 - informaes sobre serial s7

sh sess

Mostra as sees

sh int <eth>

ex. sh int eth0 - informaes sobre a ethernet0

sh frame pvc

mostra informaes sobre todos os PVCs

sh frame pvc <#>

mostra informaes sobre um pvc especifico

sh mem

mostra configuraes memria

sh history

mostra os ltimos comandos

sh users

mostra usurios logados

sh interfaces

mostra interfaces

sh proc cpu

Mostra processos CPU

ROUTER>

User exec mode

22

ENA (Router#)

Permite alterar config. do roteador, muda p/ modo

previlegiado
config t

muda para o modo de configurao global

line vty 0 4 password <senha> Especifica senha de telnet


enable secret <senha>

Habilita criptografia senha

line con 0 password <senha> Muda senha de console


enable password <senha>

Muda senha de modo privilegiado

service password-encryption Para criptografar


banner motd #

Muda banner inicial

hostname <nome>

Muda nome do roteador "prompt"

no logging console

Inibe mensagens do sistema

int <interface>

ex. int eth0, acessar determinada interface

ip unnumbered eth0

emprstimo de IPs entre interfaces

ip address <IP> <MASC>

Especifica IP e Mascara para a Ethernet

ip routing
ip route <IP> <MASC>

Configurar rotas

ip http server

Habilita web server no roteador

ip host DNS1 <IP>

Especifica o servidor DNS p/ resoluo de nomes

ip classless
no router rip
no IP domain_lookup
no ip directed-broadcast
no shutdown

Reabilita interface

clear counters 0/0


encapsulation frame-relay
desc <descriao>

Especifica

descrio

de

uma

determinada

interface
frame relay interface-dlci <#> Especifica o nmero da DLCI do PVC
band 64

Espefcica o tamanho do link

frame-relay lmi-type ansi

especifica o protocolo frame-relay a ser utilizado

23

disable

Desativa modo previlegiado

exit

Sai do modo configurao terminal

wr

Grava as configuraes

server como separador de linhas

ctrl+shift+6

Parar um trace

Frame-Relay em Roteador Cisco


Alguns aspectos de configurao do Frame-relay em roteadores CISCO.
Em primeiro lugar, a CISCO facilitou ao mximo a configurao do Framerelay em seus roteadores:
interface serial 0
encapsulation frame-relay
Esta configurao ir funcionar na maioria dos casos se voc e o seu
provedor de frame-relay utilizarem as configuraes default.
Mas se voc est trabalhando com equipamentos diferentes nas pontas, o
router poderia ser configurado da seguinte forma:
interface serial 0
encapsulation frame-relay ietf
frame-relay lmi-type ansi
Esta configurao usa o IETF (Internet Engineering Task Force)
encapsulation, ao invs do default CISCO "Gang of 4" (CISCO, Northern Telecom,
StrataCom, Digital Equipment Corporation) encapsulation.
Tambm especifica o LMI (Local Management Interface) usado pelo roteador para
falar com o Frame-relay switch. A CISCO, bvio, utiliza o LMI CISCO como
default.

24

DLCI
Tudo que voc realmente precisa saber sobre o DLCI (Data Link
Connection Identifiers) que o roteador adiciona, ao fim de um PVC, uma
identificao no pacote Frame-relay e o envia. Esta a informao necessria no
pacote para que ele chegue ao destino.
SUB-INTERFACES
Outro conceito importante em frame-relay so as sub-interfaces. Esta
outra ferramenta de Frame-relay que chegou com o IOS 9.21. Este modelo pode
ser fcil configurar mas, quando um PVC cai, o roteador pode no responder como
voc deseja.
Em alguns momentos a sua sub-interface pode continuar com o status
de ativo "Serial0/0/2 is up, line protocol is up" mesmo que o switch tenha perdido a
conexo com a outra ponta.

Isto dificulta a utilizao de rotas alternativas e

backups automticos que dependem do status da interface para acionar um


modem, por exemplo.
No entanto sub-interfaces permitem a configurao de bandwidth,
descries, e listas de acesso por PVC, evitam split-horizon que podem afetar o
AppleTalk, IPX Saps, e transparent bridging.
Exemplo:
interface Serial1/0
description (CONEXO IGX 15.1)
no ip address
no ip mroute-cache
encapsulation frame-relay IETF
no ip route-cache optimum
bandwidth 1024
frame-relay lmi-type CISCO
interface Serial1/0.1 point-to-point
description (Escritrio Santo Amaro)

25

ip address 192.163.10.1 255.255.255.252


no ip mroute-cache
bandwidth 64
ipx network 9999
ipx output-sap-filter 1000
frame-relay interface-dlci 100
Show frame-relay map
Este comando muito til para verificar o status das conexes frame-relay.
moscou#

sh frame-relay map

Serial0/0/2.3 (up): point-to-point dlci, dlci 293(0x125,0x4850), broadcast, BW


=114080 status defined, active
Serial0/0/2.2 (up): point-to-point dlci, dlci 255(0xFF,0x3CF0), broadcast, BW
=256000 status defined, active
Serial0/0/2.1 (up): point-to-point dlci, dlci 291(0x123,0x4830), broadcast, BW
=512000
Note que o BW (bandwidth) no representa o valor que voc configurou na sua
interface e sim o CIR (commitment information rate) definido no swtch.

FILTROS EM ROTEADORES CISCO


A opo de usar filtros para melhorar a segurana de uma rede tem sido bastante
utilizada nos ltimos anos. Embora a sua utilidade seja indiscutvel, ela est longe
de ser considerada uma soluo final para todos os problemas de segurana de
uma rede.

26

Os administradores devem, portanto, encarar o uso de filtros como mais uma


excelente ferramenta de auxlio na soluo dos problemas de segurana, definindo
regras que se apliquem diretamente ao "estado" de sua rede.
A implementao de filtros de pacotes em roteadores Cisco feita por meio do
mecanismo de listas de acesso (access-lists). Essas listas podem ser aplicadas em
interfaces para controle dos pacotes, bem como em portas de entrada, servios
especficos, como SNMP, ou no controle de anncios e redistribuio de rotas.
Existem dois tipos de access-lists:

standard:

onde

especificado

endereo

de

origem

access-list # {deny|permit} origem mscara

extended: onde o controle feito pelos endereos, portas com algumas


opes adicionais
access-list # {deny|permit} protocol origem mscara porta destino mscara

porta established log


A ltima forma a mais usada para o estabelecimento de filtros de pacotes. A
identificao das listas, para IP, varia de 1 a 99, para o modo standard, e de 100 a
199, para o modo extended. A sintaxe e opes disponveis mudam bastante
dependendo da verso de IOS utilizada. Outra diferena relacionada verso (e ao
hardware) o impacto no desempenho. Listas em circuitos muito utilizados, de alta
capacidade, podem comprometer o desempenho do roteador.
A aplicao da lista feita via comando ip access-group # {in|out}, nas interfaces.
O comando show access-list # auxilia no acompanhamento do filtro (as verses
mais atuais mostram o nmero de pacotes que caem em determinada regra).
Exemplo de access-list:

! spoofing
access-list 101 deny ip <num-IP-rede> 0.0.0.255 any

27

! endereos invlidos
access-list 101 deny ip 127.0.0.0 0.255.255.255 any
access-list 101 deny ip host 255.255.255.255 any
access-list 101 deny ip 10.0.0.0 0.255.255.255 any
access-list 101 deny ip 172.16.0.0 0.15.255.255 any
access-list 101 deny ip 192.168.0.0 0.0.255.255 any
! permitir conexes iniciadas internamente (j estabelecidas)
access-list 101 permit tcp any any established
! permitir mail
access-list 101 permit tcp any host <num-IP-mail-server> eq 25
! permitir web
access-list 101 permit tcp any host <num-IP-web-server> eq 80
access-list 101 permit udp any host <num-IP-web-server> eq 80
! permitir acesso ao servidor sshd
access-list 101 permit tcp any host <num-IP-sshd-server> eq 22
! permitir dns
access-list 101 permit udp any host <num-IP-dns-server> eq 53
access-list 101 permit tcp host <num-IP-secondary-server> host <num-IP-dnsserver> eq 53
interface serial 0
ip access-group 101 in
TECNOLOGIAS
Protocolo PPP (Protocolo PPP (Point-to-Point Protocol)
Point-to-point protocol uma tecnologia de WAN que tem por
objetivo passar trfego de dados em uma linha serial de forma confivel.
PPP foi desenvolvido pelo IETF (Internet Engineering Task Force)
como uma alternativa para o SLIP (Serial Link Interface Protocol). PPP

28

prov servios de autenticao e permite que diferentes protocolos sejam


executados utilizando uma linha serial.
um protocolo full-duplex que pode ser usado em vrios tipos de
mdias fsicas como par tranado, fibra ptica e transmisso por satlite e
tenta corrigir todas deficincias do protocolo SLIP. Possui uma forma de
encapsular datagramas IP em uma conexo serial.
Componentes
H basicamente 3 componentes principais relacionados ao PPP:

HDLC (High Data Link Control Protocol) - usado para


encapsular os datagramas;

LCP (Link Control Procolol) - usado para cora estabelecimento


de conexo, configurao e teste. H trs tipos de frames LPC
que juntos trabalham durante o processo de comunicao. So
eles:

a) Link establishment frames: Usados no estabelecimento e


configurao de um link;
b) Link termination frames: Utilizados na finalizao de um link;
c) Link maintenance frames: usado para realizao de operaes
de troubleshooting.

NPC (Network Control Protocol) - utilizados para criar e


configurar

protocols

de

outras

camadas.

NPC

prov

compatibilidades para diversos protocolos (ex. IP e IPX).


Como o PPP funciona
H basicamente 7 passos que o PPP toma para estabelecer uma
conexo sobre uma linha de comunicao serial:
1) PPP envia um conjunto de frames do tipo LCP para configurar a
linha serial
2) O link estabelecido

29

3) Autenticao utilizando PAP (Password Authentication Protocol)


ou CHAP (Challenge Handshake Authentication Protocol)
realizada na camada de rede
4)

PPP senvia frames do tipo NCP para configurao do protocolo


da camada

5) Pacotes do protocolo da camada de rede enviam dados na linha


serial
6) Linha serial permanece aberta para a transmisso de pacotes de
dados
7) LCP ou NCP fecha a conexo com a linha serial quando uma
operao finalizada.
O PPP composto basicamente de trs partes, sendo que a interao
entre elas obedece a um diagrama de fases:

O fluxograma acima demonstra os passos executados durante uma


tentativa de conexo PPP.
Quando a linha se encontra no estado DEAD, indica que

no h

nenhum transportador na camada fsica, no existindo conexo. Aps concluda a


conexo fsica, a linha vai para o estado ESTABLISH,

aonde o LCP inicia a

negociao das opes, e, caso as negociaes fluam corretamente a linha se


direciona para o estado AUTHENTICATE. Desta forma, ambas as partes podem
verificar a identificao do outro sistema.

30

Quando a etapa NETWORK iniciada, entra em cena o protocolo NCP,


que vai ter como tarefa, configurar a camada de rede. Caso as configuraes
ocorram com xito, o estado assumido ser OPEN, momento em que j poder
ocorrer a transmisso de dados. E finalmente, a linha vai se dirigir para
TERMINATE no momento em que a transmisso de dados termina, voltando ao
estado inicial DEAD e eliminando o transportador
Principais Vantagens

um padro para comunicao ponto a ponto sobre linhas


seriais

Compatvel com redes heterogneas atravs do uso do NCP

Compresso de dados

Autenticao

Automtica configurao e negociao dinmica de um


endereo IP, assim no precisam ser enviados em cada
pacote os endereos de destino e origem, somente nos
pacotes para estabelecimento da conexo.

Principais Desvantagens

Acrscimo de 3 bytes extra por frame em relao ao protocolo


SLIP;

Poucos frames de negociao quando a conexo


estabelecida;

Implementao mais complexa - a implementao do SLIP


utiliza-se apenas de bits do tipo END e ESC. J o protocolo
PPP utiliza-se de um conjunto de bits especiais mostrados na
figura abaixo:

31

Figura 03: Formato do pacote PPP


FRAME RELAY
Outro protocolo muito utilizado para acesso redes pblicas o Frame
Relay. As primeiras redes pblicas de Frame Relay foram estabelecidas em 1991 e
so consideradas uma evoluo das redes que utilizam protocolo X.25 de
comutao de pacotes. Tcnica de comutao rpida de pacotes com transferncia
de unidades de informao de tamanho varivel. Suporte s Redes Digitais de
Servios Integrados de Faixa Estreita ( RDSI-FE). O Frame Relay um protocolo
leve, baseado nos dois primeiros nveis do modelo OSI. uma forma de se
conseguir mltiplas conexes de dados entre dois ou mais pontos atravs de uma
rede pbica (WAN). Para utilizar de forma eficiente os recursos da rede, o trfego
da informao em um nico circuito fsico multiplexado (compartilhado) com base
em estatsticas de utilizao, enviando os "frames" na ordem correta e verificando
erros de transmisso. Porm, os frames defeituosos so simplesmente ignorados,
por isso o Frame Relay precisa funcionar em um caminho livre de erros, como
circuitos digitais ou fibra tica. A informao transmitida atravs das unidades
bsicas chamadas "frames" (quadros), sendo que pacotes gerados por outros
protocolos (como TCP/IP) podem ser "encapsulados" dentro de um frame para
serem transportados pela rede, dando a impresso ao usurio de que existe uma
conexo direta e transparente entre os dois pontos da rede. Portanto, os demais
protocolos de redes locais (como o TCP/IP, IPX, Apple Talk, etc.) funcionam sobre o
Frame Relay, porm, com redues de recursos (ignorando certas funes como

32

retransmisso automtica e outras) para aumentar sua velocidade. Tcnica de


comutao rpida de pacotes com transferncia de unidades de informao de
tamanho varivel. Suporte s Redes Digitais de Servios Integrados de Faixa
Estreita ( RDSI-FE ) .
VANTAGENS DO FRAME RELAY

A transmisso de dados ganha em desempenho;


O uso do Frame Relay reduz os custos de renovao das
ferramentas e dos recursos de acesso Internet, pois aumentam a
eficincia do equipamento j instalado, bem como do acesso s
informaes. Como o Frame Relay um protocolo no qual os dados
so enviados em forma de pacotes (de tamanho varivel), isso
garante ampla flexibilidade e grande eficincia no uso da "largura da
banda", alm de maior confiabilidade nos servios de conexo, pois
desenvolveu-se o Frame Relay com base nos recursos da rede WAN
e nas capacidades adicionais para complexos ambientes de Internet;

Permite a integrao de dados e voz;

Facilidade de migrao e interoperabilidade com o ATM;

Capacidade flexvel de multipontos;

Custos mais baixos de conexes entre redes, pois pode-se obter mltiplas
conexes lgicas em um nico meio fsico;

Os custos de equipamentos e de acesso so mais baixos - melhor


desempenho, maior acesso e menor complexidade da rede.

O emprego do Frame Relay via satlite traz os seguintes benefcios:

Possibilidade de conexes entre todas as estaes com salto nico de


satlite;

Possibilidade de implementao de redes Full Mesh;

Gerncia integrada de todo o sistema;

Reduo de investimento em equipamentos;

Reduo de custo do segmento espacial, devido economia de banda do


satlite;

33

Otimizao de trfego em funo da multiplexao estatstica;


Possibilidade de conexes assimtricas em termos de velocidade de

transmisso
Desvantagens do Frame Relay
Do mesmo modo como na Internet, as redes baseadas no Frame Relay
apresentam riscos. Quando se trata de segurana, os administradores de redes
precisam pensar alm da Internet. verdade que os usurios do Frame Relay no
esto sujeitos aos conhecidos hackers que usam a Internet. Mas, quando
contratando todo o servio de backbone do provedor de servios, isso est longe
de significar que tais redes sejam inerentemente seguras. O Frame Relay usa
switches onde as informaes so compartilhadas por uma srie de linhas
alugadas. Algumas vezes essas linhas no so sequer controladas pelo provedor
de servios. E em qualquer lugar onde o trfego seja monitorado, por razes como
congestionamento, muito fcil para as pessoas monitorarem o contedo. Mas a
maior parte dos usurios no faz qualquer segurana no Frame Relay. Elas
simplesmente confiam em seus provedores.
Comparando com a Internet, que aberta e insegura por concepo, fcil
verificar por que os administradores de rede acham que seus dados esto seguros
em outra rede pblica. Na verdade, a maioria das alternativas de linhas privadas,
como o Frame Relay, oferece maior segurana que o TCP, um protocolo que
objetiva o mximo de conectividade. Mas mais seguro que a Internet no significa
necessariamente o mesmo que adequadamente protegido. Os especialistas dizem
que as reas de vulnerabilidade incluem brechas fsicas de segurana, a facilidade
de ataques internos, engano da operadora e conexes internacionais. Segundo
eles, mesmo os administradores de redes conscientes da segurana muitas vezes
negligenciam um ponto obviamente fraco: a segurana fsica. Roteadores, switches
e dispositivos de segurana, como as caixas de criptografia das VPNs, deveriam
ser encerradas numa sala trancada.
Alm disso, os administradores deveriam se assegurar de que essas caixas
sejam to prova de adulteraes quanto possvel. Na hiptese de que possa

34

ocorrer acesso no-autorizado sala fechada, todos os equipamentos deveriam


ser protegidos por senha. As senhas escolhidas por capacidades de superviso
devem seguir regras apropriadas, como uma combinao de letras e smbolos
evitando-se nomes e palavras. As senhas tambm devem ser alteradas
rotineiramente. Se uma caixa oferece um recurso prova de adulterao, ele deve
ser apropriadamente ativado. Alm da segurana fsica, os administradores
tambm devem tomar uma atitude de confiar desconfiando das prprias
operadoras. Por exemplo, como esto particionados os sistemas de uma
operadora? A maioria das redes Frame Relay so divididas em duas avenidas: a de
entrada, que inclui os cabos e switches que transportam os dados do cliente, e a
de sada, que consiste da rede que monitora e administra a rodovia Frame Relay.
As operadoras, muitas vezes, usam TCP/IP na rede de administrao de
sada. Por isso, preciso se assegurar de que os hackers no tm acesso essa
rede. Um dos melhores mtodos para saber como uma operadora protege sua
rede simplesmente perguntando. Ela deve esclarecer sobre que tipos de polticas
e de tecnologias de segurana so utilizadas e o que elas faro se ocorrer um
ingresso no-autorizado. No lado da entrada, os administradores de rede devem
estar atentos s potenciais vulnerabilidades da prpria tecnologia. A maioria dos
provedores de Frame Relay usam PVCs (circuitos virtuais permanentes) com
caminhos ponto a ponto fixos designados ao trfego do usurio.
"High-level data link control" (HDLC)
O HDLC uma especificao do nvel 2 do MR-OSI com grande utilizao e
que inclui diversas variantes, utiliza a transmisso sncrona de tramas, orientada
por bit.
Existem trs tipos de ns:

Primrios: controlam a ligao e emitem comandos sob a forma de tramas

Secundrios: esto sob o controlo do n primrio, emitindo as respostas aos


comandos solicitados. Quando existe mais do que um n secundrio, o n
primrio mantm uma ligao lgica independente para cada um.

Combinados: controla a ligao, mas tambm emite respostas.

35

Se numa linha multiponto ou ponto a ponto existe um n primrio e um ou mais


secundrios, a ligao no balanceada. Se numa ligao ponto a ponto existem
dois ns combinados a ligao balanceada.
Numa ligao balanceada qualquer dos ns combinados pode iniciar uma
transmisso, este modo de transmisso designado por ABM (Asynchronous
balanced mode).
Numa ligao no balanceada o modo normal de funcionamento NRM
(Normal Response Mode), os ns secundrios s podem transmitir quando
solicitados pelo n primrio.
Existe ainda um terceiro modo, raramente usado, que permite que numa ligao
no balanceada os ns secundrios tomem a iniciativa de transmitir, trata-se do
ARM (Asynchronous response mode).
Tramas HDLC
Existe um nico formato de trama que usado tanto para transmisso de
dados como informao de controlo:

Todas as tramas so delimitadas por flags de sincronizao de trama.


Estas flags so constitudas por 8 bits com o padro 01111110. Uma nica
flag pode ser usada para assinalar o fim de uma trama e inicio da seguinte.
Para evitar que os dados no interior da trama sejam confundidos com a
flag que assinala o fim da trama utiliza-se o seguinte procedimento conhecido
como bit stuffing:

Antes de emitir a trama verificado se os dados contm seqncias de mais


do que 5 uns e a cada uma delas adicionado (inserido a seguir) um bit
zero.

No receptor, sempre que detectada uma seqncia de 5 uns, verifica-se o


bit seguinte, se zero trata-se de dados pelo que este bit eliminado, se
um ento trata-se da flag de sincronizao de trama.

36

O endereo usado para identificar o n secundrio a que se destina o


comando ou o n secundrio que emitiu a resposta, numa configurao ponto-aponto no necessrio, mas existe sempre.
Normalmente um endereo de 7 bits (127 ns secundrios) suficiente, mas
possvel usar endereos com qualquer nmero de bits mltiplo de 7. Para cada
octeto, se o oitavo bit um, significa que no existem mais octetos de endereo, se
zero o endereo continua. O octeto 11111111 reservado para broadcast
permitindo ao n primrio enviar uma trama para todos os secundrios.
O campo de controlo comea com dois bits que identificam o tipo de trama.
Existem trs tipos de trama e a parte restante deste campo diferente para cada
um deles. Os trs tipos de trama so:

Information Frames (I-Frames) destinam-se a transportar dados e podem


ainda ser usados para ARQ e controlo de fluxo (piggybacking).

Supervisory Frames (S-Frames), quando no usado o piggybacking so


necessrias tramas deste tipo para controlo de erros e fluxo.

Unnumbered Frames (U-Frames), tal como o seu nome indica, e ao


contrrio das anteriores, estas tramas no possuem nmero de seqncia.
Os U-frames so usados para funes de controlo diversas, tais como:
alterao do modo de funcionamento dos ns;

O esquema seguinte apresenta a constituio do campo de controlo para os


vrios tipos de "trama":

O bits assinalado com P/F (Poll/Final) tem diversas funes conforme o


tipo de trama, e de acordo com o modo de funcionamento da ligao. Por exemplo
numa trama I em modo normal de resposta (NRM), o n primrio coloca este bit a 1
para permitir ao n secundrio responder e o n secundrio coloca-o a 1 para
indicar que se trata da ultima trama da resposta.

37

As tramas I e S podem ter o campo de controlo expandido para 16 bits, isto permite
aumentar os nmeros de seqncia de 3 para 7 bits. A comutao entre control de
8 ou 16 bits realizada com funes U.
O campo de dados s existe nas tramas I e, em alguns casos, nas tramas U.
Contm os dados a transmitir ao n destinatrio, embora no standard no exista
comprimento mximo definido, cada implementao particular impe limitaes.
O FCS de 16 bits corresponde ao CRT-CCITT, no entanto, quando tal se
justifica, certas implementaes podem usar o CRC-32, dando origem a um FCS
de 32 bits.
Operao do HDLC
As transferncias de dados baseiam-se nas tramas-I, cada trama contm um
nmero de seqncia de emisso, e um nmero de seqncia de recepo. O
nmero de seqncia de recepo funciona como confirmao de recepo de
tramas anteriormente enviadas em sentido inverso (piggybackind). Trata-se do
nmero de seqncia da trama que esperada a seguir, o tamanho mximo da
janela pode variar entre 7 e 127.
Embora as tramas I possam por si controlar o fluxo e os erros, nem sempre
isso adequado (pode no existir uma trama I pronta a enviar, para transportar o
ACK), neste caso usam-se tramas S.
As tramas S permitem a implementao de ARQ em modo stop & wait, goback-n ou selective-repeat, para este efeito esto definidos os seguintes
comandos:

Cdigo no Campo
de Control (Funo
S)

ComandoFuno

Descrio
Receiver Ready, um ACK que indica que o

00

RR

receptor se encontra pronto a receber mais


tramas (stop & wait).

38

Receiver Not Ready, um ACK que indica que


10

RNR

o receptor no se encontra pronto a receber mais

01

REJ

11

SREJ

tramas (stop & wait).


Reject, um NAK do modo go-back-n
Selective Reject, um NAK do modo selectiverepeat

O nmero de trama ao qual se aplica o comando indicado no campo N


de Seqncia de Recepo da trama S.
As funes proporcionadas pelas tramas U so bastante mais extensas e
diversificadas:

Comando(C)
Resposta (R)

Descrio
Set Normal Response Mode, enviado pelo n primrio ao

SNRM (C)

SNRME (C)
SARM (C)
SARME (C)
SABM (C)
SABME (C)

SIM (C)

DISC (C)

secundrio indicando que deve entrar em modo de ligao normal,


com campo de controlo de 8 bits.
Set Normal Response Mode Extended, idntico ao anterior, mas com
campo de controlo de 16 bits.
Set Asyncronous Response Mode, idntico ao SNRM, para o modo
assncrono.
Set Asyncronous Response Mode Extended, idntico ao SNRME,
para o modo assncrono.
Set Asyncronous Balanced Mode, idntico ao SNRM, para o modo
assncrono balanceado.
Set Asyncronous Balanced Mode Extended, idntico ao SNRME,
para o modo assncrono balanceado.
Set Initialization Mode, enviado pelo n primrio ao secundrio
para que este inicie um procedimento de inicializao, durante a
inicializao so enviados dados ao n secundrio usando tramas-U
com campo de dados (UI).
Disconnect, informa o destinatrio que a estao emissora deixar

39

de estar activa.
Unnumbered Acknowledgment, indica a aceitao do comando

UA (R)

enviado.
Disconnected Mode, resposta enviada sempre que outro n envia

DM (R)

um comando a indicar que o n no est em ligao. Esta resposta


igualmente usada para indicar a no aceitao de um comando.
Request Disconnect, esta resposta usada para pedir a quebra da

RD (R)

ligao estabelecida.
Request Initialization Mode, esta resposta usada quando o n no

RIM (R)

est pronto e vai ser reinicializado.


Unnumbered Information, usados para troca de informao entre ns

UI (C/R)

(status, etc).
Unnumbered Poll, usado para pedir informaes a ns, a resposta

UP (C)

ser um UI.
Reset, este comando usado para a recuperao de erros graves

RSET (C)

(FRMR), indica que o n reinicializou o seu nmero de sequncia de


envio, o destinatrio deve tambm reinicializar o seu nmero de
sequncia de resposta.
Exchange Identification, usado para a troca de informao sobre

XID (C/R)
TEST (C/R)
FRMR (R)

endereos e caractersticas entre dois ns.


Test, permite efectuar um teste da ligao com outro n, que deve
responder o mais brevemente possvel.
Frame Reject, indica que a trama recebida tem um erro que no
pode ser recuperado por ARQ.

Os comandos SNRM, SARM e SABM so usados para estabelecer a ligao


lgica, o n que as recebe responde com UA ou DM conforme aceita ou no a
ligao.
O comando DISC usado para quebrar a ligao lgica, o n que o recebe
responde com UA.
O protocolo HDLC repleto de funcionalidade e serviu de base a
diversas implementao, em algumas delas so implementaes parciais,

40

noutras a maior diferena est na sua designao e outras ainda o HDLC


apenas serviu de inspirao:

ADCCP (Advanced data communication control procedure) - desenvolvido


pelo ANSI, e largamente adoptado nos organismos estatais dos EUA, no
tem qualquer diferena significativa relativamente ao que aqui foi descrito.

LAP-B (Link access procedure - balanced) - adoptado pelo CCITT na


norma X.25.

SDLC (Synchronous data link control) - usado pela IBM, inclui algumas
capacidades adicionais.
LLC (Logical link control) - usado na arquitetura IEEE 802 das redes locais.

Principais caractersticas :

protocolo orientado a bit ;

utilizado na recomendao X25;

modo de operao sncrona;

pode operar em modo de resposta assncrona nas duas direes, com


ambos ETD e ECD desenvolvendo uma funo primria e secundria;

transmisso half-duplex e full-duplex;

suporta configuraes ponto-a-ponto e multiponto;

opera em linhas privadas ou discadas;

transmisso de dados atravs de frames;

transparncia dos dados garantida pela tcnica bit stuffing;

utiliza o mtodo de sliding window na transmisso;

pode operar em trs modos de resposta;

protocolo orientado a conexo, contendo operaes para:


o

estabelecer conexo;

transmitir dados;

reinicializar conexo;

encerrar conexo.

PROTOCOLO X.25

41

O standard X.25 define 3 nveis: Physical Level, Link Access Level e


Packet Level adequados ao estabelecimento de circuitos virtuais. No nvel fsico o
X.25 especifica uma interface DTE/DCE idntica do standard X21.
O standard X.21 define os nveis 1 a 3 do MR-OSI para redes de comutao
de circuitos, o nvel fsico descreve uma interface sncrona com um total de apenas
7 ligaes.
O nvel 2 do standard X.25 o LAP-B, trata-se de uma variante do HDLC em
modo assncrono balanceado.
O nvel 3 define um servio de circuito virtual. So usados dois tipos de
circuito virtual:

Temporrios: virtual call ou

switched

virtual circuit (SVC), so

estabelecidos pelos ns e quando j no so necessrios so desactivados.

Permanentes:

permanent

virtual

circuit

(PVC),

so

previamente

estabelecidos durante a inicializao da rede. Esto sempre disponveis sem


a necessidade de estabelecimento, contudo so fixos entre dois ns, no
podendo ser alterados.
Ligaes Lgicas
Cada n pode estabelecer circuitos virtuais (ligaes lgicas) com vrios
outros ns. Existe uma nica interface com o DCE, mas multiplexada em vrias
ligaes lgicas, cada ligao lgica identificada por 12 bits (nmero de circuito
virtual), dos 12 bits, quatro identificam o grupo de ligao lgica Logical Channel
Group Number (LCGN) que pode ter valores de 0 a 15. Os restantes 8 bits
identificam a ligao dentro do grupo Logical Channel Number (LCN), que pode
ter valores de 0 a 255.
A combinao LCGN/LCN permite um total de 4096 canais lgicos por cada
ligao fsica. A ligao lgica nmero zero reservada para reinicializaes e
diagnostico. Quando a ligao fsica no multiplexada, apenas existe uma ligao
lgica que ter o identificador 1.
Existem quatro categorias de ligaes lgicas de acordo com a gama de
canal lgico que usam:

42

a gama mais baixa (desde 1) destina-se a circuitos virtuais permanentes

a gama seguinte destina-se a ser usada pelos DCE quando recebem um


pedido de estabelecimento de ligao virtual. Quando o DCE recebe o
pedido, atribui-lhe um nmero livre desta gama e coloca-o no pacote Call
Indicator que enviado ao DTE.

a gama mais alta (at 4095) usada pelos DTE para emitir um pedido de
ligao virtual, o DTE atribui a cada pacote Call Request um nmero desta
gama que se encontre livre.
Ao longo de rede X.25, um circuito virtual usa diversos canais para ligao

entre os diversos ns:

Na figura esto representadas vrias ligaes lgicas com os respectivos


canais, s com estes dados nada se pode dizer relativamente aos circuitos virtuais
que esto estabelecidos. Os nmeros de canal lgico apenas dizem respeito a um
dado n e no se mantm ao longo de todo o circuito. Em cada n nunca podem
existir dois nmeros de canal lgico iguais.
Suponha-se o seguinte estabelecimento de circuito virtual atravs de uma rede de
ns intermdios X.25 tal como apresentado na figura:
1. O n B envia um pacote Call Request usando o canal 4032 e como
endereo de destino a estao D.
2. O DCE do comutador 1 recebe o pacote e usa o canal 300 para o enviar ao
seu DTE.
3. O comutador 1 recebe o pacote Call Indicator (do seu DCE) no canal 300 e
envia ao DCE do comutador 2 um pacote Call Request, usando o canal
3000 (da sua gama livre).
4. O DCE do comutador 2 recebe o pedido e usa o canal 390.

43

5. O comutador 2 recebe o pacote Call Indicator, no canal 390 e envia ao


DCE do n D o pacote Call Request, usando o canal 3500 (da sua gama
livre).
6. O DCE do n D recebe o pacote e usa o canal 300.
7. O n D aceita o Call Indicator e envia ao seu DCE o pacote Call Accepted
pelo mesmo canal (300).
8. O DCE do n D envia ao comutador 2 o pacote de aceitao usando o canal
3500.
9. O comutador 2 retransmite usando o canal 390.
10. O DCE do comutador 2 envia pelo canal 3000 ao comutador 1.
11. O comutador 1 retransmite usando o canal 300.
12. O DCE do comutador 1 envia usando o canal 4032.
13. O n A recebe o pacote Call Accepted pelo mesmo canal por onde enviou
o pedido (4032).
Como se pode observar os DCE assumem o importante papel de associar os
canais usados do lado do seu DTE com os canais usados na rede pelos outros
DCE.
Pacotes X.25
Existem dois tipos bsicos de pacote X.25: de dados e de controlo. O
terceiro octeto do pacote X.25 define o seu tipo:

O DTE efetua o encapsulamento dos pacotes X.25 em tramas LAP-B (um


pacote por trama) e envia-as ao seu DCE. O DCE remove a informao de nvel 2
(LAP-B) e encapsula os pacotes X.25 de acordo com o protocolo de rede que est
a ser usado. Por outras palavras o LAP-B apenas usado para comunicao DTEDCE.

44

Este procedimento garante a independncia do DTE relativamente rede: o


acesso DTE-DCE uniforme ( sempre usado o LAP-B), por outro lado o DCE ter
de ser do tipo apropriado ao protocolo usado na rede.
Controlo de Fluxo e Erros
O controlo de fluxo dos pacotes X.25 muito idntico ao do seu nvel de
ligao lgica (HDLC). utilizado um protocolo de janela deslizante que se baseia
nos nmeros de seqncia includos nos pacotes de dados. Tal como no HDLC o
nmero de seqncia de recepo transporta o nmero do pacote esperado a
seguir (piggybacking). Quando no h pacotes de dados disponveis para
transportar esta informao, so usados pacotes de controlo Receiver Ready
(RR) e Receiver Not Ready (RNR) de um modo totalmente idntico ao HDLC.
O mecanismo de controlo de fluxo e erros pode funcionar em dois modos:

local - neste modo o controlo realizado entre o DTE e um dos DCE


envolvidos (local ou remoto), o bit D dos pacotes tem ento o valor 0.

ponto-a-ponto - neste modo o controlo realizado entre os dois DTE


envolvidos, neste caso o bit D ter o valor 1.

Seqncias de Pacotes
O X.25 permite o envio de seqncias de pacotes, que permanecem
associados uns aos outros. Esta caracterstica vantajosa quando os tamanhos
mximos de trama variam ao longo da rede: com este tipo de pacotes, a rede pode
efetuar a sua juno ou diviso para que se adaptem dimenso mxima
permitida.
So definidos dois tipos de pacotes:

Pacotes A: Tm o bit M com o valor 1 e o bit D com o valor 0, alm disso


tm o tamanho mximo permitido.

Pacotes B: Todos os outros tipos de pacote.

Uma seqncia de pacotes constituda por vrios pacotes A, e no final um pacote


B. Quando o pacote B chega ao n destinatrio ser analisado:

se D=1, ser enviado um ACK ponto-a-ponto que valida a seqncia toda.

45

se o pacote B tem M=0 ento a seqncia terminou, se M=1 significa que


continua.

Fast Select
Quando se opta por uma dada tcnica, rapidamente se notam os seus
inconvenientes e so feitas tentativas para os atenuar. O maior problema dos
circuitos virtuais a existncia de um atraso inicial devido ao estabelecimento do
circuito, quando um n pretende apenas enviar uma pequena quantidade de dados
a outro n e receber uma resposta igualmente pequena este atraso torna-se muito
pesado.
Foram por isso includos dois mecanismos: servio de datagramas e fast
select.
O servio de datagramas foi mais tarde abandonado. O mecanismo fast
select usa os pacotes Call Request e Call Indication para transportar os dados,
normalmente este tipo de pacote apenas pode transportar 16 bytes, mas nesta
situao so permitidos 128 bytes.
Este tipo de pedido pode ser feito em dois modos:

restricted: neste caso o n de destino deve responder com um pacote


Clear Request contendo tambm um mximo de 128 bytes ( estabelecido
um circuito virtual que imediatamente destrudo).

unrestricted: neste caso estabelece-se um circuito virtual normal.

MODEM DIGITEL DT64MI

CARACTERISTICAS GERAIS

46

DT64MI
de uma d e produtos com vrias opes de velocidades e interfaces voltada a
Modens Banda-Base 19.200 bit/s duplex (DT192DX/T):

Velocidades de 1.200 a 19.200 bit/s.

Suporta transmisses a 2 ou 4 fios.

Opera em modo sncrono ou assncrono.

Portadora pseudo-controlada.

Modens Banda-Base de 64, 128 e 256 Kbit/s sncrono para operao em 4 fios
(DT64MI, DT128MI e DT256MI):

Modens sncronos.

Transmisso duplex a 4 fios.

Interfaces V.11, V.35 e G.703.

Lao Analgico Local (LAL), Digital Local (LDL) e Digital Remoto (LDR).
Versatilidade e funcionalidade em modens de alta velocidade. Modens para
servios do tipo bi-canal comutado, como datafone 64, vdeo-conferncia,
etc (DT64SWC e DT64SW-U):

Modem duplex a dois fios para comunicao digital.

Dois canais de 64 kbit/s para voz ou dados.

Multi-interface no lado usurio ( RS232, V.35, V.36 e X.21 ). - Alcance at 5


Km.

Permite conexo rede de telefonia pblica para comunicao de voz.

Ideal para servios como datafone 64 e vdeo conferncia.

Especificaes

Transmisso

Binria serial, sncrona

Compatibilidade

Prticas Telebrs: 225 540 734 / 225


540 729, 225 540 750 / 225 540 773,
Mecnica: 225 540 736, 225 540 780

47

Velocidade

(SLIM), 225 540 271 (MCS).


DT-256MI: 48000 bps, 64000 bps,
128000 bps, 256000 bps, DT-128MI:
48000 bps, 64000 bps, 128000 bps, DT-

Tipo de Ligao
Tipo de Linha

64MI 48000 bps, 64000 bps.


4 fios
Linha privativa para comunicao de

Testes

dados (LPCD), tipo B


Laos Locais: Analgico e Digital, Lao

Alimentao

Remoto: Digital
GB8000: 110/127/220 Vca (+/- 15%),
DTSMP: DT-F512CA = 110-127/220 Vca
(+/-15%), DT-F512CC = -48 Vcc (+/25%), DTSMP-20: DTFS12-20CA = 110127/220 Vca (+/-15%), DTF512CC-20 =

Condies Ambientais

-48 Vcc (+/-25%).


Operao: OC a 45C,
Armazenamento: -5C a 50C,
Transporte: -40C a 70C, Umidade

Dimenses e Peso

Relativa: At 95%
Altura: 33,5 mm ou 15,5 mm (SLIM e
MCS), Largura: 177 mm, Profundidade:

Proteo EItrica na Linha

316,6 mm, Peso: 500 g.


Atravs de diodos zener no secundrio
do transformador de linha e atravs de
supressor de transiente no primrio do

Tipo de Codificao
Interface

transformador
Bipolar HDB3
Padro 180-4902 V.11(V.36), Padro
lSO-2593 (V.35), Padro G703, Prtica

Equalizao
Impedncia de Saida
Frequncia do Receptor

Telebrs 225540750
Automtica adaptativa
150 Ohms
Equivalente a taxa de dados e
sincronizada com o relgio do

48

Atraso RTS/CTS
Para ligao ponto a ponto,

transmissor remoto
Fixo menos de 2 ms
DT256MI

relao/sinal ruido maior ou igual a

256 Kbit/s: 4 km

24 dB, fio 0,4mm, com taxa de erros

128 Kbit/s: 4,5 km

menor que 1x10-6. O alcance nominal


apresentado na tabela o lado.

64 Kbit/s: 5 km
48 Kbit/s: 5 km
DT128MI
256 Kbit/s:
128 Kbit/s: 4,5 km
64 Kbit/s: 5 km
48 Kbit/s: 5 km
DT64MI
256 Kbit/s:
128 Kbit/s:
64 Kbit/s: 5 km

Portadora

48 Kbit/s: 5 km
Constante

INTERFACE
A interface utilizada pelo Modem DIGITEL DT64MI a V.35:
A recomendao V.35 da CCITT estabelece a transmisso de dados a 48
kbits/s usando largura de banda na faixa de 60 a 108 kHz.
Preferencialmente esta transmisso dever ser no modo sncrono, operando
em modo full-duplex e utilizando modulao em amplitude.
Obs.: Esta recomendao por ser considerada obsoleta, foi cancelada pelo WTSC93.
CCITT

49

"Comit Consultatif Internationale de Telegraphie et Telephonie"


Comite internacional, com sede em Genebra, que elabora uma srie de
recomendaes nas reas de telegrafia e telefonia, incluindo transmisso de
dados.
DESCRIO DA INTERFACE V.35
Segundo as normas da CCITT a interface V.35 composta pelos seguintes
circuitos :
Nmero / Descrio

102 / Signal Graund (SG) ou common return (Terra de Sinalizao)


Estabelece uma referncia de aterramento para todas as linhas,
incluindo dados, temporizao e sinais de controle. A voltagem nesse
circuito definida como 0V para que haja uma referncia para todos os
sinais,e so emitidos/recebidos pelo DCE ou DTE.

103 / Transmitted Data (TD) (Dados Transmitidos)


Este o circuito atravs do qual o fluxo serial de bits de dados passa
do terminal para o modem, onde modulado para transmisso.

104 / Received Data (RD) (Dados Recebidos)


Depois que um modem demodula os dados, eles so transferidos
para o terminal atravs desse circuito ligao. Quando o modem no est
enviando dados para o terminal, esse circuito fica na condio de marcao.

105 / Request to Send (RTS) (Solicitao para Envio)


Depois que um modem demodula os dados, eles so transferidos para o

terminal atravs desse circuito ligao. Quando o modem no est enviando


dados para o terminal, esse circuito fica na condio de marcao.

106 / Readin for Sending ou Clear to Send (CTS) (Inicializao para


Envio)

50

Esse circuito de ligao envia um sinal ao terminal indicando que o


modem est pronto para transmitir. Desligando esse cirucuito, o modem
informa ao terminal que no est pronto para receber dados. O modem
emite o sinal CTS depois que terminal inicializa um sinal Request to Send
(RTS).

107 / Data Set Ready (DSR) (Conjunto de Dados Pronto)


Os sinais nesse circuito de ligao indicam o status do modem

conectado ao terminal. Quando esse circuito est ativo (ON - nvel lgico 0), ele
serve como um sinal para informar ao terminal que o modem est conectado
linha telefnica e est pronto para transmitir dados.

109 / Data Channel Receive Line Signal Detector ou Carrier Detect (CD)
(Deteco de Portadora)
Um sinal nesse circuito indica ao terminal que o modem est recebendo

um sinal de onda portadora de um modem remoto.


A Onda Portadora um tom emitido numa determinada freqncia. Ele
sozinho no transmite qualquer informao. Para transmitir informaes no
sinal da onda portadora, o modem altera a amplitude, a freqncia e a fase do
Uma das maiores diferenas entre modems assncronos e sncronos so os
sinais e procedimentos de temporizao necessrios para a transmisso
sncrona.

114 / Transmitter Signal Element Timing (Temporizador do Sinal de


Transmisso)
Utilizado quando o DCE fornece o sinal de temporizao.
DCE/DTE
No mundo da comunicao de dados, os equipamentos como

computadores pessoais, terminais e portas de computador so chamados de


Equipamentos Terminais de Dados (DTEs). Por outro lado modems e outros

51

dispositivos de comunicao so conhecidos como Equipamentos de


Comunicao de Dados (DCEs).

115 / Receiver Signal Element Timing (Temporizador do Sinal de


Recepo)
Utilizado quando o DCE recebe o sinal de sincronizao atravs da linha

a qual ele est conectado.


A tabela1 a seguir apresenta os sinais acima com a respectiva direo
em que so emitidos/recebidos pelo DCE ou DTE.
TABELA DE INTERFACES

OPES

ESTRAPE / POSIO
S1 a S15
1-2
2-3
1-2

V.11
V.35
G703

S16 a S20
1-2
1-2
2-3

TABELA1

52

ALCANCE NOMINAL
Para ligao ponto a ponto, relao/ sinal rudo maior ou igual a 24
dB, fio 0.4mm, com taxa de erros menor que 1*10?, o alcance nominal
apresentado na tabela a seguir:
Velocidade
256.000bps
128.000bps
64.000bps
48.000bps

DT256MI
4,5
5,5
6,5
6,5

DT128MI
5,5
6,5
6,5
ALCANCE NOMINAL (km)

DT64MI
6,5
6,5

VELOCIDADE

53

OPO
DT64MI
64.000
48.000

CHAVE/POSIO
SW9-1
SW9-2
DIR
ESQ
DIR
ESQ

SW9-3
ESQ
DIR

SW9-4
DIR
DIR

Relgio Interno
Derivado do oscilador interno do modem, utilizado quando o modem
fornece o relgio para o sistema.
Relgio Regenerado
Recupera o relgio recebido da linha para sincronizar os dados transmitidos,
utilizados quando o lado remoto gera o relgio para o sistema.
Relgio Externo
Gerado pelo ETD, utilizado quando o ETD gera o relgio para o sistema.

OPES
Interno (INT)
Regenerado (RREG)
Externo (EXT)

CHAVE / POSIO
SW8-7
SW8-8
ESQ
ESQ
ESQ
DIR
DIR
ESQ
Relgio De Transmisso

CTS
Seleciona o sinal fornecido pelo pino 5 da interface digital (CT106) e indica
que o modem est pronto para transmitir dados. N a posio ON, o CT106
estar sempre ligado. Na posio controlado, o CTS106 responde ao sinal RTS,
aps decorrido o atraso de aproximadamente 2ms. Em operao com interface
G703 esta funo torna-se inoperante.
OPES
Controlado
ON

CHAVE / POSIO
SW8-1
ESQ
DIR
CTS

54

GANHO NA RECEPO
Reala o ganho na recepo do modem para linhas longas.
OPES

Estrape / POSIO
S22
0dB
0
+6dB
6
+12dB
12
Ganho na Recepo

SCRAMBLER
Utilizada para melhorar a qualidade da comunicao entre modens
permitindo uma melhor recuperao do sincronismo do sinal pelo modem remoto.O
Scrambler deve

estar habilitado no modem remoto simultaneamente. Caso

seja programado Scrambler somente uma das pontas haver erro na comunicao.
OPES

Estrape / POSIO
SW8-5
Habilitado(HAB)
ESQ
Inibido (INI)
DIR
Scrambler
FUNO DOS INDICADORES
No painel do modem existe 7 indicadores do modo de operao e sinais de
interface.
LED
ALIM

DESCRIO
Amarelo. Acesso indica que a fonte de alimentao CC interna est
fornecendo corretamente todas as tenses para operao do

TESTE

modem.
Verde. Aceso indica que o modem encontra-se em condies de

lao analgico ou digital, acionado local o remotamente.


109 / HDB3 Vermelho. 109: Quando programado interface V.35, aceso indica
portadora detectada. HDB3: Quando programado interface G703
55

104 / RX

representa presena de sinal na linha de recepo do modem.


Vermelho. Aceso quando o modem receber espao( +V ) da linha
de recepo. 104: Quando programado V.11 / V.35 representa os
dados enviados ao ETD pelo CT104. RX: Quando programado

G703 representa os dados enviados linha RX da interface G703.


106 / G703 Vermelho. 106: Quando programado interface V.11 / V.35, aceso
indica ao terminal que o modem est pronto para transmitir dados.
G703: Quando programado interface G703, aceso indica atividade
103 / TX

na linha TX da interface G703.


Vermelho. Aceso quando o

modem

est

transmitindo

espao( +V ). 103: Quando programado V.11 / V.35, representa os


dados provenientes do ETD pelo CT103. TX: Quando programado
G703 representa os dados provenientes da linha TX da interface
RINT

G703.
Vermelho. Aceso quando o modem estiver operando com relgio
interno.

56