Você está na página 1de 40

APRICOT 2014 MPLS WORKSHOP

ALCATEL-LUCENT EQUIPMENT AND LAB INTRODUCTION


AJ and Reza
February 2014
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

ALCATEL-LUCENT 7750 SERVICE ROUTER FAMILY

7750 SR-12e

7750 SR-12

7750 SR-7

7750 SR-c12

7750 SR-c4

7.2 Tb/s+
400G per slot and
beyond

4 Tb/s
200G per slot

2 Tb/s
200G per slot

90 Gb/s

90 Gb/s

12 slots (9 user slots)


1/2 rack

12 slots (10 user


slots) 1/3 rack

7 slots (5 user slots)


8RU

12 compact slots
(or 3 full slots)

4 compact slots - fully


front accessible

Terabit IP/MPLS
multiservice router

Terabit IP/MPLS
multiservice router

Mid-scale IP/MPLS
multiservice router

Small POP router for


SPs/Verticals

Small POP router for


business edge

3
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

ALCATEL-LUCENT 7750 SR-12 CHASSIS OVERVIEW


1+1 Switch Fabric/Control Processor Module
with Redundancy
(Dual Active Fabrics)

19 Rack
Width

2 Tb/s (HD) Forwarding Capacity

10 Input/Output
Line Card Slots
with 20,50 or 100 Gb/s
slots

5
SLOTS
IOM
IMM

S
F
/
C
P
M

S
F
/
C
P
M

F
A
N

5
SLOTS
IOM
IMM

14 RU Height
1/3 Rack

T
R
A
Y

F
A
N

T
R
A
Y

F
A
N

T
R
A
Y

N+1 Cooling
Redundancy
Front-to-back
Airflow
NEBS3 compliant

1+1 DC Power Inputs

Air Intake

AC through external

FRONT VIEW

REAR VIEW

H I G H - E N D M U LT I - S E RV I C E E D G E A N D C O R E R O U T E R
4
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

1 RU rectifiers

ROUTER COMPONENTS
BOF Boot Options File defines the configuration for router bootstrap (config, software, etc) and
out-of-band configuration

POST Power On Self Test checks for basic functionality of router hardware and determines what
interfaces are present
RAM holds the running software, routing memory, packet buffers, etc. There are multiple types of
RAM in the 7750SR present on multiple cards

Flash holds the software, log files, and persistent configuration. There are three flash slots in the
7750SR (per SF/CPM)
SF/CPM Switch Fabric/Control Plane Module, that provides the switch fabric between slots and
the control processor that runs the main SR-OS software and centralised functions like routing
protocols
IOM I/O Module that provides connectivity to MDAs and the switch fabric, hosts the queuing and
packet forwarding functions
MDA Media Dependent Adapter hosted in an IOM, and provides the physical layer connectivity
5
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

IN THE LAB
Virtualised lab, based in Mountain View, California
- Access will be via SSH only you will need an SSH client!

56 7750SR-12
- 1 IOM3-XP (slot 1)
- 20-port Gigabit Ethernet card (slot 1/1)

Each pod will have 8 routers


- Port descriptions are prepopulated so you can find the mappings easily
- The individual lab pods will use their designated routers, and the physical connectivity between routers

6
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

SR-OS INTRODUCTION
SR-OS is Alcatel-Lucents Service Routing Operating System that runs on all 7X50 family products
Some CLI will feel familiar to those experienced with IOS or JUNOS, other CLI will feel different
SR-OS is a real-time operating system, with real time configuration actions (except for routing
policy which does allow candidate configuration editing and atomic commits)
SR-OS also makes extensive use of service constructs which relate to individual service
configuration
- E.g. service vprn 123 is a L3VPN, with identifier 123. All protocol configuration and logical interface
configuration occurs here

SAP
SDP

7
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

INITIAL LOGIN - SROS


TiMOS-B-8.0.R5 both/hops ALCATEL SR 7750 Copyright (c) 2000-2010 Alcatel-Lucent.
All rights reserved. All use subject to applicable license agreements.

Built on Tue Sep 28 18:27:04 PDT 2010 by builder in /rel8.0/b1/R5/panos/main

Login: admin
Password: admin
*A:cses-A15#

8
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

EMAC STYLE SHORTCUTS


Shortcut

Key Combination

Start of Line

Ctrl-A (^A)

End of Line

Ctrl-E (^E)

Delete Line

Ctrl-U (^U)

Delete Cursor to End of Line

Ctrl-K (^K)

Delete Previous Word

Ctrl-W (^W)

Redraw Line

Ctrl-L (^L)

Exit from config mode

Ctrl-Z (^Z)

9
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

COMMAND COMPLETION
Space bar completes a command

Tab key completes a variable


\ or / can be used to run a top-level command from any context
- config>router>service#\show time

Help is available with ? after any command


A:NS065051303# configure service
- service

[no]
[no]
[no]
[no]
[no]
[]

apipe
cpipe
customer
egress-multica*
epipe

+
+
+
+
+

Provision
Provision
Provision
Create an
Provision

an ATM-Pipe Service
a Circuit Emulation Pipe Service
a customer
Egress Multicast Group
an Ether-Pipe Service

10
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

USING | (PIPE)
The pipe function is used to filter output

11
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

ROUTER MODES CHANGE AND PROMPTS


A:Router#
- Default privileged mode at the root prompt.
- A refers to the SF/CPM
- Router is the hostname

A:Router>config#
- Configuration mode

A:Router>config>service#
- Sub-context within configuration mode

A:Router>config>service>vprn$
- Newly created context

*A:Router#
- Config has been changed and is unsaved

12
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

KEY CLI COMMANDS


info
- Applicable to the current context and displays the current configuration at that working level

show
- Applicable to most things: ports, cards, interfaces, routing table, services, etc
- The detail keyword is often very useful

admin
- Admin commands such as upgrade, save, reboot, time setting, etc.

tools
- Debugging and OAM tools that run on the router

configure
- Enter configuration mode. You can append full configure statements to this, e.g. configure port 1/1/1 ethernet speed 1000

monitor
- Port/SAP/service/etc monitor commands

tree
- Explain the command tree from the present context. Try tree flat detail | match bgp

And many more. Start with ? !


13
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

ROUTER AND SERVICE CONSTRUCTS


Ports refer to physical ports and their configuration
- Logical interfaces (router interface, SAPs in Service Constructs) are associated to ports

Router refers to the base routing instance


- This is the backbone configuration for the router, mostly used for forming routing adjacencies between other PE
and P routers
- All MPLS, BGP, OSPF, IS-IS, etc configuration is performed here
- Ports must be configured for network/access/hybrid mode

Services are configured under the service construct


-

VLL = EPIPE, IPIPE, APIPE, FPIPE, CPIPE


VPLS = VPLS
VPRN = Virtual Private Routed Network (VRF)
IES = Internet Enhanced Service, use this for Internet Routing Services

Services are associated with customers this is mostly a billing construct, and we use a single
customer ID for the workshop

Services must be configured on access or hybrid ports


14
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

ROUTER AND SERVICE CONSTRUCTS


Services have Service Access Points (SAP)
- These are logical interfaces within the service, that are associated to a port.
- The interface name does not have to be the same as the port name.
- E.g: interface test sap 1/2/3:4 refers to an interface called test on physical port 1/2/3, sub-interface
4.
- For consistency, I like to refer to the port and interface type, e.g. interface gig-1/1/1:4.

Services also have Service Distribution Points (SDP)


-

SDPs are logical references to router-router tunnels.


SDPs are associated with LSPs.
VPRNs can auto-bind to SDPs based on MP-BGP information
L2 services require static assignment to SDP (unless VPLS BGP-AD or RADIUS config is in use).

Its all about abstraction!

15
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

INITIAL CONFIGURATION CHECKLIST


The following items should be configured at initial system configuration:
-

Admin password
Host name (this is already done)
Domain name
Configuration file location (this is already done)
System logging
Default and backup routers for management (this is already done)
Configure remote access services
User accounts
System time
System and transient interfaces
Remaining configuration needed to put the router into service (protocols, filters, etc)

16
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

INITIAL CONFIGURATION
Log in as admin
Login: admin
Password: admin
*A:NS065051303#

Configure router name


*A:NS065051303# configure system name PE21
*A:PE21#

Configure router domain name


*A:PE21# bof dns-domain apricot.net

17
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

INITIAL CONFIGURATION
Adjust logging parameters if needed.
- Default log 99 is configured
- Additional logging destinations may be configured (e.g. syslog)

Commit changes so far


- admin save
- bof save

18
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

INITIAL CONFIGURATION
Configure system services for remote access
-

configure
configure
configure
configure

system
system
system
system

security
security
security
security

ssh preserve-key
ssh no server-shutdown
telnet[v6]-server
ftp-server

Configure banner
- configure system login-control banner
- configure system login-control motd
- configure system login-control pre-login-message

Configure user accounts


- Define roles
- Super-user
- Read Only
- Read Write
- configure system security profile
- configure system security user

19
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

INITIAL CONFIGURATION
Configure time zone and manually set the time of day
- configure system time zone
- admin set-time

Configure NTP
- configure system time [s]ntp <<server>>

Configure system interface


- configure router interface system address x.x.x.x/32
- configure router interface system address X:X:X:X/128
- configure router interface system no shutdown

20
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

INITIAL CONFIGURATION
Network mode for router-router
interfaces

Validate your port configurations


Configure port 1/1/n

Access mode for service interfaces


Hybrid allows both use this for the
workshop

configure port 1/1/1 ethernet mode hybrid


configure port 1/1/1 ethernet ?

Other options configurable here


(encapsulation, MTU, etc)

Configure interfaces between your lab routers


configure router interface to-P22
address X.X.X.X/24
port 1/1/n:0

Use descriptions
Consider other options you might want:

As were using hybrid ports in the


workshop, we need to specify a VLAN on
logical interfaces. For router-to-router
interfaces, use VLAN 0 (:0)

MTU
Speed/duplex

configure router (bgp|ospf|mpls|ldp|)

21
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

CLI COMPARISON
JUNOS

IOS

SR-OS

set date

clock set

admin set-time

ping

ping

ping

request system reboot

reload

admin reboot

request message

send

write

show system uptime

show version

show uptime

show chassis environment

show environment

show chassis environment

show cli history

show history

history

show log [file <name>]

show log

show log log-id <nn>

show system processes

show process

show system cpu

show configuration

show running-config

admin display-config

request support information

show tech-support

admin tech-support

show system users

show users

show users

show version
show chassis hardware

show version

show version
show card
show mda

set cli screen-length

terminal length

environment terminal length

set cli screen-width

terminal width

Should auto size

trace

traceroute

22
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

traceroute

LAB TOPOLOGY AS65000


Router Number System IP address
Link
number

Port

Local Subnet

Local Address

E.g. Link y

1/1/y

192.168.y/24

192.168.y.x

E.g. Cx, PEx, Px

E.g. Link 12 is port 1/1/12

P12

192.168.12.10on
onCE10
CE10
192.168.12.10
192.168.12.11on
onPE11
PE11
192.168.12.11

P22

Link 6

Link 10

C10

Link 12

PE11

E.g. Link 12 is
E.g. PE21 system address is
192.168.12.10
on CE10
10.0.0.21
192.168.12.11 on PE11

Link 3

Link 5

Link 8

PE21

Link 4

Link 9
Link 11

Link 2

P13

Link 7

10.0.0.x/32

P23

Each router has the port descriptions pre-populated (show port desc)
23
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

Link 1

C20

ACCESSING THE LAB


ssh to 50.18.147.8 using the port number of the router you are attaching to
Router

Port

Router

Port

Router

Port

Pod 1 C20

2001

Pod 2 C20

2009

Pod 3 C20

2017

Pod 1 PE21

2002

Pod 2 PE21

2010

Pod 3 PE21

2018

Pod 1 P22

2003

Pod 2 P22

2011

Pod 3 P22

2019

Pod 1 P23

2004

Pod 2 P23

2012

Pod 3 P23

2020

Pod 1 P12

2005

Pod 2 P12

2013

Pod 3 P12

2021

Pod 1 P13

2006

Pod 2 P13

2014

Pod 3 P13

2022

Pod 1 PE11

2007

Pod 2 PE11

2015

Pod 3 PE11

2023

Pod 1 CE10

2008

Pod 2 CE10

2016

Pod 3 CE10

2024

Username: admin
Password: admin
24
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

ACCESSING THE LAB


ssh to 50.18.147.8 using the port number of the router you are attaching to
Router

Port

Router

Port

Router

Port

Pod 4 C20

2025

Pod 5 C20

2033

Pod 6 C20

2041

Pod 4 PE21

2026

Pod 5 PE21

2034

Pod 6 PE21

2042

Pod 4 P22

2027

Pod 5 P22

2035

Pod 6 P22

2043

Pod 4 P23

2028

Pod 5 P23

2036

Pod 6 P23

2044

Pod 4 P12

2029

Pod 5 P12

2037

Pod 6 P12

2045

Pod 4 P13

2030

Pod 5 P13

2038

Pod 6 P13

2046

Pod 4 PE11

2031

Pod 5 PE11

2039

Pod 6 PE11

2047

Pod 4 CE10

2032

Pod 5 CE10

2040

Pod 6 CE10

2048

Username: admin
Password: admin
25
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

ACCESSING THE LAB


ssh to 50.18.147.8 using the port number of the router you are attaching to
Router

Port

Pod 7 C20

2049

Pod 7 PE21

2050

Pod 7 P22

2051

Pod 7 P23

2052

Pod 7 P12

2053

Pod 7 P13

2054

Pod 7 PE11

2055

Pod 7 CE10

2056

Username: admin
Password: admin
26
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

PUTTY EXAMPLE

27
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

LAB CONFIGURATION
1. Configure both ends of interfaces on all P and PE routers (CE routers will be configured for IP
VPN lab)
a.
b.

Ports already configured


Link y => port 1/1/y => link subnet 192.168.y/24 => link address 192.168.y.x on router X
config router interface gig-1/1/y
address 192.168.y.x/24
port 1/1/y:0
info
(shows configuration of interface)

c)

Check interfaces are up on each router


show router interface

c)

Ping local interface on each router


ping 192.168.y.x

(remote link address)

28
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

LAB CONFIGURATION (IS-IS)


1. Configure IS-IS on all P and PE routers
a.

Use a single process


config router isis
area-id 49
reference-bandwidth 100000000

b.

Use a single level-2


level-capability level-2
level 2 wide-metrics-only

c.

Ensure that ISIS is enabled on all network interfaces, including system


interface system passive
interface gig-1/1/y interface-type point-to-point

d.

Verify OSPF is exchanging routes on all interfaces


show router isis interface
show router isis adjacency

e.

On each router, verify that the system (loopback) addresses are visible and reachable (ping and
traceroute)
show router route-table

29
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

LAB CONFIGURATION (OSPF OPTIONAL)


1. Configure OSPF on all P and PE routers
a.

Use a single process


config router ospf <enter>

b.

Use a single OSPF area (0.0.0.0 backbone)


config router ospf area 0.0.0.0
Ensure that OSPF is enabled on all network interfaces, including system
interface system
interface gig-1/1/y
Verify OSPF is exchanging routes on all interfaces

c.

d.

show router ospf interface


show router ospf neighbor

e.

On each router, verify that the system (loopback) addresses are visible and reachable (ping and
traceroute)
show router route-table

30
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

LAB CONFIGURATION
2. Configure MPLS on all P and PE routers
a.

b.

a)

b)

c)
d)

Using Interface LDP (I-LDP)


config router ldp
Configure LDP on all network (PE-P-P-PE) interfaces
config router ldp interface-parameters
interface gig-1/1/y
Configure paths and LSPs (loose mode) between the routers
config router mpls path
config router mpls lsp
Validate that LDP is up, peers are up, bindings are up, LSPs are up
show router ldp session
show router ldp peer
show router ldp binding
Validate that MPLS is up, peers are up, bindings are up, LSPs are up
show router mpls lsp
Enable LDP ldp-shortcut
config router ldp-shortcut
31
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

LAB CONFIGURATION
f.
g.

h.

Traceroute the system IPs between two PE routers


Validate that IP hop-by-hop routing is in effect, and each hop is seen in a traceroute
Disable mpls TTL propagation for shortcuts on all routers in the path
config router mpls no shortcut-transit-ttl-propagate
config router mpls no shortcut-local-ttl-propagate
config router ldp no shortcut-transit-ttl-propagate
config router ldp no shortcut-local-ttl-propagate
Rerun traceroute and observe the results

32
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

L3 VPN CONFIG
iBGP peering between PEs (remember between system addresses)
Configure iBGP peers
configure router
autonomous-system <AS#>
bgp group <group-name>
type internal
family ipv4 vpn-ipv4
neighbor <remote PE>
exit

Check BGP peering


show router bgp summary

33
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

Parameters

PE

VPRN/Service-ID

Configure VPRN on PE

Route Distinguisher

?:?

configure service vprn <servide-id> customer 1 create

Route Target

?:?

Interface to CE

gig-1/1/y

Address for CE link

192.168.y.x/24

L3 VPN CONFIG

no shutdown
autonomous-system <AS#>
route-distinguisher <#:#>
auto-bind ldp

vrf-target target:?:?
interface loop" create
address <you-choose>/32
loopback
exit

interface gig-1/1/y create

Configure eBGP peering to CE


bgp group <group-name>
peer-as <CE AS#>
neighbor 192.168.y.x
exit

Check peering and routes


show service id <service-id> base
show router <servide-id> route-table

show router <servide-id> interface

sap 1/1/y:<svc-id> create


exit
address 192.168.y.x/24
exit

show router <servide-id> bgp summary

34
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

L3 VPN CONFIG
Configure CE
configure router
interface "gig-1/1/y" create

bgp

Parameters

CE

Interface to CE

gig-1/1/y

Address for CE link

192.168.y.x/24

Local AS

Remote (PE) AS

group <group-name>

address 192.168.y.x/24

family ipv4

sap 1/1/y:<svc-id> create

type external

Check peering and routes

exit

local-as <local AS#>

show router route-table

exit

peer-as <PE AS#>

show router interface

interface "loop" create

neighbor 192.168.y.x

address <you-choose>/32
loopback

exit
exit

exit

35
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

show router bgp summary

L3 VPN CONFIG
Create policies

configure router policy-options


begin
policy-statement <policy-name>

Check peering, routes and routes advertised


show router route-table

entry 10
from
protocol ?????
exit
action accept
exit
exit
exit
commit

Add policy
configure service vprn <servide-id>
bgp group <group-name> export <policy-name>
configure router

show router interface


show router bgp summary
show router <servide-id> route-table
show router <servide-id> interface
show router <servide-id> bgp summary
show router bgp neighbor <remote-address> advertised-routes
<address-family>
show router <service-id> bgp neighbor <remote-address>
advertised-routes <address-family>

bgp group <group-name> export <policy-name>

36
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

COMMAND EQUIVALENTS
SLIDE 37-43
IOS

SR-OS

ip cef

No equivalent

mpls label protocol <ldp | tdp | both>

config router mpls ldp no shutdown

tag-switching tdp router-id Loopback0

Auto derived from system IP, or explicitly configured via configure router ldp
interface-parameters local-lsr-id

mpls ldp explicit-null (optional)

No equivalent (always enabled, unless implicit-null is sent)

no mpls ip propagate-ttl

Enabled by default
configure router ldp [no] shortcut-local-ttl-propagate
configure router ldp [no] shortcut-transit-ttl-propagate

mpls ip

config router ldp interface-param int <intf> no shutdown

Conditional label distribution

*A:R6# configure router policy-options


*A:R6>config>router>policy-options# info
---------------------------------------------prefix-list "loopbacks"
prefix 192.168.6.0/24 longer
exit
policy-statement "LDP_export
entry 10
from
prefix-list "loopbacks
exit
action accept
exit
exit
exit
---------------------------------------------37
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.
*A:R6# configure router ldp export "LDP_export"

COMMAND EQUIVALENTS
SLIDE 48, 52
IOS

SR-OS

show mpls interface <int> detail

show router mpls interface<interface>


show router ldp interface <interface>

show mpls ldp discovery

show router ldp discovery [detail]

show mpls ldp neighbor

show router ldp peer [detail]

show mpls ip/ldp binding <prefix> <prefix-length>

show router ldp bindings {prefix <prefix/length>}

show mpls forwarding-table <prefix> <prefix-length>

show router tunnel-table

show ip cef <prefix>

show router route-table <prefix>


tools dump router fib <slot>

show mpls ldp parameters

show router ldp peer-parameters


show router ldp status

debug mpls ldp transport


debug mpls ldp session io

debug router ldp interface


debug router ldp peer

38
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.

COMMAND EQUIVALENTS
SLIDE 98, 117
IOS

SR-OS

show mpls interface <int> detail

show router mpls interface<interface>


show router ldp interface <interface>

show mpls ldp discovery

show router ldp discovery [detail]

show mpls ldp neighbor

show router ldp peer [detail]

show mpls ip/ldp binding <prefix> <prefix-length>

show router ldp bindings {prefix <prefix/length>}

show mpls forwarding-table <prefix> <prefix-length>

show router tunnel-table

show ip cef <prefix>

show router route-table <prefix>


tools dump router fib <slot>

show mpls ldp parameters

show router ldp peer-parameters


show router ldp status

debug mpls ldp advertisements

No equivalent command

debug mpls ldp binding

debug router ldp peer <peer-ip> event bindings

debug mpls ldp message sent|received

debug router ldp interface <int> event messages

39
COPYRIGHT 2013 ALCATEL-LUCENT. ALL RIGHTS RESERVED.