Você está na página 1de 22

Telefonica Vivo

Cisco Prime Provisioning


Phase 1.5
Workshop Package #1
Cisco Advanced Services
August, 01 2014

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

Fase 1 X Fase 1.5 pacote #1 e pacote #2


Recomendaes
Intragov
Deploy Simulado
DIA
Multicast Pool
Hands-on

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

Fase 1 CPP 6.3.0.120-25


L3VPN IPv4 Cisco IOS (tag)
L3VPN IPv4 Juniper (tag)
DIA IPv4 Cisco, Juniper e Huawei (tag)

Fase 1.5 pacote #1 CPP 6.5.0.5-01


Intragov IPv4 IOS (tag, qos, Multicast)
Intragov IPv6 IOS-XR (tag, qos, Multicast)
DIA IPv6 IOS (tag)

Intragov IPv4 IOS-XR (tag, qos, Multicast)

DIA IPv6 Huawei VRP (tag)

Controle do Multicast Pool IPv4 ( Importao )


Carga de configurao dos circuitos do legado Intragov IPv4 IOS e IOS-XR para o Cisco
Prime Provisioning, utilizando Deploy Simulado, de acordo com demanda de
configurao/alterao nestes circuitos.

Fase 1.5 pacote #2 CPP 6.6.1


Intragov IPv6 IOS (tag, qos)
L3VPN IPv4 IOS-XR (tag)

L3VPN IPv6 IOS (tag)

L3VPN IPv6 IOS-XR (tag)

L3VPN IPv6 Juniper (tag)

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

Dummy SR
A Cisco recomenda que no sejam removidos os 13 Dummy Service Requests criados
para importar os valores de RD Principal
Estes esto identificados no campo descrio como No remover ou DO NOT
REMOVE

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

IPv6
Para que o CPP identifique e seja capaz de provisionar circuitos usando IPv6 a opo
6VPE deve estar habilitada em cada um dos PEs que iro utlizar IPv6.
Menu Inventory > Provider Devices > Editar o Device

Multicast Pool
A Cisco recomenda que a Telefonica|Vivo ou utilize o recurso de pool de
multicast ou adicione manualmente os valores na VPN utilizando o CPP

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

Customizaes
Toda a funcionalidade para viabilizar o aprovisionamento das vrfs Intragov foi criada
atravs do uso do policy customization utilizando o apache velocity e NOM rules para as
linhas de comando no suportadas out-of-the-box.

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

Route Targets
Foram criados os seguintes route-targets para cada uma das 13 VRFs do Intragov:
Provider

Name

VPN Topology Auto-pick Route Target 1 Route Target 2

Telefonica_Empresas Intragov_INTRAGOV

Fully Meshed

NO

27699:350001

Telefonica_Empresas Intragov_EDUCACAO

Fully Meshed

NO

27699:351001

Telefonica_Empresas Intragov_CEETEPS

Fully Meshed

NO

27699:350501

Telefonica_Empresas Intragov_FAPESP
Intragov_TRIBUNAL-
Telefonica_Empresas JUSTICA

Fully Meshed

NO

27699:356001

Fully Meshed

NO

27699:334001

Telefonica_Empresas Intragov_METROPO

Fully Meshed

NO

27699:351501

Telefonica_Empresas Intragov_USP

Fully Meshed

NO

27699:354501

Telefonica_Empresas Intragov_PREFEITURAS Fully Meshed

NO

27699:339699

Telefonica_Empresas Intragov_TRANSITO

Fully Meshed

NO

27699:353001

Telefonica_Empresas Intragov_FAZENDA

Fully Meshed

NO

27699:355501

Telefonica_Empresas Intragov_UNESP

Fully Meshed

NO

27699:353501

Telefonica_Empresas Intragov_UNICAMP

Fully Meshed

NO

27699:354001

Telefonica_Empresas Intragov_PM

Hub and Spoke

NO

27699:352001

27699:327996

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

VPN
As VPNs foram criadas com a estrutura mostrada abaixo:
Enable Mul?cast
Name

Customer

En. Unique RD

IPv4

IPv6

Route Target(s)

INTRAGOV

Intragov

YES

YES

NO

Intragov_INTRAGOV

EDUCACAO

Intragov

YES

YES

NO

Intragov_EDUCACAO

CEETEPS

Intragov

YES

NO

NO

Intragov_CEETEPS

FAPESP

Intragov

YES

NO

NO

TRIBUNAL-JUSTICA Intragov

YES

NO

NO

Intragov_FAPESP
Intragov_TRIBUNAL-
JUSTICA

METROPO

Intragov

YES

NO

NO

Intragov_METROPO

USP

Intragov

YES

NO

NO

Intragov_USP

PREFEITURAS

Intragov

YES

NO

NO

Intragov_PREFEITURAS

TRANSITO

Intragov

YES

NO

NO

Intragov_TRANSITO

FAZENDA

Intragov

YES

NO

NO

Intragov_FAZENDA

UNESP

Intragov

YES

NO

NO

Intragov_UNESP

UNICAMP

Intragov

YES

NO

NO

Intragov_UNICAMP

PM

Intragov

YES

NO

NO

Intragov_PM

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

VPN
No CPP:

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

Policies
Foram criadas 13 policies, um para cada vrf do Intragov, o operador dever
selecionar a policy de acordo com a VPN que deseja adicionar um circuito ou
simular um deploy.
EDIT

TEMPLATE
ENABLE

27699

YES

YES

TfnIntragov.xml

27699

YES

YES

HUB

TfnIntragov.xml

27699

YES

YES

NO

HUB

TfnIntragov.xml

27699

YES

YES

TRIBUNAL-
JUSTICA

NO

HUB

TfnIntragov.xml

27699

YES

YES

YES

METROPO

NO

HUB

TfnIntragov.xml

27699

YES

YES

Global Policy

YES

USP

NO

HUB

TfnIntragov.xml

27699

YES

YES

PREFEITURAS Global Policy

YES

PREFEITURAS

NO

HUB

TfnIntragov.xml

27699

YES

YES

TRANSITO

Global Policy

YES

TRANSITO

NO

HUB

TfnIntragov.xml

27699

YES

YES

FAZENDA

Global Policy

YES

FAZENDA

NO

HUB

TfnIntragov.xml

27699

YES

YES

UNESP

Global Policy

YES

UNESP

NO

HUB

TfnIntragov.xml

27699

YES

YES

UNICAMP

Global Policy

YES

UNICAMP

NO

HUB

TfnIntragov.xml

27699

YES

YES

PM_HUB

Global Policy

YES

PM

NO

HUB

TfnIntragov.xml

27699

YES

YES

PM_SPOKE

Global Policy

YES

PM

NO

SPOKE

TfnIntragov.xml

27699

YES

YES

Policy Name

Owner

CE PRESENT

INTRAGOV

Global Policy

YES

EDUCACAO

Global Policy

CEETEPS

EDIT

JOIN AS

ADD INFO

INTRAGOV

NO

HUB

TfnIntragov.xml

YES

EDUCACAO

NO

HUB

Global Policy

YES

CEETEPS

NO

FAPESP

Global Policy

YES

FAPESP

TRIBUNAL-
JUSTICA

Global Policy

YES

METROPO

Global Policy

USP

2011 Cisco and/or its affiliates. All rights reserved.

VPN

RD VALUE

Cisco Confidential

10

RDs
O ponto mais crtico do projeto manter inalterada a estrutura de cada uma das 13 vrfs j
aplicadas manualmente na rede da Telefonica|Vivo.
As cutomizaes aplicadas nas policies iro manter a nomenclatura e estrutura de cada uma
das vrfs.
Devido a algumas particularidades usadas nos valores de RD para cada uma das 13 vrfs, as
seguintes solues foram adotadas pelo grupo do projeto (Telefonica/Cisco/NEC):
RD PRINCIPAL: os valores a seguir foram adotados com base nas configuraes da rede e sero

aplicados automaticamente pelo CPP em qualquer PE (novo ou j existente) se o operador no marcar


a opo VRF and RD overwrite. Estes valores foram apontados como os mais utlizados em um maior
nmero de PEs.
VRF NAME
FAPESP
CEETEPS
EDUCACAO
FAZENDA
INTRAGOV
METROPO
PREFEITURAS
TRIBUNAL-JUSTICA
UNESP
UNICAMP
PM
USP
VPN-TRANSITO

2011 Cisco and/or its affiliates. All rights reserved.

RD PADRAO
27699:356099
27699:355180
27699:351189
27699:355580
27699:355108
27699:355506
27699:352547
27699:334000
27699:353669
27699:354178
27699:352159
27699:354191
27699:327932

PE
c-br-sp-sjc-rh-rav-01
c-br-sp-bru-ac-rav-01
c-br-sp-arc-xn-rav-01
c-br-sp-arq--rav-04
c-br-sp-bru-ac-rav-01
c-br-sp-bre-al-rav-02
c-br-sp-cas-ce-rav-01
c-br-sp-arc-xn-rav-02
c-br-sp-cas-ce-rav-01
c-br-sp-sjc-rh-rav-01
c-br-sp-spo-mb-rav-03
c-br-sp-bre-al-rav-02
c-br-sp-arc-xn-rav-02

Cisco Confidential

11

RDs
VRF and RD overwrite: esta opo dever ser utilizada sempre que o operador desejar aplicar para o

PE e vrf em questo um valor diferente do valor PRINCIPAL.

O operador ir digitar os valores a serem sobrescritos.

O operador dever fazer uma consulta prvia no PE para saber o valor do RD.

O nome da vrf dever ser igual ao aplicado no PE.

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

12

QoS
O operador ser capaz de aplicar QoS na interface do circuito utilizando o CPP nas categorias a seguir:
EDUCACAO Ethernet e TDM
Padro Ethernet e TDM

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

13

Multicast
Apenas as vrfs INTRAGOV e EDUCACAO foram customizadas para configuraes de
multicast, os dados abaixo sero aplicados pelo CPP se for opo do operador.
ip vrf EDUCACAO
mdt default 239.0.0.17 ! Configurao Global na VPN dentro do CPP
met data 239.232.13.0 0.0.0.31 threshold 1 ! Configurao Global na VPN dentro do PP
ip multicast vrf EDUCACAO route-limit 200 ! Configurao Global na VPN dentro do PP
ip pim vrf EDUCACAO rp-address 201.60.38.253 Multicast_INTRAVC ! Configurao Global na VPN dentro do PP pois o RP no muda
ip access-list standard Multicast_INTRAVC ! Comando a ser aplicado por customizao, Configurao por Service Request
permit 239.192.140.0 0.0.0.255

Na configurao acima, para VRF EDUCACAO apenas, a ACL para controlar os endereos multicast ipv4
na LAN do cliente customizada; o operador dever digitar apenas os valores multicast ipv4 e wildcard,
pois o nome da acl no muda.

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

14

Multicast
ip vrf INTRAGOV
mdt default 239.0.0.21 ! Configurao Global na VPN dentro do PP
mdt data 239.232.17.0 0.0.0.31 threshold 1 ! Configurao Global na VPN dentro do PP
ip multicast vrf INTRAGOV route-limit 200 ! Configurao Global na VPN dentro do PP
ip pim vrf INTRAGOV rp-address 201.60.134.66 multicast-tce override ! Comando a ser aplicado por customizao.
ip pim vrf INTRAGOV rp-address 201.60.200.113 Multicast_DERSA override ! Comando a ser aplicado por customizao.
ip access-list standard Multicast_DERSA ! Comando a ser aplicado por customizao, Configurao por Service Request
permit 224.30.0.1 0.0.0.0
ip access-list standard multicast-tce ! Comando a ser aplicado por customizao, Configurao por Service Request
permit 239.192.61.64 0.0.0.63

Na configurao acima para VRF INTRAGOV, os comandos para o RP e ACLs para controlar os
endereos multicast ipv4 na LAN do cliente so customizados; o operador dever digitar os valores
multicast ipv4 , wildcard, nome da ACL e endereo do RP

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

15

Deploy simulado uma funcionalidade do CPP que possibilitar a importao dos


dados de circuitos do legado do Intragov aprovisionados manualmente e tambm
viabilizar alteraes futuras nestes circuitos atravs do CPP.
Pode ser utilizado para qualquer outra VPN j existente na base de dados do CPP.
O operador dever copiar os dados do circuito com base nas configuraes aplicadas
na rede e inseri-los no CPP, seguindo os mesmos passos j utlizados para um
aprovisionamento.

IOS
interface GigabitEthernet0/1/0.400302
description EDUCACAO ID 0001
encapsulation dot1Q 400 second-dot1q 302
ip vrf forwarding EDUCACAO
ip address 187.100.13.1 255.255.255.252
ip route vrf EDUCACAO 200.200.200.103 255.255.255.255 GigabitEthernet0/1/0.400302 187.100.13.2 tag 200
ip route vrf EDUCACAO 10.120.45.0 255.255.255.224 GigabitEthernet0/1/0.400302 187.100.13.2 tag 200
ip access-list standard LAN-EDUCACAO
permit 10.120.45.0 0.0.0.31
ip access-list standard Lo0-EDUCACAO
permit 200.200.200.103

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

16

IOS XR
interface GigabitEthernet0/0/1/0.400307
description INTRAGOV ID 0002
dot1q vlan 400 307
vrf INTRAGOV
ipv4 address 187.100.32.1 255.255.255.252
router static
vrf INTRAGOV
address-family ipv4 unicast
200.200.200.14/32 GigabitEthernet0/0/1/0.400307 187.100.32.2 tag 200
192.168.30.0/24 GigabitEthernet0/0/1/0.400307 187.100.32.2 tag 200
prefix-set LAN-INTRAGOV
192.168.30.0/24
end-set
prefix-set Lo0-INTRAGOV
200.200.200.14/32
end-set

Feitos os passos e com o SR salvo, o operador dever apenas clicar na opo Simulate

Deploy ao invs de Deploy.


No altera nenhum dado no PE e no reaplica comandos, somente valida e traz as

informaes para dentro da base de dados. Estado

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

17

No foi alterado nenhum passo ou adicionada customizao que altere o

fluxo de provisionamento.

A mesma policy poder ser utilizada.

O operador dever apenas selecionar a opo de acordo com a verso

do protocolo IP a ser utilizada.

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

18

A Telefonica|Vivo solicitou que o pool de multicast atualmente utilizado e

e controlado manualmente em planilha fosse importado e controlado


pelo CPP.

Estes ranges sero marcados como utilizados, impossibilitando a

utilizao.
Novos pools podero ser criados pela Telefonica|Vivo e utilizados

atravs do CPP.

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

19

Vrf Educacao usando RD principal j importado


Vrf Fazenda usando VRF e RD override
Vrf Intragov IPv4 com qos, multicast e roteamento esttico
Vrf Educacao IPv4 com qos, multicast e roteamento BGP
Vrf Fazenda IPv6 com roteamento BGP
Vrf Educacao IPv6 com roteamento esttico
Vrf USP usando dual-stack
Deploy simulado com alteraao posterior no circuito
DIA IPv6
Multicast
Sugestes ? Dvidas ?

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

20

Thank you.

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

21

RDs
Unique RD, esta opo poder ser utilizada para criar um deploy simulado onde o PE e vpn em questo

estiver usando um valor de RD diferente do valor PRINCIPAL e seja repetido em outro PE ou mais PEs.
Desta forma ser mantido o valor e o CPP ir reutilizar este valor sempre que o operador selecionar esta
opo na policy.
No possivel utilizar VRF and RD overwrite enquanto o Unique RD estiver selecionado e vice versa.

2011 Cisco and/or its affiliates. All rights reserved.

Cisco Confidential

22