Você está na página 1de 14

Algoritmos Parte 4

Contedo: Estruturas Homogneas


Unidimensionais e Multidimensionais.
Algoritmo de Busca Sequencial. Exerccios.
Lista 4.

09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
1/14

Estruturas Homogneas (1)


Agrupamento de vrios dados numa mesma varivel
(mesmo identificador)
Homognea: dados do mesmo tipo
Conhecidas como: vetor, varivel indexada, varivel
composta, matriz, tabela em memria ou array (do
ingls)
As mesmas regras de nomenclatura valem para os
nomes de variveis de vetor

09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
2/14

Estruturas Homogneas (2)


Exemplo: imagine um problema que, dada as notas de 8
alunos, calcule a mdia. Usando variveis simples seria
assim:
algoritmo "MEDIA"
var
N1,N2,N3,N4,N5,N6,N7,N8,SOMA,MEDIA : real
inicio
leia (N1,N2,N3,N4,N5,N6,N7,N8)
SOMA <- N1+N2+N3+N4+N5+N6+N7+N8
MEDIA <- SOMA / 8
escreva (MEDIA)
fimalgoritmo

09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
3/14

Vetor unidimensional (1)


Sintaxe: nome:vetor[min..max] de tipo
min: ndice do primeiro elemento
max: ndice do ltimo elemento
tipo: tipo de dado, de cada elemento do vetor
Quantidade de elementos: (max min) + 1
Exemplo: N:vetor[1..8] de real
Cada elemento acessado individualmente, dado o
nome de varivel e seu ndice

09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
4/14

Vetor unidimensional (2)


Representao em
memria. Exemplo.
Vetor: N
ndice

Valor do Elemento

4.5

6.5

8.0

3.5

6.0

7.0

6.5

6.0

09/02/2015

ndice versus Elemento


ndice endereo do
elemento
Elemento o valor contido
na posio endereada pelo
ndice.
Qual o valor N[4]?
Atribuindo um valor a um
elemento:
N[4] <- N[4] + 0.2

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
5/14

Vetor unidimensional (3)


Problema da mdia usando vetor:
algoritmo "MEDIA_USANDO_VETOR"
var
N : vetor[1..8] de real
SOMA, MEDIA: real
I : inteiro
inicio
SOMA <- 0
para I de 1 ate 8 passo 1 faca
leia (N[I])
SOMA <- SOMA + N[I]
fimpara
MEDIA <- SOMA / 8
escreva (MEDIA)
fimalgoritmo

09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
6/14

Pesquisa em vetor
Sequencial
Vetor com elementos em ordem arbitrria (desordenado)
Consiste em percorrer, um a um, os elementos do vetor para encontrar o
valor pesquisado
(...)
leia PESQ
ACHEI <- falso
enquanto ( (nao ACHEI) e (I <= 5) ) faca
se (V[I] = PESQ) entao
ACHEI <- verdadeiro
PESQ,I:inteiro
senao
ACHEI:logico
I <- I + 1
V:vetor[1..5] de inteiro
fimse
OBS: 5 o tamanho do vetor
fimenquanto

09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
7/14

Exerccios Orientados
[ConsumoCasa]
Considere um vetor que armazena o consumo (em
kilowatts) de um condomnio de 50 casas
(numeradas de 1 a 50). Faa um algoritmo que
informe quantos pagaro tarifa social (consumo
menor que 20 kilowatts) e quantos tarifa normal.
Calcule o consumo mdio
Informe o nmero da casa que tem o maior consumo
e o consumo propriamente dito
09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
8/14

Exerccios Orientados
[PesqNome]
Faa um algoritmo que, dado o nome de 10 alunos
em ordem arbitrria, armazene-os em um vetor.
Criar a funcionalidade de pesquisa de um nome
Observao: Explicar a tabela ASCII !!!

09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
9/14

Estrutura Homogneas
Multidimensionais (1)
Possuem 2 ou mais dimenses
Como homognea, ainda assim todos os elementos
devem ser do mesmo tipo
Matriz: vetor de 2 dimenses
Matriz quadrada: mesma quantidade de elementos nas duas
dimenses

Valor de um elemento acessado individualmente.


TABELA[2,3]
Valor do elemento armazenado na 2a. linha da 3a. coluna do
vetor TABELA
09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
10/14

Estrutura Homogneas
Multidimensionais (2)
Sintaxe da declarao da matriz
<nome>:vetor[min1..max1,min2..max2] de <tipo>

min1 e max1: limites mnimo e mximo da 1a.


dimenso, com (max1-min1+1) elementos
min2 e max2: limites mnimo e mximo da 2a.
dimenso, com (max2-min2+1) elementos
Exemplo:
TAB : vetor[1..8,1..5] de inteiro
Temos nesse caso 8 * 5 = 40 elementos no total

O nmero de dimenses ilimitado


09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
11/14

Estrutura Homogneas
Multidimensionais (3)
Colunas
X

Linhas

1
2
3
4
5
6
7
8

09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
12/14

Exerccios Orientados
[MediaTurma]
Faa um programa que armazene as notas dos 4
bimestres de 20 alunos de uma turma
Faa o algoritmo que possibilite o usurio informar as 4
notas de cada aluno da turma.
Faa o algoritmo que calcule e armazene a mdia final de
cada aluno.
Faa o algoritmo que exiba a mdia geral da turma.

Lista 4: exerccios do grupo Estruturas Homogneas.


09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
13/14

Humor

09/02/2015

Prof. Mrcio Belo


http://marcio.belo.nom.br

04-Algoritmos
14/14