Você está na página 1de 10

UNIVERSIDAD DON BOSCO

FACULTAD DE ESTUDIOS TECNOLGICOS


ESCUELA DE COMPUTACION

CICLO: 02/ 2013

Nombre de la Practica:
Lugar de Ejecucin:
Tiempo Estimado:
MATERIA:

GUA DE LABORATORIO #02


Subneteo y VLSM
Laboratorio de redes
2 horas y 30 minutos
Redes de rea Amplia

I. OBJETIVOS
Que el estudiante:
Desarrollar el anlisis apropiado de requerimientos de host para las redes que componen a una topologa
Elaborar los clculos de distribucin de subredes con el mtodo de subneteo de mascara de longitud variable
(VLSM)
Determine apropiadamente los parmetros de direccionamiento ip (ip Gateway y rango ip host) para
cualquier ip de red.
Implemente la configuracin general de los dispositivos de red principales (router y switch) de una topologa.
Configure correctamente una red conmutada por vlan, incluyendo a la vlan de administracin.
Realice los clculos de una ip de resumen de ruta, por medio del Superneteo de varias ip de subred.
Realice copias FTP de respaldo de las configuraciones de los dispositivos de enrutamiento (router) y
conmutacin (switch) de una topologa.

II. INTRODUCCION TEORICA

Calculo de Superneteo
Como ha visto anteriormente, el clculo de subneteo consiste en generar de una ip red principal/base a un
conjunto secuencial de direcciones de red ms pequeas.
Pero al igual que cualquier otra operacin matemtica, como la suma, potencia, etc., el Subneteo tiene su
operacin contraria, denominada Superneteo.
El Subneteo es el proceso por el cual, dado una serie de direcciones ip red diferentes, se determina una ip red
general, que contiene a todos estos espacios de direccin ip de red iniciales.
En otras palabras, una IP resultante de un superneteo, permite resumir/ sumarizar los rangos de direcciones de
2 o ms redes pequeas, que por lo general son resultado de un subneteo previo.
Una ip sumarizada o tambin llamada ip de SuperRed permiten reducir las tablas de enrutamiento de un
router, al evitar tener que definirle un conjunto de N rutas de direcciones de red subneteadas, agregando en
cambio a solamente una ruta, que abarque los rangos de direcciones de red pequeas originales.
Ejemplo 1:
Dadas las direcciones de red 192.4.32.0 /21,192.4.40.0 /21, 192.4.48.0 /21 y 192.4.56.0 /21, determine una ip red
sumarizada que resuma los espacios de direcciones de todas estas 4 subredes iniciales.

1 / 10

Gua # 02: Subneteo y VLSM

Solucin

Se crea una tabla, en donde se escriben las diferentes ip red en binario, resaltando por cada una a sus bits de
red, contados segn su propia mascara de red.
De manera paralela, en todas las redes se comienzan a recorrer y contar los bits (de izquierda a derecha, del
bit ms significativo al bit menos significativo) que coincidan entre todas las redes en esa posicin binaria.
El proceso de conteo se detiene cuando se detecta un bit diferente (el bit 1 resaltado en la tabla).
La ip de resumen (superred) se formara con los bits coincidentes y el resto de bits no coincidentes, se le
llenara con ceros (0)
La mscara resultante ser el conteo de bits de red coincidentes entre todas las ip subred.
#red
1
2
3
4

Ip red
192.4.32.0 /21 bit de red
192.4.40.0 /21
192.4.48.0 /21
192.4.56.0 /21
Red resumen

Ip red (resaltando a sus bit red)

11000000.00000100.00100000.00000000
11000000.00000100.00101000.00000000
11000000.00000100.00110000.00000000
11000000.00000100.00111000.00000000
11000000.00000100.001000000.00000000

192.4.32.0 /19
R// la ip de sper red 192.4.32.0 /19 abarca los espacios de direccin de las 4 subredes brindadas

Ejemplo 2:
Resuma en una sola ip superred al siguiente conjunto de direcciones de red:
12.101.24.0 /21
12.101.28.64 Mk: 255.255.255.192
12.101.36.0 /22
12.101.26.0 Mk 255.255.254.0
Solucin

Se crea una tabla con las diferentes ip red en binario, resaltando a sus bits de red.
El proceso de conteo (de bit ms significativo al menos significativo) de bit de la superred se detiene cuando
se detecta un bit diferente el resto de bits de las redes evaluadas (el bit 1 resaltado en la tabla).
#red
1
2
3
3

Ip red
12.101.24.0 /21 bits red
12.101.28.64 /26
12.101.36.0 /22
12.101.26.0 /23
Red resumen

Ip red (resaltando a sus bit red)

00001100.01100101.00011000.00000000
00001100.01100101.00011100.01000000
00001100.01100101.00100100.00000000
00001100.01100101.00011010.00000000
00001100.01100101.00000000.00000000

12.101.0.0 /18
R// la ip de superred 12.101.0.0 /18 abarca los espacios de direccin de las subredes brindadas

Redes de rea Amplia

Gua # 02: Subneteo y VLSM

III. MATERIALES Y EQUIPO


Para la realizacin de la gua de prctica se requerir lo siguiente:
No.
1
2

Requerimiento
Gua de Laboratorio #02 de WAN
Estacin de trabajo (PC) con la aplicacin Cisco Packet Tracer instalada

Cantidad
1
1

IV. PROCEDIMIENTO

PARTE 1: Calculo con Subneteo VLSM.


1. Crear una carpeta denominada WANpractica2_CARNET (reemplazando palabra CARNET por su nmero de
Carnet)
2. En la Tabla 1 a continuacin se le presenta los requerimientos de redes a utilizar para la red interna de una
empresa. Elabore los clculos necesarios para aprovechar al mximo el espacio ip de la red base proporcionada y
utilizando VLSM
Red
Descripcin
Capacidad host (min.)
LAN 1
Produccion
1400
LAN 2
Ventas
2000
VLAN 25
Compras
100
VLAN 30
Presidencia
26
VLAN 120 Servicios
14
VLAN 100 Soporte
50
Importante: se requieren otras 2 redes para los enlaces entre router a interconectar.

Tabla 1: Requerimientos de red, utilizando la ip red base/inicial 140.0.192.0 Mk: 255.255.224.0.


3. Con los resultados de sus clculos de subneteo del paso anterior, llene la Tabla 2 con los parmetros de las 8
redes asignadas:
#
1

Red

IPred

Mk subred

2
3
4
5
6
7
8
Tabla 2: Parmetros de redes a configurar

Redes de rea Amplia

Ip gateway

Gua # 02: Subneteo y VLSM

PARTE 2: Configuracin general de los dispositivos de una Topologa


4. Ejecute la aplicacin Cisco Packet Tracer y prepare una nueva simulacin
Practica2_procedimiento, guardando el archivo de la simulacin en su carpeta de trabajo.

denominada

5. Agregar a la simulacin el listado inicial de equipos a continuacin:


Cantidad

Equipo

Router

Serie

Caractersticas extras

Nombre en topologa (a)


Con un modulo (WIC-2T) agregado STAR
Con un modulo (WIC-2T) y
2
Router 2621XM
PRIMARIO y SECUNDARIO
un modulo (NM-1FE-FX)
2
Switch 2960-24TT Ninguna
DISTRIB1 y DISTRIB2
2
Switch 2950-24
Ninguna
ACCESO1 y ACCESO2
(a) Cambiar los nombres de los equipos en la topologa por los indicados en esta columna
1841

6. Agregar una Laptop y cambiarle su nombre a PCadmin. Desde este equipo har las configuraciones generales
y de seguridad de acceso a los diferentes equipos.
7. Por medio de un cable de Consola, conectar puerto serial (RS-232) de PCadmin hacia el puerto Console de
router STAR.
8. Dar clic en PCadmin, para ingresar en ficha superior Desktop y luego en botn Terminal.
Ya que se ingreso va Consola al equipo, responda con no a la pregunta del asistente de configuracin inicial y
proceda a ejecutar los siguientes comandos IOS para la Configuracin General y de Control de Acceso al router
STAR:
Importante: Cuidar la escritura de contraseas indicadas o no podr ingresar posteriormente a la configuracin
del dispositivo
Comando IOS
enable
configure terminal

Descripcin del resultado


Ingrese a Modo configuracin usuario privilegiado
Ingresa a Modo configuracin Global

hostname STAR

Asigna nombre al equipo

enable password STAR


enable secret RATS

Establece contrasea al modo de usuario privilegiado


Establece contrasea secreta al modo usuario EXEC, en esta prctica, ser el
nombre del dispositivo a configurar escrito al revs

line console 0
password c0nsol3
login

Ingresa a configuracin lnea de consola.


Asigna contrasea cuando se acceda va puerto Consola
Activa la contrasea para la prxima que se ingrese va conexin de consola

exit

Retorna al modo usuario privilegiado.

line vty 0
password rem0t01
login
exit

Crea una lnea de acceso virtual (remoto o va red) vty 0


Asigna contrasea para este 1era sesin de acceso remoto

Redes de rea Amplia

Gua # 02: Subneteo y VLSM


line vty 1
password rem0t02
login
end

Crea una 2da lnea de acceso virtual (remoto o va red) vty 1


Asigna contrasea para este 2da sesin de acceso remoto
Retorna directamente a modo usuario privilegiado

9. Ejecutar comando copy running-config startup-config para guardar los cambios anteriores hacia el archivo
de configuracin de inicio (startup-config).
10. Ejecutar comando reload para que el IOS del router se reinicie y se aplique las contraseas de seguridad de
acceso.
11. Ingrese al modo usuario privilegiado. Para ello, como ha ingresado va puerto consola al router STAR, la 1er
contrasea a ingresar es la asignada a la lnea de consola 0.
Luego, desde el modo usuario sencillo, pruebe con cual contrasea ingresa al modo privilegiado La contrasea
enable o la secret?
12. Una vez ingresado al modo privilegiado, ver contenido del archivo de configuracin de ejecucin activo
(running-config), ejecutando comando (show running-config).
Localizar cuidadosamente a las diferentes contraseas configuradas previamente. Anote sus conclusiones!!
13. Cerrar la ventana de PCadmin
14. Desconecte cable de consola de Router STAR. Proceda a repetir la configuracin anterior con el router
PRIMARIO.
La configuracin ser igual al STAR, pero cambiaran el hostname y ambas contrasea enable (la password con
igual nombre del router y la secret con nombre del dispositivo escrito al revs: OIRAMIRP)
15. Repetir paso anterior para el ultimo router (SECUNDARIO), con el respectivo cambio de contraseas.

16. Hacer la configuracin bsica a cada switch, tomando en cuenta que a diferencia de los router, a cada switch se
le asignada solamente:
+ hostname
+ Contrasea de acceso privilegiado (enable password): Nombre del equipo que se configura
+ Una lnea de acceso remoto (contrasea rem0t01)
+ lnea de acceso Consola (contrasea: directo)

PARTE 3: Conexiones fsicas entre dispositivos de la topologa


17. Proceda a realizar las siguientes conexiones entre los dispositivos del rea de trabajo de la simulacin:

Conectar a ambos switch de distribucin por medio de un cable cruzado entre el puerto 21 de c/u
Pareja de switch (DISTRIB1, ACCESO2) con sus puertos #23
Pareja de switch (DISTRIB2, ACCESO1) con sus puertos #22
Pareja de switch (DISTRIB1, ACCESO1) con sus puertos #24
Pareja de switch (DISTRIB2, ACCESO2) con sus puertos #20
Puerto #24 de switch DISTRIB2 con la interfaz Fa0/0 de router STAR, con un cable plano
Cable serial entre el 1er puerto serial de ambos router (STAR y PRIMARIO), con extremo DCE en router
STAR
Enlace de fibra entre router PRIMARIO y SECUNDARIO.
Agregar 6 PC diferentes y un Servidor (ServerPT)

Redes de rea Amplia

Gua # 02: Subneteo y VLSM

PARTE 4: Configuracin de VLANs


18. A continuacin, har la configuracin de las vlans a utilizar en la red conmutada entre los switch. Para ello
tome en cuenta que la vlan de administracin (nativa) ser la #100 y la asignacin de puertos se muestra en
Tabla 3:

Para switch de capa de Distribucin (DISTRIB1 y DISTRIB2):


# VLAN

Nombre

IP red asignada

#puertos de acceso

VLAN 25

Compras

Sin puertos acceso

VLAN 30

Presidencia

Sin puertos acceso

VLAN 120

Servicios

#1 hasta #3

VLAN 100

Soporte

#10
Resto de puertos sin asignacin,
deben ser desactivados

Puertos troncales: del puerto #20 al puerto #24


Vlan 100 ser la vlan nativa, para administracin de switch

Para switch de capa de Acceso (ACCESO1 y ACCESO2):


# VLAN

Nombre

IP red asignada

#puertos de acceso

VLAN 25

Compras

#1 hasta # 4

VLAN 30

Presidencia

#5 hasta # 8

VLAN 120

Servicios

VLAN 100

Soporte

Sin puertos acceso


#19
Resto de puertos sin asignacin,
deben ser desactivados

Puertos troncales: del puerto #20 al puerto #24


Vlan 100 ser la vlan nativa, para administracin de switch

Tabla 3: Parmetros de las VLANs a configurar


19. Conectar la PC PCadmin al puerto Consola de switch DISTRIB1 e ingresar al modo configuracin Global.
20. Cree las vlan y rangos de puertos de acceso para cada una de las VLANs indicadas en Tabla 3 para este
switch, por medio de esta secuencia de comandos:
Comando IOS
Descripcin del resultado
interface vlan 1
Ingrese a la configuracin de la interface de la vlan 1 predeterminada
shutdown
Desactiva la vlan 1, para definir una vlan administracin propia
exit
vlan 25
Crea la vlan numero 25
name Compras
Asigna nombre de Compras a la vlan 25
exit
Redes de rea Amplia

Gua # 02: Subneteo y VLSM


vlan 30
name Presidencia
exit

Crea el resto de vlan requeridas

vlan 120
name Servicios
exit
vlan 100
name Soporte
exit
interface vlan 100
ip address 190.0.0.1 255.255.0.0
exit

Ingresa a la interfaz de vlan 100


Define una ip de administracin remota del switch.
Debe reemplazar la ip (190.0.0.1 y mascara) resaltada por la 1er ip de
host de la ipsubred asignada a la VLAN 100 (Soporte)

interface range fastEthernet 0/1-24


shutdown
exit
interface range fastEthernet 0/1-3
switchport mode access
switchport access vlan 120

Desactiva todos los puertos del switch (para luego ir levantando solo los
puertos necesarios)

no shutdown
exit
interface fastEthernet 0/10
switchport mode access
switchport access vlan 100
no shutdown
exit

Se selecciona el rango de interfaces fastethernet 0/1 hasta fa0/3


Se cambia modo de puerto a modo acceso y luego se define que
permitir acceso a la vlan 120.
Levanta interfaces
Selecciona solo al Puerto fa0/10, para brindar acceso a la vlan 100

interface range fastEthernet 0/20-24


switchport mode trunk
switchport trunk native vlan 100
exit

Selecciona rango de puertos fa0/20 al fa0/24,para configurar su modo de


acceso a troncal, para permitir trafico de mltiples vlan y adems,
define que la vlan de administracin ser la vlan #100

ip default-gateway 10.0.8.129

Para permitir que este switch sea administrado remotamente desde un


host de una red diferente, se le asigna una ip Gateway. Debe reemplazar
la ip resaltada por la ip de Gateway de la vlan Soporte.

+ Nota:
Observar que aun no se levanta (no shutdown) el rango de puertos troncales. Esto se debe a que este switch
DISTRIB1 ya no tiene la misma vlan nativa que el resto de switch (que tienen su vlan nativa 1 predeterminada) y
al levantarse sus interfaces troncales, se repetira continuamente este mensaje de error:
%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/22 (100), with
ACCESO1 FastEthernet0/22 (1)
21. Guarde los cambios en DISTRIB1 con el comando do write
22. Repetir los 3 pasos anteriores para configurar de manera idntica al switch DISTRIB2.
La diferencia en DISTRIB2 ser en la asignacin de la ip host para administracin en interfaz de vlan 100. Debe
utilizar la prxima ip host disponible de la vlan Soporte en cada switch.

Redes de rea Amplia

Gua # 02: Subneteo y VLSM


23. De manera similar a las configuraciones ejecutadas para ambos switch de distribucin anteriores, haga las
configuraciones necesarias en los switch (ACCESO1 y ACCESO2) para crear las vlan y #puertos indicadas en la
Tabla 3, as como desactivar los puertos no utilizados!!

24. Una vez configurados todos los switch, ingrese al modo de configuracin global de c/u de estos dispositivos y
levante su rango de puertos troncales (fa0/20 al fa 0/24).
Luego de un minuto, el protocolo STP se encargara de bloquear los enlaces redundantes entre los switch.
Llame a su instructor para confirmar que el procedimiento hasta este paso esta completo y correcto!!
25. Cambiar nombre de PC0 y PC1 por compra1 y compra2, respectivamente, para luego conectarlas a puertos de
acceso de la vlan Compras en switch diferentes (ACCESO1 y la otra PC en ACCESO2)
Asignar en ambas PCs una configuracin ip de host (ip, mascara y gateway) de la vlan asignada a la VLAN
Compras y enviar un ping entre ambas para demostrar que hay comunicacin efectiva!!
26. Repita el paso anterior para agregar parejas de clientes de las vlan (Presidencia y Soporte) y comprobar que
hay comunicacin entre 2 clientes de una misma vlan!!
27. Configurar al ServerPT con una ip host (ip, mascara y gateway) de la VLAN Servicios y conectarlo a un puerto
de la vlan Servicios del switch DISTRIB1.

PARTE 5: Comunicacin inter-vlan


28. Para continuar, es necesario que los clientes de vlan diferentes puedan comunicarse entre s. Esto se logra con
un dispositivo de enrutamiento (router).
29. Conectar la PCadmin a la interfaz de consola del router STAR e ingresar al modo de configuracin global.
30. Ejecutar la secuencia de comandos siguientes:
Comando IOS
interface fastEthernet 0/0
no shutdown
exit

Descripcin del resultado


Levanta la interfaz fsica fa0/0, a la cual se le configuraran
despus interfaces lgicas (denominadas subinterfaces) para
permitir que se transfieran tramas de vlan diferentes!!

interface fastEthernet 0/0.25


encapsulation dot1Q 25

Crea/levanta una subinterfaz 25 dentro de la interfaz fsica 0/0.


Indica el numero de vlan (vlan #25) de las tramas que podr
recibir/enviar por esta subinterfaz.
Asigna la ip Gateway de la red vlan 25. Debe reemplazar la ip y
mk resaltada por la ip Gateway de su vlan 25

ip address 10.0.0.1 255.255.255.0


description acceso a vlan compras
exit
interface fastEthernet 0/0.30
encapsulation dot1Q 30
ip address 150.0.0.65 255.255.255.240
description acceso a vlan Presidencia
exit
interface fa 0/0.120
encapsulation dot1Q 120
ip address 150.0.0.129 255.255.255.240
description acceso a vlan Servicios
exit

Redes de rea Amplia

Se crear las subinterfaces para las vlan de Presidencia y Servicios

Debe reemplazar ambas ip y mk resaltadas en esa secuencia por


las ip Gateway correspondientes a sus vlan 30 y vlan 120

Gua # 02: Subneteo y VLSM


Comando IOS
interface fastEthernet 0/0.100
encapsulation dot1q 100 native

ip address 150.0.0.193 255.255.255.240


description acceso a vlan Soporte (nativa)
exit

Descripcin del resultado


Crea la subinterfaz 100, para manejar trafico de la vlan nativa
(parmetro native agregado).
Esto significa que el IOS no le agregara modificacin de #vlan al
trfico de tramas que reciba/enve hacia esa red vlan 100.
Debe reemplazar la ip y mk resaltada por las ip Gateway
correspondientes a vlan 100 (Soporte)

31. Confirme que hay comunicacin intervlan con estas pruebas:


Prueba 1:
Ingrese al Command Prompt de PC soporte1. Ejecute comando ipconfig para ver su ip host, mascara y Gateway.
Ejecute un ping dirigido a su propia ip Gateway, la prueba debe ser exitosa!! Si no, revise la configuracin ip de
esta PC y de la subinterfaz correspondiente en router STAR.
Finalmente, enve un ping hacia PCs de otra vlan. La prueba debe resultar exitosa!!
Prueba 2:
Ingrese a la ventana del navegador web (Web Browser) de PC Presidencia2 y acceda al servidor web de ServerPT
escribiendo esta URL: http://124..0.0.25 (Recuerde reemplazar esta ip resaltada por la direccin asignada al
ServerPT de su simulacin)
Debe poder ver la pg. Index.html predeterminada del server!!
Prueba 3: Administracin remota de switch
Acceda al IOS del Switch DISTRIB2 desde PC compra2. Para ello, ingresar a la ventana de comandos (command
prompt) de PC compra2, luego haga que el switch DISTRIB2 le salude, ejecutando un ping dirigido a su ip de
administracin. La prueba debe ser exitosa
Luego ejecute una sesin telnet dirigida a la ip usada en el comando ping anterior. Se le solicita la contrasea que
usted asigno a la lnea vty 0 de DISTRIB2.
Ejecute al comando show interfaces trunk para ver las interfaces en modo trunk y cuales vlan pueden usarlos.
Cierre la sesin remota con exit.

PARTE 6: Comunicacin entre red conmutada (vlan) y el resto de LAN


32. Agregue una nueva PC y conectarla a puerto fa0/1 de router PRIMARIO. Configurar a esta PC con una ip host
de la vlan Produccion.
Ingresar al Modo configuracin global de router PRIMARIO, para configurar a su interface fa0/1 con la ip
Gateway de la LAN Produccion (segn sus datos de la Tabla 2).
33. Agregue un ServerPT y conectarlo al router SECUNDARIO en su interfaz fa0/0. Configurar una ip host y
Gateway de la red Ventas (ver de nuevo su Tabla 2).
Ingresar al modo configuracin Global de router SECUNDARIO y levantar su interface fa0/0 con la ip Gateway
de la red Ventas. Confirmar que este ServerPT puede alcanzar a su propio Gateway.
34. Haga los cambios en la configuracin de los 3 router para levantar los enlaces entre ellos, utilizando las ip
subredes designadas en su Tabla 2. Compruebe con comandos ping que hay comunicacin entre cada pareja de
router.

Redes de rea Amplia

Gua # 02: Subneteo y VLSM

35. Luego, para que router PRIMARIO pueda alcanzar a los clientes de red conmutada (con vlans), debe
ensearle una ruta por cada vlan que conecta el router STAR, es decir, 4 rutas diferentes. Pero en su lugar, le
enseara una nica ruta, que resuma/sumarice estas 4 rutas
36. Para ello, haga los clculos de una ip de SuperRed que resuma a todas las 4 ip subred asignadas a las vlan de
la topologa.
Anote la ip/mascara de la superred resultante: __________________________________________
37. En el modo configuracin global de router PRIMARIO, ingrese una ruta esttica con la ip y mascara calculada
en el paso anterior. Use una ruta de interfaz de salida.
38. De igual forma, para que router STAR alcance a las redes de Produccion y Ventas, se le enseara solamente
una ruta, que ser la ruta sumarizada de ambas redes (Produccion y Ventas).
Haga los clculos para obtener esta ip sumarizada y con la misma, agregue una ruta esttica al router STAR (ruta
esttica con interfaz de salida).
39. Compruebe que desde la PC de la red Produccion ya puede ver a cualquiera de los host de la red conmutada.

V. DISCUSION DE RESULTADOS

Ejercicio complementario

Completar la comunicacin en toda la topologa del procedimiento, haciendo los cambios que hagan falta
para integrar al ServerPT Server1 de red Ventas al resto de la red.

Demuestre que el ServerPT se ha integrado a la red, creando una cuenta en el server FTP denominada
Gustavo (con contrasea: pa$$w0rd) y con la misma, hacer una copia de respaldo (back-up) del archivo de
configuracin de inicio (startup-config) de los diferentes switch en este servidor FTP de la red Ventas.

Redes de rea Amplia

10