Você está na página 1de 18

Treinamento MikroTik Bsico

Avisos importantes

Favor, manter o celular no silencioso ou desligado durante a aula.

Evite o uso inapropriado da internet.

Busque absorver ao mximo os conceitos.

Perguntas sempre sero bem vindas.

Evite conversas paralelas.

VPN
Uma Rede Parcular Virtual (Virtual Private Network - VPN) uma rede de
comunicaes privada normalmente u"lizada por uma empresa ou um conjunto de
empresas e/ou ins"tuies, construda em cima de uma rede de comunicaes
pblica (como por exemplo, a Internet). O trfego de dados levado pela rede
pblica u"lizando protocolos padro, no necessariamente seguros.
VPNs seguras usam protocolos de criptogra.a por tunelamento que fornecem a
con.dencialidade, auten"cao e integridade necessrias para garan"r a
privacidade das comunicaes requeridas. Quando adequadamente
implementados, estes protocolos podem assegurar comunicaes seguras atravs
de redes inseguras.

VPN`s
As principais caracters"cas das VPNs so:
Promover acesso seguro sobre meios 4sicos pblicos como a Internet por
exemplo.
Promover acesso seguro sobre linhas dedicadas, wireless, etc.
Promover acesso seguro a servios em ambiente corpora"vo de correio,
impressoras, etc.
Fazer com que o usurio, na pr"ca, se torne parte da rede corpora"va remota
recebendo IPs desta e per.s de segurana de.nidos.
A base da formao das VPNs o tunelamento entre dois pontos, porm
tunelamento no sinnimo de VPN.

Servidor ou cliente PPPoE


PPPoE (point-to-point protocol over Ethernet) uma adaptao do PPP para funcionar em redes
Ethernet. Pelo fato da rede Ethernet no ser ponto a ponto, o cabealho PPPoE inclui informaes
sobre o remetente e des"natrio, desperdiando mais banda (~2% a mais).

Muito usado para auten"cao de clientes com Base em Login e senha. O PPPoE estabelece a
sesso e realiza a auten"cao com o provedor de acesso a Internet.
O cliente no tem IP con.gurado, o qual atribudo pelo PPPoE server (concentrador),
normalmente operando em conjunto com um servidor Radius. No Mikro"k ROS, no
obrigatrio o uso de servidor Radius, pois o mesmo permite a criao e gerenciamento de
usurios e senhas em uma tabela local (/ppp secrets).
O cliente descobre o servidor atravs do protocolo PPPoE discover, que tem o nome do
servio a ser u"lizado.
Precisa estar no mesmo barramento 4sico ou os disposi"vos passarem para frente as
requisies PPPoE (pppoe relay).
No Mikro"k ROS o valor padro do Keep Alive Timeout 10, e funcionar bem na maioria dos
casos. Se con.gurarmos para 0, o servidor no desconectar os clientes at que os mesmos
solicitem ou o servidor for reiniciado.

Servidor PPPoE
Con.gurao do servidor PPPoE.

Crie um pool de IPs para o PPPoE


/ip pool add name=pool-pppoe ranges=10.1.1.1-10.1.1.254

PPPoE

Adicione um Per.l de PPPoE onde:

Local address = endereo IP do concentrador


Remote address = pool do pppoe
/ppp prole add name=perl-pppoe" local-address=192.168.1.1 remote-address=pool-pppoe

PPPoE
Adicione um usurio e senha
/ppp secret add name=usuario password=123456 service=concentrador-pppoe pro.le=per.l-pppoe.

Caso queira vericar o MAC-Address, adicione-o em Caller ID. Esta opo no


obrigatria, mas um parmetro a mais que garante segurana.

PPPoE
Adicione o PPPoE Server

Service Name = nome que os clientes vo procurar (pppoe-discovery).

Perfil PPPoE

Bridge: bridge para associar ao per.l.


Incoming/Outgoing Filter: nome do
canal do Firewall para pacotes
entrando/saindo.
Address List: lista de endereos IPs
para associar ao per.l.
DNS Server: con.gurao dos
servidores DNS a atribuir nos clientes.
Pode se con.gurar mais de um
endereo IP.

Perfil PPPoE

Session Timeout: a durao mxima


de uma sesso pppoe.
Idle Timeout: o perodo de
ociosidade na transmisso de uma
sesso. Se no houver trfego IP
dentro do perodo con.gurado a
sesso terminada.
Rate Limit: limitao da velocidade na
forma rx- rate[/tx-rate] rx o upload
do cliente
Only One: permite apenas uma sesso
para o mesmo usurio.

Usurio PPPoE
Service: Especi.ca o servico disponvel
para esse cliente em par"cular.
Caller ID: MAC address do cliente
Local Address/Remote Address: endereo
IP local(servidor) e remote(cliente) que
podero ser atribudos a um cliente em
par"cular.
Limit Bytes In/Out: Quan"dades de Bytes
que o cliente pode trafegar por sesso
PPPoE
Routes: Rotas que so criadas no lado
servidor para esse cliente espec.co.Vrias
rotas podem ser adicionadas separadas
por vrgula.

Cliente PPPoE

AC Name: nome do Concentrador. Deixando em branco conecta com qualquer um.


Dial on Demand: disca automa"camente sempre que gerado um trfego de
sada.

Add default route: adiciona uma rota padro (no usa a do servidor).

Use Peer DNS: Usa o DNS con.gurado no Concentrador.

L2TP

L2TP Layer 2 Tunnel Protocol Protocolo de tunelamento de camada 2 um


protocolo de tunelamento seguro para transportar trfego IP u"lizando PPP. O
protocolo L2TP trabalha no layer 2 de forma criptografada ou no e permite
enlaces entre disposi"vos de diferentes redes unidos por diferentes protocolos.
O trfego L2TP u"liza protocolo UDP tanto para controle como para pacotes de
dados. A porta UDP 1701 u"lizada para o estabelecimento do link e o trfego
em si u"liza qualquer porta UDP disponvel, o que signi.ca que L2TP pode ser
usado com a maioria dos Firewalls e Routers, funcionando tambm atravs de
NAT.
L2TP e PPTP possuem as mesmas funcionalidades.

L2TP
Con.gure um faixa de endereos IP, em IP POOL, um per.l para o PPTP e um
usurio em PPP Secrets, conforme as imagens.

L2TP
Con.gure os servidores PPTP e L2TP. Atente-se para o per.l a u"lizar.
Con.gure nos hosts locais um cliente PPTP e realize a conexo com um servidor de
outra rede diferente da rede conectada.
Ex.: hosts da rede 192.168.100.0/24 conectarem- se a servidores da rede
192.168.200.0/24 e vice-versa.

Cliente L2TP
As con.guraes para o cliente PPTP ou L2TP so bastante simples, conforme
observamos nas imagens.

Dvidas?