Você está na página 1de 9

La Biblia es la histora o mito?

por Ernest O'Neill


Escuchar a un audio (en ingls) sobre este tema.
Por qu pregunte?
Debido a que muchos de nosotros aceptar la evidencia por pruebas de la
existencia de Dios que Darwin y Einstein 1 han presentado 2, pero nos
preguntamos si existe alguna relacin difcil, tocar y ver, la evidencia
emprica. Hemos llegado tan lejos como nosotros llamando theists: al igual
que Darwin y Einstein aceptamos que la existencia de un dios es la
explicacin ms probable para el orden y el diseo del universo y de
nuestra propia personalidad, pero creemos que debe sin duda han
expresado su directamente a s mismo de alguna manera si existe!
Podemos ver que la primera causa debe haber inteligencia (ya que el
orden y el diseo no puede resultar ms tiempo de oportunidad), y debe
ser al menos tan personal como a nosotros mismos (ya que un objeto
inanimado no puede hacer una animacin), pero esta informacin limitada
acerca de la El creador se acerca tanto como se puede obtener de las
pruebas circunstanciales siempre de Su creacin..
La naturaleza de Dios
As como usted puede decir poco sobre el tipo de hombre es un carpintero
de estudiar el cuadro que ha hecho, as que usted puede decir poco sobre
el carcter del Creador estudiando Su creacin. Sin embargo, la
informacin sobre Su naturaleza es vital, ya que, evidentemente, l es el
Uno a quien todos tenemos nuestras vidas y el Uno debe saber que el fin
de nuestras vidas. Si l es un cruel tirano o un desptico monstruo
entonces no se vern afectadas si vivimos la misma manera, pero si l es
honesto y reflexivo entonces nos podr exigir que ser los mismos. En otras
palabras, la existencia de Dios puede ser una cuestin acadmica para
nosotros, pero su naturaleza es una cuestin de vital pertinentes si
queremos vivir en la luz de la realidad.
Dios nunca ha hablado?
Pero, cmo puede saber lo que una persona es realmente, como or a
menos que usted le habla o verlo actuar? Usted no puede realmente! Y
esto es particularmente cierto en el caso del Ser Supremo que cre el
universo: a menos que opte por expresarse a s mismo o revelar a nosotros
los seres humanos, slo hay ninguna manera en la que seres menor puede
llegar a comprender el carcter de un ser mayor.
La cuestin central, entonces, para aquellos de nosotros que quieren saber
lo que Dios es como es - l nunca ha hablado? Y hemos un registro fiable
de lo que dijo? A lo largo de los siglos muchos de nuestros antepasados
han profesado que nos diga las mismas palabras que nuestro Dios ha
hablado y los muy hechos que l ha hecho.
Los mitos-Griego y Latn
Homero, por ejemplo, es la primera griego escritor cuyas obras estn
disponibles, y en el ao 900 aC describi la escena como Dios habla en el
cielo: "Zeus se dirigi a la ahora inmortales." Qu cosa lamentable es que
los hombres deben culpar a los dioses y respecto a nosotros como la
fuente de sus problemas cuando es su propia maldad que les trae
sufrimiento peor que cualquier destino que les asigna ' "3 A partir de este
incidente, podemos ver que el Ser Supremo, Zeus, es expresar a su colega,
el resentimiento dioses que los seres humanos por culpa nuestra
desgracias .... pero espere un minuto! No podemos tomar estas palabras
de Homero como una verdadera cuenta de nuestro Creador de palabras son slo el producto de la imaginacin de Homero. "La Odisea" es
simplemente una novela sobre el imaginario vagabundeos de Ulises en su
camino a casa desde el saqueo de Troya.
o que estamos tratando es mito - imaginario historias construidas sobre un
esqueleto base militar de la historia real, por lo que est leyendo aqu las
palabras que Homero hizo en su propia imaginacin. Si est recibiendo
nada acerca de Dios a todos, estamos recibiendo slo Homero la idea
subjetiva de lo que el Creador podra decir, pero ni siquiera Homero dice
ser real que nos da palabras pronunciadas por el Ser Supremo detrs del
universo. Esta es una distincin importante que hacer en nuestra
bsqueda de palabras y acciones del Creador - la diferencia entre el mito
formado por un hombre de la imaginacin y la historia de lo que sucedi
realmente en el tiempo y el espacio.
Escrituras Budista
En nuestra bsqueda de cualquier comunicacin verbal que el Creador ha
hecho a la humanidad, debemos, por tanto, dejar de lado el puramente
imaginativas creaciones literarias de los griegos y latinos mitos, y vamos a
pasar a algunos de los seres humanos que han sido considerados por
millones como los lderes religiosos - hombres que afirman ser capaces de
decirnos algo sobre la realidad detrs del universo.<
Uno de estos hombres viven alrededor de 500 aC y es considerado por
millones como un confiable lder religioso: la base de su autoridad est en
el corazn de su propia experiencia personal, y esto es descrito en los
siguientes pasajes de las escrituras budistas: "Cuando el gran vidente haba
comprendido que donde no hay ignorancia lo que sea, existe tambin el

karma de formaciones se detuvo - luego de lo que haba logrado un


correcto conocimiento de todo lo que hay que ser conocido, y se destac
en el mundo como un Buda. orador pasa a travs de las ocho etapas de
Transic conocimiento, y rpidamente lleg a su punto ms alto. Desde la
cima del mundo que la baja podra no detectar libre en cualquier lugar. Al
igual que el fuego cuando su combustible se quema, se convirti en
tranquilidad. orador haba llegado a la perfeccin, y cree que a s mismo:
"Este es el autntico camino por el que en el pasado tantos grandes
videntes, que tambin saben todos ms altos y ms bajos todas las cosas,
han viajado a final y real verdad. Y he conseguido! 4
Esto es, por supuesto, el hombre conocido como Buda, pero puede usted
ver cualquier mencin del Creador en estas palabras? La verdad es que el
propio Buda hizo poca mencin de Dios: en efecto, es dudoso si l
realmente cree en una perspectiva personal, objetivo Creador, quien
considera a Dios como ms de un estado que deben alcanzarse y con
experiencia. En realidad hizo hincapi en un mtodo de meditacin
trascendental que ayudaron a las personas ajustar psicolgica y
psquicamente a un mundo imperfecto: esta fue su nfasis en lugar de
cualquier reclamacin para poder decirnos lo que fue el creador del
pensamiento.
Sin embargo, hay un problema an mayor con las escrituras budistas. Los
budistas tienen una actitud diferente a la historia de los occidentales: el
resultado es que no hacen ninguna distincin entre lo que ha sido escrito
en B 500. y lo que estaba escrito en los quince prximos cien aos, de
manera que incluso las palabras originales de Buda son muy difciles de
separar de la mezcla de comentario y el mito de que en las escrituras
tibetano se extiende a 325 volmenes. En nuestra bsqueda de entonces,
para la comunicacin verbal de nuestro Creador, vamos a sentar de lado la
falta de atencin histrica que encontramos en la mezcla de principios y
fines de comentario sobre la vida psquica que caracteriza a las colecciones
como las escrituras budistas.
El Corn
Pasemos, pues, a algunas escrituras que hacer una distincin entre el
registro original y ms tarde los comentarios que accreted a ella.
Alrededor del ao 610 A. D. un hombre llamado Mohammed estaba
dormido o en un trance cuando el ngel Gabriel vino a l y dijo: "Recita!" l
respondi: "Qu voy a recitar?" TLa orden se repite hasta que el ngel
dice a s mismo: "Recita en el nombre de su Seor, el Creador, que cre al
hombre de cogulos de sangre. Recite! Tu Seor es la mayora de
Bounteous Uno, que por la pluma de la humanidad ha enseado cosas que
hizo no s. " Cuando se despert, estas palabras, se nos dice, parece ser
"inscrito a su corazn." 5
Esto, segn la tradicin musulmana, fue el comienzo de las revelaciones
que Mahoma continu recibiendo acerca de Dios: se les recordar por
otras personas antes de ser oficialmente recogido alrededor del ao 650
dC En ellos Mohammed nos dice que el Ser Supremo es misericordioso y
que perdona, popa en la retribucin y la justicia, y exige la fe en su apstol,
Mohammed. De dnde Mohammed obtener esta informacin?
Obviamente, desde que l llama de nuevo a la humanidad la religin de
Abraham, fue capaz de obtener gran parte de ella a partir de la
informacin original que ha ledo en el Antiguo Testamento.
El resto de la misma, sin embargo, derivado de subjetivo, experiencias
msticas o "revelaciones". Hay alguna forma de confirmar que estas
percepciones subjetivas viene en realidad el Creador? Slo hay ninguna
manera de obtener dentro de una la mente del hombre y demostrar que
las ideas existentes son de una fuente externa y no de su propia
imaginacin. En otras palabras, las ideas de Mohammed pueden existir
simplemente por su propia cuenta - no tenemos forma de corroborar:
estamos a merced de un hombre de experiencias subjetivas.
Es este hombre de alguna manera nica y, por tanto, probable que
tengan conocimiento de que una persona comn no posee? Mohammed
advertencia ningn poder para realizar milagros; se vi envuelto en todo
tipo de vengativo y pecaminosa incidentes, y muri, al igual que Buda y
Homero, al igual que un hombre ordinario.
En otras palabras, la mayora de las llamadas "sagradas escrituras" que se
consideran como las comunicaciones de Dios para el hombre son o bien
creaciones de la imaginacin literaria, la falta de acumulaciones histricas
de los comentaristas psquica, o el histrico de cuentas un hombre de
visiones subjetivas. Pero parece ms difcil encontrar histrico cuentas de
las acciones y palabras que han sido corroborados por muchas fuentes
diferentes durante un largo perodo de tiempo que viene directamente de
un Ser Supremo. Hay emprica, tocar y ver las pruebas en cualquier lugar
de este tipo de comunicacin por el Creador para nosotros criaturas?
Es el Nuevo Testamento Historia?
Si. Del 26 al 29 dC un nico ser humano vive en Palestina y su vida fue
observada y registrada por un grupo de hombres y mujeres cuyos escritos
existen en la actualidad en una coleccin conocida como el Nuevo
Testamento. Su registro indica que este singular hombre, Jess, habl y

actu como usted podra pensar el Hijo del Creador del mundo - y que l
muri, desapareci de la tierra, y luego volvi para ms de un mes para
demostrar que En realidad ha sido a travs de la muerte de su padre y fue
de hecho el Ser Supremo vivos en forma humana. Pero cmo este Nuevo
Testamento registro difieren de los griegos y los mitos hindes o los
budistas e islmicos Escrituras? Es fiable la historia no Mito! Cmo
sabemos que es fiable la historia?
Tenemos Testigos Oculares de Cuentas
Los escritores del Nuevo Testamento en realidad lo vio y vivi con l.
Pedro y Juan y los otros fueron contemporneos testigos oculares - no
"amigos de amigos" - que ellos mismos vieron a Jess sanar leprosos; que
vieron los clavos atravesar sus manos, sino que ponen sus dedos en el
orificio en su costado cuando Volvi de la tumba. Aqu estn las palabras
de Pedro: "En el caso de que no sigui inteligentemente concebido mitos
cuando se d a conocer a usted el poder y la venida de nuestro Seor
Jesucristo, pero fueron testigos oculares de Su Majestad. Para cuando
recibi el honor y la gloria de Dios El padre y la voz fue a l a cargo de la
Gloria Majestic, "Este es mi Hijo amado, con quien tengo complacencia',
que hemos escuchado esta voz cargo desde el cielo, ya que estaban con l
en el santo monte."6
Pero hemos slo su palabra de que estaban all? No, en absoluto! Cientos
de referencias a los escritos de aquellos das, confirmar que Pedro y Juan,
Pablo y Lucas y los otros escritores del Nuevo Testamento, los libros de
historia eran conocidos personajes de la poca. En su defensa pblica ante
el rey Agripa, Pablo dice: "el rey sabe sobre estas cosas... Para esto no se
hizo en un rincn." 7 En su carta a los Corintios, afirma que Jess, despus
de su resurreccin, "pareca a ms de quinientos hermanos a la vez la
mayora de los cuales todava estn vivos ", todos los 8 y los miles de
referencias a Pablo en las cartas de aquellos das confirman que tanto los
testigos oculares y las cosas que se escribieron sobre la verdad. Los
escritos de hombres como Clemente, Barnabus, Ignacio y en el primer siglo
estn llenos de referencias a los registros escritos de los hombres que
Jess observ de primera mano.9
Incluso la prxima generacin de su personal registrado entrevistas con
estos testigos oculares del Hijo del Creador:
Papias, nacido en el 60 dC, lo que los registros antiguos apstol Juan le dijo
acerca de la escritura de los evangelios: "Mark, se ha convertido en
intrprete de Pedro, escribi con exactitud todo lo que l recordaba;
aunque l no ha registrado con el fin de que lo que se hizo o dijo de Cristo.
Para l, ni odo ni el Seor le siguieron, pero posteriormente, como ya he
dicho, [se adjunta a s mismo] Peter que utiliza para enmarcar su
enseanza para atender a las [inmediato] quiere de sus oyentes, y no
como una descripcin conectivo de los discursos del Seor." Por lo tanto,
Mark cometido ningn error, tal como se escribi en algunos datos del
mismo modo que les record a la mente. Por l hubiera seguido a una
cosa, a omitir ninguno de los hechos que l escucha, y declarar falsamente
nada en su descripcin de ellos." 10
Ireneo, que vivi hasta el 203 dC, narra cmo Policarpo, que muri en 154
AD "describira su relacin con John y con el resto de los que haba visto al
Seor, y cmo se relacionan sus palabras. Y alguna cosas que l haba odo
de ellos sobre el Seor y sobre sus milagros y sobre su enseanza,
Policarpo, como haber recibido de testigos presenciales de la vida de la
Palabra, se relacionan por completo de acuerdo con las Escrituras."11
Tenemos Have testigos hostiles
Pero, si "esto no se hizo en un rincn", seguramente incluso los
historiadores que son hostiles a hacer referencias a la muerte y
resurreccin de Jess de Nazaret! Y as lo hacen - no-bblica, no cristianos
historiadores como prfido, Celso, Josefo, Plinio - confirmar que todos los
escritores del Nuevo Testamento escribi la verdad sobre los
acontecimientos que observ personalmente en Palestina en el primer
siglo.
Tcito, el principal historiador de la Roma imperial escribe: "El autor de ese
nombre (cristiano) que era Cristo en el reinado de Tiberio sufri el castigo
en virtud de su Procurador Poncio Pilato," 12 mientras que el historiador
judo Flavio Josefo escribe: "Haba alrededor de este tiempo , Jess, un
hombre sabio, si es lcito llamarlo un hombre para l era un doer de las
obras maravillosas - un maestro de los hombres tales como recibir la
verdad con placer. Orador seala a l tanto muchos de los Judios, y
muchos de los Gentiles. l era Cristo, y cuando Pilato, por sugerencia de
los principales hombres entre nosotros, le ha condenado a la cruz, los que
lo am en la primera no le abandones, porque l apareci vivo a ellos de
nuevo la tercer da ... 13
El carcter pblico del registro y el objetivo de corroborar los hechos
registrados por Pablo y Pedro y los dems se pone de manifiesto ms
claramente en la declaracin de Tertuliano, la juris-consult, familiarizados
con la romana archivos. "Tiberio en consecuencia, en cuyo da el nombre
cristiano hizo su entrada en el mundo, despus de haber recibido l mismo
de inteligencia de Palestina de los acontecimientos que han demostrado

claramente la verdad de la divinidad de Cristo, llevado el asunto ante el


senado, con su propia decisin en favor de Cristo . El Senado, porque no
haba dado la aprobacin en s, rechaz esta propuesta. Caesar celebrada a
esta opinin, amenazando de muerte contra todos los acusadores de los
cristianos."14
Ninguna otra historia antigua ha corroborado mejor de testigos registros!
Hemos fiable manuscritos de estas cuentas
Pero el mito es "historias imaginario construido sobre un esqueleto base
real de la historia" - el tipo de historias que dio lugar a cientos de aos
despus de Buda o Scrates muri. Cmo sabemos que estamos leyendo
en el Nuevo Testamento lo que los testigos oculares escribi
originalmente? Cmo sabemos que ellos o sus seguidores o las
generaciones futuras no exagerar o bordan el original la vida de Jess del
mismo modo que otros admiradores lo han hecho con sus antiguos
hroes?
La Prueba Manuscrito para Los Clsicos
El requisito obvio para el desarrollo de un mito es hora de que los testigos
oculares y sus registros escritos a morir de manera que los nuevos,
exagerado registros se pueden escribir. En el caso de Csar Historia de la
Guerra galas, el tiempo existe - 900 aos de que - entre el momento en
que Csar escribi su cuenta y la fecha de nuestro manuscrito antes de
que cuenta - 900 aos durante los cuales todo tipo de autores podran
haber bordado el manuscrito que leen, han destruido el original y se
aprueban en su versin bordada.
Incluso si no destruir deliberadamente el original, el tiempo lo destruye,
para que el ojo humano se equivoca, ya que intenta leer el deterioro de
papiro o vitela: de esta manera diferentes copistas copia palabras de otra
manera a fin de que "variante" lecturas resultado en la mayora de
manuscritos antiguos. El primer manuscrito, por lo tanto, es probable que
sea el ms cercano al original, y la ms exacta lectura de los primeros
manuscritos es el testimonio de por el mayor nmero de manuscritos.
Lamentablemente Csar Guerra galo depende de slo diez manuscritos, y
la mayor brevedad una fecha es 1000 aos despus de Csar escribi su
historia, por lo que la avanzada edad de los manuscritos deja mucho
espacio para el desarrollo del mito, y el pequeo nmero de manuscritos
de las hojas un montn de espacio para la copia errnea. Sin embargo, las
generaciones de estudiosos aceptar Caesar's Historia de la Guerra galas
como absolutamente fiable.
Tampoco duda de que hemos Plato's Republic como l lo escribi en 400
AC, aunque slo tenemos 7 y los manuscritos ms antiguos es una copia
compulsada, 1200 aos ms tarde. El mismo tipo de pruebas manuscrito
se acepta como prueba positiva de que nuestro presente copia de los
"clsicos" son reproducciones fidedignas de lo que los autores escribieron
originalmente. Por lo tanto, aceptar la autenticidad de Herdoto 'Historia
sobre la base de ocho manuscritos de los primeros que tiene fecha de
1300 aos despus de muerto Herodoto, Aristteles trabaja con cinco
manuscritos y los primeros 1400 aos ms tarde, Lucrecio trabaja con
dos manuscritos y los primeros 1100 aos posterior.
Una Comparacin de los clsicos
Y el Nuevo Testamento
Author

When
Written

Earliest
Copy

Time
Span

No. of
Copies

Plato

427-347 B.C.

900 A.D.

1,200
yrs.

Tacitus

100 A.D.

1,100 A.D.

1,000
yrs.

20

Ceasar

100-44 B.C.

900 A.D.

1,000
yrs

10

Livy

59 B.C.17A.D.

---

---

20

Pliny

61-113 A.D.

850 A.D.

750 yrs.

Thucydides

460-400 B.C.

900 A.D.

1,300
yrs

Suetonius

75-160 A.D.

950 A.D.

800 yrs

Lucretius

Died 55 or 53
A.D.

---

1,100
yrs

Euripedes

480-406 B.C.

1,100 A.D.

1,500
yrs

Aristotle

384-322 B.C.

1,100 A.D.

1,400
yrs

New
Testament

48-100 A.D.

125 A.D.

25 yrs

4,000

Si Ht = 40 Entonces
ST+0.5*T
HE
HT - 40
S
HE *TE +40*T
FIN SI
Imprimir S

La Evidencia de Manuscrito para el Nuevo Testamento


Cul es el manuscrito pruebas de la autenticidad de la historia registrada
en el Nuevo Testamento? La pieza ms antigua del manuscrito que
tenemos no es 1400 aos despus del original autgrafo como con
Sfocles o 750 aos, con Plinio, pero - 35 aos! Un trozo del Evangelio de
Juan existe en una biblioteca de Manchester en Inglaterra y tiene fecha de
125 dC - 35 aos despus de Juan escribi su vida de Jess, en otras
palabras, algunos contemporneos de Juan que han sido todava vivos en
el momento actual que los trozos de material se se pas de mano en
mano!
No exista el menor lapso de tiempo lo suficientemente largo como para
permitir que los hechos de la vida de Jess a ser olvidado y sustituido por
el mtico exageraciones. Por otra parte, el texto de esta pieza del evangelio
de Juan se ve corroborada por tres grandes manuscritos que contienen la
mayor parte de la Biblia: los cdices Alexandrinus, Vaticanus, Sinaiticus y
fecha de 350-450 dC - mucho antes de que el manuscrito antes de
cualquiera de los autores clsicos.
Pero, cmo muchos de esos manuscritos existen entre 125 y 1100 DC?
Como vimos antes, los ms antiguos manuscritos que usted tiene, el que
est ms segura de detectar los eventuales errores cometidos por
copistas. Existen ocho, con 10 o Suetonio como con Aristfanes o incluso
20, ya que con Tito Livio? Hay 4000 manuscritos griegos de la Biblia en
existencia y 8000 de fecha latn manuscritos entre 125 y 1100 DC.

Papyrus fragmento de Juan 18:31-33 en la Biblioteca John Rylands, de


Manchester, Inglaterra (con fecha de alrededor de 125 dC).
No pedazo de la historia antigua es tan cierta y segura como la historia
registrada en el Nuevo Testamento, no la historia es similar a la
sancionada por tantos manuscritos de esa edad. Ninguna otra historia ha
sido objeto de tan intenso literaria, textual, histrica, jurdica, teolgica y
examen y qued tan indemne. Slo algunos puntuacion y ortografa
variaciones se debaten por estudiosos serios, y los que ascienden a, como
mximo, una milsima parte de la historia del Nuevo Testamento. Si el
Nuevo Testamento no es fiable la historia que podemos confiar, entonces
la historia antigua no se puede confiar. Si decimos que el Nuevo
Testamento es mito, entonces la historia no existe!

Codex Sinaiticus fecha 350 dC en British Museum, Londres, Inglaterra.


El hecho es - si Csar y Platn y Tcito existido, entonces el registro de
todos los detalles de la vida de Jess en el Nuevo Testamento es cierto, y
cada uno de nosotros tiene que enfrentar el hecho de que haya vivido en
nuestra tierra 1900 aos atrs un hombre llamado que Jess era perfecto,
tena poder sobre la enfermedad y la naturaleza, no puede ser muerto, y
habl y vivi como el Hijo de Dios!
1.
A un trabajador le pagan segn sus horas de trabajo y una tarifa
de pago por horas si la cantidad de horas trabajadas es mayor ha 40
horas la tarifa se incrementa en un 50 % para las horas extras.
Calcule el salario del trabajador dada las horas trabajadas y Tarifas.
Variables: Ht,T,TE,HE,S
Inicio:
Leer Ht,T

Fin

3.En una empresa de 1000 trabajadores, se har un aumento al


salario de acuerdo al tiempo de servicio, para este aumento se
tomar en cuenta lo siguiente:
Tiempo de servicio: de 1 a 5 aos
Aumento: S/. 100
Tiempo de servicio: de 5 a 10 aos
Aumento: S/. 250
Tiempo de servicio: de 10 a 20 aos Aumento: S/. 400
Tiempo de servicio: de 20 aos a ms Aumento: S/. 550
Se desea obtener unalista del personal en orden creciente con
respecto al sueldo modificado
Inicio
Dimensionar Nombre[1200], Tiempo[1200], Sueldo[1200]
X <- 1
mientras X <= 1000 hacer
leer Nombre[X], Tiempo[X]
X <- X + 1
fin_mientras
X <- 1
mientras X <= 1000 hacer
si Tiempo[X] <= 5 entonces
Sueldo[X] <- 1000 + 100
fin_si
si Tiempo[X] <= 10 entonces
Sueldo[X] <- 1000 + 250
fin_si
si Tiempo[X] <= 20 entonces
Sueldo[X] <- 1000 + 400
sino
Sueldo[X] <- 1000 + 550
fin_si
X <- X + 1
fin_mientras
X <- 1
mientras X <= 1000 hacer
Y <- X
mientras Y <= 1000 hacer
si Sueldo[X] > Sueldo[Y] entonces
T <- Nombre[X]
Nombre[X] <- Nombre[Y]
Nombre[Y] <- T
T <- Tiempo[X]
Tiempo[X] <- Tiempo[Y]
Tiempo[Y] <- T
T <- Sueldo[X]
Sueldo[X] <- Sueldo[Y]
Sueldo[Y] <- T
fin_si
Y <- Y +1
fin_mientras
X <- X + 1
fin_mientras
X <- 1
mientras X <= 100 hacer
mostrar Nombre[X], Tiempo[X], Sueldo[X]
X <- X + 1
fin_mientras
Fin
Dado la tarifa de pago por horas de un trabajador, y sus horas
trabajadas calcular cuantos trabajadores reciben un salario mayor o
igual a S/.500 y calcular ademas el promedio de los salarios de
todos los trabajores
INICIO
|
| Leer N
| Leer Tarifa
| i=0
| C=0
| Suma=0
| mientras i<=N Hacer
| |
Leer horas

| |
salario= tarifa * horas
| |
Escribir salario
| |
Si salario >=500 entonces:
| |
c=c+1
| |
Fin_si
| |
Suma= suma + salario
| |
i=i+1
| fin_mientras
| P=suma/N
| Escribir: P,C
FIN
4. Realizar el diseo de un algoritmo que me permita :
Ingresar el cdigo del trabajar
Ingresar numero de horas trabajadas
Ingresar el costo de la hora
Calcular el sueldo bruto semanal
Calcular el sueldo neto semanal
Imprimir el sueldo bruto y el sueldo neto
respectivo(sueldo bruto menos el descuento del seguro de
pensiones 11%)
Inicio
Cod : entero
HT, CH, SB 0, SN, DESC : real
Leer "codigo",cod
Repetir
Leer "costo hora",CH
Hasta (HT > 0 y CH > 0)
Hacer SB HT * CH
Hacer Desc SB * (11/100)
Hacer SN SB - Desc
Mostrar "Sueldo Bruto",SB
Mostrar "Sueldo Neto" ,SN
Fin
5.CALCULAR:
X - (X^2)/2 + (X^3 )/3 - (X^4)/4 .....(X^N)/N
Variables X , N ,S , Pot , i
Inicio
Leer X,N
S<-1
Pot<-1
i<-1
Mientras i<=N hacer
Pot <-Pot *X
Si i mod 2 =0 entonces
S<-S + Pot / i
Si no
S<-S - Pot / i
i<-i+1
Fin mientras
Imprimr "S"
fin
4.- a un trabajador le descuentan de su sueldo el 10% , si su sueldo
es menor o igual a 1000.
por encima de 1000 y hasta 2000 el 5 % del adicional y por encima
de 2000 3 % del adicional
calcular el descuento y sueldo neto que recibe el trabajador dado su
sueldo.
variable s,d sn.
inicio
leer s
si s<-100 entonces
d<-s*0.1
si_no
si s<-2000 entonces
d<-(s-1000)*0.o5+1000*0.1
si_no
d<-(s-2000)*0.03+1000*0.05+1000*0.1
fin_si
fin_si
sn<-s-d
imprimir sn,d
fin
fin
3.-dados las horas de trabajo de una persona y la tarifa de pago.
calcular su salario imprimido.

salario<-horas*tarifa
fin_mientras
fin
2.- Determimnar si un nmero es capicua
Inicio
variable nun, pro, , x nun
leere nun
x nun= nun
pro=O
mientras nun<>O
pro=((pro x 10) +(nun nod+o))
nun=nun/10
fin niemtras
si (x nun=nun) entonces
imprimir "nmero es capicua"
sino
imprimir"nmero no es capicua"
fin-si
fin
10.-Hacer un algorismo en el que se invierta un array lineal de "P"
elementosen un solo arrays
Inicio
dimencionar a [p]
x 1
mientras x<=p hacer
leer a[x]
x x+1
Fin MIENTRAS
x1
y 1
MIENTRAS x<=n hacer
t a[x]
a[y] a[x]
a[x] t
x x+1
y y -1
FIN MIENTRAS
x 1
MIENTRAS x<=p hcer
escribir a[x]
x x+1
FIN MIENTRAS
FIN
6. Dado un ngulo en grados, convertirlo a radianes
Variables: grados, radianes, ngulos.
Inicio:
Leer grados
Radianes
ngulo * 180
Imprimir radianes
Fin
7. Dado un tiempo en segundos calcular los minutos y segundos
restantes que lo corresponden.
Variables: tiempo, minutos y segundos
Inicio:
Leer tiempo
Minutos: tiempo DIV60
Segundos: tiempo MOD 60
Imprimir minutos, segundos.
Fin
2.
A un trabajador le descuentan de su sueldo el 10% si su
sueldo es menor o igual a 1000.Por encima de1000 y hasta 2000
el 5% del adicional y por encima de 2000 el 3 % del adicional.
Calcular el descuento y sueldo neto que recibe el trabajador dado
su sueldo.

variables:horas,tarifa,salario.
Variables: S; D; SN
inicio
leer horas,tarifas
salario
mientras horas>0 y tarifas>0 hacer

Inicio:
Leer S

Si S
D

100 entonces
S*0.1

Si no
D

Hacer la derivacin del numero 1 entre el numero 2 por restas


suscritas e imprimir su cociente y residuo
Var: I, NUM1, NUM2

(S-2000) * 0.05 + 1000 *0.1


Inicio

Fin si
Fin si
SN

Leer NUM1, NUM2


I=O
S-D
Mientras NUM1 > = NUM 2 hacer
NUM1 = NUM1- NUM2
I = I+1
Fin_mientras
Escribir I, NUM 1

Imprimir SN, D
Fin
Hacer un programa que calcule el rea acumulada demarcado de
los cuadrados (los cuadrados son 13 y de igual tamao), los lados
de los cuadrados deben ser mayores a 30 y menores a 66.

Inicio
area = 0
area_acum = 0
leer x, y
si x = y

Fin
9. Determinar cuantos trabajadores recibieron uun salairo mayor
menor a s./500
variables tarifa, horas, salario,i,n,c
INICIO
leer N
leer tarifa
i=1
c=0

si x > 30 y x < 66 entonces:


area = x * x
area_acum = area * 13
fin_si
fin_si

mientras i<=N hacer


leer horas
salario=tarifa*horas
si salario >=500 entonces
c=c+1
fin_si
imprimir salairo
i=i+1
fin_mientras
imprimir c

escribe area_acum
Fin
Se desea invertir dos nmeros dados: 8 y 5

Inicio
dimensionar a (x), b (y)
x=8
mientras x <= 5 hacer:
leer a (x)
b (y) = a (x)
x = x+1
fin_mientras

FIN
Hacer un programa que imprima el cubo y la raiz cuadrada de un
numero ingresado por la pantalla; el programa debe estar
confeccionado de tal manera que el proceso a efectuarse sea
repetitivo.
Debe terminar cuando al pedir el numero se ingrese el valor 0
INICIO
Leer N

x=8
y=5
mientras x <=5 hacer
a (x) = b (y)
x = x+1
y = y-1
fin_mientras
x=8
mientras x <= 5 hacer
escribe a (x)
x = x+1
fin_mientras
Fin
Hacer un programa que calcule el M.C.D. de dos nmeros:

Si N=0 entonces:
escribe "Fin del programa"
Sino
C=N^3
R=N^0.5
IMPRIMIR C,R
Fin_si
FIN
Hacer un prpgrama que calcule las raices de una ecuacion
cuadratica cuya forma canonica es:
Ax+By+C=0
Solo se calculara raices reales. si el discriminante en menor de 0,
imprimir error y volver a ingresar datos.
Los coeficientes A,B,C seran ingresados por la pantalla

Inicio
leer nmero(a,b)
si (a <= 0 || b <= 0)
escribir a -1; // Cdigo de error
mientras (a != b)
si (a < b)
b= b - a;
// b-= a; // Igual que la anterior. Ya se ver
entonces
a= a - b;
// a-= b; // Igual que la anterior
fin_si
escribir a; // Al final el mcd est en a y en b (a == b)

INICIO
Leer A,B,C
D=B^2-4*A*C
Si D<0 entonces:
IMPRIMIR "ERROR"
Fin_si
X=(-B+D^5)/(2*A)
Y=(-B+D^5)/(2*A)

fin_mientras
IMPRIMIR X,Y
fin_si
FIN
Fin

Hacer un programa que permita calcular el area de un triangulo


cualquiera donde los valores de los lados son ingresados por el
teclado
INICIO
Leer A,B,C
S=(A+B+C)/2
AT= (S*(S-A)*S*(S-B)*S*(S-C))^0.5
IMPRIMIR AT
FIN
Hace un programa que calcule la longitud de la circunferencia, el are
del circulo y el volumen de la esfera para un radio ingresado por el
teclado
INICIO
Leer "R"
PI=3.1416
LC=2*PI*R
A=PI*R^2
V=4/3*PI*R^3
Imprimir "LC","A","V"
FIN
Disear un programa que permita controlar la venta de pasajes a los
clientes segn la categora y el destino.
INICIO
| Leer (cliente)
| Leer (CAT)
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|

| Si CAT= "econmico" , entonces


| Escribir ("ingrese destino")
| |
| Si DES = "Tumbes", entonces
| | Escribir ("No hay pasajes")
| |
| Sino
| | Si DES ="Piura", entonces
| | | P1 = 12
| | | Escribir (P1)
| | |
| | Sino
| | | Si DES ="Talara", entonces
| | | | P2 = 18
| | | | Escribir (P2)
| | | |
| | | Sino
| | | | Si DES = "Lima" , entonces
| | | | | Escribir ("No hay pasajes")
| | | | Fin_si
| | | Fin_si
| | Fin_si
| Fin_si
|
Sino
| Si CAT =Imperial, entonces
| | Escribir ("Ingrese destino")
| |
| | Si DES = Tumbes, entonces
| | P3=80
| | Escribir ("P3")
| |
| | Sino
| | | Si DES =Piura, entonces
| | | | P4= 20
| | | | Escribir (P4)
| | | |
| | | Sino
| | | | Si DES =Talara, entonces
| | | | | P5=30
| | | | | Escribir (P5)
| | | | |
| | | | Sino
| | | | | Si DES = Lima , entonces

| | | | | | | Escribir ("No hay pasajes")


| | | | | | |
| | | | | | Fin_si
| | | | | Fin_si
| | | | Fin_si
| | | Fin_si
| | |
| | Sino
| | | Si CAT = Bus cama , entonces
| | | | Escribir ("Ingrese destino")
| | | |
| | | | Si DES = Tumbes, entonces
| | | | P6=100
| | | | Escribir ("P6")
| | | |
| | | | Sino
| | | | | Si DES =Piura, entonces
| | | | | | Escribir ("No hay pasaje")
| | | | | |
| | | | | Sino
| | | | | | Si DES =Talara, entonces
| | | | | | | Escribir ("No hay pasaje")
| | | | | | |
| | | | | | Sino
| | | | | | | Si DES = Lima, entonces
| | | | | | | P7=170
| | | | | | | Escribir(P7)
| | | | | | Fin_si
| | | | | Fin_si
| | | | Fin_si
| | | Fin_si
| | Fin_si
| |
|Fin_si
|
FIN
Dadas 3 longitudes, es decir mediante un mensaje si forman un
triangulo: equilatero, isosceles o escaleno, o no forman triangulo
(cada lado tiene que ser menos que la suma de los otros dos)

INICIO
|
|
|
|
|
|
|
|
|
|
|
|
|
|

Leer a,b,c
Si a<b+c and b<a+c and c<a+b entonces
|
| Si a=b and b=c entonces:
| | escribe: "El triangulo es equilatero"
| |
| Sino
| | Si a<>b and a<>c and b<>c entonces
| | |
escribe: "El triangulo es escaleno"
| | |
| | Sino
| | |
escribe: "El triangulo es isosceles"
| | |
| |
| Fin_si
| |
|
| |
Fin_si
| |
| Sino
| |
escribe: "No forman triangulo"
| |
| Fin_si
|
|
FIN
5.- Hacer un programa que lea las "50" grupos de productos
vendidos del da de una tienda, si algunos de estos grupos excede a
1000 productos que se vende en la tienda se solicitara mercadera
(nueva mercaderia-NM),que ser el doble de los que se ha vendido,
si la venta de productos no es mayor 1000 el orden a seguir ser el
primero con el fin de llegar a mostrar la cantidad de productos
vendidos y la cantidad de mercadera a solicitar.
Inicio
Dimen V[1000], MN[1500],
N <- 50
Acum <- 0
X <-1
Mientras x < = N hacer
Leer CP[x]
X <- X+1

Fin-mientras
X <- 1
Mientras X <= N hacer
S CP[x] > 1000 entonces
NM <- 2* CP[x]
Escribir CP[x]
Acum <- Acum + MN
CP[x] <- CP[x+1]
Sino
CP[x] <-CP[x]
X <- X+1
Fin-mientras
CP[N] <-0
N <- N-1
X<- 1
Mientras X<= N hacer
escribir CP[x]
X<-X+1
Fin-mientras
Escribir Acum
Fin
3.- hacer un programa que sume 5 precios de las camisas (en
dolares) y que luego muestre el total de la venta en soles.
inicio
Acum <- 0
X<-1
Mientras X <= 5 hacer
Leer precio
N<-precio
NN<- precio*3.5
Acum<-Acum + NN
X <- X + 1
Fin-mientras
Escribir Acum
Fin
1.- hacer un algoritmo que lea los diez salarios y las horas
respectivas de trabajo de los obreros de una empresa ,los cuales
son ingresados por teclado, deseando saberse al final del programa
el salario y las horas, teniendo en cuenta que las horas trabajadas
normales son 8, las cuales tienen un salario establecido; si las horas
trabajadas son mayores al horario establecido la diferencia de horas
son pagadas a 5 soles cada hora, de suceder lo contrario, por hora
no trabajada se le descuenta 4 soles.
Inicio
X<- 1
Mientras X >=10 hacer
Leer salario , horas
Si horas = 8 entonces
S <- salario
Fin-si
Si horas > 8 entonces
Hora <- horas - 8
S<- salario + (hora*5)
Sino
Hora<- 8 - horas
S <- salario - (hora*4)
Fin-si
X <- X + 1
Fin-mientras
Escribir S, horas
Fin
5) Hacer un programa que que registre 50 numeros y que los sume
inversamente y que muestre el resultado de la suma total.
Inicio
dimensionar num[60]
x <-1
mientras x <= 50 hacer
leer num[x]
x <- x 1
fin_mientras
acum <- 0
y <- 50
mientras y >= 1 entonces
acum <- acum + y
y <- y - 1
fin_mientras
escribe acum
fin
2) Elaborar un programa que muestre el mensaje: "es multiplo de 2"
si es que el nmero lo es, "es multiplo de 3" si es que lo es, y "es
multiplo de 5" si es que el nmero lo es.

Todo esto dentro de la lectura de 200 nmeros.


Inicio
x <- 1
mientras x <= 200 hacer
M2 <- x mod 2
M3 <- x mod 3
M5 <- x mod 5
si M2 = 0 entonces
ecribe "es multiplo de 2"
fin_si
si M3 = 0 entonces
ecribe "es multiplo de 3"
fin_si
si M5 = 0 entonces
ecribe "es multiplo de 5"
fin_si
x <- x + 1
fin_mientras
Fin
5.-Hacer un programa que sume (acumule) los nmeros que son
mltiplos de 3 o 5 de 7 entre los nmeros 100 y 300 inclusive.
Inicio
Acum<-0
X<-0
mientras x<300 hacer
si(x mod 3)=0 entonces
acum<-acum+x
fin_si
si(x mod 5)=0 entonces
acum<-acum+x
fin_si
si(x mod 7)=0 entonces
acum<-acum+x
fin_si
x<-x+1
fin_mientras
fin
6) Hacer un programa donde se clasifique una lista de numeros
indicando al final la cantidad de numeros pares y la cantidad de
numeros impares, el dato aingresar es un numero y se debe el
proceso de mientras el numero ingresado sea diferente de cero.

Inicio
NP<-0 //NP es la variable de numeros pares
NI<-0 //NI es la variable de numeros impares
Mientras numero<>0 hacer
leer numero
si numero 2mod=0 entonces
NP<-NP+1
si_no
NI<-NI+1
fin_si
Fin_Mientras
escribir NP,NI
Fin
4) Hacer un programa considerando el ao actual donde considere
a las personas segun su ao de nacimiento en que etapa de su vida
estan, (ninez, adolescencia, juevntud, adultes, vejez, muerte)
considere a la muerte mayor de 75 aos.
Inicio
ao actual<-2003
leer edad, ao de nacimiento
hacer edad<-ao actual-ao de nacimiento
Si edad>0 y edad<=12 entonces
mostrar "ninez"
si_no
si edad>12 y edad<=18 entonces
mostrar "adolescencia"
si_no
si edad>18 y edad<=30 entonces
mostrar "juventud"
si_no
si edad>30 y edad<=60 entonces
mostrar "adultes"
si_no
si edad>60 y edad<=75 entonces
mostrar "vejez"
si_no
si edad>75 entonces

mostrar "mortandad"
fin_si
fin_si
fin_si
fin_si
fin_si
fin_si
Fin
3) Hacer un programa que determine y muestre meses con sus
respectivos numeros, teniendo en cuenta la siguiente condicion:
_ El pregrama terminar cuando se le ingrese un numero negativo
o un numero mayor a 12.
_ Debe detectar el mes del dia de la madre y el mes de navidad.
Inicio
leer numero
si numero=1 entonces
mostrar "mes es igual a enero"
si_no
si numero=2 entonces
mostrar "mes es igual a febrero"
si_no
Si numero=3 entonces
mostrar "mes es igual a marzo"
si_no
si numero=4 entonces
mostrar "mes es igual a abril"
si_no
si numero=5 entonces
mostrar "mes del dia de la madre"
si_no
si numero=6 entoces
mostrar "mes es igual a junio"
si_no
si numero=7 entonces
mostrar "mes es igual a
julio"
si_no
si numero=8 entonces
mostrar "mes es igual
agosto"
si_no
si numero=9
entonces
mostrar "mes es
igual a septiembre"
si_no
si numero=10
entonces
mostrar "mes
es igual a obtubre"
si_no
si
numero=11 entonces
mostrar "mes es igual a noviembre"
si_no
si
numero=12 entonces

x <- x+1
fin-mientras
//Insercin
leer w,y
Para x = 9 hasta x >= 4 de -1
a [x+1]<- a[x]
Fin_Para
a[4] <- w
Para x=10 hasta x>=2 de -1
a [x+1]<- a[x]
Fin_Para
a[2]<-y
x <- 1
mientras x <= 11 hacer
escribir a[x]
x <- x+1
fin-mientras
FIN
1.- dado a, b determinar el valor de la divisin entera y el resro de
la divisin entera de a, b
( sin usar los operadores de div. mod)

INICIO
Leer a,b
cv <- 0
mientras a>= b hacer
a <- a-b
cv <- cv+1
fin-mientras
pe <- cv
resto <- a
imprimir: Pe,resto
fin
3. Disear un algoritmo que permita encontrar la solucin a la
siguiente serie:1,1/2!,1/3!,1/4!,1/5!,...1/N! Siendo N un numero
ingresado por el teclado.
Inicio
N, H, K, F :entero
S : real
Leer N
Repetir
Hacer K K + 1
Hacer H K
Hacer F 1
Repetir
Hacer F F * H
Hacer H H-1
Hasta (H = 0)
Hacer S 1/F
Mostrar 1/F
Hasta (k = N)
Fin
3. Elaborar un algoritmo, que permita el ingreso de 100 nmeros
enteros.
El programa debe sumar todos los nmeros que sean mltiplos de
3.

mostrar "mes de navidad"


fin_si
fin_si

Inicio
Dimensionar numero[100]
x<-1
mientras x<=100 hacer
leer numero[x]
x<-x+1
fin - mientras
x<- 1
s<- 0
mientras x<=100 hacer
Si (numero[x] mod 3 = 0) entonces
s<- s+numero[x]
Fin_Si
x<-x+1
Fin_mientras
Mostrar s

fin_si
fin_si
fin_si
fin_si
fin_si
fin_si
fin_si
fin_si
fin_si
fin_si

si numero<=0 o numero>12
escribir "error de datos"
fin_si
Fin
9.Se tiene 9 marcas de jeans y se desea insertar 2 nuevas marcas
en la posicin 2 y 4.
INICIO
Dimensinar a[20]
//Leer todos los elementos
x <- 1
mientras x <= 9 hacer
leer a[x]

Fin
6Dado N y X calcular: x1/1+x3/3+x5/5+...........+x(2n)-1?
variables
I,N

inicio
leer N
I_1
mientras 1<=2*n hacer
si I mod 2=0 entonces
imprimir I
fin si
I_I+1
fin mientras
fin
7Dado el monto de una compra calcular el descuento considerado
-descuento es 10% si el monto es mayor a 100 soles
-descuento es 20% si el monto es mayor a 50 soles y menor o
igual a 100 soles
-no hay descuento si el monto es mayor o igual a 50 soles
variables
monto, descuento

a[x]<-- a[y]
a[y] <-- T
fin_si
y <-- y + 1
fin_mientras
y <-- y + 1
fin_mientras
//publicar
x <-- 5
mientras x >= 2 hacer
escribe a [x]
x <-- x + 1
fin_mientras
fin
Se ingresan 5 notas de un alumno, publicar 2 peores notas.
inicio

inicio
leer monto
si monto>100 entonces
descuento_ monto*0.1
sino
si monto>50 entonces
descuento_ monto*0.2
sino
descuento_0
fin si
fin si
imprimir descuento
fin
Se ingresan 5 notas de un alumno, publicar 2 peores notas.

dimensionar a[100]
x <-- 1
mientras x <= 5 hacer
leer a[x]
x <-- x + 1
fin_mientras
x <-- 1
mientras x <= 5 hacer
y <-- 1
mientras y <= 5 hacer
si a[x] < a[y] entonces
T <-- a [x]
a[x]<-- a[y]
a[y] <-- T
fin_si
y <-- y + 1
fin_mientras
y <-- y + 1
fin_mientras

inicio
dimensionar a[100]
x <-- 1
mientras x <= 5 hacer
leer a[x]
x <-- x + 1
fin_mientras
x <-- 1
mientras x <= 5 hacer
y <-- 1
mientras y <= 5 hacer
si a[x] < a[y] entonces
T <-- a [x]

//publicar
x <-- 5
mientras x >= 2 hacer
escribe a [x]
x <-- x + 1
fin_mientras
fin