Você está na página 1de 5

Lista de comonandos para configuracin de un Switche

Switch>Enable
Switch#config t
Switch(config)#Hostaname S1
S1(config)#enable secret cisco
S1(config)#ip domain-lookup
S1 (config)# crypto key generate rsa 1024 (RSA es el tipo de cifrado)
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password class
S1(config-line)#login
S1(config-line)#exit
S1(config)#service password-encryption
S1(config)#interface vlan 99
S1(config-if)#ip address IP mask
S1(config-if)#no shutdown
S1(config-if)#exit
S1(config)#ip default-gateway 192.168.10.1
S1(config)#banner motd #Solo personal Autorizado#
S1(config)#exit
S1#copy running-config startup-config
Creacin para una Vlan
S1(config)#vlan 10
S1(config-vlan)#name vlan10
S1(config-vlan)#exit
S1(config)#exit
S1#show vlan brief
Para eliminar una Vlan
Switch#config t
S1(config)#no vlan 20
Para apagar las interfaces
S1(config)#interface range fa0/1-24
S1(config-if-range)#shutdown
S1(config-if-range)#exit
Para levantar una interface
S1(config)#interface fa0/5
S1(config-if)#no shutdown
S1(config-if)#exit
Para asignar Puertos a una Vlan
S1#config t
S1(config)#interface f0/18
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 10
S1(config-if)# do copy running-config startup-config
Para eliminar una interface de una vlan

S1#config t
S1(config)#interface f0/18
S1(config-if)#no switchport mode access
S1(config-if)#no switchport access vlan 10
S1(config-if)# do copy running-config startup-config
Para crear el enlace troncal
S1(config)#interface fa0/1
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan 10
S1(config-if)#do copy running-config startup-config
S1#show running-config
Configuracion de los puertos con el Auto-mdix

S1(config)#interface fastEthernet 0/18


S1(config-if)#duplex auto
S1(config-if)#speed auto
S1(config-if)#mdix auto
S1(config-if)#end
Para seguridad del puerto
S1(config)#interface fastEthernet 0/6
S1(config-if)#switchport mode access
S1 (config-if)# switchport port-security
S1(config-if)#switchport port-security maximum N

S1 (config-if)# switchport port-security violation shutdown (Si se conecta otro equipo el puerto
pierde toda la comunicacin y enva un mensaje al administrador diciendo que el Puerto esta
down y requerir que el administrador lo levante manualmente)
S1 (config-if)# switchport port-security violation restrict (las tramas son descartadas y el
administrador recibir una notificacin de la violacin)
S1 (config-if)# switchport port-security violation protect (las tramas son descartadas pero no
genera ninguna modificacin ni aviso al administrador)
Los comandos que me permiten ver el estado de la seguridad que hemos configurado ser:
S1 # show port-security
S1 # show port-security address.

S1#copy running-config startup-config


Comandos de comprobaciones:

S1# show ip ssh (muestras todas las opciones activas de SSH)


S1# debug ip ssh (activa el Debugging para SSH)
Comandos para conectarnos a SSH:
SW_CUBA# ssh l nombre del host ip del host

Lista de commando para configuracion de un Router


o

Poner nombre al equipo:


Switch> enable (para cambiar a de modo usuario a modo privilegiado)
Switch# configure terminal (para entrar al modo de configuracin global)
Switch(config)# hostname SW_CUBA (comando para cambiar el nombre)
S1(config)# exit (para cambiar al modo anterior, en este caso Modo privilegiado)
S1# write (en este modo se guardan los cambios)

Contrasea de enable password y enable secret para restringir el acceso:


S1 > enable
S1# configure terminal
S1(config)# enable password LAHABANA (No est cifrada)
S1(config)# enable secret MIHABANA ( Es ms segura porque est cifrada en MD5)

Contrasea de acceso al puerto de consola:


S1(config)# line console 0 (comando para acceder a la configuracin del puerto de consola)
S1(config-line)# login (la utilidad es para que el Switch te pregunte la contrasea cada vez que intentes
conectarte al puerto de consola)
S1(config-line)# password LAHABANA (contrasea que nosotros escojamos)

Contrasea de puerto Auxiliar


S1(config)# line aux 0 (comando para acceder a la configuracin del puerto auxiliar)
S1(config-line)# login (la utilidad es para que el Switch te pregunte la contrasea cada vez que intentes
conectarte al puerto auxilar)
S1(config-line)# password MiCUBA (contrasea que nosotros escojamos)

Contrasea para acceder al equipo en remoto TELNET.


S1(config)# line VTY 0 4 (comando que permite acceder a cinco conexiones mltiples a la interfaz de telnet )
S1(config-line)# login (la utilidad es para que el Switch te pregunte la contrasea cada vez que intentes
conectarte por TELNET)
S1(config-line)# password LAHABANA (contrasea que nosotros escojamos)

Encriptaremos todas las contraseas que tenemos en el equipo configuradas con el


comando .
S1(config)# service password-encryption

El SWITCH o ROUTER cada vez que tecleamos un comando mal, el equipo intenta buscar ese
nombre en unos registros que tiene para intentar ver si el posee ese nombre. Con este comando
Desabilitamos la traduccin de nombres.
S1(config)# no ip domain-lookup

Configurar un mensaje restrictivo que se usa para informar a personas ajenas a la


administracin del equipo de que est prohibido entra al ese equipo.
S1 > enable
S1 # configure terminal
S1(config)# banner motd # Prohibido el acceso a este equipo#
S1(config#exit
S1# write

Configurar una IP de gestion al SWITCH en la Vlan1 para poder acceder por TELNET y
configurar el equipo.
S1 > enable
S1 # configure terminal
S1(config)# interface vlan 1
S1(config vlan)# ip address (direccion ip + la mascara que le vamos asignar)
S1(config vlan)# no shutdown (para levantar la comunicacion en la Vlan1 que hemos configurado)

El switch tambin necesita que le configuremos la direccin IP de su Gateway.


S1(config)# ip default-gateway (IP del Gateway)

Recordar siempre que terminemos una configuracin y comprobemos que est funcionando bien, la
guardaremos con en el caso del SWITCH se almacenara en el archivo config.text, para ello utilizaremos el
siguiente comando:
S1# copy running-config startup-config

RESUMEN DE LA CONFIGURACION
Switch> enable
Switch# configure terminal
Switch (config)# hostname SW_CUBA
S1(config)# enable password Mipass
S1(config)# enable secret MIHABANA
S1 (config)# line console 0
S1 (config-line)# password Cisco123
S1 (config-line)# login
S1 (config-line)# logging synchronous
S1 (config-line)# exit
S1 (config)# line aux 0
S1 (config-line)# password MiCUBA
S1 (config-line)# login
S1 (config-line)# exit
S1 (config)# line VTY 0 4
S1 (config-line)# password LAHABANA
S1 (config-line)# login
S1 (config-line)# logging synchronous
S1 (config-line)# exit
S1 (config)# service password-encryption
S1 (config)# no ip domain-lookup
S1 (config)# banner motd # Prohibido el acceso a este equipo#
S1(config)# interface vlan 1
S1(config vlan)# ip address 10.10.11.11 255.255.255.0
S1 (config vlan)# no shutdown
S1(config)# ip default-gateway 10.10.11.10
S1 (config)# exit

S1 # copy running-config startup-config

Comandos de configuracion bsica de Router.


Router>enable
Router#conf t
Router(config)#hostname R1
R1(config)#enable secret cisco
R1(config)#no ip domain-lookup
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 4
R1(config-line)#password class
R1(config-line)#login
R1(config-line)#exit
R1(config)#service password-encryption
R1(config)#banner motd #Solo personal Autorizado#
R1(config)#exit

El enrutamiento inter-VLAN ROUTER ON A STICK


R1(config)#interface fastEthernet 0/0.10
R1(config-subif)#encapsulation dot1q 10
R1(config-subif)#ip address 192.168.10.1 255.255.255.0
R1(config-subif)#exit.

Rutas Estticas

R1(config)#ip route (ip no directamente conectada) mask


route)
R1(config)#ip route (ip no directamente conectada) mask

(ip de la interface donde entra al


serial/giga/ (interfaces de salidad)