Você está na página 1de 16

Configurao IP Communicator (Parte1)

Exemplo de configurao de 02 (dois) IP Communicator em


um CUCME (Cisco Unified Communications Manager
Express).

Configurao do Roteador
R1(config)# telephony-service (entra no modo de configurao de
telefonia)
R1(config-telephony)# max-ephones 25 (mximo de telefones / depende
da plataforma)
R1(config-telephony)# max-dn 50 (mximo de nmeros de diretrios /
depende da plataforma)
R1(config-telephony)#create cnf-files (gera os arquivos de configurao
XML necessrios para telefones)
R1(config-telephony)# cnf-file location flash: (localizao dos arquivos
de configurao dos telefones)
R1(config-telephony)# ip source-address 192.168.1.1 port 2000 (IP do

roteador que ir trocar informaes em SCCP)


R1(config-telephony)#time-format 24 (formato de hora)
R1(config-telephony)#date-format dd-mm-yy (formato de data)
R1(config-telephony)#keepalive 20 (intervalo em segundos de envio de
keepalive / padro = 60s)
R1(config)# ephone-dn 1 (entra no modo de configurao do diretrios
de nmeros)
R1(config-ephone-dn)# number 10 (nmero do ramal)
R1(config-ephone-dn)# name Rodrigo (nome do ramal)
R1(config)# ephone 1 (entra no modo de configurao do telefone)
R1(config-ephone)# mac-address 0800.2735.735B (endereo mac do
telefone)
R1(config-ephone)#type CIPC (informa que este telefone um IP
Communicator)
R1(config-ephone)# button 1:1 (configura o boto 1 do telefone com os
dados do ephone-dn 1)
R1(config)# ephone-dn 2 (entra no modo de configurao do diretrios
de nmeros)
R1(config-ephone-dn)# number 20 (nmero do ramal)
R1(config-ephone-dn)# name Lucas (nome do ramal)
R1(config)# ephone 2 (entra no modo de configurao do telefone)
R1(config-ephone)# mac-address 0009.5B1B.67BD (endereo mac do
telefone)
R1(config-ephone)#type CIPC (informa que este telefone um IP
Communicator)
R1(config-ephone)# button 1:2 (configura o boto 1 do telefone com os
dados do ephone-dn 2)

Configurao do IP Communicator
Click com o boto esquerdo do mouse no IP Communicator e v em:
Preferencias/Rede e configure o IP do roteador.

Comandos para verificar o funcionamento dos telefones.


Mostra o registro dos telefones SCCP
R1#show ephone
Verifica os telefones carregados
R1#show ephone phone-load
Mostra as ligaes ativas
R1#show call active voice
Mostra o histrico de ligaes
R1#show call history voice
Comandos para uso com o "debug" para mostrar os eventos na tela de
telnet ou ssh
R1#terminal monitor
(config)#logging on
Para desabilitar os eventos na tela de telnet ou ssh
R1#terminal no monitor
R1(config)#no logging on
Permite visualizar os eventos de registro SCCP dos telefones
R1#debug ephone register
Permite visualizar os eventos TFTP.
R1r#debug tftp events

Comandos para realizar reboot dos telefones


O comando reset realiza um "hard reboot" similar ao desligamento do
telefone.
R1(config-ephone)#reset
R1(config-register-global)#reset all
R1(config-register-global)#reset 0800.2735.735B
O comando restart realiza um "soft reboot" no necessita realizar DHCP
ou TFTP.
R1(config-ephone)#restart
R1(config-register-global)#restart all
R1(config-register-global)#restart 0800.2735.735B

Ler mais: http://www.ti-redes.com/voip/cisco-cme/conf-ip-communicator/


Crie o seu website grtis: http://www.webnode.pt

Comandos teis para verificao do


CUCME
Comandos Show
Mostra o registro dos telefones SCCP
R1#show ephone
Verificar os telefones registrados
R1#show ephone registred
Verifica os telefones carregados
R1#show ephone phone-load
Mostra as portas de voz instalada no roteador.
R1#show voice port summary

Mostra o encapsulamento, pattern e status dos dial-peer.


R1#show dial-peer voice summary
Mostra as ligaes ativas
R1#show call active voice
Mostra o histrico de ligaes
R1#show call history voice
Mostra todas conexes RTP ativas
show voip rtp connection

Comandos Show para Conexes SIP


Mostra o total de ligaes SIP (UAC ou UAS)
R1#show sip-ua call summary
Mostra o estatus dos registros SIP
R1#show sip-ua register status

Comandos de Teste
Realiza o teste de uma translation-rule
R1# test voice translation-rule 1 089644312
(089644312 = Nmero digitado)
Comando mostra o dial-peer associado a uma sequncia de dgitos
(neste caso ao nmero 32327640)
#show dialplan number 32327640
Simula uma ligao de dentro do roteador
R1#csim start 2001
(2001 = Nmero do telefone)

Comandos para realizar reboot dos telefones


O comando reset realiza um "hard reboot" similar ao desligamento do
telefone.
R1(config-register-global)#reset all
R1(config-register-global)#reset 0800.2735.735B
R1(config-ephone)#reset

O comando restart realiza um "soft reboot" no necessita realizar DHCP


ou TFTP.
R1(config-register-global)#restart all
R1(config-register-global)#restart 0800.2735.735B
R1(config-ephone)#restart

Comandos para Debug


Comandos para uso com o "debug" para mostrar os eventos na tela de
telnet ou ssh
R1#terminal monitor
(config)#logging on
Para desabilitar os eventos na tela de telnet ou ssh
R1#terminal no monitor
R1(config)#no logging on
Permite visualizar os eventos de registro SCCP dos telefones
R1#debug ephone register
Mostra mensagens SCCP.
R1#debug sccp message
Permite visualizar os eventos TFTP.
R1r#debug tftp events
Permite visualizar os eventos TCP.
R1r#debug ip tcp transactions
Comando para depurar chamadas VoIP fim-a-fim
R1#debug voip ccapi inout
Permite visualizar as mensagens SIP
R1# debug ccsip message
Verifica as atividades das regras translation rule
R1#debug voice translation

Autor: Rodrigo Salvo

Ler mais: http://www.ti-redes.com/voip/cisco-cme/comandos-de-verifica/


Crie o seu website grtis: http://www.webnode.pt

Expresses para Destination Patterns


09 AD
*e#
+
.
%
^
$
T
\
[ ]
( )

Caracteres padro.
So considerados caracteres padres e so utilizados para recursos especiais. Por exemplo,
quando um usurio precisa digitar uma senha para realziar uma chamada.
Indica que um nmero padro E.164, caso contrrio, especifica que o dgito anterior ocorreu
uma ou mais vezes.
Coincide a qualquer digito de entrada (utilizado como curinga).
Indica que o dgito anterior ocorreu uma ou mais vezes.
Coincide com o caracter inicial.
Coincide com um digito o final do nmero.
Carcter temporizador, faz o roteador esperar at que todos os dgitos (0-32) sejam recebidos
antes de encaminhar as chamadas.
Seguido por um nico caracter, coincide com o caracter.
Indica um range de digitos.
Indica um pattern (padro).

Exemplos de Associao
32327640

Coincide exatamente com o nmero 32327640.

^32327640$ Coincide exatmente com o nmero 32327640 deixando


explicito o incio eo final do nmero.
3232764[5-9]

Coincide com o range 32327645 at 32327649.

32327[3-4] Analise at 7 nmeros, coincidindo com o sexto dgito que


pode ser 3 ou 4 e o ltimo digito pode ser qualquer dgito.
.T

Qualquer nmero de telefone com comprimento de 1 a 32 dgitos.

(200)?32327640
32327640.
1[2-3]%4

Coincide com os numeros 20032327640 e

Coincide com os nmeros que iniciam com 1 e qualquer

nmero com os digitos 2 ou 3 e com o final 4.


0T Coincide com nmeros que iniciam com 0 e faz o roteador esperar
at que todos os dgitos (0-32) sejam recebidos
1T Coincide com nmeros que iniciam com 0 e faz o roteador esperar
at que todos os dgitos (0-32) sejam recebidos
9....

Coincide com nmeros com 4 digitos que iniciam com 9

0800.......
[1-3]...
3
[1-3].....
3

Coincide com nmeros com 11 digitos iniciados com 0800

Coincide com nmeros de 4 digitos que comeam com 1,2 ou


Coincide com nmeros de 6 digitos que comeam com 1,2 ou

[148]...
8

Coincide com nmeros de 4 digitos que comeam com 1,4 ou

[1489]...
ou 9

Coincide com nmeros de 4 digitos que comeam com 1,4,8

Ler mais: http://www.ti-redes.com/voip/cisco-cme/destination-patterns/


Crie o seu website grtis: http://www.webnode.pt

Comandos teis para verificao do


CUCME
Comandos Show
Mostra o registro dos telefones SCCP
R1#show ephone
Verificar os telefones registrados
R1#show ephone registred
Verifica os telefones carregados
R1#show ephone phone-load
Mostra as portas de voz instalada no roteador.
R1#show voice port summary
Mostra o encapsulamento, pattern e status dos dial-peer.
R1#show dial-peer voice summary
Mostra as ligaes ativas
R1#show call active voice
Mostra o histrico de ligaes
R1#show call history voice
Mostra todas conexes RTP ativas
show voip rtp connection
Comandos Show para Conexes SIP
Mostra o total de ligaes SIP (UAC ou UAS)
R1#show sip-ua call summary
Mostra o estatus dos registros SIP
R1#show sip-ua register status
Comandos de Teste
Realiza o teste de uma translation-rule
R1# test voice translation-rule 1 089644312

(089644312 = Nmero digitado)


Comando mostra o dial-peer associado a uma sequncia de dgitos
(neste caso ao nmero 32327640)
#show dialplan number 32327640
Simula uma ligao de dentro do roteador
R1#csim start 2001
(2001 = Nmero do telefone)
Comandos para realizar reboot dos telefones
O comando reset realiza um "hard reboot" similar ao desligamento do
telefone.
R1(config-register-global)#reset all
R1(config-register-global)#reset 0800.2735.735B
R1(config-ephone)#reset
O comando restart realiza um "soft reboot" no necessita realizar DHCP
ou TFTP.
R1(config-register-global)#restart all
R1(config-register-global)#restart 0800.2735.735B
R1(config-ephone)#restart
Comandos para Debug
Comandos para uso com o "debug" para mostrar os eventos na tela de
telnet ou ssh
R1#terminal monitor
(config)#logging on
Para desabilitar os eventos na tela de telnet ou ssh
R1#terminal no monitor
R1(config)#no logging on
Permite visualizar os eventos de registro SCCP dos telefones
R1#debug ephone register
Mostra mensagens SCCP.

R1#debug sccp message


Permite visualizar os eventos TFTP.
R1r#debug tftp events
Permite visualizar os eventos TCP.
R1r#debug ip tcp transactions
Comando para depurar chamadas VoIP fim-a-fim
R1#debug voip ccapi inout
Permite visualizar as mensagens SIP
R1# debug ccsip message
Verifica as atividades das regras translation rule
R1#debug voice translation
Ler mais: http://www.ti-redes.com/voip/cisco-cme/comandos-de-verifica/
Crie o seu website grtis: http://www.webnode.pt
Criando e vinculando ramais (extensions numbers) no CME
CCNA Voice - See more at:
http://www.dltec.com.br/blog/cisco/ccna-voice/criando-evinculando-ramais-extensions-numbers-no-cme-ccnavoice/#sthash.xGql7Sn2.dpuf
l pessoal, vamos nesse artigo analisar um template bsico e
como aplic-lo para criar uma linha (ramal/extenso/extension)
ou adicionar uma nova linha a um telefone existente em um
ambiente com Call Manager Express (CME).
O princpio bsico criar um novo directory number (DN) no
ephone-dn e depois vincular esse DN ao dispositivo (ao
telefone IP) no ephone. Esse nmero depende do seu plano
de discagem e deve ser um ramal vago (no deve estar sendo
utilizado). 1. Criando um novo DN ephone-dn X dual-line
number XXXX description Ramal XXXX Exemplo da criao de
um novo Directory Number ephone-dn 15 dual-line number
8127 description Ramal 8127 ephone-dn 16 dual-line number

8191 description Ramal 8191 2. Vinculando o DN ao Dispositivo


ephone X mac-address XXXX.XXXX.XXXX button 1:X 2:X No
exemplo do template acima temos um telefone com dois
botes, vamos a um exemplo prtico vinculando os ephone-dn
s criados no passo anterior aos botes 1 e 2 de um telefone
Cisco 7942. ephone 1 mac-address A001.E002.1234 button
1:15 2:16 Portanto colocamos no ephone 1, que um telefone
IP ou softphone com o MAC A001.E002.1234, o primeiro boto
1:15 vinculado ao DN 8127 (ephone-dn 15) e para o segundo
boto 2:16 (ephone-dn 16) o ramal 8191. Veja a imagem do
telefone IP abaixo que tem 2 botes, o modelo 7942. Agora
voc pode fazer essa configurao utilizando o packet tracer
verso 5.3 ou com GNS3 e CME utilizando um Cisco IP
Communicator como telefone IP (CIPC). Espero que vocs
tenham gostado e at uma prxima! - See more at:
http://www.dltec.com.br/blog/cisco/ccna-voice/criando-evinculando-ramais-extensions-numbers-no-cme-ccnavoice/#sthash.xGql7Sn2.dpuf

Ol caros Leitores, Alunos e Internautas! Nesse artigo vamos passar alguns comandos sobre a
configurao do voice over ip (VoIP) disponveis no Packet Tracer 5.3. Esses comandos sero teis
para que est se preparando para o CCNA Voice (ICOMM verso 8.0).
Neste artigo vamos ver os seguites tpicos

Como configurar o Call Manager ExpressTM (CME) bsico em um roteador 2811,

Como utilizar os dispositivos de telefonia do packet tracer 5.3

Topologia de Rede

Vamos montar uma topologia bem bsica com apenas dois telefones IP para ficar mais simples,
porm voc pode expandir e colocar quantos telefones e roteadores desejar.
Uma dica sobre os telefones IP que eles no iro ligar sozinhos, pois os switches no tem PoE,
portanto voc vai ter que mover o cabo da fonte para o conector do telefone IP. Veja a figura 1 abaixo
com a dica de ligao da energia do telefone IP. Veja a figura abaixo.

Configurando a interface FastEthernet 0/0 e o DHCP


no RouterA (2811)
Vamos iniciar as configuraes, porm note que vamos mostrar o necessrio para fazer a parte de
telefonia funcionar e omitiremos comandos bsicos do CCNA.
RouterA>enable
RouterA#configure terminal
RouterA(config)#interface FastEthernet0/0
RouterA(config-if)#ip address 192.168.10.1 255.255.255.0
RouterA(config-if)#no shutdown
O prprio roteador servir nesse caso como servidor DHCP e para o CME preciso que voc
fornea o IP do servidor TFTP para que os telefones possam buscar seu firmware e arquivos de
configurao. Isso feito com a opo 150 do DHCP. Veja a configurao abaixo:
RouterA(config)#ip dhcp pool VOICE
RouterA(dhcp-config)#network 192.168.10.0 255.255.255.0
RouterA(dhcp-config)#default-router 192.168.10.1
RouterA(dhcp-config)#option 150 ip 192.168.10.1

Configurando o Call Manager Express (telephony


service no RouterA)
Agora vamos ativar o Call Manager Express (telephony service) no RouterA para habilitar o VoIP em
nossa rede.
RouterA(config)#telephony-service
RouterA(config-telephony)#max-dn 5
RouterA(config-telephony)#max-ephones 5
RouterA(config-telephony)#ip source-address 192.168.10.1 port 2000
RouterA(config-telephony)#auto assign 1 to 5
Os comandos bsicos e obrigatrios para configurar o CME esto dentro do modo de configurao
do telephony-service. O Max-dn define o nmero mximo de linhas que voc vai ter, j o max-

ephones define o mximo de telefones fsicos que voc vai ter. Cada modelo de roteador permite um
nmero mximo de telefones IP para o CME.
O comando ip source-address 192.168.10.1 port 2000 define que o roteador 192.168.10.1 ser o
responsvel pelo registro dos telefones atravs da porta 2000.
Por ltimo temos o auto-assign, comando que faz o registro automtico dos telefones e vincula os
DNs (directory numbers ou linhas) aos telefones fsicos, economizando comandos para criao dos
telefones fsicos (ephones). Na prtica quase no utilizamos essa tcnica e configuramos os
telefones IP inserindo os ephones manualmente, vinculando o MAC de cada telefone a um ramal
(DN).

Configurando a voice vlan no SwitchA


Como vamos utilizar apenas telefones no vamos ter duas VLANs separadas para voz e dados, por
isso vamos utilizar a VLAN 1 mesmo como VLAN de Voz. Esse comando utilizado para separar o
trfego de voz e dados, por isso se voc for utilizar computadores nas portas de switch do telefone IP
voc precisar criar 2 VLANs, onde o trfego de voz passado pela voice vlan e o de dados pela
vlan de acesso normal. Vamos configurar as portas de 1 a 5 para conectar telefones IP, veja abaixo:
SwitchA(config)#interface range fa0/1 5
SwitchA(config-if-range)#switchport mode access
SwitchA(config-if-range)#switchport voice vlan 1

Configurando 0 ramal do telefone (directory number


do IP Phone 1)
O ramal (extenso/extension/linha) chamado de nmero de diretrio (directory number ou DN).
Apesr dp IP Phone 1 estar conectado ao SwitchA e j estar com a VLAN de voz ele no vai subir
sozinho, pois precisamos configurar os ramais que esses telefones iro utilizar para serem capazes
de se comunicar entre si. Para isso precisamos ir no RouterA para definir os nmeros de telefon ou
DNs que iremos utilizar nos telefones IP. Isso feito com o comando ephone-dn 1 (nesse caso
devido ao max-dn e max-ephone estarem em 5 podemos ter de 1 a 5), conforme abaixo:
RouterA(config)#ephone-dn 1
RouterA(config-ephone-dn)#number 54001
Portanto o primeiro telefone que conectarmos ao switch ter o ramal 54001 configurado nele. Faa o
seguinte, ao montar a topologia lique apenas o telefone 1 e o 2 deixe desconectado, assim voc
garante que esse ramal estar no telefone 1. Depois que o telefone 1 estiver configurado voc pode
conectar o 2. Para verificar a configurao basta parar com o cursor do mouse encima do telefone. O
registro (processo do telefone pegar as configuraes e se registrar no roteador CME) pode demorar
um pouco.

Verificando a configurao
Agora vamos verificar a config fo IP Phone A e ver se ele recebe o IP e o nmero 54001 do RouterA
corretamente (lembre que pode demorar um pouco!).

Clicando na aba GUI voc tem uma viso grfica do telefone e poder fazer os testes, porm tudo
imaginrio, ou seja, no vai tocar nada apenas aparecer mensagens do tipo ringing, etc.

Configurando o DN para o IP Phone 2


Agora vamos inserir o ramal do IP Phone 2 e conect-lo ao SwitchA . O telefone IP 2 ter o ramal
54002, veja os comandos abaixo.
RouterA(config)#ephone-dn 2
RouterA(config-ephone-dn)#number 54002
- See more at: http://www.dltec.com.br/blog/cisco/telefonia-ip-basica-e-cme-com-packet-tracer-ccnavoice/#sthash.4cwli9Oq.dpuf

https://www.youtube.com/watch?v=8YcWe2UIQVE
https://www.youtube.com/watch?v=w9lGDvdQWdY
https://www.youtube.com/watch?v=iOfrGs7oGTU
https://www.youtube.com/watch?v=iOfrGs7oGTU

https://www.youtube.com/watch?v=2gq7cEi1nS8
https://www.youtube.com/watch?v=6aAol9w3OFY