Você está na página 1de 14

Laboratrio - Uso do CLI IOS com tabelas de endereos MAC do

switch
Topologia

Tabela de Endereamento
Dispositivo

Interface

Mscara de
Sub-Rede

Endereo IP

Gateway Padro

R1

G0/1

192.168.1.1

255.255.255.0

ND

S1

VLAN 1

192.168.1.11

255.255.255.0

192.168.1.1

S2

VLAN 1

192.168.1.12

255.255.255.0

192.168.1.1

PC-A

NIC

192.168.1.3

255.255.255.0

192.168.1.1

PC-B

NIC

192.168.1.2

255.255.255.0

192.168.1.1

Objetivos
Parte 1: Criar e configurar a rede

Instale os cabos da rede de acordo com o diagrama de topologia.

Configure os dispositivos de rede de acordo com a Tabela de Endereamento.

Parte 2: Examinar a tabela de endereos MAC do switch

Use os comandos show para observar o processo de criao da tabela de endereos MAC do switch.

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch

Histrico/cenrio
O objetivo de um switch LAN da camada 2 fornecer quadros Ethernet a dispositivos host na rede local.
O switch registra os endereos MAC dos host que esto visveis na rede e mapeia os endereos MAC para
suas prprias portas do switch Ethernet. Esse processo chamado de criao da tabela de endereos MAC.
Quando um switch recebe um quadro de um PC, examina os endereos MAC origem e destino do quadro.
O endereo MAC origem gravado e mapeado para a porta do switch em que chegou. O endereo MAC
destino procurado na tabela de endereos MAC. Se o endereo MAC destino for um endereo conhecido,
o quadro ser enviado para fora da porta do switch correspondente do endereo MAC. Se o endereo MAC
for desconhecido, o quadro ser enviado por broadcast em todas as portas do switch, exceto aquela na qual
chegou. importante observar e entender a funo de um switch e como ele realiza a entrega de dados na
rede. A maneira como um switch opera apresenta implicaes para os administradores de rede cujo trabalho
garantir comunicao confivel e consistente da rede.
Os switches so usados para interconectar e fornecer informaes aos computadores em redes de rea
local. Os switches fornecem quadros Ethernet a dispositivos host identificados por endereos MAC da placa
de rede.
Na parte 1, voc criar uma topologia com vrios switches e roteadores com um tronco que vincula os dois
switches. Na parte 2, voc efetuar ping em vrios dispositivos e observar como dois switches criam suas
tabelas de endereos MAC.
Observao: Os roteadores usados com laboratrios prticos CCNA so Roteadores de Servios Integrados
(ISRs) Cisco 1941 com a verso 15.2(4) M3 do IOS Cisco (imagem universalk9). Os switches usados so
Cisco Catalyst 2960s com a verso 15.0(2) (imagem lanbasek9) do IOS Cisco. Outros roteadores, switches
e verses do IOS Cisco podem ser usados. Dependendo do modelo e da verso do IOS Cisco, os comandos
disponveis e a sada produzida podem diferir do que consta nos laboratrios. Consulte a tabela Resumo da
Interface do Roteador no final deste laboratrio para obter os identificadores de interface corretos.
Observao: Certifique-se de que os roteadores e switches tenham sido apagados e que no haja
configuraes iniciais. Se estiver em dvida, entre em contato com seu instrutor.

Recursos necessrios

1 roteador (Cisco 1941 com a verso 15.2(4)M3 do IOS Cisco, imagem universal ou semelhante)

2 Switches (Cisco 2960 com a verso 15.0(2) do IOS Cisco, imagem lanbasek9 ou semelhante)

2 PCs (Windows 7, Vista ou XP com o programa de emulao de terminal, como o Tera Term)

Cabos de console para configurar os dispositivos IOS Cisco atravs das portas de console

Cabos ethernet conforme mostrado na topologia

Observao: As interfaces Fast Ethernet em switches Cisco 2960 possuem deteco automtica e um cabo
direto Ethernet pode ser usado entre os switches S1 e S2. Se estiver usando outro modelo de switch da
Cisco, pode ser necessrio usar um cabo cruzado para Ethernet.

Parte 1: Crie e configure a rede


Etapa 1: Instale os cabos da rede de acordo com a topologia.
Etapa 2: Configure os hosts do computador.
Etapa 3: Inicialize e reinicie os roteadores e os switches conforme necessrio.
Etapa 4: Defina as configuraes bsicas de cada switch.
a. Configure o nome do dispositivo conforme mostrado na topologia.

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch


b. Configure o endereo IP e o gateway padro conforme listado na Tabela de Endereamento.
c.

Atribua cisco como o console e senhas vty.

d. Atribua class como a senha do EXEC privilegiado.

Etapa 5: Defina as configuraes bsicas do roteador.


a. Desative a pesquisa do DNS.
b. Configure o endereo IP do roteador conforme listado na Tabela de Endereamento.
c.

Configure o nome do dispositivo conforme mostrado na topologia.

d. Atribua cisco como o console e senhas vty.


e. Atribua class como a senha do EXEC privilegiado.

Parte 2: Examine a tabela de endereo MAC do switch


Um switch aprende endereos MAC e cria a tabela de endereos MAC, visto que os dispositivos de rede
iniciam a comunicao na rede.

Etapa 1: Registre endereos MAC do dispositivo de rede.


a. Abra um prompt de comando no PC-A e no PC-B e digite ipconfig /all. Quais so os endereos fsicos
do adaptador Ethernet?
Endereo MAC do PC-A: _______________________________________________________________
Endereo MAC do PC-B: _______________________________________________________________
As respostas iro variar.
b. Use o console para se conectar ao roteador R1 e digite o comando show interface G0/1. Qual o
endereo de hardware?
Endereo MAC Gigabit Ethernet 0/1 do R1:
____________________________________________________
As respostas iro variar, mas na sada do exemplo abaixo, o endereo MAC G0/1 30f7.0da3.17c1.
R1# show interface G0/1
GigabitEthernet0/1 is up, line protocol is up
Hardware is CN Gigabit Ethernet, address is 30f7.0da3.17c1 (bia 30f7.0da3.17c1)
Internet address is 192.168.1.1/24
<output omitted>
R1#

c.

Use o console para se conectar ao switch S1 e S2 e digite o comando show interface F0/1 em cada
switch. Na segunda linha da sada do comando, o que so os endereos de hardware (ou burned-in
address [bia, endereo gravado na ROM])?
Endereo MAC Fast Ethernet 0/1 do S1: ___________________________________________________
Endereo MAC Fast Ethernet 0/1 do S2: ___________________________________________________
As respostas iro variar, mas na sada do exemplo abaixo, o endereo MAC F0/1 do S1
0cd9.96d2.3d81 e o endereo MAC F0/1 do S1 0cd9.96d2.4581.
S1# show interface f0/1
FastEthernet0/1 is up, line protocol is up (connected)
Hardware is Fast Ethernet, address is 0cd9.96d2.3d81 (bia 0cd9.96d2.3d81)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch


<output omitted>
S1#
S2# show interface f0/1
FastEthernet0/1 is up, line protocol is up (connected)
Hardware is Fast Ethernet, address is 0cd9.96d2.4581 (bia 0cd9.96d2.4581)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
<output omitted>
S2#

Etapa 2: Examine a tabela de endereo MAC do switch.


Use o console para se conectar ao switch S2 e visualize a tabela de endereos MAC, antes e depois de
executar os testes de comunicao de rede com ping.
a. Estabelea uma conexo de console para S2 e entre no modo EXEC privilegiado.
b. No modo EXEC privilegiado, digite o comando show mac address-table e pressione Enter.
S2# show mac address-table
Mesmo que no haja comunicao de rede iniciada pela rede (isto , nenhum uso do ping), possvel
que o switch tenha aprendido endereos MAC da conexo ao PC e ao outro switch.
Existe algum endereo MAC gravado na tabela de endereos MAC?
____________________________________________________________________________________
O switch pode ter um ou mais endereos MAC em sua tabela, com base em se os alunos inseriram ou
no um comando ping ao configurar a rede. O switch provavelmente ter aprendido os endereos MAC
atravs da porta do switch F0/1 de S1. O switch registrar vrios endereos MAC dos hosts aprendidos
atravs da conexo a outro switch em F0/1.
S2# show mac address-table
Mac Address Table
------------------------------------------Vlan
---All
All
All
All
All
All
All
All
All
All
All
All
All
All
All
All
All

Mac Address
----------0100.0ccc.cccc
0100.0ccc.cccd
0180.c200.0000
0180.c200.0001
0180.c200.0002
0180.c200.0003
0180.c200.0004
0180.c200.0005
0180.c200.0006
0180.c200.0007
0180.c200.0008
0180.c200.0009
0180.c200.000a
0180.c200.000b
0180.c200.000c
0180.c200.000d
0180.c200.000e

Type
-------STATIC
STATIC
STATIC
STATIC
STATIC
STATIC
STATIC
STATIC
STATIC
STATIC
STATIC
STATIC
STATIC
STATIC
STATIC
STATIC
STATIC

Ports
----CPU
CPU
CPU
CPU
CPU
CPU
CPU
CPU
CPU
CPU
CPU
CPU
CPU
CPU
CPU
CPU
CPU

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch


All
0180.c200.000f
STATIC
CPU
All
0180.c200.0010
STATIC
CPU
All
ffff.ffff.ffff
STATIC
CPU
1
0cd9.96d2.3d81
DYNAMIC
Fa0/1
1
1cc1.de91.c35d
DYNAMIC
Fa0/1
Total Mac Addresses for this criterion: 22
S2#

Quais endereos MAC esto registrados na tabela? Em que portas do switch esto mapeados e a que
dispositivos eles pertencem? Ignore os endereos MAC que esto mapeados para a CPU.
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
Pode haver vrios endereos MAC registrados na tabela de endereos MAC, especialmente endereos
MAC aprendidos atravs da porta do switch F0/1 de S1. Na sada do exemplo acima, o endereo MAC
F0/1 de S1 e o endereo MAC do PC-A so mapeados para S2 F0/1.
Se voc no tiver registrado anteriormente endereos MAC dos dispositivos de rede na etapa 1, como
poderia dizer a que dispositivos pertencem os endereos MAC, usando apenas a sada do comando
show mac address-table? Funciona em todos os cenrios?
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
A sada do comando show mac address-table mostra a porta em que o endereo MAC foi aprendido. Na
maioria dos casos, isso identificaria a que dispositivo de rede o endereo MAC pertence, exceto no caso de
vrios endereos MAC associados mesma porta. Isso acontece quando os switches so conectados
a outros switches e registram todos os endereos MAC dos dispositivos conectados a outro switch.

Etapa 3: Limpe a tabela de endereos MAC de S2 e exiba a tabela de endereos MAC novamente.
a. No modo EXEC privilegiado, digite o comando clear mac address-table dynamic e pressione Enter.
S2# clear mac address-table dynamic
b. Digite rapidamente o comando show mac address-table novamente. A tabela de endereos MAC
possui algum endereo para a VLAN 1? H outros endereos MAC listados?
___________________________________________________________________________________
No. O aluno provavelmente descobrir que o endereo MAC da porta do switch F0/1 de outro switch foi
reintroduzido rapidamente na tabela de endereos MAC.
S2# show mac address-table
Mac Address Table
------------------------------------------Vlan
---All
All
All
All

Mac Address
----------0100.0ccc.cccc
0100.0ccc.cccd
0180.c200.0000
0180.c200.0001

Type
-------STATIC
STATIC
STATIC
STATIC

Ports
----CPU
CPU
CPU
CPU

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch


All
0180.c200.0002
STATIC
CPU
All
0180.c200.0003
STATIC
CPU
All
0180.c200.0004
STATIC
CPU
All
0180.c200.0005
STATIC
CPU
All
0180.c200.0006
STATIC
CPU
All
0180.c200.0007
STATIC
CPU
All
0180.c200.0008
STATIC
CPU
All
0180.c200.0009
STATIC
CPU
All
0180.c200.000a
STATIC
CPU
All
0180.c200.000b
STATIC
CPU
All
0180.c200.000c
STATIC
CPU
All
0180.c200.000d
STATIC
CPU
All
0180.c200.000e
STATIC
CPU
All
0180.c200.000f
STATIC
CPU
All
0180.c200.0010
STATIC
CPU
All
ffff.ffff.ffff
STATIC
CPU
1
0cd9.96d2.3d81
DYNAMIC
Fa0/1
Total Mac Addresses for this criterion: 21
S2#

Aguarde 10 segundos, digite o comando show mac address-table e pressione Enter. H novos
endereos na tabela de endereos MAC? __________________ As respostas iro variar. Pode haver.

Etapa 4: No PC-B, efetue ping nos dispositivos na rede e observe a tabela de endereos MAC
do switch.
a. No PC-B, abra um prompt de comando e digite arp -a. No incluindo os endereos multicast ou de
broadcast, quantos pares de endereo IP para MAC do dispositivo foram aprendidos por ARP?
____________________________________________________________________________________
As respostas iro variar. O cache ARP pode no ter uma entrada nele, ou ter o endereo IP do gateway
para o mapeamento de endereo MAC.
C:\Users\PC-B> arp -a
Interface: 192.168.1.2 --- 0xb
Internet Address
Physical Address
192.168.1.1
30-f7-0d-a3-17-c1
C:\Users\PC-B>

Type
dynamic

b. No prompt de comando do PC-B, efetue ping no roteador/gateway R1, PC-A, S1 e S2. Todos os
dispositivos tiveram respostas com xito? Se no, verifique seu cabeamento e as configuraes de IP.
____________________________________________________________________________________
____________________________________________________________________________________
Se a rede foi cabeada e configurada corretamente, a resposta deve ser sim.
c.

Em uma conexo de console para S2, insira o comando show mac address-table. O switch adicionou
outros endereos MAC tabela de endereos MAC? Em caso afirmativo, que endereos e dispositivos?
____________________________________________________________________________________
____________________________________________________________________________________
Pode haver apenas um outro mapeamento de endereo MAC adicionado tabela, provavelmente
o endereo MAC do PC-A.

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch


S2# show mac address-table
Mac Address Table
------------------------------------------Vlan
Mac Address
Type
Ports
------------------------All
0100.0ccc.cccc
STATIC
CPU
All
0100.0ccc.cccd
STATIC
CPU
All
0180.c200.0000
STATIC
CPU
All
0180.c200.0001
STATIC
CPU
All
0180.c200.0002
STATIC
CPU
All
0180.c200.0003
STATIC
CPU
All
0180.c200.0004
STATIC
CPU
All
0180.c200.0005
STATIC
CPU
All
0180.c200.0006
STATIC
CPU
All
0180.c200.0007
STATIC
CPU
All
0180.c200.0008
STATIC
CPU
All
0180.c200.0009
STATIC
CPU
All
0180.c200.000a
STATIC
CPU
All
0180.c200.000b
STATIC
CPU
All
0180.c200.000c
STATIC
CPU
All
0180.c200.000d
STATIC
CPU
All
0180.c200.000e
STATIC
CPU
All
0180.c200.000f
STATIC
CPU
All
0180.c200.0010
STATIC
CPU
All
ffff.ffff.ffff
STATIC
CPU
1
0021.700c.050c
DYNAMIC
Fa0/18
1
0cd9.96d2.3d81
DYNAMIC
Fa0/1
1
0cd9.96d2.3dc0
DYNAMIC
Fa0/1
1
1cc1.de91.c35d
DYNAMIC
Fa0/1
1
30f7.0da3.17c1
DYNAMIC
Fa0/1
Total Mac Addresses for this criterion: 25
S2#

No PC-B, abra um prompt de comando e digite novamente arp -a. O cache ARP do PC-B tem entradas
adicionais para todos os dispositivos de rede que receberam pings?
____________________________________________________________________________________
As respostas podem variar, mas o cache ARP no PC-B deve ter mais entradas.
C:\Users\PC-B> arp -a
Interface: 192.168.1.2 --- 0xb
Internet Address
Physical Address
192.168.1.1
30-f7-0d-a3-17-c1
192.168.1.3
1c-c1-de-91-c3-5d
192.168.1.11
0c-d9-96-d2-3d-c0
192.168.1.12
0c-d9-96-d2-45-c0
C:\Users\PC-B>

Type
dynamic
dynamic
dynamic
dynamic

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch

Reflexo
Em redes Ethernet, os dados so fornecidos aos dispositivos por seus endereos MAC. Para que isso
acontea, os switches e os computadores criam dinamicamente caches ARP e tabelas de endereos MAC.
Com apenas alguns computadores na rede, este processo parece muito fcil. Quais seriam alguns dos
desafios em redes maiores?
_______________________________________________________________________________________
Os broadcasts ARP podem causar tempestades de broadcast. Como ARP e as tabelas MAC do switch no
autenticam nem validam os endereos IP para endereos MAC, seria fcil falsificar um dispositivo na rede.

Tabela Resumo da Interface do Roteador


Resumo da Interface do Roteador
Modelo do
Roteador

Interface Ethernet n1

Interface Ethernet n2

Interface Serial n 1

Interface serial N 2

1800

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

1900

Gigabit Ethernet 0/0


(G0/0)

Gigabit Ethernet 0/1


(G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2801

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

2811

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2900

Gigabit Ethernet 0/0


(G0/0)

Gigabit Ethernet 0/1


(G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

Observao: Para descobrir como o roteador est configurado, analise as interfaces para identificar o tipo de
roteador e quantas interfaces ele possui. No h como listar com eficcia todas as combinaes de
configuraes para cada classe de roteador. Esta tabela inclui identificadores para as possveis combinaes de
interfaces seriais e Ethernet no dispositivo. Essa tabela no inclui nenhum outro tipo de interface, embora um
roteador especfico possa conter algum. Um exemplo disso poderia ser uma interface ISDN BRI. A sequncia
entre parnteses a abreviatura vlida que pode ser usada nos comandos IOS Cisco para representar
a interface.

Configuraes do dispositivo
Roteador R1
R1#show running-config
Building configuration...
Current configuration : 1128 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch


boot-end-marker
!
!
!
no aaa new-model
!
no ipv6 cef
!
!
!
!
!
ip cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
Interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
Interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch


ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end

Switch S1
S1#show running-config
Building configuration...
Current configuration : 1355 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname S1
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch


!
!
no aaa new-model
system mtu routing 1500
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch


interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.11 255.255.255.0
!
ip default-gateway 192.168.1.1
ip http server
ip http secure-server
!
line con 0
line vty 0 4
password cisco
login
line vty 5 15
login
!
end

Switch S2
S2#show running-config
Building configuration...
Current configuration : 1355 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch


!
hostname S2
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
!
!
no aaa new-model
system mtu routing 1500
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12

Laboratrio - Uso do CLI IOS com Tabelas de Endereos MAC do Switch


!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.12 255.255.255.0
!
ip default-gateway 192.168.1.1
ip http server
ip http secure-server
!
line con 0
line vty 0 4
password cisco
login
line vty 5 15
login
!
end