Você está na página 1de 4

PLANEJAMENTO DE UMA UNIDADE DIDÁTICA

Robson Mendonça do Nascimento

1 ESTRUTURA GERAL DO PLANO DE ENSINO

O objetivo desta Unidade Didática é trabalhar dentro da disciplina de Algoritmos o conceito proposto no conteúdo programático:

Estruturas para controle de fluxo do algoritmo.

o Estruturas condicional e de repetição.

Em resumo são conceitos de decisão do algoritmo sobre o caminho a seguir para executar seu procedimento, dadas as variáveis, e o comando de repetição de um conjunto de códigos.

2 ESTRUTURAS PARA CONTROLE DE FLUXO DO ALGORITMO

Em algoritmos o computador executa linearmente um comando dado por códigos informados pelo programador. A execução linear pode ser alterada conforme a situação exigida, nesta unidade será explorado o conceito de estrutura condicional de um algoritmo.

2.1 ESTRUTURA CONDICIONAL

Como um programador, é necessário ter as ferramentas adequadas para resolver determinados problemas. Caso seja necessário implementar mais de um caminho para o mesmo sistema, ao invés de ficar escrevendo diversos tipos de algoritmos, é possível utilizar um comando condicional em seu código, aproveitando desta forma tudo o que ali está presente. Uma estrutura condicional é semelhante a uma bifurcação no caminho que podemos encontrar numa estrada. Conforme a necessidade do sistema, o algoritmo deverá seguir pelo caminho que execute o objetivo proposto. Sua estrutura é

se <condição> entao <ações a serem realizadas se a condição for verdadeira> senao <ações a serem realizadas se a condição for falsa> fimse

Agora vamos entender cada trecho do código:

se <condição> entao representa a linha inicial que ordena ao algoritmo

entrar numa condicional de execução. Nesse caso vamos validar alguma

variável para definir qual o caminho a ser seguido. Lembrando que

“entao” não pode ser acentuado.

<ações> representa qualquer conjunto de instruções que podem ser

inseridas nesse trecho. Sua variação vai de 1 linha ao número necessário

para executar a ação.

senao representa a linha que vai prosseguir com o código caso a

condição testada inicialmente for falsa. Lembrando que “senao” não pode

ser acentuado.

fimse é o aviso para o sistema sobre o término daquela estrutura

condicional.

se valor<=dinheiro entao compra <- produto senao Escreva ("Saldo insuficiente") fimse

No exemplo podemos entender que o sistema é de vendas. Se a variável

definida como valor for menor que a variável definida como dinheiro, ou seja, se o

produto for de valor menor ao saldo monetário do usuário, será efetuada a compra.

Caso o usuário não possua saldo monetário para a compra, o sistema vai informar

na tela "Saldo insuficiente" e a compra não é realizada.

Outra estrutura de condicionais é

escolha <variável> caso <valor> <ação> outrocaso <ação> fimescolha

Vamos agora entender os trechos deste código:

escolha <variável> é a primeira linha que testa a condição necessária

para execução do sistema. Analogamente podemos comparar com uma

chave que o sistema recebe, e somente 1 porta poderá ser aberta.

caso <valor> é o teste que se repetirá para ver qual o caminho o sistema seguirá, podemos dizer que é o teste das fechaduras com a chave recebida.

outrocaso é aquela última situação que sobra ao sistema quando não tem mais testes a fazer com o valor obtido. Este é o caso a ser analisado com exceção da regra proposta, sendo assim se nenhum caminho funcionar é preciso pensar em uma ação para o sistema executar.

<ação> representa um trecho de códigos que o programador pode inserir naquelas linhas.

fimescolha é o alerta para o sistema que a estrutura condicional chegou ao fim.

Aqui temos um teste logo no inicio, sendo que conforme a ação do usuário neste teste o sistema seguirá por um caminho específico. Seguindo um exemplo com o sistema de vendas, podemos ter

leia item escolha item caso 1 produto <- agua caso 2 produto <- cafe caso 3 produto <- cha caso 4 produto <- refrigerante outrocaso item <-null Escreva (“Produto não existe no sistema.”) fimescolha

No exemplo acima, o usuário escolhe seu produto digitando números através da linha leia item. Se o número digitado coincidir com determinado produto, será automaticamente acionado o trecho para aquela situação com as linhas caso, e assim o sistema vai efetuar a venda do produto selecionado. Caso não exista o produto o sistema entra na linha outrocaso e registrará um código nulo ao produto além de escrever na tela “Produto não existe no sistema.”. Como nas duas formas de se estruturar uma condição, pudemos ver que o sistema mesmo tendo 5 linhas para o primeiro exemplo e 14 linhas para o segundo, somente 3 ou 4 linhas serão executadas no primeiro exemplo, e para o segundo 8

ou 9 linhas a serem executadas. O sistema não ficará pesado e o programador pode reutilizar um mesmo código quantas vezes achar necessário, diminuindo seu tempo de elaboração do sistema.