Você está na página 1de 9

BGP Sample

ISPRouter1 Configuration
!
!
hostname "ISProuter1"
no enable password
!
ip subnet-zero
ip classless
ip routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 10.3.0.1 255.255.255.0
no shutdown
!
interface eth 0/2
ip address dhcp hostname "ProCurveSR7102dl"
shutdown
!
!
!
interface t1 1/1
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface t1 1/2
line-length 0
shutdown
!
interface t1 2/1
tdm-group 2 timeslots 1-24 speed 64
no shutdown
!
interface t1 2/2
clock source through
shutdown
!

interface bri 1/3


shutdown
!
interface modem 2/3
shutdown
!
interface ppp 1
ip address 10.1.0.1 255.255.255.0
no shutdown
bind 1 t1 1/1 1 ppp 1
!
interface ppp 2
ip address 10.4.0.1 255.255.255.0
no shutdown
bind 2 t1 2/1 2 ppp 2
!
!
!
router bgp 1
no auto-summary
no synchronization
network 10.1.0.0 mask 255.255.255.0
network 10.3.0.0 mask 255.255.255.0
network 10.4.0.0 mask 255.255.255.0
neighbor 10.1.0.3
no default-originate
soft-reconfiguration inbound
remote-as 3
neighbor 10.3.0.2
no default-originate
soft-reconfiguration inbound
remote-as 2
!
!
no ip tftp server
no ip http server
no ip http secure-server
no ip snmp agent
no ip ftp agent
!
!
!
!
!
!
!
line con 0
no login
!
line telnet 0 4
login
!
end

ISProuter2 Configuration
!
!
hostname "ISProuter2"
no enable password
!
ip subnet-zero
ip classless
ip routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 10.3.0.2 255.255.255.0
no shutdown
!
interface eth 0/2
no ip address
shutdown
!
!
!
interface t1 3/1
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface t1 3/2
shutdown
!
interface t1 3/3
shutdown
!
interface t1 3/4
shutdown
!
interface t1 3/5
shutdown
!
interface t1 3/6

shutdown
!
interface t1 3/7
shutdown
!
interface t1 3/8
shutdown
!
interface ppp 1
ip address 10.2.0.2 255.255.255.0
no shutdown
bind 1 t1 3/1 1 ppp 1
!
!
!
router bgp 2
no auto-summary
no synchronization
network 10.2.0.0 mask 255.255.255.0
network 10.3.0.0 mask 255.255.255.0
neighbor 10.2.0.3
no default-originate
soft-reconfiguration inbound
remote-as 3
neighbor 10.3.0.1
no default-originate
soft-reconfiguration inbound
remote-as 1
!
!
no ip tftp server
no ip http server
no ip http secure-server
no ip snmp agent
no ip ftp agent
!
!
!
!
!
!
!
line con 0
no login
!
line telnet 0 4
login
!
end

BGP3 Configuration
!
!
hostname "bgp3"
enable password pnb
!
ip subnet-zero
ip classless
ip routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
!
!
interface eth 0/1
ip address 10.1.1.0 /24
no shutdown
!
interface eth 0/2
no ip address
shutdown
!
!
!
interface t1 3/1
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface t1 3/2
tdm-group 2 timeslots 1-24 speed 64
no shutdown
!
interface t1 3/3
shutdown
!
interface t1 3/4
shutdown
!
interface t1 3/5
shutdown
!
interface t1 3/6
shutdown
!
interface t1 3/7
shutdown
!
interface t1 3/8
shutdown
!

interface ppp 1
ip address 10.1.0.3 255.255.255.0
no shutdown
bind 1 t1 3/1 1 ppp 1
!
interface ppp 2
ip address 10.2.0.3 255.255.255.0
no shutdown
bind 2 t1 3/2 2 ppp 2
!
!
router ospf
network 10.1.1.0 0.0.0.255 area 0
!
router bgp 3
no auto-summary
no synchronization
bgp router-id 10.1.0.3
neighbor 10.1.0.1
no default-originate
soft-reconfiguration inbound
remote-as 1
neighbor 10.2.0.2
no default-originate
soft-reconfiguration inbound
remote-as 2
!
!
no ip tftp server
no ip http server
no ip http secure-server
no ip snmp agent
no ip ftp agent
!
!
!
!
!
!
!
line con 0
no login
!
line telnet 0 4
login
password pnb
!
end

Customer2 Configuration
!
!
hostname "Customer2"
enable password pnb
!
ip subnet-zero
ip classless
ip routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
no ip address
shutdown
!
interface eth 0/2
no ip address
shutdown
!
!
!
interface t1 3/1
tdm-group 1 timeslots 1-24 speed 64
no shutdown
!
interface t1 3/2
shutdown
!
interface t1 3/3
shutdown
!
interface t1 3/4
shutdown
!
interface t1 3/5
shutdown
!
interface t1 3/6

shutdown
!
interface t1 3/7
shutdown
!
interface t1 3/8
shutdown
!
interface adsl 2/1
training-mode multi-mode
shutdown
!
interface ppp 1
ip address 10.4.0.2 255.255.255.252
no shutdown
bind 1 t1 3/1 1 ppp 1
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 10.4.0.1
!
no ip tftp server
no ip http server
no ip http secure-server
no ip snmp agent
no ip ftp agent
!
!
!
!
!
!
!
line con 0
no login
!
line telnet 0 4
login
password pnb
!
end

Você também pode gostar