Você está na página 1de 10

Capitulo 6 Roteamento IP

O que necessario para o router efetuar o roteamento:


- Endereo de destino.
- Routers vizinhos.
- Rotas possveis as redes remotas
- Melhor rota para cada rede remota
- Como manter e verificar informaes relativas ao roteamento.
O router j possui conhecimento sobre todas as redes que se encontram diretamente
conectadas. Caso a rede no se encontre diretamente conectada, ele deve descobrir o caminho
para alcana-la atravs de roteamento dinmico, esttico ou default.
O roteamento esttico o processo de criao de tabelas de rotas pelo administrador,
manualmente. J o roteamento dinmico utiliza protocolos de roteamento para se comunicar
com routers vizinhos e, automaticamente, gerar tal tabela.
Roteamento dinmico
Vantagens:
- Simplifica o gerenciamento da rede.
- vivel em redes de grande porte
Desvantagens:
- utiliza largura de banda nos links entre routers.
- Requer processamento pela CPU
- Menor controle da internetwork
O processo de roteamento dinmico utiliza protocolos para encontrar e atualizar tabelas
de roteamento de routers.
Um protocolo de roteamento define as regras a serem utilizadas por um router quando
este se comunica com routers vizinhos. Os quatro protocolos de roteamentos cobrados no exame
CCNA so: RIP, IGRP, OSPF e o EIGRP.
Os protocolos de roteamento utilizados em intenetworks pertecem a uma de duas
categorias: IGP, EGP. IGP so usados para troca de informaes entre routers pertencentes a um
mesmo Sistema Autonomo (AS), que uma coleo de redes sob um mesmo domnio
administrativo. J o protocolo EGP so utilizados para comunicao entre routers pertencentes a
ASs distintos.
Router(config)# interface e0/0
Router(config-if)# ip address 172.16.10.0(rede) 255.255.255.0(mascara) 172.16.10.1(endereo
do ponto que recebera o pacote e o enviara a rede destino.
Criando rota
Router(config)#ip route 172.16.10.0 255.255.255.0 172.16.10.2
Roteamento Default
Roteamento default usado no envio de pacotes para redes que no se encontrem na tabela de
roteamento. Porem usando-se roteamento default, podemos instruir o router que, emvez de
simplesmente descartar o pacote com destino desconhecido, o encaminhe para uma interface
especifica de sada( por exemplo, uma interface com sada para a internet ou conectada a um
router que talvez conhea a rota para aquele destino.
Ex: Router(config)# ip route 0.0.0.0 0.0.0.0 serial0/0.
Serial0/0 a interface do prximo roteador.
Distancia administrativa
Quando configurando protocolos de roteamento, deve-se atentar para um valor chamado
Distancia Administrativa (ADs), que so mtricas utilizadas para classificar a confiabilidade das
informaes roteadas recebidas por um router, vindas de um router vizinho. A Distancia

Administrativa representada por um numero inteiro compreendido entre 0 e 255, 0 sendo a


rota mais confivel e 255 significando que determina rota inalcanvel.
Quanto menor for o valor da AD, mais confiave ser a rota.
Existem trs classes quando falamos em protocolos de roteamento:
Distance Vector: Os protocolos classificados nessa categoria utilizam a distancia a rede remota
para definio do melhor caminho, o menor numero de saltos ate determinada rede remota
determina a melhor rota. EX: RIP e IGRP.
Link State: Tipicamente conhecidos como caminho mais curto antes cada router cria trs
diferentes tabelas. Uma dessas tabelas mantm informaes sobre redes diretamente conectadas,
outra determina a topologia de toda a rede e a ultima a tabela de roteamento. Ex: OSPF
Hybrid: Trata-se de protocolos de roteamento que possuem caractersticas de ambas as classes
anteriores. Ex: EIGRP.
Protocolos baseados no algritmo Distance Vector
Nesse caso, a distancia administrativa o primeiro fator a ser checado na determinao
da rota preferencial.
O RIP, por exemplo, utiliza apenas a contagem de saltos para determinao da melhor
rota para uma rede remota. Se o RIP deparar-se com mais de um link para a mesma rede remota
com a mesma contagem de saltos, ele distribuir alternadamente a carga entre links de igual
custo. O RIP pode realizar balanceamento de carga para at 6 links.
Entretanto um problema com esse tipo de mtrica aparece quando dois ou mais
caminhos para uma mesma rede remota possuem a mesma contagem de saltos, porm diferentes
larguras de banda.
Loops de Roteamento (Routing Loops)
Protocolos de roteamento distance vector mantem registros de todas as mudanas
ocorridas na rede atravs do broadcast peridico de atualizaes das tabelas de roteamento para
todas as interfaces ativas.
A lenta convergncia dos protocolos de roteamento distance vector pode causar
atualizaes inconsistentes nas tabelas de roteamento e loops podem vir a ocorrer. Loops de
roteamento podem ocorrer quando os routers existentes na rede so atualizados
simultaneamente.
Mecanismo Existentes para Minimizar a Ocorrencia de Loops
Maximum Hop Count: Uma maneira de se resolver esse problema definindo um numero
Maximo de saltos que um pacote de dados deve atravessar antes de ser descartado. Protocolos
distance vector como o RIP permitem uma contagem de saltos at 15.
Split Horizon: Esse mtodo reduz a transmisso de informaes incorretas pela rede, assim
como o overhead em redes baseadas em distance vector atravs da imposio da regra a
informao no pode ser enviada de volta na mesma direo em que foi recebida. Isso
preveniria o router A de enviar a atualizao de tabela de roteamento recebida do router B de
volta ao router B.
Route Poisoning: Ele envia uma atualizao chamada veneno reverso sw volta ao router E.
Isso assegura que todas as rotas no segmento tenham recebido a informao sobre a rota.
Holddowns: Eles previnem que uma mensagem regular de atualizao reative uma rota que, na
verdade, encontra-se inalcanvel por algum motivo. Tambm agem na preveno de mudanas
repentinas nas rotas, disponibilizando certo tempo para que uma rota que se encontre desativada
por algum motivo torne-se ativa ou para que a rede se estabilize antes de decidir pela melhor
rota. Tambm informam os routers para reter, por um perodo especifico de tempo quaisquer
mudanas que possam vir a afetar rotas recm-desativadas.
Trs so as ocasies em que triggered updates reiniciam o timer do holddowns
- O timer do holddown expira.
- O router recebe uma requisio de processamento proporcional ao numero de links na
internetwork
- Outra atualizao recebida indicando que a situao da rede foi alterada.

Caracteristicas do Protocolos RIP


- Envia a tabela de roteamento completa para todas as interfaces a cada 30 segundos.
- Utiliza apenas a contagem de hops como mtrica.
- Limita a contagem mxima de hops a 15, ou seja, no vivel em redes de grande porte ou
com muitos routers.
- O RIP verso 1 utiliza roteamento classful, ou seja, todos os dispositivos conectados a rede
devem estar sob a mesma mascara de rede.
Temporizadores do protocolo RIP (RIP TIMERS)
RIP utiliza quatro diferentes tipos de timers para regular sua performance:
ROUTE UPDATE TIMER (RUT): Estabelece um intervalo( geralmente 30 segundos) entre as
atualizaes regulares, nas quais os routers enviam uma copia completa de suas tabelas de
roteamento para todos os routers vizinhos.
ROUTE INVALID TIMER (RIT): Determina a quantidade de tempo que deve ocorrer
(normalmente 180 segundos) antes de um router determinar que uma rota tornou-se invalida.
ROUTE HOLDDOWN TIMER(RHT): Informa aos routers para reter, por um perodo
especifico de tempo (180 segundos, normalmente) quaisquer mudanas que possam via a afetar
rotas recm-desativadas. Isso previne rotas inoperantes de serem prematuramente restauradas
nas tabelas de outro routers.
ROUTE FLUSH TIMER (RFT): Estabelece o tempo (normalmente 240 segundos) entre uma
rota tornar-se invalida e sua remoo da tabela de roteamento.
Resumindo:
RUT=30
RIT = RUT x 6
RHT = RUT x 6
RFT = RUT x 8
Configurando RIP
Primeiramente devemos excluir as rotas estaticas estabelecidas antes (comando no ip
route) caso isso no seja feito, o router continuar aceitando a configurao de rotas
dinamicas, porm, como rotas estticas possuem uma distancia administrativa AD defaullt de 1
e o protocolo RIP possui uma AD 120, as rotas estatcas sero sempre preferidas pelo router.
Router(config)# no ip route 172.16.10.0 255.255.255.0 172.16.20.1
Router(config)# no ip route 172.16.50.0 255.255.255.0 172.16.40.2
Router(config)# router rip
Router(config-router)# network 172.16.0.0
Limitando a Propagao do RIP
Um exemplo de utilizao, que no h vantagens em anunciar sua rede RIP para a
Internet. Eis um exemplo de como utilizar o camando:
Router(config)# router rip
Router(config-router)#network 10.0.0.0
Router(config-router)#passive-interface serial 0
RIP Verso 2(RIPv2)
RIPv2 no muito diferente do RIPv1, no sentido de que continua sendo um protocolo
essencialmente distance vector e segue usando a contangem de saltos como metrica. O RIPv2
tambm envia sua tabela completa de roteamento periodicamente e, finalmente, os timers vistos
para RIPv1 valem tambm para o RIPv2.
RIPv1
RIPv2
Tipo
Distance-vector
Distance-vector
Mtrica
Contagem de saltos (Max 15) Contagem de saltos (Max 15)
Anuncios
Classful
Classless
VLSM
NO
SIM

Redes descontiguas
NO
Autenticao
NO
Propagao
Periodica (broadcast)
CIDR
NO
Para configurar RIPv2 em um router CISCO:
Router(config)# router rip
Router(config-router)# version2
Router(config-router)# network 10.0.0.0

SIM
SIM
Periodica (Multicast)
SIM

Verificao das configuraes RIP


Show running: apresenta toda a configurao presente no router, incluindo as configuraes do
protocolo RIP.
Show ip route: Apresenta a tabela de roteamento completa.
Show ip route rip: Apresenta apenas as rotas informadas pelo protocolo RIP.
Show ip rip database: Disponivel apenas quando o modo triggered encontra-se habilitado.
Caracteristicas do protocolo IGRP
- Proprietrio CISCO
- Contagem mxima de saltos = 255, com default em 100 (til em redes de grande porte)
- Utiliza largura de banda e atraso de linha como mtricas default
- Permite que outras mtricas como reability, load e MTU sejam utilizadas.
Temporizadores do protocolo (IGRP TIMERS)
O IGRP utiliza quatro diferentes tipos de timers para regular sua performance:
ROUTE UPDATE TIMER (RUT): Estabelece um intervalo( geralmente 90 segundos) entre as
atualizaes regulares, nas quais os routers enviam uma copia completa de suas tabelas de
roteamento para todos os routers vizinhos.
ROUTE INVALID TIMER (RIT): Determina a quantidade de tempo que deve ocorrer
(normalmente 270 segundos) antes de um router determinar que uma rota tornou-se invalida.
ROUTE HOLDDOWN TIMER(RHT): Informa aos routers para reter, por um perodo
especifico de tempo (280 segundos, normalmente) quaisquer mudanas que possam via a afetar
rotas recm-desativadas. Isso previne rotas inoperantes de serem prematuramente restauradas
nas tabelas de outro routers.
ROUTE FLUSH TIMER (RFT): Estabelece o tempo (normalmente 630 segundos) entre uma
rota tornar-se invalida e sua remoo da tabela de roteamento.
Resumindo:
RUT = 90
RIT = 270
HDT = 280
RFT = 630
Configurando IGRP
A configurao do IGRP em um router bastante semelhante a do RIP, com uma
importante diferena: voc precisa informar o numero do sistema autnomo (AS). Na ilustrao
a seguir, configuramos IGRP no router 2501B de nossa rede sugerida . Em seguida, utilizamos o
camando router igrp 10 para entrar no modo de configurao de roteamento (config-router),
onde 10 o numero do sistema autnomo. O comando network como no RIP, informa ao router
qual a rede a ser propagada. (172.16.0.0, no caso)
Router(config)# router igrp 10
Router(config)# network 172.16.0.0
Router# show ip route
A letra I indica que essa rota foi aprendida pelo protocolo IGRP, e os valores entre colchetes
indicam a distancia administrativa desse protocolo e a mtrica da rota em questo.

Balanceando Carga com IGRP


IGRP pode balancear a carga entre quatro links desiguais, utiliza largura de banda para
determinar como balancear a carga. No balanceamento de carga entre links desiguais, o
comando variance controla o balanceamento entre a melhor e a pior mtrica aceitvel.
Router(config)# router igrp 100
Router(config-router)#variance <1-128>
Router(config-router)# traffic-share (balanced ou min)
A sada anterior ilustra o comando variance, que o multiplicador de mtrica. A sada
do comando traffic-share nos apresenta duas opes: balanced e min. A opo balanced informa
o protocolo IGRP para compartilhar a carga de modo inversamente proporcional as mtricas,
enquanto a opo min informa o protocolo IGRP para utilizar no processo de balanceamento
apenas as rotas de menor custo.
Verificao das Configuraes IGRP
Comando: Route# show ip route
show protocols apresenta o endereo de rede configurados em cada interface.
Show ip protocols apresenta os protocolos de roteamento configurados em um router, os
valores dos timers utilizados pelos protocolos roteadores configurados, ASs, redes sendo
propagadas, gateways e ADs.
Debug ip rip envia as atualizaes propagadas e recebidas pelo router ao console, essa uma
grande ferramenta para identificao de problemas.
Debug ip igrp events apresenta um resumo das informaes de roteamento IGRP que esto
sendo propagadas pela rede. Dados como origem e destino de cada atualizao, assim como o
numero de routers em cada uma so apresentadas. Informaes sobre rotas individuais no so
apresentadas por esse comando.
Debug ip igrp transactions apresenta requisies de atualizaes feitas por routers vizinhos e
as atualizaes enviadas pelo router para esses routers.
Protocolo OSPF
um protocolo independente de fabricantes e no-proprietrio assim como o RIP. Os
protocolos IGRP e EIGRP por exemplo so proprietrios CISCO. A principal vantagem que os
clculos realizados pelo algoritmo levam em conta a largura de banda na procura pela melhor
rota, diferentemente dos protocolos distance vector.
Esse protocolo j foi criado tendo-se em vista redes de grande porte. Ele no trabalha
com propagao via broadcast, mas via multicast, ou seja apenas routers que estejam rodando
esse protocolo recebero as atualizaes necessrias.
O protocolo OSPF permite a hierarquizao de um rede atravs da sua diviso em
diversas reas.
Alguns conceitos:
- A rea zero sempre deve existir em redes com mais de uma rea. Essa rea em uma rede OSPF,
conhecida como backbone rea.
- Todas as outras reas devem se conectar a rea zero. Essa regra deve sempre ser obedecida, ou
a rede OSPF no funcionara a contento.
- Para interconectar uma rea que no esta diretamente conecta a rea zero deve-se usar o
artifcio dos virtual links.
- Como os routers pertencentes a rea zero normalmente tero um processamento mais elevado,
por isso devem ser escolhidos routers que tenham porte e capacidades adequadas.
Comparao entre protocolos RIP, IGRP e OSPF.
Caracteristicas
RIP
RIPv2
IGRP
OSPF
Tipo de
Distance Vector Distance Vector Distance Vector
Link State
protocolo
Suporte a
NO
SIM
NO
SIM
VLSM

(Classless
routing)
Auto
summarization
Manual
Summarization
Suporte as redes
descontiguas
Tipo de
propagao
Mtrica utilizada
Limite de saltos
Convergencia
Suporte a
autenticao
Suporte a
hierarquizao
Tipo de
atualizao
Algoritmo
adotado

SIM

SIM

SIM

NO

NO

SIM

NO

SIM

NO

SIM

NO

SIM

Broadcast

Multicast

Broadcast

Multicast

Saltos
15
Lenta
NO

Saltos
15
Lenta
SIM

Composta
255
lenta
NO

Largura de banda
N/A
Rapida
SIM

NO

NO

NO

SIM

Updates
peridicos
Bellman-Ford

Updates
peridicos
Bellman-Ford

Updates
peridicos
Proprietario

Event Triggered
SPF

Designated Router/Backup Designated Router


O protocolo OSPF, quando operando em redes multiacesso (como redes Ethernet),
utiliza o artifcio de eleger um router como DR e outro como Backup DR(BDR).
O router com a maior prioridade eleito DR para seu segmento e o com a segunda
maior prioridade BDR. Se os valores de prioridade nos routers, no entanto, forem os default 1
ou iguais, o router ID de cada um usado para o desempate. Lembrando que o RID
basicamente, o maior valor IP configurado no router ou o IP de uma interface loopback.
O comando para configurar a prioridade OSPF em uma interface:
Router(config)#int f0/0
Router(config-if)# ip ospf priority 2
Formao da Arvore SPF
Dentro de uma rea, cada router calcula o melhor(mais curto) caminho para todas as
redes pertencentes a mesma rea. Esse calculo baseado nas informaes coletadas na base de
dados topolgicas e um algoritmo chamado SPF.
Imagine cada router em uma rea construindo uma arvore - como uma arvore
genealgica onde o router a raiz e todas as outras redes so arranjadas nos galhos
remanescentes. Essa seria a arvore SPF usada pelo router para insero de rotas na tabela de
roteamento.
importante frisar que essa arvore contem apenas redes contidas na mesma rea na qual
o router se encontra. Se um router pertence a mltiplas reas, ento mltiplas arvores sero
formadas, uma para cada rea.
A mtrica usada pelo protocolo OSPF o custo. Um custo associada a cada interface
de sada includa em uma arvore SPF. O custo total de um dado caminho a soma dos custos
das interfaces de sada, conforme o caminho evolui.
Configurao do protocolo OSPF
Comando para ativar o protocolo OSPF:
Router(config)#router ospf < 1 65535>

O valor compreendido entre < 1 65535> identifica o processo OSPF que ser ativado
no router em questo. O interessante aqui notar que o valor de processo, e nada tem a ver
com sistema autnomo como o caso do IGRP.
Seguindo em nosso exerccio de configurao, vamos a prxima etapa
Router(config)# router ospf 64
Router(config-router)# network 192.168.10.0 0.0.0.255 area < 0 4294967295>
importante frisar que a combinao do endereo de rede e do wilcard mask identifica
a interface na qual o processo OSPF estar operando e tambm ser includo nos updates LSA,
ou seja, o protocolo OSPF, ativado por interface e no no router todo.
Verificando a Configurao OSPF
Router# show ip route mostra redes identificadas pelo protocolo OSPF isso pode ser
evidenciado tanto pela letra O que precede as rotas quanto pela distancia administrativa de
110 de cada uma delas.
Router# show ip ospf
Router# show ip ospf data A sada desse comando mostra o link ID (lembre-se que uma
interface tambm um link, quando falamos de OSPF), o RID do router e o processo OSPF
ativo nele.
Router# show ip protocols Esse comando til independentemente de qual protocolo voc
esteja utilizando, ele proce um resumo das operaes e status dos protocolos ativos no router.
Router# show ip ospf interface Apresenta Endereo IP da interface, rea OSPF a qual ela
pertence, ID do processo OSPF, Router ID(RID), Tipo de rede ( point-to-point, point-tomultipoint), custo, prioridade, Informao sobre DR/BDR, se aplicvel, valores dos timers
HELLOe DEAD, informaes sobre adjacncias.
Router# show ip neighbor
Uso de interfaces Loopback em redes OSPF
A loopback uma interface virtual, existente apenas no software do router e, por ser
virtual ela nunca esta down. O objetivo de configurar uma interface loopback quando se esta
usando OSPF exatamente forar o router a adotar como RID o IP dessa interface e, como ela
nunca vai estar down, o router nunca ira trocar seu router ID.
Router(config)# interface loopback0
Router(config-if)# ip address 1.1.1.1 255.255.255.255
Portanto, a partir deste momento, o RID deste router passa a ser 1.1.1.1 (endereo de
interface loopback0)
Identificando problemas em Redes OSPF
Se voc notar problemas aps configurar seus routers, observe se:
- Os timers do OSPF (hello e dead) esto consistentes atravs da rede (os default so 10 e 40,
respectivamente);
- Existem outros protocolos configurados? Lempre-se de que IGRP, por exemplo, tem uma
distancia administrativa de 100, enquanto a do OSPF 110.
- Existe consistncia nas reas configuradas.
- Os parmetros do comando network foram corretamente inseridos, lembrando sempre que
devemos usar o wildcard mask, e no o formato padro de mascaras, com OSPF.
Protocolos Hibridos Oprotocolo EIGRP da CISCO
O EIGRP um protocolo do tipo classless, com algumas caracterisitcas tanto de
distance vector como de link state, por isso hibrido. O EIGRP como o prprio nome sugere
uma verso tonificada do protocolo que j estudamos o IGRP. O EIGRP usa o conceito de
sistema autnomo para descrever um frupo de routers que rodam um memo tipo de protocolo de
roteamento, compartilhando informaes de roteamento. Entretanto capaz de lidar com
mascaras de rede, tornando possvel a ele a adoo de praticas como VLSM, CIDR e
sumarizao de rotas. O EIGRP tambm oferece suporte a autenticao, aumentando a
segurana da rede.

Vantagens em se adotar o EIGRP:


- Suporta mltiplos protocolos de camada 3 (IP, IPX), enquanto o OSPF suporta apenas IP.
- um protocolo classless, portanto suporta VLSM e CIDR
- Suporta sumarizao e redes no-contiguas
- eficiente em sua operao, sendo sua convergncia substancialmente mais rpida que a de
outros protocolos
- Utiliza o algoritmo DUAL que inibe a formao de loops e bastant eficiente.
O Processo de descoberta dos Routers Vizinhos
Antes de routers rodando EIGRP poder trocar informaes de roteamento com outro,
eles devem tornar-se vizinhos. Existem basicamente trs condies para que esse relao ocorra:
- Pacotes hello ou ACK so recebidos.
- Ambos os routers encontram-se dentro do mesmo sistema autnomo (as)
- Ambos possuem os parmetros usados para calculo de mtricas(K values) idnticos.
Reliable Transport Protocol (RTP)
O EIGRP usa um protocolo proprietrio, chamado RTP, para gerenciar o fluxo de
informaes entre routers EIGRP. Como o prprio nome sugere, trata-se de um protocolo que
garante a integridade dessas informaes.
Quando O EIGRP envia trafego multicast, ele usa o endereo de classe D 224.0.0.10.
Como j mencionado, cada router EIGRP sabe quem so seus vizinhos e a cada multicast
enviado, uma lista com os vizinhos ativos mantida. Se aps um multicast um vizinho no
responde, o EIGRP alternar para unicast e continuara tentando obter uma resposta daquele
vizinho especifico. Se aps 16 tentativas unicast ainda no houver resposta, o vizinho tido
como dead.
Diffusing Update Algorithm (DUAL)
O EIGRP usa o algoritmo DUAL para selecionar e manter em sua tabela de roteamento
a melhor rota para uma rede remota. As principais funes desse algoritmo so:
- Determinao de uma rota alternativa, se cabvel.
- Suporte a VLSM e CIDR.
- Identificao dinemica de rotas.
- Procura identificar uma rota alternativa, caso nenhuma seja encontrada.
Os pontos chaves para a velocidade de convergncia so dois:
- Mantem uma copia de todas as rotas conhecidas por routers vizinhos, que so usadas para o
calculo do melhor custo para cada uma das redes remotas.
- Seno houver uma rota alternativa na tabela topolgica local, o router EIGRP contatar seus
vizinhos perguntando se algum deles possui uma rota alternativa para a rede em questo.
Conceito de Redes Descontiguas
O EIGRP, assim como o RIPv2, oferece suporte a redes descontiguas, ou seja, duas ou
mais sub-redes de uma rede classful conectadas entre si atravs de uma rede classful diferente.
bastante importante entender que redes descontiguas no podem funcionar com os
protocolos RIPv1 ou IGRP, j que estes apenas suportam classful para os protocolos RIPv2 e
EIGRP suportem esses redes preciso desativar o recurso de auto-sumarizao que encontra-se
habilitado em ambos por default.
Mtricas EIGRP
As mtricas do EIGRP so praticamente as mesmas do IGRP
Simbolo
Valor
K1
Bandwitch
K2
Load
K3
Delay
K4
Reliability
K5
MTU

Os valores dos Ks devem ser consistentes na rede inteira ou o protocolo no ir


sincronizar.
Assim como o IGRP, o EIGRP tambm pode prover balanceamento de carga em at
quatro links com mtricas diferentes entretanto, possvel alcanar um balanceamento de carga
com at seis links usando-se o comando maximum-paths:
Router(config)# router eigrp 10
Router(config-router)# maximum-paths 6
Configurao EIGRP
Exemplo de configurao do EIGRP em dois Routers sabendo-se que ambos tem
sistema autnomo de numero 100.
RouterA(config)#router eigrp 100
RouterA(config-router)#network 172.16.0.0
RouterA(config-router)#network 10.0.0.0
Para que as atualizaes EIGRP no sejam transmitidas pela interface f0/0 por exemplo
RouterA(config-router)#passive-interface f0/0
Para desativar o recurso de auto-sumarizao do EIGRP.
RouterA(config-router)#no auto-summary
Verificao do EIGRP
Router# show ip route As rotas trazidas pelo EIGRP so prefixadas pela letra D de DUAL e
traz tambm o valor da distancia adminitrativa 90.
Router# show ip eigrp neighbor Esse comando traz as seguintes informaes.
- Holdtime Indica o tempo que esse router ira aguardar por um pacote hello do vizinho
especificado.
- Uptime Indica a quanto tempo a adjacncia foi estabelecida.
- SRTT Indica quanto tempo leva para alcanar o vizinho em questo e retornar.
- RTO Tempo que o protocolo aguarda antes de retransmitir um pacote da fila de
retransmisso para o vizinho em questo.
- Q Indica se existem mensagens excepcionais na fila de transmisso. Numeros altos aqui
podem indicar um problema.
- Seq Indica o numero de sequencia do ultimo update do vizinho em questo. Usado para
manter a sincronizao e evitar duplicidade de informao ou pacotes fora de sequencia.
Router#show ip eigrp topology O estado de ative-state indica que a rota em questo no se
encontra mais na tabela de roteamento. Quando a rota encontra-se em estado passive-state (P)
tudo esta normal e ela encontra-se inserida natabela de roteamento.
Traduzindo Endereos com NAT
Alm de permitir o acesso a redes publicas, o NAT tambm aumenta a segurana da
rede privada, uma vez que mascara da internet os endereos IP internos.
Existem basicamente trs tipos de NAT:
- NAT esttico: Prove o mapeamento de um para um, ou seja, para cada endereo IP privado,
existe um endereo IP valido para sada para a internet.
-NAT dinmico: Prov um mapeamento de endereos no validos para validos, porem , sem a
necessidade de possuirmos em endeeo valido para cada endereo invalido. Nesse caso
trabalha-se com um intervalo de endereos validos pool, que alocado conforme necessidade.
- Overloading: Essa modalidade de NAT permite que poucos ou at mesmo apenas um endereo
valido seja usado para todas as maquinas com endereos invlidos.
Eis um exemplo de configurao, vamos adotar o overloading ate mesmo por essa ser a
mais comumente usada.
Router(config)# int f0/0
Router(config-if)# ip nat inside
Router(config-if)# int s0/0
Router(config-if)# ip nat outside
Router(config-if)# exit

Router(config)# Access-list 10 permit 172.16.0.0 0.0.255.255


Router(config)# ip nat pool internet 200.124.231.1 200.124.231.1 prefix 24
Router(config)# ip nat inside source list 10 pool internet overload.
A CISCO define quatro tipos de endereos IPs quando o assunto NAT.
Inside local address: O endereo IP associado a um host dentro da rede local (inside). Esse
endereo, provavelmente, no um endereo IP valido para roteamento na internet ex:
172.16.10.1.
Inside Global address: Um endereo IP valido para roteamento na internet que representa um ou
mais IPs internos a rede para o mundo externo.
Outside local address: Endereo IP de um host externo a rede organizao, do modo como ele
percebido localmente, pelas maquinas da rede local.
Outside Global address: Qualquer endereo IP externo a organizao, do modo como ele
percebido pela internet. Basicamente, local usado para definio do ponto de vista interno a
rede local, enquanto global usado para definir o ponto de vista externo a rede local.
Local address: Qualquer endereo IP que interno a rede local estando, portanto, sujeito a
traduo.
Global address: Qualquer endereo IP externo a rede local.
Sumarizao de Rotas Usando EIGRP e OSPF
o mesmo conceito de sumarizao, a configurao segue os comandos abaixo.
EIGRP
Router(config)# router eigrp 10
Router(config-router)# netowk 192.168.10.0
Router(config-router)# network 10.0.0.0
Router(config-router)# no auto-summary
Router(config-router)# interface fastethernet 0/0
Router(config-if)# ip summary-address eigrp 10 192.168.10.64 255.255.255.224
OSPF
Router(config)# router ospf 1
Router(config-router)# netowk 192.168.10.64 0.0.0.3 area 1
Router(config-router)# network 192.168.10.68 0.0.0.3 area 1
Router(config-router)# network 10.10.10.0 0.0.0.255 area 0
Router(config-router)# rea 1 range 192.168.10.64 255.255.255.248
Observe que para o protocolo OSPF, o comando no auto-summary no requerido, j
que ele no realiza sumarizao por default como faz o EIGRP.
Sumarizao de rota usando RIPv2
Para sumarizao manual usndo o protocolo RIPv2, basta usar o comando ip summaryaddress rip.
Router(config)# int Ethernet0
Router(config-if)# ip address 10.1.1.1 255.255.255.0
Router(config-if)# ip summary-address rip 10.2.0.0 255.255.0.0
Assim como no EIGRP, rotas manualmente sumarizadas tero prioridade sobre rotas
automaticamente sumarizadas.