Você está na página 1de 6

UNICARIOCA

Atividade
Supervisionada
Algoritmos I

Nome: Brenda Assuno de Oliveira Matrcula: 2015200265


Nome: Juliana de Souza Ferreira Berdeville Matrcula: 2015201168
Turma: 841

Questo 1:
VARIVEIS:
Inteiro: n,cont,resto,i
INCIO
cont0, i0
Ler n
Se(n>1) ento
Enquanto (i<=(n-1)) faa
reston mod (n-i)
Se (resto=0) ento
contcont+1
Fim_Se

{ i o valor que ser subtrado do numero digitado.


Esse numero sofrer a subtrao at i ser igual ao seu
antecessor. O objetivo saber os restos das divises
desse numero por todos os nmeros possveis (de 1
at ele mesmo)}

ii+1
Fim_Enquanto
Se (cont=2) ento
Escreva "O nmero primo"
Seno
Escreva "O nmero no primo
Fim_Se

{Se de todas as divises possveis, s duas apresentarem resto 0 porque


esse nmero s divisvel por 1 e por ele mesmo. Portanto, se trata de um
numero primo}

Seno
Escreva "O nmero no primo
Fim_Se
FIM

Questo 2:
VARIVEIS:
Inteiro: n,notas,caixa
INCIO
n0, caixa1000
Enquanto(n>=0) faa
Escreva n

{O mod utilizado para descobrir se o valor mltiplo de 10.}

Se n mod 10=0 ento


Notasn/10
Se (caixa >= notas) ento
Caixacaixa-notas
Escreva "Voc sacou: ",notas," notas de 10 reais"
Seno
Escreva "O valor no pode ser fornecido por falta de notas"
Fim_Se
Seno
Se (n<0) ento
Escreva "Fim"
Seno
Escreva "O caixa s possui notas de 10"
Fim_Se
Fim_Se
Fim_Enquanto
FIM

{Se o valor solicitado no for divisvel por 10, ele pode estar querendo
finalizar o processo, ao digitar um nmero negativo, ou simplesmente quer
um valor que no mltiplo de 10.}

Questo 3:
VARIVEIS:
Inteiro: cont,n1,n2,n3,termos
INCIO
cont2, n11, n21, n30
Ler termos
Se (termos>=10) ento
Escreva n1
Escreva n2

{a sequencia iniciada com os dois primeiros termos.}

Enquanto (cont<termos) faa


n3n1+n2
Escreva n3
n1n2
n2n3

{ a sequencia vai recebendo o termo seguinte (n3)


atravs da soma dos dois termos anteriores at
chegar ao nmero de termos desejado }

contcont+1
Fim_Enquanto
Seno
Escreva "A sequencia deve ter 10 termos ou mais "
Fim_Se
FIM

Questo 4:
VARIVEIS:
Inteiro: num, cont, fat
Real: result1, result2, result3
INCIO
num1, cont0, result11.0, result20, result30
Enquanto (num<=4) faa
fatnum
Enquanto (cont<num) faa
fatfat*(num-cont)
contcont+1
Fim_Enquanto
Se (num<=2) ento
result1 result1+(1.0/fat)
Fim_Se
Se (num=3) ento
result2 result1+(1.0/fat)
Fim_Se
Se (num=4) ento
result3 result2+(1.0/fat)
Fim_Se
cont1
numnum+1
Fim_Enquanto
Escreva "A soma dos 3 primeiros termos e: ", result1
Escreva "A soma dos 4 primeiros termos e: ", result2
Escreva "A soma dos 5 primeiros termos e: ", result3
FIM

{num representa a quantidade de termos que


possuem fatorial, so um total de 5 termos sendo que
4 possuem calculo com fatorial }
{cont o valor que d origem aos nmeros seguintes de um fatorial iniciado por n}
{fat o fatorial de num , esse calculo finalizado quando o termo a ser multiplicado
(num-cont) for igual a 1}
{aqui realiza a soma dos 3 primeiros termos}

{aqui realiza a soma dos 4 primeiros termos}

{aqui realiza a soma dos 5 termos}

{cont retorna a 1 para incrementar o prximo fatorial}

Questo 5:
VARIVEIS:
Inteiro: x,termo
Long: y=1
INCIO
termo1, y1
Ler x
Enquanto (termo<=12) faa
Yy*termo*x
Termotermo+1
Fim_Enquanto
Escreva "O valor da expresso : ",y
FIM

Questo 6:
VARIVEIS:
Inteiro: x, d
Real: s,n
INCIO
x0, d1, s0, n1000.0
Repita
ss+(n/d)
nn-3
dd+1

{n comea com valor 1000.0 (a casa decimal


necessria por se tratar de um nmero real) e
decrescido de 3 em 3 ao passo que d comea com 1e
acrescido at que o contador x receba valor igual a
31 nesse nterim, o somador j calculou a soma de
todos os 30 termos.}

xx+1
At x=31
Escreva "O valor da serie e: ",s
FIM

Questo 7:
VARIVEIS:
Inteiro: anos
Real: HBi, HBe
INCIO
anos1, HBi0, HBe0
Repita
HBe(anos*0.03)+1.05
HBi(anos*0.02)+1.30

{HBe e HBi representam as alturas de Beatriz e Bianca


respectivamente, e ambas as equaes recebem o
numero de anos e os cm que elas crescem por ano.
Esse valor multiplicado e somado a altura atual das
meninas}

anosanos+1
At (HBe > HBi)

Escreva ("Sao necessrios ",anos," anos para que Beatriz seja mais alta que Bianca")
FIM

Questo 8:
VARIVEIS:
Inteiro: n,t,x
INCIO
x0
Ler n
{Cada linha da tabuada (t) recebe o contador (x)
Enquanto (n>0) faa
multiplicado por n at que o x assuma valor igual a n.
Repita
Esse ser o fim da tabuada (n x n)}
xx+1
tx*n
{Cada linha da tabuada (t) impressa at x=n}
Escreva x," X ",n," = ",t
At (x=n)
{depois de finalizada a tabuada o contador x
zerado e a varivel n solicitada novamente para dar
inicio a nova tabuada}

x0
Ler n
Fim_Enquanto
FIM

Questo 9:
{como o mostrador do relgio deve ser mostrado na
forma 00:00:00, foi feita 2 variveis para cada termo
VARIVEIS:
(horas, minutos, segundos)}
Inteiro: h1,h2,m1,m2,s1,s2
INCIO
h10, h20, m10, m20, s10, s20
{O fim da cronometragem ser quando o mostrador
Enquanto ( (h1<2) ou (h2<4) ou (m1<5) ou (m2<9) ou (s1<5) ou (s2<=9) ) faa
estiver em 24:59:59. Portanto as operaes devem

Se (s2>9) ento
s20
s1s1+1
Fim_Se
Se (s1>5) ento
s10
m2m2+1
Fim_Se

ser feitas enquanto o cronometro no chega a esses


valores}
{A unidade dos segundos (s2) deve ir at
9, ao passar de 9 ela zerada e acrescido
1 dezena dos segundos (s1) que por sua
vez dever ir at 5. O mesmo processo
ocorre para as demais variveis}

Se (m2>9) ento
m20
m1m1+1
Fim_Se
Se (m1>5) ento
m10
h2h2+1
Fim_Se
Se (h2>9) ento
h20
h1h1+1
Fim_Se
Escreva h1,h2,":",m1,m2,":",s1,s2
s2s2+1

{O cronmetro incrementado atravs da unidade de segundo (s2).


Atravs dela as demais variveis vo sendo incrementadas }

Fim_Enquanto
h10, h20, m10, m20, s10, s20
Escreva h1,h2,":",m1,m2,":",s1,s2
FIM

{Ao finalizar loop at 24:59:59, acrescida a linha final onde o


cronometro zerado }

Questo 10:
VARIVEIS:
Char: nome,nomef,fabricomp1
Inteiro: armazenamento, d, menor, x
INCIO
fabricomp1"", d0, x1
Ler nome
Ler nomef
Ler armazenamento

{ d o contador para o n de computadores da fabricante Dell}

Enquanto (nome<>"fim") faa


Se (nomef="dell") ento
dd+1
Fim_Se
Se (armazenamento<menor) ou (x=1) ento
menorarmazenamento
Fim_Se
Se (nome="comp/1") ento
fabricomp1nomef
Fim_Se
Ler nome
Ler nomef
Ler armazenamento
xx+1
Fim_Enquanto
Escreva "a menor capacidade de memoria e: ",menor
Escreva "a dell fabrica: ",d," computadores"
Escreva "o fabricante de comp/1 e: ",fabricomp1
FIM

{Se o armazenamento informado for menor que a varivel menor


ou se for o primeiro valor para armazenamento, ento a varivel
menor receber o valor do armazenamento. Este valor ser um
parmetro de comparao para o prximo armazenamento a ser
informado.}