Você está na página 1de 11

1) Escreva um algoritmo em PORTUGOl que leia um numero e 0 imprima caso

ele seja maior que 20.

AlGORITMO PASCAL
Algoritmo numero Program nurnero;
Declare num inteiro uses ert;
leia (num) var num:integer;
Se (num>20) begin
Entao esereva ('numero e: '. num) elrser;·
Fim-se writeln ('Oigite urn numero:');
Fim-algoritmo readln (num);
if (num>20)then writeln ('0 numero e:' .num);
readkey;
end.

2) Construa um algorimto em PORTUGOl que leia dois valores numericos inteiros


e efetue a adi~o; easo 0 resultado seja maior que 10. apresenta-Io.

AlGORITMO PASCAL
Algoritmo numero Program numero;
Declare n1, n2. n3 inteiro uses crt;
leia (n1) var n1 .n2.n3:integer;
leia (n2) begin
N3 <- n1+n2 elrser;
Se (n3>10) write'n ('Digite um numero:');
Entao esereva ('numero e:". n3) readln (n1);
Fim-se writeln ('Digite oulro numero:');
Fim-algorilmo readln (n2);
n3:= n1+n2;
if (n3>10)then writeln ('0 numero e:\n3:4:2);
readkey;
end.
3) Construa um algoritmo em PORTUGOl que determine (imprima) se um dado
numero N inteiro (recebido atraves do tectado) e PAR ou iMPAR.

AlGORITMO PASCAL
Algoritmo numero Program numero;
Declare num inteiro uses crt;
leia (num) var num:integer;
Sa (num mod 2=0) begin
Entao escreva ('numero e par) clrscr;
Fim-se writeln ('Digite um numero:');
Senao se (num mod 2 <>O) readln (num);
EntaQ escreva ('0 numero e imparl =
if (num mod 2 O) then writeln ('0 numero
Fim-se e par)
Fim-algoritmo else if (nurn mod 2 <> 0) then writeln ('0
numero e imparl;
readkey;
end.

4) Escreva um algoritmo em PORTUGOl para determinar se um dado numero N


(recebido atraves do teclado) e POSITIVO, NEGATIVO ou NUlO.

AlGORITMO PASCAL
Algoritmo numero Program numero;
Declare num inteiro uses crt;
leia (nurn) var num:integer;
Se(num>O) begin
Entaoescreva ('numero e positivo') clrscr;
Fim-se write)n ('Digite um numero:');
Sanao se (nurn < 0) readln (num);
Entao escreva ('0 numero e if (num > 0) then writeln' Co numero e
negativo'} positivo')
Fim-se else if (num < 0) then writeln ('0 numero
SenaQ se (num = 0) e negativo')
Entao escreva ('0 numero e nulo') else if (num = 0) then writeln ('0
Fim-se numero e nulo');
Fim-algoritmo readkey;
end.
5) Construir urn algoritmo em PORTUGOl que leia dois numeros e efetue a
adil;ao.Caso 0 valor somado seja maior que 20, este devers ser apresentado
somando-se a ele mais 8; caso 0 valor somado seja menor ou igual a 20, este
devers ser apresentado subtraindo-se 5.

AlGORITMO PASCAL
Algoritmo numero Program numera;
Declare n1, n2, n3 inteiro uses crt;
leia (n1) var n1,n2,n3:integer;
leia (n2) begin
N3<- n1+n2 clrser;
Se (n3>20) writeln ('Digite urn numero:');
Entao n3 <- (n3 + 8) readln (n1);
Fim-se writeln ('Oigite outro numero:');
Senao se (n3 <= 20) readln (n2);
Entao n3 <- (n3 - 5) n3:= n1+n2;
Firn-se if (n3 > 20) then n3 := (n3 + 8)
Escreva ('0 numera e: <, n3:4:2) else if (03 <= 20) then n3 := (03 - 5);
Fim-algoritmo writeln ('0 numero e:' ,n3:4:2);
readkey;
end.

6) Escreva urn algoritmo em PORTUGOl que leia urn numero e imprima a raiz
quadrada do numero caso ele seja positivo ou igual a zero e 0 quadrado do
numero caso ele seja negativo.

AlGORITMO PASCAL
Atgoritmo numera Program numero;
Declare n1 inteiro uses crt;
Leia (n1) var n1:real;
Sa (n1 >= 0) begin
Entao n1 <- «sqrt (n1» clrser;
Fim-se writeln ('Digite urn numero:');
Senao se (n1 < 0) readln (n1);
Entao n1 <- «sqr (n1» if (n1 >= 0) then n1 := (SQRT(n1»
Fim-se else if (n1 < 0) then n1 := (SQR(n1»;
Escreva ('0 numero e: <, n1:4:2) Writeln ('0 numero e: " n1:4:2);
~Fim-algoritmo readkey;
end.
7) Esereva urn algoritmo em PORTUGOL que receba urn numero e imprima uma
das mensagens: "e multiplo de 3" ou "nao e multiplo de 3".

ALGORITMO PASCAL
Algoritmo numero Program numero;
Declare n1 inteiro uses ert;
Leia (n1) var n1 :integer,
=
~ (n1 mod 3 0) begin
Entao esereva eo numero e multiplo elrser,
de 3') writeln ('Digite urn numero:');
Fim-se readln (n1);
Senao escreva ('0 numero nao multiplo if (n1 mod 3 = 0) then write'n ('0
de 3') numero e multipio de 3')
Fim-se else writeln('O numero nao e multiplo
Fim-algoritmo de 3');
readkey;
end.

8) A prefeitura de Contagem abriu uma linha de Crt3dito para os funcionarios


estatutarios. 0 valor maximo da presta~o nao podera ultrapassar 30% do salario
bruto.Fazer urn algoritmo que permita entrar com 0 salario bruto e 0 valor da
presta~o, e informar se 0 emprestimo pede OU nao ser coneedido.

ALGORITMO PASCAL
Algoritmo numero Program numero;
Declare s_bruto, pres, pore real uses ert;
Leia (s_bruto) var s_bruto,prest,pore:real:
Leia (prest) begin
Pore <- s_bruto * (30/100) elrser;
Se (prest <= pore) writeln ('Digite seu salario bruto:');
Entao escreva ('0 emprestimo sera readln (s_bruto);
eoncedido') writeln ('Oigite 0 valor da presta~o:');
Fim-se readln (prest);
Senao escreva ('0 emprestimo nao pore:= s_bruto * (30/100);
sera concedido') if (prest <= pore) then writeln ('0
Fim-se emprestimo sera concedido')
Fim-algoritmo else write'n ('0 emprestimo nao sera
concedido');
readkey;
end.
9) Construa um algoritmo em PORTUGOl que dado quatro valores, A, B, CeO, 0
algoritmo imprima 0 maior e 0 menor valor possivel.

AlGORITMO PASCAL
Algoritmo numero Program numero;
Declare A, B, C, 0, maior, menor inteiro uses crt;
leia (A) var A,B,C,D,maior,menor:integer;
leia (B) begin
leia (C) clrscr;
leia (D) writeln ('Digite 0 valor de A:');
Se «A>B) e (A>C) e (A>D» readln (A);
Entao maior:= (A) writeln ('digite 0 valor de B:');
Fim-se readln (B);
Senao se «A<B) e (A<C) e (A<D» writeln ('Digite 0 valor de C:');
Entao menor:= (A) readln (C);
Fim-se writeln ('Digite 0 valor de 0:');
8enao se «B>A) e (B>C) e (B>D» readln (D);
Entao maior:= (B) if «A>B) and (A>C) and (A>D»
Fim-se then maior := (A)
Senao se «B<A) e (B<C) e (8<0» else if «A<B) and (A<C) and (A<D»
Entao menor:= (B) then menor := (A)
Fim-se else if «B>A) and (B>C) and (B>D»
Senao sa «C>A) e (C>B) e (C>D» then maior := (B)
Entao maior:= (C) else if «B<A) and (B<C) and (B<D»
Fim-se then menor := (B)
Senao se «C<A) e (C<B) e (C<D» else if «C>A) and (C>B) and (C>D»
Entao menor:= (C) then maior := (C)
Fim-se else if «C<A) and (C<B) and (C<D»
Senao se «D>A) e (0)8) e (D<C» then menor := (C)
Entao maior:= (D) else if «D>A) and (D>B) and (D<C»
Fim-se then maior := (D)
Senao se «D<A) e (D<B) e (D>C» else if «D<A) and (D<B) and (D>C»
Entao menor:= (D) then menor := (D);
Fim-se writeln ('0 maior valor e:', maior);
Escreva ('0 maior valor e: " maior) writeln ('0 menor valor e:', menor);
Escreva ('0 menor valor e: " menor) readkey;
Fim-alaoritmo end.
10) Construa urn algoritmo de PORTUGOl para determinar se 0 individuo esta
com urn peso favoravel. Essa situayao e determinada atraves do IMC (indica de
Massa Corporeal, que e definida como sendo a relac;ao entre 0 peso (PESO) e 0
quadrado da Altura (ALTURA) do indivfduo. Ou seja, IMC=PESO / AL TURA2 e, a
situayao do peso e determinada pela tabela abaixo:
Condiyao Situayao
IMC abaixo de 20 Abaixo do peso
IMC de 20 ate 25 Peso Normal
IMC de 25 ate 30 Sobre Peso
IMC de 30 ate 40 Obeso
IMC de 40 e acima Obeso M6rbido

AlGORITMO PASCAL
Algoritmo numero Program numero;
Declare peso, altura, massa real . uses crt;
Leia (peso) var peso, altura, massa: real;
Leis (altura) Begin
Massa <- {peso/sqr (altura» clrscr;
Se (massa < 20) writeln ('Digite seu peso:');
Entao escreva ('Abaixo do peso') readln (peso);
Fim-se writeln ('Digite sua altura:');
Senao se (massa=20) e (massa<=25) readln (altura);
Entao escreva ('Peso normal') massa:= (peso/sqr(altura»;
Fim-se if (massa<20)
Senae se (massa=25) e (massa<=30) then writeln ('Abaixo do peso')
Entao escreva ('Sobre peso') else if (massa=20) and (massa<=25)
Fim-se then writeln ('Peso normal')
Sanao se (massa=30) e (massa<=40) else if (massa=25) and (massa<=30)
Entao escreva ('Obeso') then writeln ('Sobre peso')
Fim-se else if (massa=30) and (massa<=40)
Senao se (massa>=40) then writeln ('obeso')
Entao escreva ('Obeso morbido') else if (massa>=40)
Fim-se then writeln ('Obeso morbido');
Fim-algoritmo readkey;
end.
12) Escreva urn algoritmo em PORTUGOl que dada a idade de uma passoa,
determine sua classifica~o segundo a seguinte tabela:
Maior de idade;
Menor de idade;
Pessoa idosa (idade superior ou igual ha 65 anos).

AlGORITMO PASCAL
Algoritmo numero Program numero;
Declare idade inteiro uses crt;
leia {idade) var idade:integer;
Se (idade >= 18) begin
Entao escreva ('Maior idade') clrscr;
Fim-se writeln ('Digite sua idade');
Senao se (idade < 18) readln (idade);
Entao escreva ('Menor idade') if (idade>=18)
Fim-se then writeln ('Maior idade')
Senao sa (idade >= 65) else if (idade<18)
Entao escreva (,Pessoa idosa') then writeln ('Menor idade')
Fim-se else if (idade>=65)
Fim-algoritmo then writeln ('Pessoa Idosa');
readkey;
end.

13) Crie urn algoritmo em PORTUGOl que leia a idade de uma passoa e informe .
a sua classe eleitoral:
Nao eleitor (abaixo de 16 anos);
Elenor obrigat6rio (entre a faixa de 18 e menor de 65 anos);
Eleitor facultativo (de 16 ate 18 anos e maior de 65 anos, inclusive).

AlGORITMO PASCAL
Algoritmo numero Program numero;
Declare idade inteiro uses crt;
Leis (idade) var idade:integer;
Se (idade < 16) begin
Entao escreva {'Naoeleitor} clrscr;
Fim-se writeln ('Digite sua idade');
Senao se (idade >= 18) e (idade < 65) readln (idade);
Entao escreva CEleilor obrigat6rio') if (idade<16) then writeln ('Nao eleitor)
Fim-se else if «idade>=18) and (idade<65»
Senao se (idade=16) e (idade=18) e then writeln ('Eleitor obrigatorio')
(idade>65) else if «idade=16) and (idade=18)
Entao escreva ('Eleitor facultativo') and (idade>65)} then writeln ('Eleitor
Fim-se facultativo');
Fim-algoritmo readkey;
end.
14) A confederaC;ao brasileira de natac;ao ira promover eliminat6rias para 0
proximo mundial. Fazer um algoritmo em PORTUGOl que receba a idade de um
nadador e determine (imprima) a sua categoria segundo a tabela a seguir:
Categoria ldade
Infantil A 5 - 7 anos
Infantil B 8 - 10 anos
Juvenil A 11 - 13 anos
Juvenil B 14 - 17 anos
senior Maiores de 18 anos

ALGORITMO PASCAL
Algoritmo numero Program numero;
Declare nome literal uses crt;
Declare idade inteiro var nome:string;
Leia (nome) var idade:integer;
Leia (idade) begin
Se (idade > 5) e (idade <= 7) clrscr;
Entao escreva ('Infantil A') writeln ('Digite seu nome:');
Fim-se readln (nome);
Senao se (idade>8) e (idade<=10) writeln ('Digite sua idade:');
Entao escreva ('Infantil B') readln (idade);
Fim-se if «idade>5)and(idade<=7»
Senao se (idade>11) e (idade<=13) then writeln ('Intantil A')
Entao escreva ('Juvenil A') else if «idade>8)and{idade<:o:10»
Fim-se then writeln ('Intantil S')
Senao se (idade>14) e (idade<:o:17) else if «idade>11 )and(idade<=13»
Entao escreva ('Juvenil S') then write'n ('Juvenil A')
Fim-se else if «idade>14)and(idade<=17»
Senao se (idade>=18) then writeln ('Juvenil S')
Entao escreva ('Senior') else if (idade>=18)
Fim-se then writeln ('Senior');
Fim-algoritmo readkey;
end.
15) Depois da liberayao do governo para as mensalidades dos pianos de saude,
as pessoas comeyaram a fazer pesquisas para descobrir um bom plano, nao
muito caro. Um vendedor de um plano de saude apresentou a tabela a seguir.
Criar um algoritmo em PORTUGOl que entre com a idade de uma PaSsoa e
imprima 0 valor que ela devera pagar, segundo a seguinte labela:
Idade Valor
Ale 10 anos R$ 30,00
Acima de 10 ale 29 anos R$ SO,OO
Acima de 29 ate 45 anos R$ 120,00
Acima de 45 ate 59 anos R$ 150,00
Acima de 59 ata 65 anos R$ 250,00
Maior que 65 anos R$ 400,00

AlGORITMO PASCAL
Algoritmo numero Program numero;
Oeclare idade inteiro uses crt;
leia (idade) var idade:integer; ~
Se (idade <=10) begin
Entao escreva ('0 valor a R$30.00') clrscr;
Fim-se writeln ('Oigite sua idade');
Senao se (idade > 10) e (idade <= 29) readln (idade);
Entao escreva ('0 valor e R$SO.OOI) if (idade <=10)
Fim-se then writeln ('0 valor e R$30.00')
Senao se (idade > 29) e (idade <= 45) else if «idade > 10) and (idade <= 29»
Entao escreva ('0 valor a R$120.00') then writeln ('0 valor e R$60.00')
Fim-se else if «idade > 29) and (idade <= 45»
Senao se (Idade > 45) e (idade <= 59) then writeln ('0 valor e R$120.00')
Entao escreva ('0 valor a R$150.oo') else if «Idade > 45) and (idade <= 59»
Fim-se then writeln ('0 valor e R$150.oo')
Senao se (Idade > 59) e (idade <= 65) else if ((Idade > 59) and (idade <= 65»
Entao escreva ('0 valor e R$250.00') then writeln ('0 valor e R$250.00')
Fim-se else if (idade > 65)
Senao se (idade > 65) then writeln ('0 valor e R$400.001);
Entao escreva ('0 valor e R$400.00') readkey;
Fim-se end.
Fim-algoritmo
16) Um comereiante caleula 0 valor da venda, tendo em vista a tabela a seguir:
Valor da Compra Valor da Venda
Valor < R$ 10,00 Luero de 70%
R$10,OO <= Valor < R$ 30,00 Luero de 50%
R$ 30,00 <= Valor < R$ 50,00 Luero de 40%
Valor >= R$ 50,00 Luero de 30%

ALGORITMO PASCAL
Algommo numero Program numero;
Declare VC, W real Uses crt;
Leia (VC) Var VC, W: real;
Se (VC < 10.00) Begin
Entao W <- ({VC*70) /100} Clrser;
Fim-se writeln CDigite 0 valor da eompra:t);
Senao se (VC<=10.oo) e {VC<30.00} readln (VC);
Entao W <- «VC*50) /100} if (VC<10.00)
Fim-se then W:=({VC*70)/100)
Senao se (VC<=30.oo) e (VC<50.00) else if ((VC<=10.oo)and(VC<30.oo»
Entao W <- «VC*40) /100) then W:=( (VC*50)/1 00)
Fim-se else if «VC<=30.oo)and{VC<50.oo»
Senao se (VC >= 50.00) then W:=«VC*40)/1oo)
Entao W <- ((VC*30) 1100) else if (VC>=50~OO)
Fim-se then W:=({VC*30)/100);
Esereva ('0 valor da venda e: "
W) writeln (to valorda venda e:',W);
Fim-afgoritmo Readkey;
End.
17) Construa urn algoritmo em PORTUGOL para determinar a situa~o
(APROVADO/EXAMEIREPROVADO) de umaluno, dado a sua frequencia (FREQ)
(porcentagem de 0 a 100%) e sua nota (NOTA) (nota de 0.0 a 10.0), sando que:
Condic;ao Situac;ao
FreqOencia ate 75% Reprovado
FreqOencia entre 75% e 100% e Nota ate 3.0 Reprovado
FreqOencia entre 75% e 100% e Nota de 3.0 ate 7.0 Exame
FreqOencia entre 75% e 100% e Nota entre 7.0 e 10.0 Aprovado
ALGORITMO
Algoritmo Aprovado
Declare freq, nota real
Leia (freq)
Leia (nota)
Sa (freq<=0.75)
Entao escreva ('Reprovado')
Fim-se
Senao se «freq >= 0.75) e (freq <= 1.00) e (nota <= 3.0»
Entao esereva ('Reprovado')
Fim-se
Senao se «freq >= 0.75) e (freq <= 1.00) e (nota> 3.0) e (nota <= 7.0»
Entao escreva ('Exame')
Fim-se
Senao se «freq >= 0.75) e (freq <= 1.00) e (nota >= 7.0) e (nota <= 10.0»
Entao escreva ('Aprovado')
Fim-se
Fim-algoritmo

PASCAL
Program aprovado;
uses crt;
Var freq, nota: real;
begin
elrser;
Writeln ('Digitesua frequeneia: ');
readln (freg);
writeln ('Digite sua nota:');
readln (nota);
if (freq<=0.75)
then writeln ('Reprovado')
else if «freq>=0.75) and (freq<=1.oo) and (nota<=3.0»
then writeln ('Reprovado')
else if «freq>=0.75) and (freg<=i.oo) and (nota>3.0) and (nota<=7.0»
then writeln ('Exame')
else if «freq>=0.75) and (freq<=1.00) and (nota>=7.0) and (nota<=10.0»
then writeln('Aprovado');
readkey;
end.