Você está na página 1de 16

Arreglos en PSeInt

Por: Carlos Arrieta

Los arreglos son estructura de datos homogneas (todos los datos son del
mismo tipo) que permiten almacenar un determinado nmero de datos bajo un
mismo identificador, para luego referirse a los mismos utilizando uno o ms
subndices. Los arreglos pueden pensarse como vectores, matrices, etc. Para
crear un arreglo en PSeInt se utiliza la palabra clave Dimensin, seguido del
nombre del arreglo (identificador) y su tamao (nmero de subndices) entre
corchetes []. Dimensin identificador [tamao]; En PSeInt los subndices
(posiciones) de los arreglos empiezan desde 1. En Java desde 0.

Ejemplo 1
Crear un arreglo llamado nmeros que almacene los siguientes datos: 20, 14,
8, 0, 5, 19 y 4

Proceso sin_titulo
Dimension numeros[7];
numeros[1]<-20
numeros[2]<-14
numeros[3]<-8
numeros[4]<-0
numeros[5]<-5
numeros[6]<-19
numeros[7]<-4

Para i<-1 Hasta 7 Con Paso 1 Hacer


Escribir "El elemento en la posicion: ",i," es: ",numeros[i];
FinPara
FinProceso

Visual
#include <conio.h>
#include <iostream>
using namespace std;
int main()
{
int numeros[100];
numeros[0]
numeros[1]
numeros[2]
numeros[3]
numeros[4]
numeros[5]
numeros[6]

=
=
=
=
=
=
=

20;
14;
8;
0;
5;
19;
4;

for (int i = 0; i < 6; i++)


{
cout << "El elemento en la posicion: " << i << " es: " <<
numeros[i]<<"\n";
}

system("pause");
return 0;

Ejemplo 2: Crear un arreglo de 5 posiciones y llnelo con los nmeros que el


usuario desee.

Proceso sin_titulo
Dimension numeros[5];
Para i<-1 Hasta 5 Con Paso 1 Hacer
Escribir "Digite el numero";
Leer numeros[i];
FinPara

Para i<-1 Hasta 5 Con Paso 1 Hacer


Escribir "El numero que hay en la posicion ",i,"es: ",numeros[i];
Leer numeros[i];
FinPara
FinProceso

Visual
#include <conio.h>
#include <iostream>
using namespace std;
int main()
{
int numeros[4];

for (int i = 0; i < 4; i++)


{
cout << "Digite el numero: ";
cin >> numeros[i];
}
for (int i = 0; i < 4; i++)
{
cout << "El numero que hay en la posicion : " << i << " es: " << numeros[i]
<< "\n";

}
system("pause");
return 0;
}

Ejemplo 3: Crear un arreglo llamado nombres y que almacene los siguientes


nombres de personas: Juan, Pedro, mara, Humberto y Oscar.

Proceso sin_titulo
Dimension nombres[5];
nombres[1]<-"Juan"
nombres[2]<-"Pedro"
nombres[3]<-"Maria"
nombres[4]<-"Humberto"
nombres[5]<-"Oscar"
Para i<-1 Hasta 5 Con Paso 1 Hacer
Escribir "El nombre que hay en la posicion ",i,"es: ",nombres[i];
FinPara
FinProceso

Visual
#include <conio.h>
#include <iostream>
using namespace std;
int main()
{
char *numeros[5];
numeros[0]
numeros[1]
numeros[2]
numeros[3]
numeros[4]

=
=
=
=
=

"Juan";
"Pedro";
"Maria";
"Humberto";
"Oscar";

for (int i = 0; i < 5; i++)


{
cout << "El nombre que hay en la posicion "<< i << " es: " << numeros[i]
<<"\n";
}
system("pause");
return 0;
}

Ejemplo 4: Llenar un arreglo con nombres de personas. Preguntar al usuario


cuantos datos desea ingresar
Proceso sin_titulo
Dimension nombres[200];
Escribir "Ingrese la cantidad de datos:";
Leer n;
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir "Digite el nombre",i;
leer nombres[i];
FinPara

Para i<-1 Hasta n Con Paso 1 Hacer


Escribir "El nombre es: ",nombres[i];
FinPara
FinProceso

VISUAL
#include <conio.h>
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int main()
{
char *numeros[200];
int n;
char f[100];
cout << " Ingrese la cantidad de datos:";
cin >> n;
for (int i = 0; i < n; i++)
{
cout << "Digite el nombre "<< i <<": ";
cin >> f;
numeros[i]=f;
cout << "El nombre es: " << numeros[i] << "\n";
}

for (int j = 0; j < n; j++)


{
cout << "El nombre es: " << numeros[j]<<"\n";
}

system("pause");
return 0;

Ejemplos con vectores:


Sumar los elementos de un arreglo: Para sumar los elementos de un vector
debemos usar un acumulador inicializado en cero.
Proceso sin_titulo
Dimension nombres[200];
acum<-0;
Escribir "Ingrese la cantidad de datos:";
Leer n;
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir "Digite el numero",i;
leer nombres[i];
acum<-acum+nombres[i];
FinPara
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir "La suma de: ",nombres[i];
FinPara

Escribir "Es: ",acum;


FinProceso

Llenar un vector de 10 posiciones con nmeros aleatorios entre 1 y 100: Para


los nmeros aleatorios PSeInt utiliza la funcin Azar, sta escoge un entero
aleatorio entre 0 y x-1.

Proceso sin_titulo
Dimension nombres[10];
Para i<-1 Hasta 10 Con Paso 1 Hacer
nombres[i]<-azar(100)+1;
FinPara
Para i<-1 Hasta 10 Con Paso 1 Hacer
Escribir "num[",i,"]"," <-", nombres[i];
FinPara
FinProceso

Llenar un vector con nmeros enteros (nmeros positivos negativos). Mostrar


la cantidad de nmeros positivos que hay en dicho arreglo.

Proceso sin_titulo
Dimension nombres[200];
cont<-0;
Escribir "Digite tamao arreglo";
Leer c;
Para i<-1 Hasta c Con Paso 1 Hacer
Escribir "Digite numero";
leer nombres[i];
FinPara
Para i<-1 Hasta c Con Paso 1 Hacer
si nombres[i]>0 Entonces
cont<-cont+1
FinSi
FinPara
Escribir "Hay ", cont, " positivos";
FinProceso