Você está na página 1de 22

Alta disponibilidade utilizando

Roteamento Virtual no RouterOS


GUILHERME RAMIRES

Nome: Guilherme M. Ramires


Analista de Sistemas
Ps-Graduado em Tecnologia e Gerenciamento de
Redes de Computadores
CEO da Link Point Internet
Membro da equipe de treinadores da Lancore
Networks
Mikrotik Consultant desde 2009
Mikrotik Training Partner desde 2010
2

Indice
Introduo
Tcnicas e protocolos para alta disponibilidade
Roteamento Virtual
Exemplos
Consideraes finais

Introduo
Alta disponibilidade a capacidade que o

sistema tem de se moldar as mudanas de


estados fisicos ou lgicos de forma a manter o
fluxo de dados.
possvel implementar esta alta disponibilidade
no Router OS atravs de diversos parametros,
tecnicas ou protocolos como por exemplo:
Bonding, Roteamento esttico, Roteamento
Dinmico, VRRP, etc

Introduo Cont
Todos estes recursos podem ser utilizados
simultaneamente ou de forma isolada. Entretanto
em muitos casos ser necessrio a utilizao de
todos para se prover alta disponibilidade.
A utilizao isolada dos recursos citados
anteriormente no capaz de prover alta
disponibilidade de forma satisfatria.

Topologia comun

ISP 1

Somente um ISP
Somente um gateway LAN
Rede sem roteamento

Topologia recomendada
OSPF

BGP
ISP 1
BGP
ISP 2

Pelo menos dois ISP`s


Vrios gateways LAN
Rede roteada / segmentada
7

RIP

Tcnicas e protocolos para alta


disponibilidade
Bonding
Roteamento esttico
Roteamento dinmico
Roteamento virtual (VRRP)

Bonding
O bonding funciona com a interligao de duas ou

mais interfaces com o intuito de agregar links ou


para utilizao na forma de link master e backup.
Entrentando em alguns casos o failover chega a
demorar 20 segundos para se recuperar.

Roteamento Esttico
Neste ponto o roteamento esttico infinitamente
mais veloz, entretanto a utilizao exclusiva
desse recurso torna o gerenciamento muito mais
complexo e sujeito a falhas humanas.

10

Roteamento Dinmico
O problema do roteamento esttico solucionado

utilizando protocolos de Roteamento Dinmico(RIP,


OSPF, MME, BGP, etc)
Os protocolos de roteamento dinmico so capazes de
comunicar mudanas de topologia e conforme seus
algoritmos, as tabelas de roteamento so modificadas.

11

VRRP
O Virtual Router Redundancy Protocol ( VRRP )

um protocolo de rede que prev a atribuio


automtica de roteadores disponveis para os hosts
participantes. Isso aumenta a disponibilidade e a
confiabilidade dos caminhos de roteamento atravs
da seleo de gateways default de forma
automtica.
O protocolo consegue isso atravs da criao de
roteadores virtuais, que so uma representao
abstrata de mltiplos roteadores, ou seja, roteadores
master e backup, agindo como um grupo. O
gateway padro de um host participante atribudo
ao roteador virtual em vez de um roteador fsico.
12

VRRP
Se o roteador fsico que faz o roteamento de

pacotes em nome do roteador virtual falhar, outro


roteador fsico selecionado automaticamente para
substitu-lo. O roteador fsico que faz o
encaminhamento de pacotes em um determinado
momento chamado de roteador master.

13

VRRP
Mikrotik implementa VRRP conforme as RFC 5798 e

RFC 3768, portanto, pode ser usado em redes


Ethernet , MPLS, IPv4 e IPv6.
O VRRP fornece informaes sobre o estado de um
roteador, e no as rotas processadas e trocadas por
esse roteador.
Normalmente em redes LANs, utilizamos protocolos
de roteamento dinmico como o OSPF e RIP. Porm
nem sempre s a utilizao desses protocolos
suficiente para prover redundncia de forma eficiente.
Esses protocolos modificam a tabela de roteamento
de forma dinmica e isso as vezes leva um tempo
elevado para ocorrer.

14

Implementao
Um roteador virtual deve usar 00-00-5E-00-01-XX

como o seu MAC. O ltimo byte do endereo


(XX) o identificador Router Virtual (VRID), que
diferente para cada roteador virtual na rede. Este
endereo usado por apenas um roteador fsico
de cada vez, e ele ir responder com este
endereo MAC quando uma solicitao ARP
enviado para o endereo IP do roteador virtual.
Roteadores fsicos dentro do roteador virtual
devem se comunicar usando pacotes multicast
com endereo IP 224.0.0.18.
15

Implementao Cont
Roteadores tm uma prioridade entre 1-255 e o
roteador com a maior prioridade ser o master. Quando
uma retirada planejada de um roteador master est para
acontecer, sua prioridade pode ser reduzida, o que
significa um roteador de backup ir antecipar-se o
status do roteador master ao invs de ter que esperar o
tempo de espera expirar. Isso reduz o perodo de
buraco negro.

16

Exemplo #1
A implementao da VRRP

relativamente simples.
Alguns parametros avanados
podem ser ajustados para se
atingir alguns resultados
esperados como por exemplo:
Se voc quiser que o Roteador
R1 seja sempre o mestre
necessrio que sua prioridade
seja maior que o de R2 e que
a opo Preampetable Mode
esteja como yes.
17

Conf. do Exemplo #1
Para o Router R1:
/interface vrrp add interface=ether1 vrid=49 priority=150
/ip address add address=192.168.1.1/24 interface=ether1
/ip address add address=192.168.1.254/32 interface=vrrp1

Para o Router R2:


/interface vrrp add interface=ether1 vrid=49 priority=100
/ip address add address=192.168.1.2/24 interface=ether1
/ip address add address=192.168.1.254/32 interface=vrrp1

18

Exemplo #2
possivel fazer
balanceamento de
carga utilizando
VRRP.
Neste caso
necessrio criar 2
grupos de roteadores
virtuais.

19

Conf. do Exemplo #2
Para o Router R1:
/ip address add address=192.168.1.1/24 interface=ether1
/interface vrrp add interface=ether1 vrid=49 priority=150
/interface vrrp add interface=ether1 vrid=77 priority=100
/ip address add address=192.168.1.253/32 interface=vrrp1
/ip address add address=192.168.1.254/32 interface=vrrp2

Para o Router R2:


/ip address add address=192.168.1.2/24 interface=ether1
/interface vrrp add interface=ether1 vrid=49 priority=100
/interface vrrp add interface=ether1 vrid=77 priority=150
/ip address add address=192.168.1.253/32 interface=vrrp1
/ip address add address=192.168.1.254/32 interface=vrrp2
20

Consideraes Finais
Podemos concluir que um nico recurso de
redundncia de forma isolada no tem efeito
satisfatrio.
Entretanto a coperao multua de todas estas
tcnicas nos permite prover um servio de alta
disponibilidade.
Todos estes recursos utilizados nesta
apresentao esto disponiveis no Router OS.

21

OBRIGADO!!
Guilherme Ramires
guilhermeramires@gmail.com

22