Você está na página 1de 14

RESPOSTAS NA LTIMA PGINA

NOTA 100

Questo 1/10
Para a parte de programa abaixo, com m=3 e n=3, qual seria a sada?

leia(m,n)
para i de 1 ate m faca
para j de 1 ate n faca
se(s=1) entao
matriz[i,j]<-1
senao
matriz[i,j]<-0
fimse
fimpara
fimpara

100

110
011

100

100
100

111

100
100

111

000
000

Questo 2/10
Para o algoritmo abaixo, qual a melhor substituio para que o programa execute n vezes a repetio:

algoritmo "prog2"
var
x, idade,crianca,preadole,adolescente,adulto: inteiro
inicio
// Seo de Comandos
para x de 1 ate 10 faca
escreva("Digite uma idade: ")
leia(idade)
se idade<=11 entao
crianca<-crianca+1
fimse
se (idade>11) e (idade<=14) entao
preadole<-preadole+1
fimse
se (idade>14) e (idade<=17) entao
adolescente<-adolescente+1
fimse
se idade >= 18 entao
adulto<-adulto+1
fimse
fimpara
escreval("*** Totais por faixa-etria ***")
escreval("Nmero de criancas: ",crianca)
escreval("Nmero de pre-adolescentes: ",preadole)
escreval("Nmero de adolescentes: ",adolescente)
escreval("Nmero de adultos: ",adulto)

fimalgoritmo

1.

var

x, idade,crianca,preadole,adolescente,adulto: inteiro

inicio
// Seo de Comandos
escreval("Digite a quantidade de entradas:")
leia(qt)
para x de 1 ate qt faca

1.

var

x, idade,crianca,preadole,adolescente,adulto,qt: inteiro

inicio
// Seo de Comandos
escreval("Digite a quantidade de entradas:")
leia(qt)
para x de 1 ate qt faca

1.

var

x, idade,crianca,preadole,adolescente,adulto,qt: inteiro

inicio
// Seo de Comandos
escreval("Digite a quantidade de entradas:")
para x de 1 ate qt faca

1.

var

x, idade,crianca,preadole,adolescente,adulto,qt: inteiro

inicio
// Seo de Comandos
escreval("Digite a quantidade de entradas:")
leia(qt)
para x de 1 ate qt faca
Questo 3/10
Para a parte de programa abaixo, com m=3 e n=3, qual seria a sada?

leia(m,n)
para i de 1 ate m faca
para j de 1 ate n faca
se(i=j) entao
matriz[i,j]<-1
senao
matriz[i,j]<-0
fimse
fimpara
fimpara
A

100

010
001

100

100
100

111

100
100

111

000
000
Questo 4/10
Para um vetor v1 de tamanho 10, qual seria a lgica mais adequada para fazer a entrada, via teclado, de
cada elemento?

para i de 1 ate 10 faca

escreval("Digite um numero qualquer:")


leia(v1[1])
fimpara

para i de 1 ate 10 faca

escreval("Digite um numero qualquer:")


leia(v1[i])
fimpara
C

para i de 1 ate 10 faca

escreval("Digite um numero qualquer:")

leia(v1[10])
fimpara
D

para i de 1 ate 10 faca

escreval("Digite um numero qualquer:")


leia(v1)
fimpara
Questo 5/10
Lgica de programao pode ser definida como o uso correto das leis do pensamento, da ordem da razo
e de processos de raciocnio e simbolizao formais na programao de computadores.
incorreto afirmar, ao se falar de lgica e lgica de programao, que:

Um dos principais objetivos a racionalidade e o desenvolvimento de tcnicas que cooperam na


produo de solues logicamente vlidas e coerentes.

O mesmo raciocnio pode ser expresso em qualquer idioma existente, mas continuaria representando
o mesmo raciocnio atravs de outra conveno.

Uma vez a lgica estruturada, poderamos represent-la em qualquer linguagem de programao.

O raciocnio algo concreto e tangvel.

Questo 6/10
Para o algoritmo abaixo, identifique qual a parte de cdigo preencheria a parte faltante (substitui o
quadro):

algoritmo "prog1"
var
x, idade,crianca,preadole,adolescente,adulto: inteiro
inicio

// Seo de Comandos
para x de 1 ate 10 faca
escreva("Digite uma idade: ")
leia(idade)
se idade<=11 entao
crianca<-crianca+1
fimse
+----------------------------------------+
|
|
|
|
|
+----------------------------------------+
se (idade>14) e (idade<=17) entao
adolescente<-adolescente+1
fimse
se idade >= 18 entao
adulto<-adulto+1
fimse
fimpara
escreval("*** Totais por faixa-etria ***")
escreval("Nmero de criancas: ",crianca)
escreval("Nmero de pre-adolescentes: ",preadole)
escreval("Nmero de adolescentes: ",adolescente)
escreval("Nmero de adultos: ",adulto)
fimalgoritmo

se (idade>12) e (idade<=14) entao

preadole<-preadole+1
fimse
B

se (idade>=11) e (idade<=14) entao

preadole<-preadole+1
fimse
C

se (idade>11) e (idade<=14) entao

|
|
|
|
|

preadole<-preadole+1
fimse
D

se (idade>11) e (idade<14) entao

preadole<-preadole+1
fimse
Questo 7/10
Para um vetor v1 de tamanho 50, qual seria a lgica mais adequada para mostrar o valor dos elementos na
tela?

para i de 1 ate 50 faca

leia("v",i,": ",v1[i])
fimpara
B

para i de 1 ate 50 faca

leia (v1)
fimpara
C

para i de 1 ate n faca

escreval("v",i,": ",v1)
fimpara
D

para i de 1 ate 50 faca

escreval(v1[i])
fimpara
Questo 8/10
Para o algoritmo abaixo, identifique qual a parte de cdigo representaria melhor a entrada dos dados:

escreval("Digite um valor o raio : ")

leia(raio)
escreval(Digite o valor de Pi:)
leia(Pi)

escreval("Digite um valor o raio : ")


leia(raio)

escreval("Digite um valor o raio : ")

leia(raio)
escreval(Digite o valor de Pi:)

leia(raio)

Questo 9/10
Para o algoritmo abaixo, identifique a ordem das principais etapas da construo do algoritmo:

1-Entrada, 2-Sada, 3-Processamento

1-Entrada, 2-Processamento, 3-Sada

1-Declarao de variveis, 2-Entrada e Processamento, 3-Sada

1-Declarao de variveis e Entrada, 2-Processamento, 3-Sada

Questo 10/10
Para o algoritmo abaixo, identifique qual a parte de cdigo preencheria a lacuna em aberto. O algoritmo
faz a distribuio dos nmeros em outros dois vetores, um vetor s com o zero e os nmeros positivos e
outro s com nmeros negativos:

algoritmo "vetores"
var
i,j,k,n : inteiro
v: vetor [1..50] de real
vp: vetor [1..50] de real
vn: vetor [1..50] de real
aux: real
inicio
//seo de comandos
escreval("Digite o nmero de elementos do vetor:")
leia(n)
para i de 1 ate n faca
escreval("Digite um numero qualquer:")
leia(v[i])
fimpara
limpatela
+------------------------------------------------------------------------------------------------------------------------------+

+------------------------------------------------------------------------------------------------------------------------------+
escreval("Positivos:")
para i de 1 ate k faca
escreval(vp[i])
fimpara
escreval("Negativos:")
para i de 1 ate j faca
escreval(vn[i])

fimpara
fimalgoritmo
A

para i de 1 ate n faca

se (v[i]>1) entao
k<-k+1
vp[k]<-v[i]
senao
j<-j+1
vn[j]<-v[i]
fimse
fimpara

k<-0

j<-0
para i de 1 ate n faca
se (v[i]>=0) entao
k<-k+1
vp[k]<-v[i]
senao
j<-j+1
vn[j]<-v[i]
fimse

fimpara

para i de 1 ate n faca

se (v[i]>0) entao
k<-k+1

vp[i]<-v[i]
senao
j<-j+1
vn[i]<-v[i]
fimse
fimpara

1.

k<-0

j<-0
para i de 1 ate n faca
se (v[i]>0) entao
vp[k]<-v[i]
senao
vn[j]<-v[i]
fimse

fimpara

RESPOSTAS NA PRXIMA PGINA

AH, AGORA SIM ... EIS AS RESPOSTAS ...


01000001 00100000 01110010 01100101 01110011 01110000 01101111 01110011 01110100
01100001 00100000 01100101 01110011 01110100 11100001 00100000 01100011 01110010
01101001 01110000 01110100 01101111 01100111 01110010 01100001 01100110 01100001
01100100 01100001 00101110 00001010 01001111 00100000 01110100 01100101 01101101
01110000 01101111 00100000 01110001 01110101 01100101 00100000 01110110 01101111
01100011 11101010 00100000 01110000 01100101 01110010 01100100 01100101 01110101
00100000 01110000 01100001 01110010 01100001 00100000 01110100 01100101 01101110
01110100 01100001 01110010 00100000 01100100 01100101 01110011 01100011 01101111
01100010 01110010 01101001 01110010 00100000 01100001 01110011 00100000 01110010
01100101 01110011 01110000 01101111 01110011 01110100 01100001 01110011 00100000
01100100 01100001 00100000 01110000 01110010 01101111 01110110 01100001 00101100
00100000 01110000 01101111 01100100 01100101 01110010 01101001 01100001 00100000
01110100 11101010 00101101 01101100 01101111 00100000 01110101 01110011 01100001
01100100 01101111 00101100 00100000 01100101 01110011 01110100 01110101 01100100
01100001 01101110 01100100 01101111 00101110 00001010 01010110 01100001 01101001
00100000 01100101 01110011 01110100 01110101 01100100 01100001 01110010 00100000
00101110 00101110 00101110 00100000 01100100 01100101 01101001 01111000 01100001
00100000 01100100 01100101 00100000 01110011 01100101 01110010 00100000 01110110
01100001 01100100 01101001 01101111 00100000 00101110 00101110 00101110 00001010
00001010 01000001 01100010 01110010 01100001 11100111 01101111 01110011 00101110