Você está na página 1de 12

Mtodo para Construo de Algoritmos

Os passos necessrios para a construo de um


algoritmo so:
ler atentamente o enunciado do problema,
compreendendo-o e destacando os pontos mais
importantes;
definir os dados de entrada, ou seja, quais dados
sero fornecidos;
definir os dados de sada, ou seja, quais dados sero
gerados depois do processamento;
definir o processamento, ou seja, quais clculos sero
efetuados e quais as restries para esses clculos. O
processamento responsvel pela obteno dos
dados de sada com base nos dados de entrada;
definir as variveis necessrias para armazenar as
entradas e efetuar o processamento;
elaborar o algoritmo;
testar o algoritmo realizando simulaes.

51

Pseudocdigo

Com base nos conceitos vistos podemos


aprofundar nosso estudo sobre os mtodos de
representao de algoritmos, iniciaremos pelo
pseudocdigo.
Pseudocdigo uma tcnica textual de
representao de um algoritmo. Tambm
conhecida como Portugus Estruturado ou Portugol.
Nele os verbos (aes) disponveis para utilizao
so limitados e empregados no imperativo, deve-se
evitar as expresses excessivamente longas, estas
restries visam eliminar a possibilidade de
ambigidade.
A tcnica baseada em uma PDL (Program Design
Language), que uma linguagem genrica na qual
possvel representar um algoritmo de forma
52semelhante das linguagens de programao.

Pseudocdigo Estrutura

A estrutura de um algoritmo em pseudocdigo pode variar


um pouco de acordo com o autor ou com base na linguagem
de programao que ser utilizada posteriormente, mas
essas variaes ocorrem apenas na sintaxe, pois a
semntica deve ser exatamente a mesma.
A estrutura que empregaremos para a construo de
nossos pseudocdigos ser a seguinte:
algoritmo nome //Tem como objetivo identificar o
//algoritmo, deve-se utilizar um nome o mais significativo
//possvel, para facilitar a identificao
var
// Seo de Declaraes - Neste ponto so informadas
//quais variveis, e seus respectivos tipos, sero
// utilizadas no algoritmo
inicio
// Seo de Comandos - Aqui ser escrita a seqncia de //
comandos que deve ser executada para solucionar
// o
problema em questo
53fimalgoritmo //marca o final do algoritmo

Pseudocdigo

As palavras reservadas presentes na


estrutura do pseudocdigo apresentado
foram:
algoritmo
var
inicio
fimalgoritmo

54

Pseudocdigo Exemplo

Observaremos agora um pseudocdigo que


recebe um valor inteiro, fornecido pelo usurio, e o
retorna no monitor.
algoritmo exemplo 1
var x: inteiro
inicio
leia (x)
escreva (x)
fimalgoritmo

55

Pseudocdigo Exemplo

Outro exemplo o pseudocdigo de um


algoritmo que recebe um valor inteiro, acresce
duas unidades a este, e exibe o resultado desta
manipulao.
algoritmo exemplo 2
var n: inteiro
inicio
escreva (Digite um nmero inteiro: )
leia (n)
n <- n+2
escreval (Resultado (nmero + 2): , n)
fimalgoritmo

56

Pseudocdigo Exerccio 1

Construa um pseudocdigo para representar um


algoritmo que efetue a multiplicao de dois
inteiros quaisquer.

57

algoritmo exerccio 1
var n1, n2, res: inteiro
inicio
escreva (Digite o multiplicando inteiro: )
leia (n1)
escreva (Digite o multiplicador inteiro: )
leia (n2)
res <- n1 * n2
escreva (Resultado da multiplicao: , res)
fimalgoritmo

Pseudocdigo Exerccio 1

Construa um pseudocdigo para representar um


algoritmo que efetue a multiplicao de dois
inteiros quaisquer.

58

algoritmo exerccio 1b
var n1, n2: inteiro
inicio
escreva (Digite o multiplicando inteiro: )
leia (n1)
escreva (Digite o multiplicador inteiro: )
leia (n2)
escreva (Resultado da multiplicao: , n1*n2)
fimalgoritmo

Pseudocdigo Exerccio 1

Construa um pseudocdigo para representar um


algoritmo que efetue a multiplicao de dois
inteiros quaisquer.
algoritmo exerccio 1c
var n1, n2: inteiro
inicio
escreva ("Digite o multiplicando e em seguida ")
escreva (" o multiplicador (ambos inteiros): ")
leia (n1, n2)
escreva ("Resultado da multiplicao: ", n1*n2)
fimalgoritmo

59

Pseudocdigo Exerccio 2

Gere um pseudocdigo que aplique um desconto


de 30% sobre o valor de um produto, recebido
como entrada, e retorne o resultado da
manipulao na sada padro.
algoritmo exerccio 2a
var valor, resultado: real
inicio
escreva (Entre com o valor do produto: )
leia (valor)
resultado <- valor * 0.7
escreva (Valor com desconto de 30%: )
escreva (resultado)
fimalgoritmo
60

Pseudocdigo Exerccio 2

Gere um pseudocdigo que aplique um desconto


de 30% sobre o valor de um produto, recebido
como entrada, e retorne o resultado da
manipulao na sada padro.
algoritmo exerccio 2b
var valor: real
inicio
escreva (Entre com o valor do produto: )
leia (valor)
valor <- valor * 0.7
escreva (Valor com desconto de 30%: )
escreva (valor:6:2)
fimalgoritmo

61

Pseudocdigo Exerccio 2

Gere um pseudocdigo que aplique um desconto


de 30% sobre o valor de um produto, recebido
como entrada, e retorne o resultado da
manipulao na sada padro.

algoritmo exerccio 2c
var valor: real
inicio
escreva (Entre com o valor do produto: )
leia (valor)
escreva (Valor com desconto de 30%: , valor *
0.7:6:2)
fimalgoritmo

62