Você está na página 1de 7

http://www.mikrotik.com/testdocs/ros/3.0/interface/bonding_content.

php

Home > Documentation > V3.0 > Interface Bonding PDF version

Interface Bonding
Document revision: 1.2 (September 10, 2007, 14:35 GMT)
Applies to:

V3.0

General Information
Summary
Bonding is a technology that allows to aggregate multiple ethernet-like interfaces into a single virtual link, thus getting higher data rates and
providing failover.

Quick Setup Guide
Let us assume that we have 2 NICs in each router (Router1 and Router2) and want to get maximum data rate between 2 routers. To make this
possible, follow these steps:
1. Make sure that you do not have IP addresses on interfaces which will be enslaved for bonding interface!
2. Add bonding interface on Router1:
[admin@Router1] interface bonding> add slaves=ether1,ether2

And on Router2:
[admin@Router2] interface bonding> add slaves=ether1,ether2

3. Add addresses to bonding interfaces:
[admin@Router1] ip address> add address=172.16.0.1/24 interface=bonding1

[admin@Router2] ip address> add address=172.16.0.2/24 interface=bonding1

4. Test the link from Router1:

1 din 7

16.04.2015 09:22

2 ping timeout 172.http://www.php [admin@Router1] interface bonding> /pi 172.the interface will use ARP proxy-arp .16.16.0.04.0.IP target address which will be monitored if link-monitoring is set to arp.the interface will not use ARP enabled . You can specify multiple IP 2 din 7 16. but in our case this is the most important).16.0. ARP .0/interface/bonding_content.100) .Address Resolution Protocol periodically (for arp-interval time) checks the link status.2 ping timeout 172. Neighbour MAC addresses will be resolved using /ip arp statically set table only arp-interval (time.time in milliseconds which defines how often to monitor ARP requests arp-ip-targets (IP address.16.mikrotik. It can be: MII (Media Independent Interface) type1 or type2 .2015 09:22 .com/testdocs/ros/3. default: "") .the interface will only reply to the requests originated to its own IP addresses.0.2 64 byte ping: ttl=64 time=2 ms 172.2 ping timeout 172. Specifications Packages required: system License required: Level1 Submenu level: /interface bonding Standards and Technologies: None Hardware usage: Not significant Related Documents Linux Ethernet Bonding Driver mini-howto Description To provide a proper failover.2 172.0.2 64 byte ping: ttl=64 time=2 ms Note that bonding interface needs a couple of seconds to get connectivity with its peer. link-monitoring is used to check whether the link is up or not. default: 00:00:00. you should specify link-monitoring parameter. Property Description arp (disabled | enabled | proxy-arp | reply-only.16.Media Independent Interface is an abstract layer between the operating system and the NIC which detects whether the link is running (it performs also other functions.Address Resolution Protocol for the interface disabled . default: enabled) .0.16.the interface will use the ARP proxy feature reply-only .

3ad . but not load balancing.adaptive load balancing. mtu (integer: 68. broadcast .100) . This value works only with mode=active-backup slaves (name) . If you use a switch between 2 bonding routers.uses MII type2 to determine link status (used if mii-type1 is not supported by the NIC) none .0/interface/bonding_content.uses Address Resolution Protocol to determine whether the remote interface is reachable mii-type1 . Device driver should support for setting the mac address.. the interfaces are aggregated in a group where each slave shares the same speed.04.if a link has been brought up.IEEE 802. Can be one of: 802. balance-xor .descriptive name of bonding interface primary (name. No special switch is required. LACP tries to adapt to these changes providing failover.provides link backup. Value should be a multiple of mii-interval lacp-rate (1sec | 30secs. then it means that this card don't support this possibility. It includes balance-tlb and received traffic is also balanced.Maximum Transmit Unit in bytes name (name) .3ad dynamic link aggregation. If primary interface fails. Provides fault tolerance and load balancing. Value should be a multiple of mii-interval Notes 3 din 7 16. If receiving slave fails. Another slave becomes active only. it is not considered as down (but no traffic passes through it. This provides fault tolerance but slows down traffic throughput on some slow machines. Provides only failover (in very good quality).Use XOR policy for transmit. balance-tlb . Incoming traffic is received by the current slave.how often to monitor the link for failures (parameter used only if link-monitoring is mii-type1 or mii-type2) mode (802. which will be used for bonding up-delay (time.Outgoing traffic is distributed according to the current load on each slave. be sure that this switch supports IEEE 802. default: 00:00:00.http://www.if a link failure has been detected.Interface is used as primary output media.com/testdocs/ros/3.no method for link monitoring is used.uses Media Independent Interface type1 to determine link status.round-robin load balancing. balance-rr .mikrotik. Used to determine whether link is up or other changes have occured in the network.3ad standard. mii-type2 . Doesn't require any special switch support. If a link fails. default: none) .method to use for monitoring the link (whether it is up or down) arp .php addresses. bonding interface is disabled for down-delay time. default: none) .Link Aggregation Control Protocol rate specifies how often to exchange with LACPDUs between bonding peer.interface bonding mode. separated by comma down-delay (time.3ad | active-backup | balance-alb | balance-rr | balance-tlb | balance-xor | broadcast. bonding interface is disabled for up-delay time and after this time it is enabled. only then others slaves will be used. default: balance-rr) . active-backup . In this mode. default: 00:00:00) . then it is active. yet. default: 00:00:00) . mac-address (read-only: MAC address) .MAC address of the bonding interface mii-interval (time. when it should not be. If bonding shows that the link status is up. Only one slave can be active at a time. Link status determenation relies on the device driver.2015 09:22 . thus). Otherwise balance-alb doesn't work. if first one fails. default: 1500) .Broadcasts the same data on all interfaces at once. balance-alb .1500. Slaves in bonding interface will transmit and receive data in sequential order.at least two ethernet-like interfaces separated by a comma. then another slave takes the MAC address of the failed slave. Provides load balancing and fault tolerance. default: 30secs) . link-monitoring (arp | mii-type1 | mii-type2 | none.

R . the Active load balancing (mode=balance-alb) does not work on some cheap cards.0/interface/bonding_content. D .1/24 1.1.1.com/testdocs/ros/3.1. Application Examples Bonding two Eoip tunnels Assume you need to configure the MikroTik router for the following network setup. it may require up to 20 seconds.php Link failure detection and failover is working significantly better with expensive network cards.disabled.http://www.255 INTERFACE isp2 isp1 MTU 1500 1500 on Office2 4 din 7 16.disabled.1.1.111/24 10.1. then with more cheap ones. made by Intel.dynamic # ADDRESS NETWORK BROADCAST 0 1. You want combine links for getting double speed and provide failover: We are assuming that connections to Internet through two ISP are configured for both routers.1.mikrotik.255 1 10. while on some other cards.0.0.1.running # NAME 0 R isp1 1 R isp2 TYPE ether ether [admin@office1] > /ip address print Flags: X . Also.0 10.0. I . where you have two offices with 2 ISP for each.invalid.dynamic.0 1. for example. on Intel cards failover is taking place in less than a second after link loss. For example.2015 09:22 .1. Configuration on routers on Office1 [admin@office1] > /interface print Flags: X .04. D .

dynamic.2.disabled. D .112 tunnel-id=2 for Office2 through ISP1 [admin@office2] > interface eoip add remote-address=10. mac-address=FE:FD:00:00:00:03 [admin@office1] interface eoip> print Flags: X . I .0.disabled.0.255 TYPE ether ether MTU 1500 1500 INTERFACE isp2 isp1 Eoip tunnel confguration for Office1 through ISP1 [admin@office1] > interface eoip add remote-address=10.1 tunnel-id=1 \..0. remote-address=10. mac-address=FE:FD:00:00:00:04 [admin@office1] > interface eoip print Flags: X .2.0/interface/bonding_content.com/testdocs/ros/3.1 tunnel-id=1 5 din 7 16.mikrotik.0 2.running # NAME 0 R isp2 1 R isp1 [admin@office2] interface> /ip add print Flags: X .0...disabled...disabled.2015 09:22 . R .php [admin@office2] interface> print Flags: X .1.0.2. R .1..0.2.running 0 R name="eoip-tunnel2" mtu=1500 mac-address==FE:FD:00:00:00:04 arp=enabled \.invalid. R .2..1.running 0 R name="eoip-tunnel1" mtu=1500 mac-address=FE:FD:00:00:00:03 arp=enabled remote-address=2. R .dynamic # ADDRESS NETWORK BROADCAST 0 2.0. mac-address=FE:FD:00:00:00:02 [admin@office2] > interface eoip print Flags: X .1..2.running 0 R name="eoip-tunnel2" mtu=1500 mac-address=FE:FD:00:00:00:02 arp=enabled \.0 10.1.112/24 10.2.disabled. remote-address=10.112 tunnel-id=2 \.1/24 2.2.2.255 1 10.04.111 tunnel-id=2 \.1..111 tunnel-id=2 for Office1through ISP2 [admin@office1] > interface eoip add remote-address=2.http://www..1. D .2.

255 isp1 2 3.1/24 3.1.255 isp2 1 10.1/24 1.1.111/24 10..3.3.0.0.invalid.http://www.running 0 R name="eoip-tunnel1" mtu=1500 mac-address=FE:FD:00:00:00:01 arp=enabled remote-address=1.100 down-delay=00:00:00 up-delay=00:00:00 lacp-rate=30secs [admin@office1] ip address> add address=3.3.eoip-tunnel2 6 din 7 16.3.255 bonding1 for Office2 [admin@office2] interface bonding> add slaves=eoip-tunnel1.0.3.0.1 tunnel-id=1 1 R name="eoip-tunnel2" mtu=1500 mac-address=FE:FD:00:00:00:02 arp=enabled remote-address=10.com/testdocs/ros/3.2015 09:22 .eoip-tunnel2 [admin@office1] interface bonding> print Flags: X .1. I .running 0 R name="bonding1" mtu=1500 mac-address=00:0C:42:03:20:E7 arp=enabled slaves=eoip-tunnel1. mac-address=FE:FD:00:00:00:01 [admin@office2] interface eoip> print Flags: X .112 tunnel-id=2 for Office2through ISP2 [admin@office2] > interface eoip add remote-address=1.3.3.0/interface/bonding_content.disabled.111 tunnel-id=2 Bonding confguration for Office1 [admin@office1] interface bonding> add slaves=eoip-tunnel1.0 1.0.1 tunnel-id=1 \.100 arp-ip-targets="" mii-interval=00:00:00.1. R .1.1.1.1/24 interface=bonding1 [admin@office1] ip address> print Flags: X .disabled.1.1. R .1.eoip-tunnel2 mode=balance-rr primary=none link-monitoring=none arp-interval=00:00:00.1.3.dynamic # ADDRESS NETWORK BROADCAST INTERFACE 0 1.1.mikrotik.disabled.0 10.04.1.php 1 R name="eoip-tunnel2" mtu=1500 mac-address=FE:FD:00:00:00:04 arp=enabled remote-address=10.1.1.. D .0 3.

3.0/2 ms © Copyright 1999-2007.1. 0% packet loss round-trip min/avg/max = 2/2.2.3. All rights reserved.2/24 interface=bonding1 [admin@office2] ip address> print Flags: X .3.255 isp2 1 10. R .disabled.0 2.com/testdocs/ros/3.2.disabled. I .3.255 bonding1 [admin@office2] ip address> /ping 3. Mikrotik.04.php [admin@office2] interface bonding> print Flags: X .0.100 down-delay=00:00:00 up-delay=00:00:00 lacp-rate=30secs [admin@office2] ip address> add address=3. D .3.0 10.3.1/24 2. MikroTik.1.2.3.0.invalid.1 64 byte ping: ttl=64 time=2 ms 2 packets transmitted. Other trademarks and registered trademarks mentioned herein are properties of their respective owners.112/24 10.0/interface/bonding_content. RouterOS and RouterBOARD are trademarks of Mikrotikls SIA.2.3.http://www.2015 09:22 .3.2. 7 din 7 16.1 64 byte ping: ttl=64 time=2 ms 3.3.3.running 0 R name="bonding1" mtu=1500 mac-address=00:0C:42:03:20:E7 arp=enabled slaves=eoip-tunnel1.2.0 3.0.3.3. 2 packets received.2/24 3.eoip-tunnel2 mode=balance-rr primary=none link-monitoring=none arp-interval=00:00:00.dynamic # ADDRESS NETWORK BROADCAST INTERFACE 0 2.1.255 isp1 2 3.3.100 arp-ip-targets="" mii-interval=00:00:00.mikrotik.1 3.