Você está na página 1de 20

Problema N 1

Elaborar un algoritmo que refleje la ejecucin de un proceso denominado PROC, un


nmero indefinido de veces.
Proceso PROCES
Definir botn, PROC Como Logico
boton = True
Mientras boton = True Hacer
PROC = True
Fin Mientras
FinProceso

Problema N 2
Elaborar un algoritmo que refleje la ejecucin de un proceso denominado PROC,
solamente un nmero N de veces.
Proceso Process
Definir c, num_veces Como
Numerico
Definir PROC Como Logico
c=0
Escribir "Ingrese numero de
repeticiones"
Leer num_veces
Mientras c <= num_veces Hacer
PROC = True
c = c +1
Escribir c
Fin Mientras
FinProceso

Problema N 3
Elaborar un algoritmo que refleje la ejecucin de los procesos denominados PROC 1 y
PROC 2, un nmero indefinido de veces. (PRIMERA SOLUCIN).

Proceso PROCES
Definir botn, PROC1, PROC2 como logico
boton = True
Mientras boton = True Hacer
PROC1 = True
PROC2 = True
Fin Mientras
FinProceso

Problema N 4
Elaborar un algoritmo que refleje la ejecucin de los procesos denominados PROC 1
y PROC 2 un nmero definido de veces. (SEGUNDA SOLUCIN).
Proceso P4
Definir c, num_veces como
numerico
Definir PROC1, PROC2 como logico
c=0
Escribir "Ingrese numero de
repeticiones"
Leer num_veces
Mientras c <= num_veces Hacer
PROC1 = True
PROC2 = True
c <- c +1
Escribir c
Fin Mientras
FinProceso

Problema N 5
Se trata de leer desde cualquier medio externo SOLO dos nmeros, tales como A y B,
luego sumarlos e imprimir este resultado; todo este proceso debe hacerse un nmero
indefinido de veces. Elaborar un algoritmo que refleje el conjunto de operaciones indicado.

Proceso P5
Definir A, B como numrico
Definir botn como logico
boton = 1
Mientras boton = 1 Hacer
Escribir "Ingrese A"
Leer A
Escribir "Ingrese B"
Leer B
sum <- A + B
Escribir sum
boton = 1
Fin Mientras
FinProceso

Problema N 6
Se trata de leer desde cualquier medio externo, SOLO dos nmeros, tales como A y B;
luego sumarlos e imprimir este resultado; todo este proceso debe hacerse tantas veces
hasta cundo como dato A venga un /* en cuyo caso debe finalizar. Elaborar el diagrama
que refleje las instrucciones para conseguir tal objetivo.
Proceso P6
Definir A como cadena
Definir B como numerico
Definir boton como logico
boton = 1
Mientras boton = 1 Hacer
Escribir "Ingrese A"
Leer A
Escribir "Ingrese B"
Leer B
Si A = "/" Entonces
boton = 0
Sino
A = char to num (A)
sum <- A + B
Escribir sum
boton = 1
Fin Si
Fin Mientras
FinProceso

Problema N 7
Se desea introducir por teclado dos nmeros (A y B), sumarlos; si la suma es mayor
que 500 imprimir el resultado y finalizar el proceso; caso contrario, finalizar el proceso.
Previo un anlisis elaborar un algoritmo que permita codificar en instrucciones a fin de
automatizar el proceso.
Proceso P7
Definir A, B, sAB Como Real
Escribir "Ingrese A"
Leer A
Escribir "Ingrese B"
Leer B
sAB = A +B
Si sAB>500 Entonces
Escribir sAB
FinSi
FinProceso

Problema N 8
Se debe obtener un listado de los primeros 100 nmeros mltiplos de 4: no se
necesitan datos de entrada; un anlisis elabrese un algoritmo que refleje las instrucciones
para que este proceso pueda ser automatizado.
Proceso P8
Definir n,c Como Entero
n<-4
c<-0
Repetir
Escribir n
n<-n+4
c<-c+1
Hasta Que c = 100
FinProceso

Problema N 9
Hora tras hora se va anotando en el dossier clnico la temperatura de los pacientes, medida
en grados centgrados, se trata de convertir dichas temperaturas a grados Fahrenheit; a

partir de la libreta se ha perforado una ficha para cada hora y temperatura. En una hoja de
salida hay que imprimir junto a cada hora la temperatura Fahrenheit y la centgrada.
Elabore, previo un anlisis el algoritmo que refleje las instrucciones necesarias para
que ste proceso sea automatizado.
NOTA: El final del archivo viene identificado por un 1 en la columna 80 en una tarjeta
adicional.

Problema N 10

Se desea obtener un listado de los primeros 100 nmeros pares y se desea


representar en pantalla en forma sucesiva los primeros 1.000 nmeros impares. No se
considera al nmero cero para nuestro objetivo. Previo un anlisis elabrese el algoritmo
que refleje las instrucciones para que ste proceso sea automatizado.
Proceso P10
Definir imp, p, ci, cp Como Entero
imp = 1
p=2
ci = 0
cp = 0
Repetir
Escribir imp
imp = imp + 2
ci = ci + 1
Si cp < 100 Entonces
Escribir p
p = p +2
cp = cp + 1
Fin Si
Hasta Que ci >= 1000
FinProceso

Problema N11
Se trata de leer 10 tarjetas con 10 pares de valores. Calcular el promedio de cada par de
valores e imprimir los valores ledos y su promedio. Elabore el algoritmo necesario para
codificar en instrucciones y automatizar el proceso.
Proceso P11
Definir tar, num_t Como Entero
Definir v1,v2,prom Como Real
tar = 0
Repetir
Leer num_t
v1 = (num_t%10)
v1 = (num_t - v1)/10
v2 = num_t - (v1*10)
prom = (v1 + v2)/2
Escribir prom
tar = tar +1
Hasta Que tar =10
FinProceso

Problema N 12
Se tiene dos tarjetas, en las que estn perforadas 2 nmeros enteros (uno en cada
tarjeta), siendo el de la segunda mayor que el de la primera. Se trata de elaborar un
algoritmo que refleje las instrucciones necesarias a fin de obtener la suma de todos los
enteros comprendidos entre esos dos nmeros, incluidos estos, e imprimir el resultado.
Proceso P12
Definir tar,sum, num1, num2,c
Como Entero
tar = 0
sum = 0
Leer num1
Leer num2
c = num1
Si num2 > num1 Entonces
Repetir
sum = sum + c
c=c+1
Hasta Que c > num2
Escribir sum
Fin Si
FinProceso

Problema N 13
La precipitacin lluviosa se calcula a partir de los datos diarios previamente
perforados en fichas; se pretende obtener un listado en donde aparezca el n de mediciones
y el promedio.
Previo un anlisis, elaborar el algoritmo para que el proceso se automatice.
NOTA: El final del lote de tarjetas est identificado por una tarjeta adicional que contiene
un /*.

Proceso P13
Definir c, sum, prom Como Real
Definir med Como Caracter
c=0
sum = 0
Repetir
Leer med
Si med <> "\" Entonces
c=c+1
sum = sum + med
Fin Si
Hasta Que med = "\"
prom = sum / c
Escribir c
Escribir prom
FinProceso

Problema N 14
Se trata de leer desde cualesquiera medios externos 2 nmeros B y N (B pertenece a los
nmeros reales y N a los enteros positivos), y desarrollar un proceso a fin de obtener el valor
de A que ser B ^N, imprimir este resultado y finalizar.
Elaborar el algoritmo que identifique el conjunto de instrucciones para lograr su
automatizacin.
NOTA: Considere que no es posible hacer la operacin de potenciacin directamente.
Proceso P14
Definir B,op como Real
Definir N,c como Entero
Leer B
op = B
Leer N
Repetir
op = op * B
c=c+1
Hasta Que c = (N-1)
Escribir op
FinProceso

Problema N 15
Se trata de leer desde cualquier medio un nmero entero positivo A y calcular su
factorial; imprimir este resultado y finalizar. Elabore previo un algoritmo las instrucciones
necesarias para automatizarlo a travs de un computador.
Proceso P15
Definir A,c,fact como Entero
Leer A
fact = A
c=A
Repetir
c=c-1
fact = fact * c
Hasta Que c = 1
Escribir fact
FinProceso

Problema N 16
Se trata de calcular el factorial de un nmero entero positivo N que viene perforado
en una tarjeta. Elaborar un algoritmo que identifique el proceso a seguirse para lograr
automatizarlo. NOTA: Se debe imprimir el nmero N y su factorial.
Proceso P16
Definir A,fact,c Como Entero
Leer A
fact = A
c=A
Repetir
c=c-1
fact = fact * c
Hasta Que c = 1
Escribir A
Escribir fact
FinProceso

Problema N 17
Otra forma de resolver el problema anterior (factorial). NOTA: funciona si N > 1
Proceso P17
Definir N,fact,c Como Entero
Repetir
Leer N
fact = N
c=N
Hasta Que N >1
Repetir
c=c-1
fact = fact * c
Hasta Que c =1
Escribir fact
FinProceso

Problema N 18
Se trata de calcular el promedio de 10 valores que vienen perforados a razn de uno
por tarjeta. Elaborar un algoritmo que refleje las instrucciones a darse al computador para
automatizar el proceso indicado.
Proceso Prom
Definir cont, pr como entero
pr1 como real
cont <- 0
pr <- 0
Repetir
cont <- cont+1
Escribir 'Ingresar ',cont,' nmero'
Leer num
pr <- pr+num
Hasta Que cont=10
<- pr/10
Escribir 'El promedio es ',pr1
FinProceso
Problema N 19
Y se debe calcular como una funcin de X de acuerdo a:
Y = 16.7X + 2.2X^2 1.02X^3
No hay datos de entrada: calcular e imprimir X y Y para valores de X de 1.0 a 9.9 con
incrementos de 0.1. Elaborar el algoritmo para lograr su automatizacin.

Problema N 20
Previo anlisis, elabrese el algoritmo necesario que refleje las instrucciones a darse
al computador para que resuelva el siguiente problema:
En un conjunto de fichas vienen perforadas 3 campos que representan las horas, los
minutos y los segundos en las que se toman unas ciertas temperaturas. El final de este
fichero est identificado por una tarjeta adicional que tiene 999 en el campo de horas: se
pretende obtener un listado con temperaturas y las horas, minutos, transformado a
segundos.
Al final del listado se obtendr el nmero total de temperaturas tomadas y el total de
segundos.

Proceso Temperaturas
Definir cont, pr,
hr, mn, sg como
entero
Definir hr2, mn2
como real
cont<-0
pr<-0
hr<-0
mn<-0
sg<-0
Escribir
"INGRESAR NUMERO DE
TEMPERATURAS A
TOMARSE"
Leer temp
Repetir
cont<cont+1
Escribir
cont " Temperatura
tomada"
Escribir
"Ingresar " cont " horas"
Leer hr
hr1<hr1+hr
Escribir
"Ingresar " cont " minuto"
Leer mn
mn1<mn1+mn
Escribir
"Ingresar " cont "
segundo"
Leer sg
sg1<-sg1+sg
Hasta Que cont=temp
hr2<-(hr1+999)/3600
mn2<-mn1/60
sgT<-sg1+hr2+mn2
Escribir "El numero de temperaturas tomadas fue " temp " y demor " sgT "
segundos."
FinProceso

Problema N 21
Se ha enviado al Instituto Nacional de Estadstica un lote de tarjetas perforadas. Cada
tarjeta corresponde a una Provincia y contiene: cdigo de Provincia; el nmero de
empleados pblicos con ttulo universitario; el nmero de empleados pblicos sin ttulo
universitario.
Elaborar un algoritmo que represente las instrucciones a darse al computador a fin de
obtener un listado con el total nacional de: Empleados pblicos con ttulo universitario:
Empleados pblicos sin ttulo universitario: Empleados Pblicos.

Problema N 22
Un supermercado perfora una ficha para cada venta que efecta a clientes que
tienen tarjeta DINNERS. Dichas fichas contienen el nmero del cliente y el importe de la
venta: al final del mes hay que calcular e imprimir un informe mensual que contenga lo
siguiente:
1. El listado de Los nmeros de los clientes a quienes se ha vendido
2. El importe de cada venta individual
3. El total de ventas efectuado
4. El porcentaje total a pagarse por concepto de comisin a la Compaa DINNERS,
sabiendo que se dar el 10 por ciento del valor total de ventas.
Previo un anlisis, elabrese un algoritmo que refleje las instrucciones a darse para
que este proceso se realice automticamente.
NOTA: El final del lote de tarjetas viene identificado por una tarjeta de FIN DE ARCHIVO
que contiene un /*.

Proceso Importe
Definir cont como entero
Definir imp,imp1 como real
cont<-0
imp1<-0
Escribir "Ingrese el numero total de clientes para el calculo del importe"
Leer clt
Repetir
cont<-cont+1
Escribir "Ingrese el importe del cliente 00" cont
Leer imp
imp1=imp1+imp
Hasta Que cont=clt
Escribir "El total de ventas es $" imp1
com<-0.10*(imp1)
Escribir "El valor del 10% a pagar por comisin a dinners es $" com
FinProceso
Problema N 23
Previo un anlisis, elaborar un algoritmo, que identifique el siguiente proceso: Leer
desde cualquier medio un numero N entero positivo, hallar el producto de los N primeros
nmeros impares, imprimir este resultado.

Problema N 24
Se trata de leer el valor de N que identifica a los N nmeros que deben ingresar con
el objeto de calcular su media aritmtica. Tanto N como los N valores vienen en cualquier
soporte.
Elabore el algoritmo que refleje las instrucciones necesarias para automatizar el
proceso.

Problema N 25
Se trata de detectar e imprimir el valor mximo del exponente al que debe ser elevado la
variable X de la serie:
X X^3/3 + X^5/5 X^7/7 + X^9/9.............. para que sea <= 10^-8 X (- :1]
X ingresara por teclado.
Elabore el algoritmo para automatizar el proceso indicado.
Proceso P25
Definir s,c,Res,op, X Como Real
s = -1
c=1
Res = 1
Leer X
Mientras X > 0 y X < (-1) Hacer
Leer X
Fin Mientras
Mientras Res > (10^(-8)) Hacer
s= s *(-1)
op = s*((X^c)/c)
Res = Res + op
c=c+2
Fin Mientras
c=c-2
Escribir Res
Escribir c
FinProceso

Problema N 26
Elaborar un algoritmo que identifique la realizacin de un modo alternado, de Los
procesos PROC 1 y PROC 2, un numero K de veces.

Problema N 27
Elaborar un algoritmo que refleje la realizacin de los procesos (PROC 1, PROC 1,
PROC 2), un numero M de veces.

Problema N 28
Elaborar un algoritmo que muestre la ejecucin de los procesos (PROC 1, PROC 2, PROC
3) en forma indefinida.

Problema N 29
Elaborar un algoritmo que muestre la ejecucin de los procesos (PROC 1, PROC 2,
PROC 3), un numero W de veces.

Problema N 30
Elaborar un algoritmo que refleje la ejecucin de la secuencia (PROC 1, PROC 2,
PROC 3, PROC 4) tantas veces, dependiendo del valor N que previamente se leer desde
cualquier medio, procediendo as:
Si n=100 hacer 100 veces la secuencia
N= 20 hacer 50 veces la secuencia
n = 20 hacer n veces la secuencia.