Você está na página 1de 6

algoritmo "Indice de Massa Corporal

"
// Função :
// Autor :MarcosdiAlencar
// Data : 14/09/2011
// Seção de Declarações
var
IMC,peso,altura:real
inicio
Escreval("Digite seu peso")
leia(peso)
Escreval("Digite sua altura")
leia(altura)
IMC <- peso / (altura^2)
Se IMC <= 18.5 entao
Escreval("Seu IMC - Indice de Massa Corporal é
com magreza")
senao
Se (IMC > 18.5) e (IMC < 24.5) entao
Escreval("Seu IMC - Indice de Massa Corporal é
saudável")
senao
Se (IMC > 24.5) e (IMC < 29.9) entao
Escreval("Seu IMC - Indice de Massa Corporal é
com peso em exesso")
senao
Se (IMC > 29.9) e (IMC < 34.9) entao
Escreval("Seu IMC - Indice de Massa Corporal é
em Obesidade I")
senao
Se (IMC > 34.9) e (IMC < 39.9) entao
Escreval("Seu IMC - Indice de Massa Corporal é
em obesidade II (severa)")
senao
Se IMC > 39.9 entao
Escreval("Seu IMC - Indice de Massa Corporal é
em Obesidade III(mórbida)")
Fimse
fimse
fimse
fimse
fimse
fimse
fimalgoritmo

:",IMC," e voce está

:",IMC," e voce está

:",IMC," e voce está

:",IMC," e voce está

:",IMC," e voce está

:",IMC," e voce está

swing. JOptionPane. // classe Scanner import javax. String h_resultado = ("\n\n Abaixo do peso: Menor que 20.util. calcular_IMC. altura.7.out.8. \n Peso ideal: Maior que 20. \n").8}. \n Para feminino digite [2]. if (nome_sexo == 1) { System. \n Acima do peso: 26.\n").nextInt().0) \n\n Criado por Jaqueline Beserra de Lima. double m_imc[] = {19.print("Qual é o seu sexo: masculino ou feminino? \n Para masculino digite [1]. \n Acima do peso: 25./* Calculo IMC criado por Jaqueline Beserra de Lima */ import java. // classe JOptionPane public class NewClass { public static void main(String args[]) { int sexo.\n"). Scanner input = new Scanner(System.Scanner.JOptionPane. sexo = input. String message = ("Bem vindo ao programa para Calcúlo de IMC! \n (Versão 1.").4. message).out. String m_resultado = ("\n\n Abaixo do peso: Menor que 19. double peso.4.7 e Menor que 26.O seu sexo é: masculino!"). double h_imc[] = {20.8.in). \n Peso ideal: Maior que 19.7.1 e Menor que 25. } .1.print(". // salva na váriavel sexo.4}.showMessageDialog(null. nome_sexo. 26. nome_sexo = sexo.1. 25. System.

out.2f metros!". calcular_IMC).print("\n\n Qual é a sua altura [Exemplo: 1.out. peso).print("\n\n Resultado IMC (Masculino):"). peso = input. } System.printf("\n.if (nome_sexo == 2) { System. System.out. } .A sua altura é: %6.out. // salva na váriavel altura.O seu sexo é: feminino!"). } if ((calcular_IMC > h_imc[0]) && (calcular_IMC < h_imc[1])) { System. System. System.out.print("\n\n Qual é o seu peso [Exemplo: 60.out.O seu IMC é: %6.out. altura).nextDouble().out.5]?\n").out.printf("\n. // calcula o valor do IMC if (sexo == 1) { if (calcular_IMC < h_imc[0]) { System.print("\n\n Resultado IMC (Masculino):"). // salva na váriavel peso.1f.out. System.70]?\n").O seu peso é: %6.out.print(".printf(". altura = input. System. Você está abaixo do peso!". System.print(h_resultado).1f kilogramas!". System. Você está no peso ideal!". calcular_IMC).print(h_resultado).printf(". calcular_IMC = peso / ((altura)*(altura)).nextDouble().1f.O seu IMC é: %6.

System.out.O seu IMC é: %6.printf("\n. Você está abaixo do peso!".out.print(h_resultado). System.out.print("\n\n Resultado IMC (Feminino):").print("\n\n Resultado IMC (Feminino):").print(m_resultado). Você está no peso ideal!".if (calcular_IMC > h_imc[1]) { System. } } if (sexo == 2) { if (calcular_IMC < m_imc[0]) { System.print("\n\n Resultado IMC (Masculino):"). Você está acima do peso!".out.out. System.out. .1f. calcular_IMC). calcular_IMC). System.out. } if (calcular_IMC > m_imc[1]) { System.O seu IMC é: %6.O seu IMC é: %6.1f. System. System.out.out.printf("\n. System.print("\n\n Resultado IMC (Feminino):").O seu IMC é: %6.out.printf("\n.print(m_resultado).print(m_resultado).1f.out. Você está acima do peso!". calcular_IMC). calcular_IMC).printf("\n.1f. System.out. } if ((calcular_IMC > m_imc[0]) && (calcular_IMC < m_imc[1])) { System.

printf("**ESTE PROGRAMA ANALISA SEU IMC (Prova .altura=0.h> #include <stdlib. Entre 18 e 25 sarado. %s \n\n". &nome).h>//Inclusão da Biblioteca para entrada e saída de dados main() //Inicio da função principal main { int peso=0. . > que 30 obeso. printf("Qual sua altura? ").} } } } // fim da classe Calculo_IMC #include <stdio.&peso). float imc=0. //se imc<18 abaixo do peso.Jaqueline Beserra**\n\n"). printf ("Boa noite. char nome[999]. nome). getche(). scanf("%d". Entre 26 e 30 acima. scanf ("%s". printf("Digite sua peso: "). printf ("Digite seu nome: \n\n").

} . Voce esta acima do peso. Trate-se imediatamente. else if (imc<=30) printf("Atencao. //Dá uma pausa no sistema. imc=peso/(altura*altura).\n\n").\n\n").&altura). else if (imc<=25) printf("Parabens.\n\n"). if (imc<18) printf("Voce esta abaixo do peso. Pode ser trocado por system("pause").\n\n"). getch(). Voce esta sarado. else printf("Voce e OBESO.scanf("%f".