Você está na página 1de 6

algoritmo "Indice de Massa Corporal"

// Funo :
// Autor :MarcosdiAlencar
// Data : 14/09/2011
// Seo de Declaraes
var
IMC,peso,altura:real
inicio
Escreval("Digite seu peso")
leia(peso)
Escreval("Digite sua altura")
leia(altura)
IMC <- peso / (altura^2)
Se IMC <= 18.5 entao
Escreval("Seu IMC - Indice de Massa Corporal
com magreza")
senao
Se (IMC > 18.5) e (IMC < 24.5) entao
Escreval("Seu IMC - Indice de Massa Corporal
saudvel")
senao
Se (IMC > 24.5) e (IMC < 29.9) entao
Escreval("Seu IMC - Indice de Massa Corporal
com peso em exesso")
senao
Se (IMC > 29.9) e (IMC < 34.9) entao
Escreval("Seu IMC - Indice de Massa Corporal
em Obesidade I")
senao
Se (IMC > 34.9) e (IMC < 39.9) entao
Escreval("Seu IMC - Indice de Massa Corporal
em obesidade II (severa)")
senao
Se IMC > 39.9 entao
Escreval("Seu IMC - Indice de Massa Corporal
em Obesidade III(mrbida)")
Fimse
fimse
fimse
fimse
fimse
fimse
fimalgoritmo

:",IMC," e voce est

:",IMC," e voce est

:",IMC," e voce est

:",IMC," e voce est

:",IMC," e voce est

:",IMC," e voce est

/* Calculo IMC
criado por Jaqueline Beserra de Lima */

import java.util.Scanner; // classe Scanner


import javax.swing.JOptionPane; // classe JOptionPane

public class NewClass


{
public static void main(String args[])
{
int sexo, nome_sexo;
double peso, altura, calcular_IMC;
double h_imc[] = {20.7, 26.4};
double m_imc[] = {19.1, 25.8};
String h_resultado = ("\n\n Abaixo do peso: Menor que 20,7. \n Peso
ideal: Maior que 20,7 e Menor que 26,4. \n Acima do peso: 26,4.\n");
String m_resultado = ("\n\n Abaixo do peso: Menor que 19,1. \n Peso
ideal: Maior que 19,1 e Menor que 25,8. \n Acima do peso: 25,8.\n");

String message = ("Bem vindo ao programa para Calclo de IMC! \n


(Verso 1.0) \n\n Criado por Jaqueline Beserra de Lima.");
JOptionPane.showMessageDialog(null, message);

Scanner input = new Scanner(System.in);

System.out.print("Qual o seu sexo: masculino ou feminino? \n Para


masculino digite [1]. \n Para feminino digite [2]. \n");
sexo = input.nextInt(); // salva na vriavel sexo.
nome_sexo = sexo;

if (nome_sexo == 1)
{
System.out.print("- O seu sexo : masculino!");
}

if (nome_sexo == 2)
{
System.out.print("- O seu sexo : feminino!");
}

System.out.print("\n\n Qual o seu peso [Exemplo: 60,5]?\n");


peso = input.nextDouble(); // salva na vriavel peso.
System.out.printf("- O seu peso : %6.1f kilogramas!", peso);

System.out.print("\n\n Qual a sua altura [Exemplo: 1,70]?\n");


altura = input.nextDouble(); // salva na vriavel altura.
System.out.printf("- A sua altura : %6.2f metros!", altura);

calcular_IMC = peso / ((altura)*(altura)); // calcula o valor do IMC

if (sexo == 1)
{
if (calcular_IMC < h_imc[0])
{
System.out.print("\n\n Resultado IMC (Masculino):");
System.out.printf("\n- O seu IMC : %6.1f. Voc est abaixo do
peso!", calcular_IMC);
System.out.print(h_resultado);
}

if ((calcular_IMC > h_imc[0]) && (calcular_IMC < h_imc[1]))


{
System.out.print("\n\n Resultado IMC (Masculino):");
System.out.printf("\n- O seu IMC : %6.1f. Voc est no peso
ideal!", calcular_IMC);
System.out.print(h_resultado);
}

if (calcular_IMC > h_imc[1])


{
System.out.print("\n\n Resultado IMC (Masculino):");
System.out.printf("\n- O seu IMC : %6.1f. Voc est acima do
peso!", calcular_IMC);
System.out.print(h_resultado);
}
}

if (sexo == 2)
{
if (calcular_IMC < m_imc[0])
{
System.out.print("\n\n Resultado IMC (Feminino):");
System.out.printf("\n- O seu IMC : %6.1f. Voc est abaixo do
peso!", calcular_IMC);
System.out.print(m_resultado);
}

if ((calcular_IMC > m_imc[0]) && (calcular_IMC < m_imc[1]))


{
System.out.print("\n\n Resultado IMC (Feminino):");
System.out.printf("\n- O seu IMC : %6.1f. Voc est no peso
ideal!", calcular_IMC);
System.out.print(m_resultado);
}

if (calcular_IMC > m_imc[1])


{
System.out.print("\n\n Resultado IMC (Feminino):");
System.out.printf("\n- O seu IMC : %6.1f. Voc est acima do
peso!", calcular_IMC);
System.out.print(m_resultado);

}
}
}
} // fim da classe Calculo_IMC

#include <stdio.h>
#include <stdlib.h>//Incluso da Biblioteca para entrada e sada de dados
main()

//Inicio da funo principal main

{
int peso=0;
//se imc<18 abaixo do peso. Entre 18 e 25 sarado.
Entre 26 e 30 acima. > que 30 obeso.
float imc=0,altura=0;
char nome[999];

printf("**ESTE PROGRAMA ANALISA SEU IMC (Prova - Jaqueline


Beserra**\n\n");
printf ("Digite seu nome: \n\n");
scanf ("%s", &nome);
printf ("Boa noite, %s \n\n", nome);
getche();

printf("Digite sua peso: ");


scanf("%d",&peso);
printf("Qual sua altura? ");

scanf("%f",&altura);
imc=peso/(altura*altura);
if (imc<18) printf("Voce esta abaixo do peso.\n\n");
else if (imc<=25) printf("Parabens. Voce esta sarado.\n\n");
else if (imc<=30) printf("Atencao. Voce esta acima do peso.\n\n");
else printf("Voce e OBESO. Trate-se imediatamente.\n\n");

getch(); //D uma pausa no sistema. Pode ser trocado por


system("pause");
}

Você também pode gostar