Você está na página 1de 44

ApplicationNotesMPLS

maro/2013

ApplicationNotesMPLS

Glossrio...............................................................................................................................................4
1CenrioseServios..........................................................................................................................6
2ConfiguraesBsicas......................................................................................................................8
2.1ConfiguraoBsicadosSwitchesDM4000............................................................................8
2.1.1DM4004PE1....................................................................................................................8
2.1.2DM4001PE2....................................................................................................................9
2.1.3DM4001PE3..................................................................................................................10
2.2ConfiguraoBsicadoSwitchesDM3000...........................................................................12
2.2.1DM3000CE1..................................................................................................................12
2.2.2DM3000CE2..................................................................................................................12
2.2.3DM3000CE3..................................................................................................................13
3ConfiguraesdeRoteamento........................................................................................................14
4.1ExemplodeconfiguraodoprotocoloOSPF.......................................................................14
4.1.1DM4004PE1..................................................................................................................14
4.1.2DM4001PE2..................................................................................................................14
4.1.3DM4001PE3..................................................................................................................15
5ConfiguraesdaInfraestruturaMPLS..........................................................................................16
5.1InfraestruturaMPLS:ProtocoloLDP.....................................................................................16
5.1.1OperaodoProtocoloLDP...........................................................................................16
5.1.1.1MododedescobrimentobsicodavizinhanaLDP...............................................16
5.1.1.2MododedescobrimentoestendidodavizinhanaLDP..........................................17
5.1.1.3EstabelecimentodeSessesLDP............................................................................17
5.1.1.4Gerenciamentoedistribuiodelabels...................................................................17
5.1.1.5Anunciandoosendereosdeinterface....................................................................18
5.1.1.6DivulgandoLabels..................................................................................................18
5.1.1.7MensagensdeNotificao.......................................................................................18
5.1.1.8ManutenodasSessesLDP.................................................................................18
5.1.1.9ManutenodasAdjacnciasLDP..........................................................................18
5.1.2ConfigurandoLDPemSwitchesDatacom.....................................................................19
5.1.2.1ExemplosdeConfiguraes....................................................................................19
5.1.3VerificaoLDP.............................................................................................................21
5.2InfraestruturaMPLS:ProtocoloRSVPTE............................................................................23
5.2.1MododeOperaodoprotocoloRSVP..........................................................................23
5.2.1.1RSVPPathMessages..............................................................................................23
5.2.1.2RSVPResvMessage...............................................................................................23
5.2.1.3RSVPErrorMessage...............................................................................................23
5.2.1.4RSVPTearMessage................................................................................................23
5.2.2ExemplodeconfiguraodoRSVPnosSwitchesDatacom..........................................24
5.2.2.1ExemplodeConfiguraodoprotocoloRSVPTE................................................25

Page 2

5.2.3VerificaodosTneisRSVP.........................................................................................27
5.3TunelamentodeLDPsobreRSVPTE...................................................................................29
5.3.1ExemplodeConfiguraodoLDPoRSVP.....................................................................29
5.3.2VerificaodoLDPoRSVP............................................................................................31
6ServiosMPLS...............................................................................................................................32
6.1Layer2VirtualPrivateNetworkL2VPN............................................................................32
6.1.1ExemplodeCenrioL2VPNVPWS..............................................................................33
6.1.1.1VerificandoEstadoOperacionaldeVPWS.............................................................34
6.1.1.2RemovendoConfiguraodeVPWS......................................................................35
6.1.2ExemplodeConfiguraodeL2VPNVPWScomBackupPW....................................36
6.1.2.1VerificandoEstadoOperacionaldeVPWScomBackupPW................................37
6.1.2.2RemovendoConfiguraodeBackupPW..............................................................37
6.1.3ExemplodeCenrioL2VPNVPLS................................................................................39
6.1.3.1VerificandoEstadoOperacionaldeVPLS..............................................................39
6.1.3.2RemovendoConfiguraodeVPLS.......................................................................40
6.1.4ExemplodeCenrioL2VPNHVPLS...........................................................................41
6.1.4.1VerificandoEstadoOperacionaldeHVPLS..........................................................41
7QoS.................................................................................................................................................43
7.1ExemplodeConfiguraodeQoS..........................................................................................43
7.1.1ConfiguraoComumparaTodososPEs......................................................................43
7.1.2Verificandoaconfigurao.............................................................................................44

Page 3

Glossrio
ABR
AS
ASBR
BGP
CSPF
CE
CoS
EBGP
EVC
FEC
FRR
HVPLS
IBGP
IGP
L2VPN
LAG
LDP
LER
LIB
LSP
LSR
MP2MP
MPBGP
MPLS
NE
OSPF
OSPFTE
P2MP
P2P
PE
PHP
PWE3
PWID
QoS
RSVP
RSVPTE
TE
TLV
VC

AreaBorderRouter
AutonomousSystem
AutonomousSystemBoundaryRouter
BorderGatewayProtocol
ConstraintShortestPathFirst
CustomerEdge
ClassofService
ExternalBorderGatewayProtocol
EthernetVirtualConnection
ForwardingEquivalenceClasses
FastReroute
HierarchicalVirtualPrivateLANService
InternalBorderGatewayProtocol
InteriorGatewayProtocol
Layer2VirtualPrivateNetwork
LinkAggregation
LabelDistributionProtocol
LabelEdgeRouter
LabelInformationBase
LabelSwitchedPath
LabelSwitchingRouter
MultiPointtoMultiPoint
MultiprotocolBorderGatewayProtocol
MultiProtocolLabelSwitching
NetworkElement
OpenShortestPathFirst
OpenShortestPathFirstTrafficEngineering
PointtoMultiPoint
PointtoPoint
ProviderEdge
PenultimateHopPopping
PseudoWireEmulationEdgetoEdge
PseudoWireIdentifier
QualityofService
ResourceReservationProtocol
ResourceReservationProtocolTrafficEngineering
TrafficEngineering
TypeLengthValuestructureusedinLDPmessages
VirtualCircuit

Page 4

VPLS
VPWS
VRF

VirtualPrivateLANService
VirtualPrivateWireService
VPNRoutingandForwarding

Page 5

1 CenrioseServios
A topologia abaixo ser utilizada como referncia para a execuo do caderno MPLS
demonstradonestedocumento.
PC 1

CE 1

DM 4004-PE 1

IP / M P L S
10G
DM 4001-PE 2

D M 4001-PE 3

CE 2

CE 3

PC 2

PC 3

AlinhatracejadaacimarepresentaumlinkqueserusadoapenasnostestesdeVPWScom
BackupPW,naseo(6.1.2).

Page 6

Asseguintesfuneslgicasestorepresentadasnatopologiaacima:

Core10GdaredeIP:representadopelosequipamentosPE1,PE2ePE3;

Equipamentosdeclientes:representadospeloselementosCE1,CE2eCE3;

Destaforma,algunsexemplosdeconfiguraoMPLSserocobertosporestedocumento*:

InfraestruturaMPLSutilizandoLDP;

InfraestruturaMPLSutilizandoLDPoRSVP;

L2VPNVPWSouEVCpontoaponto(P2P);

L2VPNVPWScomBackupPW;

L2VPNVPLSEVCpontoamultiponto(P2MP)oumultipontoamultiponto(MP2MP);

L2VPNHVPLSouhubandspokeEVCP2MP;

*ParamaioresinformaessobrecomandosutilizadosnoMPLS,consultardocumento
DmSwitchCommandReference.

Page 7

2 ConfiguraesBsicas
Estecaptulocontmasconfiguraesbsicasdosequipamentos,taiscomoplanodeVLANs,
endereamentoIP,servidordeclock,dentreoutros.
ValelembrarqueosequipamentosPEdatopologiadevero,previamente,possuiraversode
firmwareealicenahabilitada,especficosparaafuncionalidadeMPLS.

2.1 ConfiguraoBsicadosSwitchesDM4000
2.1.1 DM4004PE1
!
hostname Dm4004_PE1
!
no terminal paging
!
ip routing
!
ip default-gateway 172.16.1.254
!
monitor destination 1/8
!
sntp client
sntp server 172.16.1.94
clock timezone BRA -3
!
cpu-dos-protect rate-limit global 350
!
interface vlan 100
set-member tagged ethernet 1/4
!
interface vlan range 1500 1502
set-member tagged ethernet 1/1
!
interface vlan 3106
ip address 40.40.6.2/30
set-member untagged ethernet 1/26
link-detect
!
interface vlan 3108
ip address 40.40.8.1/30
set-member untagged ethernet 1/25
link-detect
!
interface ethernet 1/1
no loopback-detection
monitor source all
!
interface ethernet 1/4
no loopback-detection
switchport native vlan 100
monitor source all

Page 8

!
interface ethernet 1/25
no loopback-detection
switchport native vlan 3108
monitor source all
!
interface ethernet 1/26
no loopback-detection
switchport native vlan 3106
monitor source all
!
interface loopback 0
ip address 1.1.1.1/32
!
interface mgmt-eth
ip address 172.16.1.211/24
!
interface vlan 1
no set-member ethernet all
!
no spanning-tree 1
!

2.1.2 DM4001PE2
!
hostname Dm4001_PE2
!
no terminal paging
!
ip routing
!
ip default-gateway 172.16.1.254
!
monitor destination 1/8
!
sntp client
sntp server 172.16.1.94
clock timezone BRA -3
!
cpu-dos-protect rate-limit global 350
!
interface vlan 100
set-member tagged ethernet 1/4
!
interface vlan range 1500 1502
set-member tagged ethernet 1/1
!
interface vlan 3100
ip address 40.40.0.2/30
set-member untagged ethernet 1/25
link-detect
!
interface vlan 3108
ip address 40.40.8.2/30
set-member untagged ethernet 1/26
link-detect
!
interface ethernet 1/1
no loopback-detection
monitor source all

Page 9

!
interface ethernet 1/4
no loopback-detection
switchport native vlan 100
monitor source all
!
interface ethernet 1/25
no loopback-detection
switchport native vlan 3100
monitor source all
!
interface ethernet 1/26
no loopback-detection
switchport native vlan 3108
monitor source all
!
interface loopback 0
ip address 1.1.1.2/32
!
interface mgmt-eth
ip address 172.16.1.169/24
!
interface vlan 1
no set-member ethernet all
!
no spanning-tree 1
!

2.1.3 DM4001PE3
!
hostname Dm4001_PE3
!
no terminal paging
!
ip routing
!
ip default-gateway 172.16.1.254
!
monitor destination 1/8
!
sntp client
sntp server 172.16.1.94
clock timezone BRA -3
!
cpu-dos-protect rate-limit global 350
!
interface vlan 100
set-member tagged ethernet 1/4
!
interface vlan range 1500 1502
set-member tagged ethernet 1/1
!
interface vlan 3100
ip address 40.40.0.1/30
set-member untagged ethernet 1/25
link-detect
!
interface vlan 3106
ip address 40.40.6.1/30
set-member untagged ethernet 1/26

Page 10

link-detect
!
interface ethernet 1/1
no loopback-detection
monitor source all
!
interface ethernet 1/4
no loopback-detection
switchport native vlan 100
monitor source all
!
interface ethernet 1/25
no loopback-detection
switchport native vlan 3100
monitor source all
!
interface ethernet 1/26
no loopback-detection
switchport native vlan 3106
monitor source all
!
interface loopback 0
ip address 1.1.1.3/32
!
interface mgmt-eth
ip address 172.16.1.188/24
!
interface vlan 1
no set-member ethernet all
!
no spanning-tree 1
!

Page 11

2.2 ConfiguraoBsicadoSwitchesDM3000
2.2.1 DM3000CE1
hostname Dm3000_CE1
!
monitor destination 1/8
!
ip routing
!
interface vlan range 1500 1502
set-member tagged ethernet 1/25
set-member tagged ethernet 1/28
!
interface vlan 1511
ip address 100.100.5.162/28
set-member tagged ethernet 1/25
!
interface vlan 2001
ip address 192.168.10.2/24
set-member tagged ethernet 1/28
!
interface ethernet 1/25
monitor source all
no loopback-detection
!
interface ethernet 1/28
monitor source all
no loopback-detection
!
interface loopback 0
ip address 50.50.50.1/32
!
interface vlan 1
no set-member ethernet all
!
no spanning-tree 1
!

2.2.2 DM3000CE2
hostname Dm3000_CE2
!
monitor destination 1/8
!
ip routing
!
interface vlan range 1500 1502
set-member tagged ethernet 1/25
set-member tagged ethernet 1/28
!
interface vlan 1512
ip address 100.100.5.146/28
set-member tagged ethernet 1/25
!
interface vlan 2002
ip address 192.168.20.2/24
set-member tagged ethernet 1/28

Page 12

!
interface ethernet 1/25
monitor source all
no loopback-detection
!
interface ethernet 1/28
monitor source all
no loopback-detection
!
interface loopback 0
ip address 50.50.50.2/32
!
interface vlan 1
no set-member ethernet all
!
no spanning-tree 1
!

2.2.3 DM3000CE3
hostname Dm3000_CE3
!
monitor destination 1/8
!
ip routing
!
interface vlan range 1500 1502
set-member tagged ethernet 1/25
set-member tagged ethernet 1/28
!
interface vlan 1513
ip address 100.100.5.130/28
set-member tagged ethernet 1/25
!
interface vlan 2003
ip address 192.168.30.2/24
set-member tagged ethernet 1/28
!
interface ethernet 1/25
monitor source all
no loopback-detection
!
interface ethernet 1/28
monitor source all
no loopback-detection
!
interface loopback 0
ip address 50.50.50.3/32
!
interface vlan 1
no set-member ethernet all
!
no spanning-tree 1
!

Page 13

3 ConfiguraesdeRoteamento
4 OsitensaseguirapresentamumexemplodeconfiguraoparaativaodoprotocoloIGP
nosequipamentosDatacom.Nesteexemplo,serutilizadooprotocoloderoteamentoOSPF.

4.1 ExemplodeconfiguraodoprotocoloOSPF
Os roteadores PEsero configurados em uma nica rea OSPF denominada rea 0.As
mensagensOSPFutilizaroautenticaocriptografadaMD5.Nesteexemplo,seroconfiguradas
porinterfacevlannosequipamentos.
4.1.1 DM4004PE1
router ospf
network 40.40.6.0/30 area 0.0.0.0
network 40.40.8.0/30 area 0.0.0.0
network 1.1.1.1/32 area 0.0.0.0
router-id 1.1.1.1
!
interface vlan 3106
ip ospf network point-to-point
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 datacom6
!
interface vlan 3108
ip ospf network point-to-point
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 datacom8
!

4.1.2 DM4001PE2
router ospf
network 40.40.0.0/30 area 0.0.0.0
network 40.40.8.0/30 area 0.0.0.0
network 1.1.1.2/32 area 0.0.0.0
router-id 1.1.1.2
!
interface vlan 3100
ip ospf network point-to-point
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 datacom0
!
interface vlan 3108
ip ospf network point-to-point
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 datacom8
!

Page 14

4.1.3 DM4001PE3
router ospf
network 40.40.0.0/30 area 0.0.0.0
network 40.40.6.0/30 area 0.0.0.0
network 1.1.1.3/32 area 0.0.0.0
router-id 1.1.1.3
!
interface vlan 3100
ip ospf network point-to-point
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 datacom0
!
interface vlan 3106
ip ospf network point-to-point
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 datacom6
!

Page 15

5 ConfiguraesdaInfraestruturaMPLS
OsdoisprotocolosdesinalizaosuportadospeloswitchDatacomsooResourceReservation
Protocol (RSVP) eo Label Distribution Protocol (LDP).RSVP um protocolo de sinalizao
genricoquefoiadaptadoparaousodoMPLS.JoLDPfoidesenvolvidoexclusivamenteparao
MPLS.Essesdoisprotocolossoindependentesumdooutro,maspodemserusadosemconjunto
namesmarede.
A seguir, sero apresentadas as configuraes dos protocolos MPLS para a formao de
caminhos(LSPs)emumaredeemtopologiaanel10G.Nesteexemplo,serdemonstradoocaso
ondeoprotocoloLDPutilizadoparaadistribuiodoslabels.

5.1 InfraestruturaMPLS:ProtocoloLDP
OprotocoloLDP,especificadopelaRFC3036,foidesenvolvidopeloMPLSWorkingGroupdo
IETFnofinaldadcadade1990.
AlgumasconsideraesemrelaoaoprotocoloLDP:
O protocolo LDP foi desenvolvido especificamente para a utilizao de MPLS e no tem
capacidadedeTE(trafficengineering);

CadacaminhoLSPsegueoIGPdarede,nocaso,serutilizadooOSPF;

Cada roteador LDP anuncia um endereo via label MPLS dentro do domnio LDP. Essa
informaotrocadaentreosvizinhosfazendocomquetodososroteadoresdaredesejamingress
routersparatodososegressrouters.OresultadofinalumfullmeshdeLSPs;

DetectavizinhosatravsdemensagensHelloLDP(UDP,port:646)e,seencontrado,criauma
conexoTCP(port:646)comosvizinhosparatrocarinformaesdoslabels;

5.1.1 OperaodoProtocoloLDP
5.1.1.1 MododedescobrimentobsicodavizinhanaLDP
QuandooprotocoloLDPiniciadonoequipamento, LDPLinkHellomessages soenviadas
paratodasasinterfacesdavlanquepossuemoLDPhabilitado.Essasmensagenspossuemendereo
IPmulticastdedestinoconhecido224.0.0.2/32esoenviadaspelaportaUDP646.AsLDPHello
messagescontmumcampocomaidentificaodoLDPeutilizaanotao<RouterID:Label
Space>.OLDPIDpossui6bytes,4bytesrepresentandooRouterID(ouLSRid)e2bytesoLabel
Space.OswitchDatacomutilizalabelspaceiguala0,oquerepresentaquelabelsrecebidosso
compartilhadosportodasasinterfacesdoequipamento(perplatform).

Page 16

5.1.1.2 MododedescobrimentoestendidodavizinhanaLDP
EstemecanismodedescobrimentodevizinhanasLDPutiliza LDPTargetedHello

messages

,
cujoprincpiodefuncionamentodiferedo anteriorsomentepelofatodeasmensagensserem
enviadasemunicast,diretamenteaoroteadordedestino,aoinvsdemensagensmulticast.
5.1.1.3 EstabelecimentodeSessesLDP
QuandodoisvizinhosLDPconhecemseusrespectivos labelspaceeoendereodetransporte,
aprendidosviaLDPHellomessages,umasessoLDPpodeserestabelecida.Essasessousada
paraoanunciodosendereosdasinterfaces,labelseprefixosalcanveisatravsdasLSPs.Para
umamaiorconfiabilidadedasinformaes,essasessoestabelecidaviaprotocoloTCPpelaporta
646einiciadapeloroteadorcommaiorLSRid,conhecidocomonativo.Quandoosvizinhosse
comunicamviaprotocoloTCP,onativo(activenode)enviaumaLDPinitializationmessagepara
oseupeer(passivenode).Essamensagemdeinicializaocontminformaesbsicasnecessrias
paraestabelecerumasessoLDPentreosvizinhos(porexemplo,versodoprotocoloLDP,mtodo
dedistribuiodelabels,dentreoutros).
5.1.1.4 Gerenciamentoedistribuiodelabels
a)MtodosdeDistribuiodeLabels:
UnsolicitedDownstream:umLSRdistribuilabelsassociadosparaoutrosLSRssemquetenha
sidoexplicitamentesolicitado;
Downstreamondemand:umLSRsolicitaumlabelassociadoparaumFECemparticularpara
seuLSRvizinho.

OsequipamentosDatacomutilizamomtododedistribuiodelabelsUnsolicitedDownstream.
b)MododeRetenodeLabels
Liberal:umLSRarmazenatodososlabelsassociadosaumaFECemparticularrecebidosde
diferentesLSR,osquaisnosonecessariamenteosLSRdiretamenteconectados.

Conservative: um LSR descarta labels associados que so recebidos de outro LSR no


diretamenteconectados.

OsswitchesDatacomutilizamomododeretenodelabelsLiberal.
c)MododealocaodeLabels
Independent:umLSRpodeanunciarlabelsassociadosparaumLSRdiretamenteconectadoa
qualquermomento.

Ordered: um LSR pode anunciar labels associados para um LSR diretamente conectado
somentesetiverrecebidodeseudownstreamLSRumlabelassociadoparaadeterminadaFECou
seexistirumegressLSRparaaquelaFEC.

OsswitchesDatacomutilizamomododealocaodelabelsOrdered.

Page 17

5.1.1.5 Anunciandoosendereosdeinterface
AprimeirainformaotransmitidaentredoispeersoendereodasinterfacesLDPdoroteador.
Issopermitequeosroteadoresdedestinoassociemumlabelcomainterfacefsicadonexthop.
EssainformaotransmitidapelaLDPaddressmessage.
5.1.1.6 DivulgandoLabels
A distribuio de labels para cada FEC ocorre, geralmente, pelo envio de Label Mapping
messages,ondeum LSRrecebeumamensagemdoroteadordownstreameadivulganosentido
upstream. Osroteadoresdownstreamquerecebemopacote,(localizadosnofinalounomeiodo
LSP)informamparaoupstream(roteadorimediatamenteanterior)quallabeldeverserusadono
LSP.OslabelsdosVirtualCircuitscriados(VClabels)tambmsodivulgadosviaLabelMapping
messages.
QuandoumLSRquerretirarumaFECeumlabelanunciado,eleenviaumaLabelWithdrawn
message.
AsLabelRequestmessagessoutilizadasporumLSRupstreamparaexplicitamentesolicitar
queoLSRdownstreamatribuaedivulgueumlabelparaumadeterminadaFEC.
5.1.1.7 MensagensdeNotificao
LDPNotificationmessagescarregamstatusdosTLVs,informandoeventosespecficosqueesto
sendosinalizados.Porexemplo,nosequipamentosDatacom,LDPNotificationMessagespodem
ser enviadas a um LSR vizinho para sinalizar que a porta de acesso local de uma VPN
VPWS/VPLSmodificouseustatusatual(updown)e,portanto,ostatusdoVCremotodeveriaser,
damesmaforma,modificadoparadown;
5.1.1.8 ManutenodasSessesLDP
DepoisqueumasessoLDPestabelecida,umLSRmantmaintegridadedasessoenviando
LDP Keep Alive messages a cada 60 segundos, por default. A temporizao do Keepalive
reiniciada toda vez que um pacote recebido por aquela sesso LDP. Se a temporizao do
Keepaliveexpira(180segundos,pordefault),oLDPconcluiqueaconexoTCPestdeterioradae
queopeernoestmaisativo.
Um LSRpodefinalizarumasessoLDPaqualquermomentoenviandouma LDPShutdown
messageparaopeer.
5.1.1.9 ManutenodasAdjacnciasLDP
OLDPutilizaorecebimentoconstantedeLDPHellomessagesparaindicaraintenodeum
peeremcontinuarutilizandoumdeterminadolabelspace.UmLSRmantmumHoldTimerpara
cadaadjacncia,oqualreiniciadoacadarecebimentodeumaHellomenssageenviadaporuma

Page 18

adjacnciaemparticular.Seatemporizaoexpira,oLDPconcluiqueaquelepeernodesejamais
trocarlabelscomaquelelabelspaceouopeernoestmaisativo.OLDP,ento,finalizaasesso
estabelecidaatravsdoenviodeumaLDPNotificationmessageedofechamentodaconexoTCP.
5.1.2 ConfigurandoLDPemSwitchesDatacom
OspassosabaixodevemserseguidosparaaconfiguraodoLDP:

1)HabilitantoMPLSnaInterfaceloopback:comopremissaparautilizaodoMPLS,
necessriohabilitloemumainterfaceloopback.EsteconfiguraodefiniroLSRidutilizado
pelosswitchesDatacom;
2)HabilitandoLDPnainterfaceVlan: paraqueinformaesdelabelssejamtrocadas
entreosswitchespertencentesaodomnioMPLS,oLDPdeveestarhabilitadonasinterfacevlando
equipamentos.Pordefault,oswitchDatacomanunciasomenteainterfaceLoopbackcomoFEC,
possibilitandoquetodososroteadoresnaredeestabeleamumLSPcomsuasloopbacks,criando
assim,umfullmeshdeLSPs.
3)DefinindoLDPTargeted Sessions: Emumcenrioemanel,casoos links entreos
switchesvizinhosfalhem,assessesLDPseromantidasviaassessesLDPtargetedredundantes
criadas;
5.1.2.1 ExemplosdeConfiguraes
a) DM4004PE1:
interface loopback 0
mpls enable
!
interface vlan 3106
ldp enable
!
interface vlan 3108
ldp enable
!

Page 19

mpls ldp neighbor 1.1.1.2


!
mpls ldp neighbor 1.1.1.3

b) DM4001PE2:
interface loopback 0
mpls enable
!
interface vlan 3100
ldp enable
!
interface vlan 3108
ldp enable
!
mpls ldp neighbor 1.1.1.1
!
mpls ldp neighbor 1.1.1.3

c) DM4001PE3:
interface loopback 0
mpls enable
!
interface vlan 3100
ldp enable
!
interface vlan 3106
ldp enable
!
mpls ldp neighbor 1.1.1.1
!
mpls ldp neighbor 1.1.1.2

Page 20

5.1.3 VerificaoLDP
LDPDiscovery:mostraasvizinhanasLDPmantidaspelasHellomessages(UDP,port646),via
mododedescobrimentobsico(multicast)ouestendido(unicast);
Dm4001_PE1(config)#sh mpls ldp discovery
---------------------------------------------------------------------------Adjacency ID
|Discovery Mechanism
|Hold Time
|
---------------------------------------------------------------------------1.1.1.2:0|
Basic|
15 s|
1.1.1.2:0|
Extended|
45 s|
1.1.1.3:0|
Basic|
15 s|
1.1.1.3:0|
Extended|
45 s|
----------------------------------------------------------------------------

LDPNeighbor:mostraassessesLDPestabelecidas(TCP,port646).Notequeafunolocal
(localrole)podeserPassivaouAtiva.OvizinhocomomaiorLSRiddesempenhaafunoativa:
Dm4001_PE1(config)#sh mpls ldp neighbor
---------------------------------------------------------------------------Adjacency ID
|Status
|Local Role
|
---------------------------------------------------------------------------1.1.1.2:0|
Operational|
Passive|
1.1.1.3:0|
Operational|
Passive|
----------------------------------------------------------------------------

LDPDatabase:mostratodasasFECseosLSPspossveisparacadaumadelas,atravsdoslabels
aprendidosdosswitchesdownstreameenviadosparaosswitchesupstream,duranteatrocade
LabelMappingMessages;
Dm4001_PE1(config)#sh mpls ldp database
Number of Entries: 9
Number of FECs...: 3
NS = Not Selected
------------------------------------------------------------------------------Network Prefix
|UpStream LSR-ID
|Label
|DownStream LSR-ID |Label
|
------------------------------------------------------------------------------1.1.1.1/32|
1.1.1.2|
3|
-|
-|
1.1.1.1/32|
1.1.1.3|
3|
-|
-|
NS
1.1.1.1/32|
-|
-|
1.1.1.2|
17|
1.1.1.2/32|
1.1.1.2|
17|
-|
-|
NS
1.1.1.2/32|
-|
-|
1.1.1.2|
3|
1.1.1.2/32|
-|
-|
1.1.1.3|
17|
1.1.1.3/32|
1.1.1.2|
16|
-|
-|
NS
1.1.1.3/32|
-|
-|
1.1.1.2|
16|
1.1.1.3/32|
-|
-|
1.1.1.3|
3|
-------------------------------------------------------------------------------

Page 21

TabeladeroteamentodoIGP:mostraatabeladerotasdoprotocoloderoteamento,aqualser
seguidapeloLDP;
Dm4001_PE1(config)#sh ip route
Codes: AD - Administrative Distance
Destination/Mask
-----------------1.1.1.1/32
1.1.1.2/32
1.1.1.3/32
40.40.0.0/30
40.40.6.0/30
40.40.6.2/32
40.40.8.0/30
40.40.8.1/32
172.16.4.0/24
172.16.4.187/32
0.0.0.0/0
40.40.6.0/30
40.40.8.0/30

Gateway
--------------0.0.0.0
40.40.6.1
40.40.6.1
40.40.6.1
40.40.6.2
0.0.0.0
40.40.8.1
0.0.0.0
172.16.4.187
0.0.0.0
172.16.1.254
0.0.0.0
0.0.0.0

Protocol AD/Cost
Output Interface
-------- ---/------ -----------------connect
0/0
ospf
30/2
VLAN 3106
ospf
30/1
VLAN 3106
ospf
30/2
VLAN 3106
connect
0/0
VLAN 3106
connect
0/0
connect
0/0
VLAN 3108
connect
0/0
connect
0/0
mgmt-eth
connect
0/0
static
0/0
ospf
30/1
VLAN 3106
ospf
30/1
VLAN 3108

Status
-------Active
Active
Active
Active
Active
Active
Active
Active
Active
Active
Inactive
Inactive
Inactive

Atravsdastabelasacima,possvelverificarqueumLSPestabelecidodePE1paraPE2,por
exemplo,seriaroteadodiretamenteentreosequipamentos(definidopeloIGP),sendorealizadauma
aodenoinserodelabelemPE1(PHP=label3).ParadeterminaroslabelsutilizadospeloLSP
atodestino,podeseverificarastabelasdelabelsnosequipamentosintermediriosdaredeatravs
docomandoshowmplsldpdatabase.
Geralmente,oequipamentodedestinodoLSPinformaoupstreamparaquenenhumlabelseja
encaminhadoparaele,talfuncionalidadechamadadePHP(PenultimateHopPopping).
ComooprocotoloLDPpodetantoservirparaotransporteedistribuiodelabels,podese
seguirdiretamenteparaocaptulo5paraostestesdeserviosMPLS(infraestruturaMPLSusando
somenteoprotocoloLDP).
ApsotrminodostestesdeserviosMPLSdocaptulo5,retornaraocaptulo4.2e4.3paraos
testes de infraestrutura MPLS usando o protocolo RSVP. Neste caso, o protocolo RSVP ser
utilizadoparaotransportedelabelseoprotocoloLDPparaadistribuiodelabels(infraestrutura
MPLSLDPoRSVP).

Page 22

5.2 InfraestruturaMPLS:ProtocoloRSVPTE
OprotocoloRSVPTEutilizadoparaincorporarsredesMPLSfuncionalidadestaiscomo,
trafficengineering(TE)eFastReroute(FRR),possibilitandoummaiorcontroleeredundnciados
caminhos estabelecidos. Este captulo abordar os passos necessrios para a configurao do
protocoloRSVPTEemanisL3formadosporswitchesDatacom,bemcomoacriaodostneis
RSVPeoFastReroute.
5.2.1 MododeOperaodoprotocoloRSVP
MensagensRSVPsoenviadasnaredepeloHeadendRouterparaidentificaradisponibilidade
derecursosdocaminho deumaorigemespecificaatodestino. O Headendrouter semprea
origemdeumtnelRSVPeo Tailendrouter odestinofinaldestetnel. Asquatroprincipais
mensagensutilizadaspeloRSVPTEso:RSVPPathmessage,RSVPResvmessage,RSVPError
messageeRSVPTearmessage.
5.2.1.1 RSVPPathMessages
SogeradaspeloHeadendRoutereencaminhadaspelaredeatoTailendRouter.Acadanda
rede,aPathmessageverificaadisponiblidadedosrecursossolicitadosearmazenaestainformao.
OutrafunodaPathmessagesolicitarmapeamentodelabels(LabelRequest)nodomnioMPLS,
propagandoestepedidopelaredenosentidodownstream.
5.2.1.2 RSVPResvMessage
CriadaspeloTailendRouternodomnioMPLSeutilizadasparaconfirmarareservaderecursos
solicitadospelasPathmessages.AsResvmessagestambmpossuemafunodeatribuirlabelse
propaglospelarede,nosentidoupstream,atoHeadendrouter.Esteprocessodeatribuiode
labelsrepetidoemcadandarede,ondeocorremapeamentoealocaolocaisdelabelsparao
tnelRSVP.
5.2.1.3 RSVPErrorMessage
Casoocorraindisponibilidadedosrecursossolicitados,determinadoroteadorenviaumaError
messageparaoroteadorquehaviasolicitadoorecurso.
5.2.1.4 RSVPTearMessage
DoistiposdeTearmessagespodemsercriadas,PathTearmessageeResvTearmessage.Estas
mensagenspermitemaliberaodosrecursospreviamenteutilizados,possibilitandooreusopara
solicitaessubsequentes.

Page 23

5.2.2 ExemplodeconfiguraodoRSVPnosSwitchesDatacom
ParaconfigurarRSVPemswitchesDatacom,recomendaseseguirospassosabaixo:

1. HabilitandoMPLSnaInterfaceloopback: comopremissaparautilizaodoMPLS,
necessriohabilitloemumainterfaceloopback.Casoestecadernoestejasendoexecutadona
sequncia,nosernecessriohabilitaroMPLSnainterfaceloopbacknovamente.
2. HabilitandoRSVPedefinindotimersdoprotocolo:paraquemensagensRSVPpossam
sertrocadasentreosswitches vizinhos,oRSVPdeveestarhabilitadonasinterfacesvlan.Os
timers de RSVP Hello e Refresh messages podem ser alterados para melhorar os tempos de
convergnciadoprotocolo.Pordefault,ostemposdeenviodeRSVPHelloeRefreshMessages
30segundos;
3. DefinindoexplicitamenteocaminhodotnelRSVP:permitidoaousuriodefiniruma
listadenexthopspelosquaisotunelRSVPsercriado.Estaconfiguraoopcional.Ousurio
pode apenas definir o tnel RSVP de destino e confiar nos protocolos CSPF/OSPF para
estabeleceromelhorcaminhoparaodestino;
4. ConfigurandoparmetrosdetnelRSVP:sodefinidasascaractersticasgeraisdotnel
RSVP,taiscomo:destino,mododeproteo,larguradebandaexigida,definiodocaminhodo
tnelpelarede,dentreoutros.Nesteexemplo,sermostradoomodo1:1doFastReroute;
5. AnunciandotneisnatabeladeroteamentodoIGP:permiteautilizaodetneisRSVP
como nexthop na tabela de roteamento do IGP. Esta configurao necessria em caso de
tunelamentodeLDPsobreRSVP,poisoLDPsegueocaminhodefinidopeloIGP.Oexemplo
sobrecomoanunciarostneisnatabeladeroteamentoIGPsercobertonocaptuloLDPsobre
RSVPTE(seo5.3);
6. ConfigurandoIGPparasuporteMPLSTE: habilitaousodeextensesTEparaoIGP
utilizado.ParaoprotocoloderoteamentoOSPF,permiteatrocadeOpaqueLSAs;

Page 24

5.2.2.1 ExemplodeConfiguraodoprotocoloRSVPTE
a)DM4004PE1:
interface loopback 0
mpls enable
!
mpls rsvp
signalling refresh interval 10000
!
interface vlan 3106
rsvp signalling hello refresh interval 5000
rsvp signalling hello refresh misses 3
rsvp enable
!
interface vlan 3108
rsvp signalling hello refresh interval 5000
rsvp signalling hello refresh misses 3
rsvp enable
!
mpls expl-path
explicit-path identifier 2
tsp-hop 1 path-option 1 next-address ipv4 40.40.8.2 strict
!
explicit-path identifier 3
tsp-hop 1 path-option 1 next-address ipv4 40.40.6.1 strict
!
!
mpls te
interface te-tunnel 12
tunnel mpls destination
tunnel mpls traffic-eng
tunnel mpls traffic-eng
no shutdown
!
interface te-tunnel 13
tunnel mpls destination
tunnel mpls traffic-eng
tunnel mpls traffic-eng
no shutdown
!

1.1.1.2
fast-reroute one-to-one
path-option 1 explicit-path identifier 2

1.1.1.3
fast-reroute one-to-one
path-option 1 explicit-path identifier 3

!
router ospf
mpls traffic-eng

Page 25

b)DM4001PE2:
interface loopback 0
mpls enable
!
mpls rsvp
signalling refresh interval 10000
!
interface vlan 3100
rsvp signalling hello refresh interval 5000
rsvp signalling hello refresh misses 3
rsvp enable
!
interface vlan 3108
rsvp signalling hello refresh interval 5000
rsvp signalling hello refresh misses 3
rsvp enable
!
mpls expl-path
explicit-path identifier 1
tsp-hop 1 path-option 1 next-address ipv4 40.40.8.1 strict
!
explicit-path identifier 3
tsp-hop 1 path-option 1 next-address ipv4 40.40.0.1 strict
!
!
mpls te
interface te-tunnel 21
tunnel mpls destination
tunnel mpls traffic-eng
tunnel mpls traffic-eng
no shutdown
!
interface te-tunnel 23
tunnel mpls destination
tunnel mpls traffic-eng
tunnel mpls traffic-eng
no shutdown
!

1.1.1.1
fast-reroute one-to-one
path-option 1 explicit-path identifier 1

1.1.1.3
fast-reroute one-to-one
path-option 1 explicit-path identifier 3

!
router ospf
mpls traffic-eng

c)DM4001PE3:
interface loopback 0
mpls enable
!
mpls rsvp
signalling refresh interval 10000
!
interface vlan 3100
rsvp signalling hello refresh interval 5000
rsvp signalling hello refresh misses 3
rsvp enable
!

Page 26

interface vlan 3106


rsvp signalling hello refresh interval 5000
rsvp signalling hello refresh misses 3
rsvp enable
!
mpls expl-path
explicit-path identifier 1
tsp-hop 1 path-option 1 next-address ipv4 40.40.6.2 strict
!
explicit-path identifier 2
tsp-hop 1 path-option 1 next-address ipv4 40.40.0.2 strict
!
!
mpls te
interface te-tunnel 31
tunnel mpls destination
tunnel mpls traffic-eng
tunnel mpls traffic-eng
no shutdown
!
interface te-tunnel 32
tunnel mpls destination
tunnel mpls traffic-eng
tunnel mpls traffic-eng
no shutdown
!

1.1.1.1
fast-reroute one-to-one
path-option 1 explicit-path identifier 1

1.1.1.2
fast-reroute one-to-one
path-option 1 explicit-path identifier 2

!
router ospf
mpls traffic-eng

5.2.3 VerificaodosTneisRSVP
StatusdetneisRSVP:mostraasinformaespertinentesaotneisRSVPiniciados(Headend),
terminados (Tailend) e intermedirios (Transit) do equipamento, bem como o mapeamento de
labels,interfacesdesada,disponibilidadedoFRR,dentreoutros;
Dm4001_PE1#sh mpls te traffic-eng tunnels
Tunnel-Name
-------------------Dm4001_PE1_T12
Dm4001_PE1_T13
Dm4001_PE2_T21
Dm4001_PE3_T31

Destination
---------------1.1.1.2
1.1.1.3
1.1.1.1
1.1.1.1

Protect. Up-If
Down-If
Adm/Oper
-------- --------- --------- ---------avail.
3108,3
up/up
avail.
up/up
up/up
3106,3
up/up

Page 27

StatusdoFastReroute: mostraasinformaesatuaisdoFRRparacadatnel,bemcomoa
relaoaosnexthopsutilizados(principalebackup);
Dm4001_PE1#show mpls rsvp-table
+-----------+--------------+-----------------+--------------+-----------------+
| Tnl (P/F)| Prot. Handle | Prot. Next Hop | Fail Handle | Backup Next Hop |
+-----------+--------------+-----------------+--------------+-----------------+
|
13 (1/2)| 0x01320000 | 40.40.6.1
| 0x01650000 | 40.40.8.2
|
|
12 (1/2)| 0x013c0000 | 40.40.8.2
| 0x016a0000 | 40.40.6.1
|
+-----------+--------------+-----------------+--------------+-----------------+
RSVP LSC Status: 0 - UNDEF, 1 - ACT, 2 - UP, 3 - DOWN, 4 - UPD, 5 - RENEW
Table entries: 2

TambmpossvelverificaroestadooperacionaldetneisRSVPutilizandoafuncionalidade
pingmplsrsvp<TunnelID>.

Page 28

5.3 TunelamentodeLDPsobreRSVPTE
Nesteitem,mostrasecomoconciliarasvantagensdoLDPedoRSVPTE,aliandosimplicidade
nacriaodeLSPssfuncionalidadescomooTEeFRR.
OtunelamentodeLDPsobreRSVPTEseparaafunodetransportedelabelsdafunode
distribuiodelabels.OstneiscontinuamsendocriadoscomoauxliodoprotocoloRSVPTE,
mantendotodasasvantagensdecontroledoscaminhosestabelecidosemecanismosderedundncia
notransportedelabels,cabendoagoraaoLDP,atarefadeatribuiredistribuirlabelsaolongoda
rede.
AoutilizarLDPtuneladosobreRSVPTE,podeseassociarmltiplasFECsaomesmotnel,
poisoprotocoloLDPgaranteadefiniodelabelsdistintosparacadaumadelassemsepreocupar
comoLSPescolhido.OutraconsequnciaofatodoLDP"concatenar"vriostneisRSVPTE
paraformarumLSPatravsdaredeMPLS.Aoperaoderedenonecessariamentecriartneis
conectandotodososequipamentosdebordaentresi.Logo,noseriapossvelutilizarumnico
tnelparaalcanartodososdestinos.ComLDP,podeseencontrarnaredeumasequnciadetneis
adjacentesquepermitamalcanarqualquerroteadornarede.ApesardoLSPtersidoestabelecido
peloLDP,todootrfegoencaminhadosegundoasdiretrizesdeTEaplicadasaostneis.
5.3.1 ExemplodeConfiguraodoLDPoRSVP
a)LDPoRSVPemDM4004PE1:
mpls te
interface te-tunnel 12
tunnel mpls traffic-eng autoroute announce
!
interface te-tunnel 13
tunnel mpls traffic-eng autoroute announce
!
!
interface vlan 3106
ip ospf cost 100
!
interface vlan 3108
ip ospf cost 100
!
mpls ldp neighbor 1.1.1.2
!
mpls ldp neighbor 1.1.1.3
!

Page 29

b)LDPoRSVPemDM4001PE2:
mpls te
interface te-tunnel 21
tunnel mpls traffic-eng autoroute announce
!
interface te-tunnel 23
tunnel mpls traffic-eng autoroute announce
!
!
interface vlan 3100
ip ospf cost 100
!
interface vlan 3108
ip ospf cost 100
!
mpls ldp neighbor 1.1.1.1
!
mpls ldp neighbor 1.1.1.3
!

c)LDPoRSVPemDM4001PE3:
mpls te
interface te-tunnel 31
tunnel mpls traffic-eng autoroute announce
!
interface te-tunnel 32
tunnel mpls traffic-eng autoroute announce
!
!
interface vlan 3100
ip ospf cost 100
!
interface vlan 3106
ip ospf cost 100
!
mpls ldp neighbor 1.1.1.1
!
mpls ldp neighbor 1.1.1.2
!

Page 30

5.3.2 VerificaodoLDPoRSVP
LDPNeighbor:mostraassessesLDPestabelecidassobreotnelRSVP;
Dm4001_PE1#sh mpls ldp neighbor
---------------------------------------------------------------------------Adjacency ID
|Status
|Local Role
|
---------------------------------------------------------------------------1.1.1.2:0|
Operational|
Passive|
1.1.1.3:0|
Operational|
Passive|
----------------------------------------------------------------------------

Tabela de roteamento IGP: mostra que as FECs so alcanveis atravs dos tneis RSVP
estabelecidos;
Dm4001_PE1#sh ip route
Codes: AD - Administrative Distance
Destination/Mask
-----------------1.1.1.1/32
1.1.1.2/32
1.1.1.3/32
10.1.0.0/16
40.40.0.0/30
40.40.6.0/30
40.40.6.2/32
40.40.8.0/30
40.40.8.1/32
172.16.4.0/24
172.16.4.187/32
0.0.0.0/0
40.40.6.0/30
40.40.8.0/30

Gateway
--------------0.0.0.0
0.0.0.0
0.0.0.0
172.16.4.254
0.0.0.0
40.40.6.2
0.0.0.0
40.40.8.1
0.0.0.0
172.16.4.187
0.0.0.0
172.16.1.254
0.0.0.0
0.0.0.0

Protocol AD/Cost
Output Interface
-------- ---/------ -----------------connect
0/0
ospf
30/1
Dm4001_PE1_T12
ospf
30/1
Dm4001_PE1_T13
static
0/0
mgmt-eth
ospf
30/101
Dm4001_PE1_T13
connect
0/0
VLAN 3106
connect
0/0
connect
0/0
VLAN 3108
connect
0/0
connect
0/0
mgmt-eth
connect
0/0
static
0/0
ospf
30/100
VLAN 3106
ospf
30/100
VLAN 3108

Status
-------Active
Active
Active
Active
Active
Active
Active
Active
Active
Active
Active
Inactive
Inactive
Inactive

Page 31

6 ServiosMPLS
OsitensaseguirexemplificamosserviosbaseadosemMPLSpropostosnestedocumento.

6.1 Layer2VirtualPrivateNetworkL2VPN
L2VPN vem a ser uma tcnica na qual utilizase uma rede MPLS para transportar dados
baseandose apenas na camada 2. No caso das redes Metro Ethernet, os pacotes ingress so
encaminhadosnaredeMPLSdeacordocomcritrioscomoportadeentrada,VLANdeentradae
MACdedestino.
AconfiguraodoservioL2VPNsedivideemduasetapas:provisionamentodainfraestrutura
MPLS (tnel ou LSP que conecta os LERs ingress e egress), e provisionamento dos circuitos
virtuaisquedistinguemasL2VPNsentresi.OsLSPjforamprovisionadosnositensanteriores.
Emrelaoaoscircuitos,seroexemplificadostantocircuitosP2PdotipoVPWSquantocircuitos
P2MPdotipoVPLSouHVPLS;

Page 32

6.1.1 ExemplodeCenrioL2VPNVPWS
Este cenrio visa demonstrar a criao de uma L2VPN entre elementos pertencentes a um
mesmoanelL3,atravsdeumcircuitoP2Pentreoselementos.
AnegociaodoslabelsdeVCserfeitadeformasinalizadapeloprotocoloLDPatravsda
tcnica PWE3 (conforme RFC 4447), simplificando o provisionamento e gerncia dos labels
utilizados. As mesmas entidades LDP targeted criadas anteriormente em cada LER (ingress e
egress)seroutilizadastambmparaatrocadelabelsdeVC.
a) DM4001PE1:
mpls vpws
vpn 1
xconnect vlan 1500 vc-type vlan
neighbor 1.1.1.2 pwid 100
mplstype non-te
no shutdown
!
!
vpn 2
xconnect vlan 1501 vc-type vlan
neighbor 1.1.1.3 pwid 101
mplstype non-te
no shutdown
!
!

b) DM4001PE2:
mpls vpws
vpn 1
xconnect vlan 1500 vc-type vlan
neighbor 1.1.1.1 pwid 100
mplstype non-te
no shutdown
!
!
vpn 2
xconnect vlan 1502 vc-type vlan
neighbor 1.1.1.3 pwid 102
mplstype non-te
no shutdown
!
!

c) DM4001PE3:
mpls vpws
vpn 1
xconnect vlan 1501 vc-type vlan
neighbor 1.1.1.1 pwid 101
mplstype non-te

Page 33

no shutdown
!
!
vpn 2
xconnect vlan 1502 vc-type vlan
neighbor 1.1.1.2 pwid 102
mplstype non-te
no shutdown
!
!

6.1.1.1 VerificandoEstadoOperacionaldeVPWS

Verificaodoestadodostneis:showmplstetrafficengtunnels

VerificaodoestadodasL2VPNs:showmplsl2vpn

VerificaodetalhadadasVPNs:showmplsl2vpndetail

VerificaodofuncionamentodaL2VPNVPWSentrePE1PE2,PE2PE3ePE1PE3atravs
doenviodepingentreosPCs(ouTestset);

CapturaeanlisedospacotesenviadosentreasVPNsatravsumanalisadordeprotocolos;

StatusdoscircuitosL2VPNVPWSestabelecidos
Dm4004_PE1(config)#show mpls l2vpn
------------------------------------------------------------------------------VPN
|Access Int|Uplink Intfs (PW's)
|Status
|Labels
------------------------------------------------------------------------------ID |Type|VC typ/VID|Pwid |Dest address
|PW
|VC |Backup |Local |Remote
------------------------------------------------------------------------------1|VPWS|vlan 1500 |100
|1.1.1.2
|Up
|Up |None
|31
|25
------------------------------------------------------------------------------2|VPWS|vlan 1501 |101
|1.1.1.3
|Up
|Up |None
|32
|21
-------------------------------------------------------------------------------

Dm4001_PE2(config)#show mpls l2vpn


------------------------------------------------------------------------------VPN
|Access Int|Uplink Intfs (PW's)
|Status
|Labels
------------------------------------------------------------------------------ID |Type|VC typ/VID|Pwid |Dest address
|PW
|VC |Backup |Local |Remote
------------------------------------------------------------------------------1|VPWS|vlan 1500 |100
|1.1.1.1
|Up
|Up |None
|25
|31
------------------------------------------------------------------------------2|VPWS|vlan 1502 |102
|1.1.1.3
|Up
|Up |None
|26
|22
-------------------------------------------------------------------------------

Page 34

Dm4001_PE3(config)#show mpls l2vpn


------------------------------------------------------------------------------VPN
|Access Int|Uplink Intfs (PW's)
|Status
|Labels
------------------------------------------------------------------------------ID |Type|VC typ/VID|Pwid |Dest address
|PW
|VC |Backup |Local |Remote
------------------------------------------------------------------------------1|VPWS|vlan 1501 |101
|1.1.1.1
|Up
|Up |None
|21
|32
------------------------------------------------------------------------------2|VPWS|vlan 1502 |102
|1.1.1.2
|Up
|Up |None
|22
|26
-------------------------------------------------------------------------------

6.1.1.2 RemovendoConfiguraodeVPWS
AmesmasequnciadecomandosutilizadanosequipamentosDM4001PE1,DM4001PE2e
DM4001PE3pararemoverasVPNsVPWS;
mpls vpws
no vpn all
exit

Page 35

6.1.2 ExemplodeConfiguraodeL2VPNVPWScomBackupPW
EstaseodemonstracomoconfigurarumaVPNP2PcomPWderedundnciautilizandouma
segundaVPWScriadacomobackup.
necessrioestabelecerumsegundolinkdeacessoentreCE2ePE3pararedundnciaL2.Esse
linkserconfiguradodamesmaformaqueolinkCE2PE2.Oobjetivoqueexistaredundnciade
PWentreCE1eCE2.
Em caso de falha de link de acesso entre CE2 e PE2, o PW 'Standby' (PE1PE3) se torna
imediatamenteativoepassaaencaminharotrfegoentreCE1CE2.QuandoolinkentreCE2e
PE2recuperado,oPWprincipal(PE1PE2)setornanovamenteativo.
a) ConfigurandoCE2
!
interface vlan 1500
set-member tagged ethernet 1/27
!

b) ConfigurandoDM4001PE2:
mpls vpws
vpn 1
xconnect vlan 1500 vc-type vlan
neighbor 1.1.1.1 pwid 500
mplstype non-te
no shutdown
!

c) ConfigurandoDM4001PE3:
!
interface vlan 1500
no set-member ethernet 1/1
set-member tagged ethernet 1/2
!
mpls vpws
vpn 1
xconnect vlan 1500 vc-type vlan
neighbor 1.1.1.1 pwid 500
mplstype non-te
no shutdown
!

d) ConfigurandoDM4001PE1:
!
mpls vpws
vpn 1
xconnect vlan 1500 vc-type vlan
neighbor 1.1.1.2 pwid 500
backup-peer 1.1.1.3 pwid 500
backup-delay 0 0
mplstype non-te
no shutdown

Page 36

6.1.2.1 VerificandoEstadoOperacionaldeVPWScomBackupPW

Verificaodoestadodostneis:showmplstetrafficengtunnels

VerificaodoestadodasL2VPNs:showmplsl2vpn

VerificaodetalhadadasVPNs:showmplsl2vpndetail

VerificaodofuncionamentodaL2VPNVPWSentrePE1PE2,PE2PE3ePE1PE3atravs
doenviodepingentreosPCs(ouTestset);

CapturaeanlisedospacotesenviadosentreasVPNsatravsumanalisadordeprotocolos;

StatusdoscircuitosL2VPNVPWSestabelecidos
Dm4004_PE1(config)#show mpls l2vpn
------------------------------------------------------------------------------VPN
|Access Int|Uplink Intfs (PW's)
|Status
|Labels
------------------------------------------------------------------------------ID |Type|VC typ/VID|Pwid |Dest address
|PW
|VC |Backup |Local |Remote
------------------------------------------------------------------------------1
|VPWS|vlan 1500 |500
|1.1.1.2
|Up
|Up |Active |42
|68
|
|
|500
|1.1.1.3
|Up
|Up |Standby|45
|33
-------------------------------------------------------------------------------

Dm4001_PE2(config)#show mpls l2vpn


------------------------------------------------------------------------------VPN
|Access Int|Uplink Intfs (PW's)
|Status
|Labels
------------------------------------------------------------------------------ID |Type|VC typ/VID|Pwid |Dest address
|PW
|VC |Backup |Local |Remote
------------------------------------------------------------------------------1
|VPWS|vlan 1500 |500
|1.1.1.1
|Up
|Up |None
|68
|42
-------------------------------------------------------------------------------

Dm4001_PE3(config)#show mpls l2vpn


------------------------------------------------------------------------------VPN
|Access Int|Uplink Intfs (PW's)
|Status
|Labels
------------------------------------------------------------------------------ID |Type|VC typ/VID|Pwid |Dest address
|PW
|VC |Backup |Local |Remote
------------------------------------------------------------------------------1
|VPWS|vlan 1500 |500
|1.1.1.1
|Up
|Up |None
|33
|45
-------------------------------------------------------------------------------

6.1.2.2 RemovendoConfiguraodeBackupPW
A mesma sequncia de comandos pode ser usada para remover as VPNs de DM4001PE1,
DM4001PE2eDM4001PE3;
mpls vpws
no vpn all
exit

Page 37

RemovendoaconfiguraodeCE2:
!
interface vlan 1500
set-member tagged ethernet 1/27
!

etambmdeDM4001PE3:
!
interface vlan 1500
set-member tagged ethernet 1/1
no set-member ethernet 1/2
!

Page 38

6.1.3 ExemplodeCenrioL2VPNVPLS
EstecenriovisademonstraracriaodeumaL2VPNP2MPentre3PEsdeummesmoanelL3.
SerocriadoscircuitosdotipoVPLSinterligandoPE1PE2ePE3.
a) DM4001PE1:
mpls vpls
vpn 1
xconnect vlan 1500 vc-type vlan
neighbor 1.1.1.2 pwid 201
mplstype non-te
no shutdown
!
neighbor 1.1.1.3 pwid 201
mplstype non-te
no shutdown
!

b) DM4001PE2:
mpls vpws
vpn 1
xconnect vlan 1500 vc-type vlan
neighbor 1.1.1.1 pwid 201
mplstype non-te
no shutdown
!

c) DM4001PE3:
mpls vpws
vpn 1
xconnect vlan 1500 vc-type vlan
neighbor 1.1.1.1 pwid 201
mplstype non-te
no shutdown
!
!

6.1.3.1 VerificandoEstadoOperacionaldeVPLS

Verificaodoestadodostneis:showmplstetrafficengtunnels

VerificaodoestadodasL2VPNs:showmplsl2vpn

VerificaodetalhadadasVPNs:showmplsl2vpndetail

VerificaodofuncionamentodaL2VPNVPLSentrePE1PE2ePE1PE3atravsdoenviode
pingentreosPCs(ouTestset);

CapturaeanlisedospacotesenviadosentreasVPNsatravsumanalisadordeprotocolos;

Page 39

StatusdoscircuitosL2VPNVPLSestabelecidos
Dm4001_PE1(config)#show mpls l2vpn
------------------------------------------------------------------------------VPN
|Access Int|Uplink Intfs (PW's)
|Status
|Labels
------------------------------------------------------------------------------ID |Type|VC typ/VID|Pwid |Dest address
|PW
|VC |Backup |Local |Remote
------------------------------------------------------------------------------1
|VPLS|vlan 1500 |201
|1.1.1.2
|Up
|Up |None
|30
|33
|
|
|201
|1.1.1.3
|Up
|Up |None
|31
|31
-------------------------------------------------------------------------------

Dm4001_PE2(config)#show mpls l2vpn


------------------------------------------------------------------------------VPN
|Access Int|Uplink Intfs (PW's)
|Status
|Labels
------------------------------------------------------------------------------ID |Type|VC typ/VID|Pwid |Dest address
|PW
|VC |Backup |Local |Remote
------------------------------------------------------------------------------1
|VPWS|vlan 1500 |201
|1.1.1.1
|Up
|Up |None
|33
|30
-------------------------------------------------------------------------------

Dm4001_PE3(config)#show mpls l2vpn


------------------------------------------------------------------------------VPN
|Access Int|Uplink Intfs (PW's)
|Status
|Labels
------------------------------------------------------------------------------ID |Type|VC typ/VID|Pwid |Dest address
|PW
|VC |Backup |Local |Remote
------------------------------------------------------------------------------1
|VPWS|vlan 1500 |201
|1.1.1.1
|Up
|Up |None
|31
|31
-------------------------------------------------------------------------------

6.1.3.2 RemovendoConfiguraodeVPLS
AmesmasequnciadecomandosutilizadanosequipamentosDM4001PE1,DM4001PE2e
DM4001PE3pararemoverasVPNsVPLS;
mpls vpws
no vpn all
exit
mpls vpls
no vpn all

Page 40

6.1.4 ExemplodeCenrioL2VPNHVPLS
EstecenriovisademonstraracriaodeumaL2VPNP2MPentre3elementos,sendooPE1o
hub da configurao hubspoke. Sero criados circuitos do tipo HVPLS interligando os
equipamentosPE2ePE3viaPE1.
a) DM4001PE1:
mpls vpls
vpn 1
xconnect vlan 1500 vc-type vlan
neighbor 1.1.1.2 pwid 301
mplstype non-te
no-split-horizon
no shutdown
!
neighbor 1.1.1.3 pwid 301
mplstype non-te
no-split-horizon
no shutdown
!

b) DM4001PE2:
mpls vpws
vpn 1
xconnect vlan 1500 vc-type vlan
neighbor 1.1.1.1 pwid 301
mplstype non-te
no shutdown
!

c) DM4001PE3:
mpls vpws
vpn 1
xconnect vlan 1500 vc-type vlan
neighbor 1.1.1.1 pwid 301
mplstype non-te
no shutdown
!

6.1.4.1 VerificandoEstadoOperacionaldeHVPLS

Verificaodoestadodostneis:showmplstetrafficengtunnels

VerificaodoestadodasL2VPNs:showmplsl2vpn

VerificaodetalhadadasVPNs:showmplsl2vpndetail

Verificao do funcionamento da L2VPN HVPLS entre PE1PE2, PE1PE3 e PE2PE3


atravsdoenviodepingentreosPCs(ouTestset);

Page 41

CapturaeanlisedospacotesenviadosentreasVPNsatravsumanalisadordeprotocolos;

StatusdoscircuitosL2VPNVPLSestabelecidos
Dm4004_PE1(config)#show mpls l2vpn
------------------------------------------------------------------------------VPN
|Access Int|Uplink Intfs (PW's)
|Status
|Labels
------------------------------------------------------------------------------ID |Type|VC typ/VID|Pwid |Dest address
|PW
|VC |Backup |Local |Remote
------------------------------------------------------------------------------1
|VPLS|vlan 1500 |301
|1.1.1.2
|Up
|Up |None
|36
|34
|
|
|301
|1.1.1.3
|Up
|Up |None
|37
|32
-------------------------------------------------------------------------------

Dm4001_PE2(config)#sh mpls l2vpn


------------------------------------------------------------------------------VPN
|Access Int|Uplink Intfs (PW's)
|Status
|Labels
------------------------------------------------------------------------------ID |Type|VC typ/VID|Pwid |Dest address
|PW
|VC |Backup |Local |Remote
------------------------------------------------------------------------------1
|VPWS|vlan 1500 |301
|1.1.1.1
|Up
|Up |None
|34
|36
-------------------------------------------------------------------------------

Dm4001_PE3(config)#sh mpls l2vpn


------------------------------------------------------------------------------VPN
|Access Int|Uplink Intfs (PW's)
|Status
|Labels
------------------------------------------------------------------------------ID |Type|VC typ/VID|Pwid |Dest address
|PW
|VC |Backup |Local |Remote
------------------------------------------------------------------------------1
|VPWS|vlan 1500 |301
|1.1.1.1
|Up
|Up |None
|32
|37
-------------------------------------------------------------------------------

Page 42

7 QoS
7.1 ExemplodeConfiguraodeQoS
Nestaseoserodemonstradasalgumasopesdeconfiguraoparamapeamentodosvalores
EXP,CoSeDSCP,definindoosparmetrosdeQoSdarede.
7.1.1 ConfiguraoComumparaTodososPEs
mpls exp-map egress prio
mpls exp-map egress prio
mpls exp-map egress prio
mpls exp-map egress prio
mpls exp-map egress prio
mpls exp-map egress prio
mpls exp-map egress prio
mpls exp-map egress prio
!
mpls exp-map ingress exp
mpls exp-map ingress exp
mpls exp-map ingress exp
mpls exp-map ingress exp
mpls exp-map ingress exp
mpls exp-map ingress exp
mpls exp-map ingress exp
mpls exp-map ingress exp
!
dscp-table 0 0 0
dscp-table 12 12 3
dscp-table 14 14 3
dscp-table 18 18 3
dscp-table 26 26 3
dscp-table 30 30 6
dscp-table 34 34 4
dscp-table 36 36 4
dscp-table 38 38 4
dscp-table 46 46 5
dscp-table 57 57 7

0
1
2
3
4
5
6
7

exp
exp
exp
exp
exp
exp
exp
exp

0
1
2
3
4
5
6
7

prio
prio
prio
prio
prio
prio
prio
prio

0
2
1
3
4
5
6
7
0
2
1
3
4
5
6
7

Page 43

7.1.2 Verificandoaconfigurao
OprocedimentoparaverificarQoSconsisteemcapturareanalisartrfegodaVPNutilizandoum
analisadordeprotocolos.
PacotesqueentrampeloLAGdePE1evlan.id==1500,recebidoscomDSCP46,temseu
campoDSCPremarcado,repriorizado(dscptable46465)esoencaminhadosparaaredeMPLS
comEXP=5(mplsexpmapegressprio5exp5).

Pacotesrecebidospelaporta2/1dePE4evlan.id==1500,recebidoscomcampo802.1p=2,
somapeadoseencaminhadosparaaredeMPLScomEXP=1(mplsexpmapegressprio2exp1).

PacotesrecebidosdaredeMPLSsoencaminhadosdeacordocomomapeamentodeexp
mapingress(mplsexpmapingressexp5prio5/mplsexpmapingressexp2prio1);

Page 44