Você está na página 1de 2

CURSOTCNICOEMINFORMTICA

ALGORITMOS

ALUNO:

DATA:

19/04/2012

PROVA 001 - INTRODUO


1. Indique os tipos de dados mais adequados para armazenar os valores abaixo,
seguindo a seguinte notao: I=inteiro; R=real; C=caractere; L=lgico [1,0 ponto]:
(
(
(
(

) 1000
) 0
) -900
) true

(
(
(
(

)V
) 456
) Cinco
) -9.12

(
(
(
(

) 99.8
) falso
) 678
) 1.56

2. Suponha que uma fbrica utilize como cdigo de produto, um nmero inteiro no
formato MMMLLCCCV, onde [3,0 pontos]:
Os trs primeiros dgitos, representados pela letra M, correspondem ao
modelo do produto;
Os dois dgitos seguintes, representados pela letra L, correspondem ao
nmero do lote;
Os trs dgitos seguintes, representados pela letra C, correspondem ao cdigo
da cor (01-Vermelho; 02-Preto; 03-Amarelo);
O ltimo dgito, representado pela letra V, corresponde voltagem (1 = 110v;
2=220v);
Crie um algoritmo que leia o cdigo do produto e imprima um relatrio, conforme o
exemplo:
Produto: 100020012
Modelo: 100
Lote: 2
Cor: Vermelho
Voltagem: 220v
3. Para as expresses aritmticas abaixo, faa [1,5 pontos]:
I. transforme a expresso em uma instruo de algoritmo;
II. calcule o resultado sabendo-se que os valores de X, Y e Z so,
respectivamente: 1, 2 e 5;
a) Z mod Y div Y
b) X + Y + Z / 3
c) Z Y * X
Instruo

d) (Z > Y) e (X <= Y)
e) (8 = Y * Z) ou no (Z <> X)

Resultado

a)
b)
c)
d)
e)

CURSOTCNICOEMINFORMTICA
ALGORITMOS

4. Observe o algoritmo abaixo [2,0 pontos]:


Algoritmo No_no_juizo
var
L1, L2, L3 : caracter
inicio
leia (L1,L2,L3) //deve ser digitado apenas as letras V ou F
se (L1 = V) entao
escreva (A)
senao
se (L2 = V) entao
se (L3 = V) entao
escreva(B)
senao
escreva (C)
escreva(D)
fimse
fimse
fimse
escreva(E)
fimalgoritmo

Agora, responda as seguintes questes:


a) Se forem lidos V, V e F, o que ser escrito pelo programa?
b) Se forem lidos F, V e F, o que ser escrito pelo programa?
c) Se forem lidos F, V e V, o que ser escrito pelo programa?
d) Que valores deveriam ser lidos para que fosse escrito apenas 'E'?

5. Um turista deseja fazer uma viagem e passar alguns dias fora do Brasil. Ele ficar
dez dias nos Estados Unidos e quatro dias na Frana. Uma dificuldade
encontrada pelo turista est na converso de moedas, ou seja, para que o turista
possa ir para os Estados Unidos ele deve ter em mos Dlares Americanos e
para a Frana ele deve ter Euros. Diante desta necessidade, faa um algoritmo
que, a partir de um valor qualquer, gere o seu valor correspondente na moeda
necessitada pelo turista. Para tanto, o turista, primeiramente, deve informar a
moeda de origem, o valor expresso na moeda de origem e, por fim, a moeda de
destino. Use a relao: R$ 2,50 (dois reais e cinquenta centavos) = US$ 1,50 (um
dlar e cinquenta centavos de dlar) = E$ 1,10 (um euro e dez centavos de euro)
para converter valores entre as moedas.
Ao final, o algoritmo deve apresentar o valor na moeda de origem e o seu valor
correspondente na moeda destino [2,5 pontos].
DICA: use regra de trs para resolver esse problema.
R$ 2,50
U$ 1,50
U$ 1,50
E$ 1,10
X
?
X
?

R$ 2,50
X

E$ 1,10
?

BOA PROVA!