Você está na página 1de 12

JULIANA PAULINA MORA REYES

TICS
1G
METODOLOGA DE LA
PROGRAMACIN
NELSON CROZBY PADILLA
ALVAREZ

DIAGRAMAS DE FLUJO
Y PSEDOCODIGOS
Algoritmo ejercicio1

Leer i1;

Leer i2;

Si i1>i2 Entonces

Escribir i1;

Escribir 'mayor';

Sino

Escribir i2;

Escribir 'mayor';

FinSi

FinAlgoritmo
Algoritmo ejercicio2

Leer t1;

Leer t2;

Si t2<t1 Entonces

Escribir t2;

Escribir 'menor';

Sino

Escribir t1;

Escribir 'menor';

FinSi

FinAlgoritmo
Algoritmo ejercicio3

Leer i1;

Leer t2;

N <- i1+t2;

Escribir 'La suma de los dos numeros es';

Escribir N;

FinAlgoritmo
Algoritmo ejercicio4
Leer A;
Leer B;
Mientras B==A Hacer
Escribir 'se repitio, asignar otro valor';
Leer B;
FinMientras
Leer C;
Mientras C==A | C==B Hacer
Escribir 'SE REPITIO, ASIGNAR OTRO VALOR';
Leer C;
FinMientras
Escribir 'los valores son diferentes';
Si A>B Entonces
Si A>C Entonces
Escribir A;
Escribir 'MAYOR';
Sino
Escribir C;
Escribir 'MAYOR';
FinSi
Sino
Si B>C Entonces
Escribir B;
Escribir 'MAYOR';
Sino
Escribir C;
Escribir 'MAYOR';
FinSi
FinSi
Si A<B Entonces
Si A<C Entonces
Escribir A;
Escribir 'MENOR';
Sino
Escribir C;
Escribir 'MENOR';
FinSi
Sino
Si B<C Entonces
Escribir B;
Escribir 'MENOR';
Sino
Escribir C;
Escribir 'MENOR';
FinSi
FinSi
FinAlgoritmo
Algoritmo EJERCICIO5
Leer A
Leer B
Leer C
Si A>B Entonces
Si A>C Entonces
Escribir ' A ES MAYOR'
FinSi
Sino
Si B>C Entonces
Escribir 'B ES MAYOR'
Sino
Escribir 'C ES MAYOR'
FinSi
FinSi
FinAlgoritmo
Algoritmo EJERCICIO6
Leer A;
LEER B;
LEER C;
Leer D;
Si A>B Entonces
Si A>C Entonces
Si A>D Entonces
Escribir "A MAYOR";
Sino
Escribir "D MAYOR";
Fin Si
Sino
Si C>D Entonces
Escribir "C MAYOR";
Sino
Escribir "D MAYOR";
Fin Si
Fin Si
Sino
Si B>C Entonces
Si B>D Entonces
Escribir "B MAYOR";
Sino
Escribir "D MAYOR";
Fin Si
Sino
Si C>D Entonces
Escribir "C MAYOR";
Sino
Escribir "D MAYOR"
Fin Si
Fin Si
Fin Si
Si A<B Entonces
Si A<C Entonces
Si A<D Entonces
Escribir "A MENOR";
Sino
Escribir "D MENOR";
Fin Si
Sino
Si C<D Entonces
Escribir "C MENOR";
Sino
Escribir "D MENOR";
Fin Si
Fin Si
Sino
Si B<C Entonces
Si B<D Entonces
Escribir "B MENOR";
Sino
Escribir "D MENOR";
Fin Si
Sino
Si C<D Entonces

Escribir "C MENOR";


Sino
Escribir "D MENOR";

Fin Si
Fin Si
Fin Si
FinAlgoritmo
Algoritmo EJERCICIO7
suma <- 0
Para i<-5 Hasta 100 Con Paso 5 Hacer
Escribir i
suma <- suma+i
i <- i+5
FinPara
Escribir 'la suma de los multiplos que estan entre 5 y 100 es de'
Escribir suma
FinAlgoritmo
Algoritmo ejercicio8
sumimpar<-0;
contaimpar<-0;
PAR<-0;
Para i<-1 Hasta 300 Con Paso 1 Hacer
Leer n;
Si n MOD 2=0 Entonces
PAR<-PAR+1
Sino
contaimpar<-contaimpar+1;
sumimpar<-sumimpar+n;

FinSi
i<-i+1;
Fin Para
Escribir contaimpar;
Escribir sumimpar;

FinAlgoritmo