Você está na página 1de 11

Universidad Tecnolgica de Morelia

Metodologa de la
Programacin 1G

01/01/2016

Valor Creativo
Metodologa de la Programacin 1G
1. Desarrolle un algoritmo que permita leer dos valores distintos, determinar cul de los dos valores es el
mayor y escribirlo.

Algoritmo NumeroMayor

Escribir 'Escriba un numero'

Leer A

Escribir 'Escriba un Numero'

Leer B

Si A>B Entonces

Escribir 'el mayor es ' A;

Sino

Escribir 'el mayor es ' B;

FinSi

FinAlgoritmo
Metodologa de la Programacin 1G
2. Realizar un algoritmo que permita leer dos valores, determinar cul de los dos valores es el menor y
escrbalo.

Algoritmo NumeroMenor

Escribir 'Escriba un numero';

Leer A

Escribir 'Escriba un Numero';

Leer B

si A<B Entonces

Escribir 'el menor es ',A

Sino

Escribir 'el menor es ',B

FinSi

FinAlgoritmo
Metodologa de la Programacin 1G
3. Realizar un algoritmo que sume dos nmeros.

Algoritmo SumarNumero

Escribir 'Escriba un numero';

Leer A

Escribir 'Escriba un Numero';

Leer B

Escribir 'La suma es ',A+B

FinAlgoritmo
Metodologa de la Programacin 1G
4. Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A, B y C
respectivamente. El algoritmo debe imprimir cual es el mayor y cul es el menor. Recuerde constatar que os
tres valores introducidos por el teclado sean valores distintos. Presente un mensaje de alerta en caso de que
se detecte la introduccin de valores iguales.

Algoritmo NumeroMayorMenor
Escribir 'Escriba un numero'
Leer A
Escribir 'Escriba un Numero'
Leer B
Escribir 'Escriba un Numero'
Leer C
Si A<>B Y A<>C Entonces
Si A>B Y B<C Y A>C Entonces
Escribir 'El Mayor es ',A
Escribir 'El Menor es ',B
Sino
Si A>B Y B>C Y A>C Entonces
Escribir 'El Mayor es ',A
Escribir 'El Menor es ',C
Sino
Si B>A Y A<C Y B>C Entonces
Escribir 'El Mayor es ',B
Escribir 'El Menor es ',A
Sino
si B>A Y A>C Y B>C Entonces
Escribir 'El Mayor es ',B
Escribir 'El Menor es ',C
SINO
si C>A Y A<B Y B<C ENTONCES
Escribir 'El Mayor es ',C
Escribir 'El Menor es ',A
Sino
si C>B Y B<A Y A<C ENTONCES
Escribir 'El Mayor es ',C
Escribir 'El Menor es ',B
FINSI
FinSi
FinSi
FinSi
FinSi
FinSi
Sino
Escribir 'DATO NO VALIDO, FIN DEL PROGRAMA'
FinSi
FinAlgoritmo
Metodologa de la Programacin 1G
Metodologa de la Programacin 1G
5. Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A, B, y C
respectivamente. El algoritmo debe indicar cul es el menor. Asumiendo que los tres valores introducidos
por el teclado son valores distintos.

Algoritmo NumDistintosMenor
Escribir 'A'
Leer A
Escribir 'B'
Leer B
Escribir 'C'
Leer C
Si A<>B Y A<>C Entonces
Si A<B Y A<C Entonces
Escribir 'El Menor es A '
Sino
Si B<A Y B<C Entonces
Escribir 'El Menor es B '
Sino
Si C<A Y C<B Entonces
Escribir 'El Menor es C '
FinSi
FinSi
FinSi
Sino
Escribir 'DATO NO VALIDO, FIN DEL PROGRAMA'
FinSi
FinAlgoritmo
Metodologa de la Programacin 1G
6. Desarrolle un algoritmo que lea cuatro nmeros diferentes y a continuacin imprima el mayor de los
cuatro nmeros introducidos y tambin el menor de ellos.

Algoritmo sin_titulo
l<-1
may <- -100000
men <- 100000
Mientras l<=4 Hacer
leer num
si num>may Entonces
may<-num
finsi
si num<men Entonces
men<-num
FinSi
l<-l+1
Fin Mientras
Escribir 'el mayor es ' may;
Escribir 'el menor es ' men;
FinAlgoritmo
Metodologa de la Programacin 1G
7. Desarrolle un algoritmo que realice la sumatoria de los nmeros enteros mltiplos de 5, comprendidos
entre el 1 y el 100, es decir, 5 + 10 + 15 +. + 100. El programa deber imprimir los nmeros en cuestin y
finalmente su sumatoria.

Algoritmo Multiplos5
n<-0
sum<-0
Mientras n<100 Hacer
n<-n+5
Escribir n
sum<-sum+n
Fin Mientras
Escribir 'La Suma es ' sum;
FinAlgoritmo
Metodologa de la Programacin 1G
8. Desarrolle un algoritmo que lea los primeros 300 nmeros enteros y determine cuntos de ellos son
impares; al final deber indicar su sumatoria.

Algoritmo sin_titulo
n<-0
par<-0
impar<-0
suma<-0
cont<-0
Mientras n<300 Hacer
n<-n+1
si n mod 2 = 0 entonces
par<-par+n
Sino
impar<-impar+n
cont<-cont+1
FinSi
Escribir n
Fin Mientras
suma<-suma+impar
Escribir 'La cantidad de numeros impares es ' cont;
Escribir 'La Suma de numeros impares es ' suma;
FinAlgoritmo
Metodologa de la Programacin 1G
9. Determinar la hipotenusa de un tringulo rectngulo conocidas las longitudes de sus dos catetos.
Desarrolle el algoritmo correspondiente.

Algoritmo sin_titulo
Escribir 'Longitud de Cateto A?'
Leer catA
Escribir 'Longitud de Cateto B?'
Leer catB
hip<-rc(caA^2+caB^2)
Escribir 'la hipotenusa de este triangulo rectangulo es ' hip;
FinAlgoritmo