Você está na página 1de 7

9 DIAGRAMAS DE Profr: Nelson Crozby

Padilla lvarez

FLUJO Alumno: Jess Alfredo


Molina Barajas

1.- G

Metodologa de la Programacin

TICs
1. Desarrolle un algoritmo que permita leer dos nmeros distintos,
determinar cul de los dos valores es mayor y escribirlo.

PSEUDOCDIGO DIAGRAMA DE FLUJO

Algoritmo ejercicio1

Leer N1;
Leer N2;
Si N1>N2 Entonces
Escribir N1;
Escribir 'Es mayor';
Sino
Escribir N2;
Escribir 'Es mayor';
FinSi

FinAlgoritmo

2. Desarrolle un algoritmo que permita leer dos nmeros distintos,


determinar cul de los dos valores es menor y escribirlo.

PSEUDOCDIGO DIAGRAMA DE FLUJO

Algoritmo ejercicio2

Leer N1;
Leer N2;
Si N1<N2 Entonces
Escribir N1;
Escribir 'Es menor';
Sino
Escribir N2;
Escribir 'Es menor';
FinSi

FinAlgoritmo

1
3. Realizar un algoritmo que sume dos nmeros.

PSEUDOCDIGO DIAGRAMA DE FLUJO

Algoritmo ejercicio3

Leer N1;
Leer N2;
Suma = N1 + N2;
Escribir Suma;

FinAlgoritmo

4. Desarrolle un algoritmo que permita leer 3 valores y almacenarlos en las


variables A, B y C respectivamente. El algoritmo debe indicar cul es el
menor. Asumiendo que los 3 valores introducidos son distintos.

PSEUDOCDIGO DIAGRAMA DE FLUJO

Algoritmo ejercicio5
Escribir "Ingresa el valor de A";
Leer A;
Escribir "Ingresa el valor de B";
Leer B;
Escribir "Ingresa el valor de C";
Leer C;
Si A<B Entonces
Si A<C Entonces
Escribir "A es menor";
Sino
Si B<C Entonces
Escribir "B es menor";
Sino
Escribir "C es menor";
FinSi
FinSi
FinSi
FinAlgoritmo

2
5. Desarrolle un algoritmo que permita leer 3 valores y almacenarlos en las
variables A, B y C respectivamente. El algoritmo debe imprimir cul es el
mayor y cul es el menor. Recuerde constatar que los tres valores
introducidos por el teclado sean valores distintos. Presente un mensaje
de alerta cuando se detecte la introduccin de valores iguales.

PSEUDOCDIGO DIAGRAMA DE FLUJO

Algoritmo ejercicio4
Escribir "Ingresa el valor de A";
Leer A;
Escribir "Ingresa el valor de B";
Leer B;
Mientras B==A Hacer
Escribir "Variable B vale lo mismo que A; debe modificarse";
Leer B;
FinMientras
Escribir "Ingresa el valor de C";
Leer C;
Mientras C==A | C==B Hacer
Escribir "El valor de la variable C debe modificarse";
Leer C;
FinMientras
Si A>B Entonces
Si A>C Entonces
Escribir "A es mayor";
Sino
Escribir "C es mayor";
FinSi
Sino
Si B>C Entonces
Escribir "B es mayor";
Sino
Escribir "C es mayor";
FinSi
FinSi
Si A<B Entonces
Si A<C Entonces
Escribir "A es menor";
Sino
Si B<C Entonces
Escribir "B es menor";
Sino
Escribir "C es menor";
FinSi
FinSi
FinSi
FinAlgoritmo

3
6. Desarrolle un algoritmo que lea 4 nmeros diferentes y a continuacin
imprima el mayor de los 4 nmeros introducidos y tambin el menor de
ellos.

PSEUDOCDIGO DIAGRAMA DE FLUJO


Algoritmo ejercicio6
Escribir "Ingresa el valor de A";
Leer A;
Escribir "Ingresa el valor de B";
Leer B;
Mientras B==A Hacer
Escribir "Variable B vale lo mismo que A; debe modificarse";
Leer B;
FinMientras
Escribir "Ingresa el valor de C";
Leer C;
Mientras C==A | C==B Hacer
Escribir "El valor de la variable C debe modificarse";
Leer C;
FinMientras
Escribir "Ingresa el valor de D";
Leer D;
Mientras D==A | D==B | D==C Hacer
Escribir "El valor de la variable D debe modificarse";
Leer D;
FinMientras
Si A>B Entonces
Si A>C Entonces
Si A>D Entonces
Escribir "A es mayor";
Sino
Escribir "D es mayor";
FinSi
Sino
Si C>D Entonces
Escribir "C es mayor";
Sino
Escribir "D es mayor";
FinSi
FinSi
Sino
Si B>C Entonces
Si B>D Entonces
Escribir "B es mayor";
Sino
Escribir "D es mayor";
FinSi
Sino
Si C>D Entonces
Escribir "C es mayor";
Sino
Escribir "D es mayor";
FinSi
FinSi
FinSi
Si A<B Entonces

4
Si A<C Entonces
Si A<D Entonces
Escribir "A es menor";
Sino
Escribir "D es menor";
FinSi
Sino
Si C<D Entonces
Escribir "C es menor";
Sino
Escribir "D es menor";
FinSi
FinSi
Sino
Si B<C Entonces
Si B<D Entonces
Escribir "B es menor";
Sino
Escribir "D es menor";
FinSi
Sino
Si C<D Entonces
Escribir "C es menor";
Sino
Escribir "D es menor";
FinSi
FinSi
FinSi
FinAlgoritmo

7. Desarrolle un algoritmo que realice la sumatoria de los nmeros enteros


mltiplos de 5, comprendidos entre 1-100, es decir, 5+10+15++100. El
programa deber imprimir los nmeros en cuestin y finalmente su
sumatoria.
PSEUDOCDIGO DIAGRAMA DE FLUJO

Algoritmo ejercicio7
Para i<-5 Hasta 100 Con Paso 5 Hacer
Escribir i;
suma=suma+i;
i<-i+5;
FinPara
Escribir "La suma de los mltiplos de 5, del 1 al 100 es";
Escribir suma;
FinAlgoritmo

5
8. Desarrolle un algoritmo que lea los primeros 300 nmeros enteros y
determine cuntos de ellos son impares; al final deber indicar su
sumatoria.
PSEUDOCDIGO DIAGRAMA DE FLUJO

Algoritmo ejercicio8
Para i<-1 Hasta 300 Hacer
Escribir 'Escribe la cantidad nmero';
Escribir i;
Leer num;
Si i%2==1 Entonces
cimp <- cimp+1;
simp <- simp+i;
FinSi
FinPara
Escribir 'la cantidad de nmeros impares que ingresaste fueron';
Escribir cimp;
Escribir 'la suma de los nmeros impares es de';
Escribir simp;
FinAlgoritmo

9. Determinar la hipotenusa de un tringulo rectngulo, conociendo las


longitudes de sus dos catetos. Desarrolle el algoritmo correspondiente.

PSEUDOCDIGO DIAGRAMA DE FLUJO

Algoritmo ejercicio9

Escribir "Escribe la medida del Cateto Opuesto";


Leer cop;
Escribir "Escribe la medida del Cateto Adyacente";
Leer cad;
hyp=rc((cop*cop)+(cad*cad));
Escribir "La medida de la Hipotenusa es";
Escribir hyp;

FinAlgoritmo