Você está na página 1de 8

Nelson Crozby Padilla Alvarez

Metodologa de la programacin

Diagramas de flujo

Tecnologas de la informacin y comunicacin

Heriberto Ortiz Ortiz

Grupo 1G vespertino
1. Desarrolle un algoritmo que permita leer un valor entero positivo N y determinar si
es primo o no.
2. Realice un algoritmo que calcule el monto a pagar por el servicio de estacionamiento,
teniendo en cuenta que por la primera hora de estada se tiene una tarifa de $24 y las
restantes tienen un costo de $12. Se tiene como datos: hora de entrada, hora de salida
(formato 24 horas), iniciada una hora se contabiliza como hora total.
3. Desarrolle un algoritmo para una empresa constructora., que le permita calcular e
imprimir la nmina para su pago a un total de 50 obreros calificados a quienes debe pagar
por horas trabajadas. La hora trabajada se paut en $25.
4. En este ejercicio se pide que se desarrolle el pseudocdigo a partir del enunciado
proporcionado y del DFD: Desarrolle un algoritmo que permita determinar a partir de un
nmero de das, ingresado por pantalla, Cuntos aos, meses, semanas y das;
constituyen el nmero de das proporcionado utilizando la estructura Mientras o While?.
5. Desarrolle el algoritmo anterior utilizando la estructura (ciclo) Repetir (REPEAT).
6. Determine el resultado (realizar la prueba de escritorio) del siguiente diagrama de flujo,
realice el pseudocdigo. Elabore su enunciado.
Desarrolle un diagrama de flujo que le permita determinar a una empresa el nmero de
pagos a realizar a diferentes bancos teniendo en cuenta sus limitaciones presupuestales
mediante una cantidad dada imprima el resto.

Proceso SEIS
BC<-0;
BV<-0;
BD<-0;
BC2<-0;
BM<-0;
Leer N;
C<-N;
Mientras C>=50000 Hacer
BC<-BC+1;
C<-C-50000;
ESCRIBIR C;
FinMientras
Mientras C>=20000 Hacer
BV<-BV+1;
C<-C-20000;
ESCRIBIR C;
FinMientras
Mientras C>=10000 Hacer
BD<-BD+1;
C<-C-10000;
ESCRIBIR C;
FinMientras
Mientras C>=5000 Hacer
BC2<-BC2+1;
C<-C-5000;
ESCRIBIR C;
FinMientras
Mientras C>=1000 Hacer
BM<-BM+1;
C<-C-1000;
ESCRIBIR C;
FinMientras
RESTO<-C;
Escribir "N" ,N;
Escribir "BC" ,BC;
Escribir "BV" ,BV;
Escribir "BD" ,BD;
Escribir "BC2" ,BC2;
Escribir "BM" ,BM;
Escribir "RESTO" ,RESTO;
FinProceso