Você está na página 1de 26

Universidade Estadual de Campinas

Conceitos bsicos e aplicaes em

redes de computadores

Orientador: Prof. Dr. Luis Fernando de Avila


Coordenador Associado do curso de Engenharia de Telecomunicaes e Tecnologia
em Sistemas de Telecomunicaes da Faculdade de Tecnologia FT da Universidade
Estadual de Campinas UNICAMP

Supervisor de estgio: Gerson Celio Costa Soares


Gestor do Departamento de Tecnologia e Telecomunicaes da Empresa CSC da
Camargo Corra

Bolsista e Estagirio: Rony da Silva Albano


Aluno de Graduao do curso de Tecnologia em Sistemas de Telecomunicaes da
Faculdade de Tecnologia FT da Universidade Estadual de Campinas UNICAMP e
estagirio de Tecnologia e Telecom na empresa CSC da Camargo Corra

Limeira, Julho de 2015

1
Universidade Estadual de Campinas

Histrico da evoluo das redes de computadores

A histria das redes de computadores iniciou por volta da dcada de 60, onde o meio de
comunicao que estava em grande expanso mundial era a rede telefnica, onde atravs de circuitos de
comutao a voz era transmitida de uma origem para seu destino. Havia o desenvolvimento dos primeiros
microcomputadores com melhores desempenhos e menor tamanho do que os primeiros sistemas criados
na dcada de 50 permitindo a instalao de considervel poder computacional em vrias localizaes, ao
invs de em uma determinada rea, mas era preciso um meio para unir estes computadores. Os altos
custos dos computadores da poca no intimidou a necessidade de seu aperfeioamento e grande interesse
de centros de pesquisa e governos visando sua utilizao, dessa forma, comeou a ocorrer necessidade
de interligar computadores de modo que se pudessem compartilhar informaes entre diferentes usurios
e diferentes regies. O trfego gerado por estes usurios ocorreria em uma sequncia de atividades, onde
ao acionar um comando a um computador distante, este permaneceria por alguns instantes inativo,
explorando e aguardando uma resposta. Alguns grupos de pesquisa nessa mesma dcada estudavam como
poderiam utilizar as redes telefnicas para a transmisso de pacotes de informao, pode-se citar a
contribuio do cientista Leonard Kleinrock nos laboratrios MIT usou a teoria das filas para criar a
comutao de pacotes baseada no trfego em rajadas, onde esse e outros trabalhos junto com Lawrence
Roberts tambm no MIT lideravam o projeto de cincia de computadores na ARPA (EUA - Agncia de
Projetos de Pesquisa Avanada). No final da dcada de 60 foi publicado a ARPAnet que precursora da
Internet, sendo essa a primeira rede de computadores que usava comutao de pacotes. Os primeiros
comutadores de pacotes ficaram conhecidos como IMPs (interface message processors), processadores de
mensagens de interface, sendo fabricados pela empresa BBN. Esta rede por ser a nica na poca era uma
rede fechada e para se comunicar com suas mquinas era preciso estar ligado a um de seus IMPs. Na
dcada de 70 comearam a surgir outras redes de comutao de pacotes como: ALOHAnet: rede de
microondas via rdio que interligava as ilhas do Hava; TAYMNET e TRANSPAC: rede de comutao
de pacotes franceses, TELENET: comutao de pacotes comerciais da BBN baseada na tecnologia da
Arpanet, que possibilitou o aumento no numero de pequenas redes, onde mais tarde foram denominadas
de LANs. O trabalho pioneiro das primeiras interconexes de redes foi supervisionado pela DARPA
(Agencia de Projetos de Pesquisa Avanada de Defesa), onde foi criado a arquitetura TCP responsvel
pela entrega confivel e sequencial dos pacotes. Com o tempo ouve a necessidade de utilizar o protocolo
TCP para a organizao dos pacotes na rede e por necessidade criou-se o protocolo IP para ser
responsvel pela funo de envio de pacotes e o UDP que ficou responsvel pelo controle do fluxo de
voz nos pacotes. Algumas empresas da poca desenvolveram suas prprias arquiteturas de redes, a Digital
Corporation lanou sua primeira verso de rede em 1975, a DECnet interligando apenas dois
computadores PDP-11, que continuou evoluindo com o conjunto de protocolos OSI (interconexo de
sistemas abertos

Na dcada de 80 ao passar a poca de guerra a Arpanet no tinha mais importncia para os


militares, sendo passada ento para maioria das universidades e outros pesquisadores que foram
estendendo a comunicao por outros pases chegando ate a cem mil mquinas interligadas nessa poca,

2
Universidade Estadual de Campinas

formando uma grande rede mundial que passou a ser conhecida como Internet. No ano 1983 o
protocolo TCP/IP tornou-se oficial, sendo obrigatrio estar em todas as mquinas, tambm nesta poca
foi desenvolvido o DNS (Domain Name System), usado para converso dos endereos em forma de letras
e palavras, pois so de mais fcil memorizao para ns, na forma de endereo IP de 32 bits, a linguagem
dos computadores. Na Frana foi desenvolvido o projeto Minitel, uma rede publica de comutao de
pacotes baseada num conjunto de protocolos chamado X.25 que usava circuitos virtuais, terminais baratos
e modems embutidos, porm de baixa velocidade, disponibilizava sites de listas telefnicas e outros,
havia tambm sites particulares onde eram pagas taxas pelos usurios conforme o tempo de uso.

. Na dcada de 1990 a ARPAnet deixou de existir, a Milnet e a Rede de Dados de Defesa


passaram a controlar maior parte do trfego do Departamento de Defesa dos EUA e a NSFNET passou a
ser o backbone de conexo entre os Estados Unidos e todas as redes do exterior. Nessa mesma dcada
entrou-se em funcionamento aWorld Wide Web, nos lares e empresas de milhes de pessoas espalhadas
por todo mundo, para fins comerciais, bancrios, empresariais, educacionais e para prpria diverso. A
Web foi inventada no Cern(Centro Europeu para Fsica Nuclear) por Tim Berners Lee no perodo de
1989 a 1991, baseados em trabalhos realizados por Bush e Ted Nelson respectivamente nas dcadas de 40
e 60. Berners Lee e seus companheiros desenvolveram verses iniciais de HTML, HTTP, um servidor
web e um Browser. O Brasil entrou na rede em 1990 criando a RNP (rede nacional de pesquisas). Em
1992 foi criada a Internet Society e j existiam 200 servidores web em operao, nesta poca as pesquisas
estavam mais voltadas para o desenvolvimento de browsers. Em 1996 a Microsoft entrou com tudo na
web com o browser Internet Explorer. Como o desenvolvimento avanava a cada dia, iniciaram pesquisas
por roteadores e roteamento de alta velocidade para redes locais. e recursos como o comrcio eletrnico e
textos, imagens, multimdia e outros.

No final da dcada de 90 a evoluo do servio em redes passou a ser muito rpido, tanto em
empresas como em lares surgiram alm das redes Ethernet que so redes locais, redes Intranet que so
redes locais ligadas a grande rede mundial, muito utilizada pelas empresas hoje para diversos fins , como
comunicao com filiais, comunicao entre setores atravs de um sistema em rede etc. A grande rede de
computadores formada por milhes redes menores hoje o componente mais importante na rea da
comunicao a popular e grande rede global de computadores a Internet, ainda no parou de crescer e
com certeza no parar, pois o nmero de usurios tanto para fins empresariais como pessoais aumenta a
cada dia, pois, hoje o custo para aquisio, ou acesso a uma rede menor e tende a ficar cada vez mais
barato, e ainda as maiores dificuldades seriam condies tcnicas.

Hubs

A funo principal dos hubs fazer o papel de barramento, ou seja, sendo um centralizador de
conexes que tambm isola os cabos de cada equipamento conectado a ele, facilitando assim a
identificao e resoluo de problemas envolvendo os cabos utilizados na conexo da rede local.
Funcionando assim como uma pea central, que recebe os sinais transmitidos pelas estaes e os
retransmite para todas as demais portas (broadcasting). Existem os hubs passivos que so concentradores

3
Universidade Estadual de Campinas

de cabos que no possuem qualquer tipo de alimentao eltrica funcionando apenas como um
espelho, refletindo os sinais recebidos para todas as estaes a ele conectadas. Como ele apenas distribui
o sinal, sem fazer qualquer tipo de amplificao, o comprimento total dos dois trechos de cabo entre um
micro e outro, passando pelo hub, no pode exceder os 100 metros permitidos pelos cabos de par
tranado. J os hubs ativos tem a vantagem de regenerar os sinais que recebem de suas portas antes de
envi-los para todas as portas. Funcionando como repetidores, possibilitando assim um aumento na
distncia entre dois micros pertencentes a uma mesma rede.

Figure 1 Hub. Fonte = http://www.wifinotes.com/computer-networks/what-is-hub.html e http://online-source.net/2011/12/23/active-


and-passive-ethernet-hubs/

Bridges

So equipamentos utilizados para interligar duas redes locais, isolando o trfego de ambas. Os
Bridges tem a capacidade de ler e analisar os quadros de dados que esto circulando na rede extraindo
informaes do endereamento MAC (endereos de nvel 2 da camada OSI) colocando esses endereos
em uma tabela por meio de um algoritmo chamado spanning-tree, usando esses dados para que a ponte
no replique para outros segmentos dados que tenham como destino o mesmo segmento de origem. Outro
papel que a ponte em principio poderia ter o de interligar redes que possuem arquiteturas diferentes.

Figure 2 Brigdes. Fonte = https://antonioviana.wordpress.com/2009/11/

4
Universidade Estadual de Campinas

Gateway

um sistema composto de hardware e software que faz a converso de diferentes protocolos, ele
necessrio, pois em uma mesma rede corporativa, pode-se ter o funcionamento de diversos tipos de
arquiteturas como TCP/IP e o SNA permitindo com que ambos se comuniquem. Ele tambm utilizado
quando se precisam conectar aplicaes que ficam em computadores e sistemas de fabricantes diferentes.
Para isso ele recebe os dados da camada de aplicao do modelo OSI (camada 7) de uma determinada
arquitetura e converte a informao nas camadas mais baixas, ate a transmisso para outra arquitetura,
reconvertendo atravs das camadas superiores at a camada de aplicao utilizando a arquitetura utilizada
pela rede de destino.

Figure 3 Gateway. Fonte = http://www.adlsservicos.com.br/2015/02/05/gateway/

Switches

O switch um equipamento que opera de maneira anloga a um bridge, permitindo que muitas
redes locais sejam segmentadas e se comuniquem entre si duas a duas de maneira que somente no so
replicadas informaes para a rede de origem dos dados transmitidos. O switch tambm atua na camada
de enlace do modelo OSI, ele armazena informaes de endereamento MAC (mdium Acces Control)
por meio de uma tabela de endereos das portas atravs do algoritmo spanning-tree e pode fazer a
comutao de vrios segmentos de rede ao mesmo tempo, desde que as comunicaes no envolvam
portas de origem ou destino que j estejam sendo usadas em outras comunicaes. Ele tem a vantagem de
trazer micro processadores internos que garantem ao aparelho um poder de processamento, capaz de
traar os melhores caminhos para o trfego dos dados, evitando a coliso dos pacotes e ainda conseguindo
tornar a rede mais confivel e estvel. De maneira geral a funo do switch muito parecida com a de um
bridge, com a exceo que um switch tem mais portas e um melhor desempenho, j que manter o
cabeamento da rede livre. Existem duas arquiteturas bsicas de Switches de rede, o cut-through apenas
examina o endereo de destino no frame e faz a comutao, minimizando o tempo de propagao dos

5
Universidade Estadual de Campinas

pacotes na rede antes e store-and-forward que l o frame recebido, armazena e analisa o pacote inteiro
para em seguida reencaminhar o pacote, permitindo assim a deteco de alguns erros, evitando a sua
propagao pela rede.

Figure 4 Swichtes. Fonte = http://www.lindy-usa.com/tips/hubsAndSwitches.html

Roteadores

Roteadores so pontes que operam na camada de Rede do modelo OSI (camada 3), essa camada
no utiliza informaes dos elementos fsicos da rede (Endereo MAC das placas de rede, que so valores
fsicos e fixos), mais sim pelo protocolo mais usado hoje em dia, o TCP/IP, o protocolo IP (mais
comumente utilizado o IPv4) o responsvel por criar o contedo dessa camada. Isso Significa que os
roteadores no analisam os quadros fsicos que esto sendo transmitidos, mas sim os datagramas
produzidos pelo protocolo que no caso o TCP/IP, os roteadores so capazes de ler e analisar os
datagramas IP contidos nos quadros transmitidos pela rede. O papel fundamental do roteador poder
escolher um caminho para o datagrama chegar at seu destino, caso ele receba um datagrama destinado a
uma rede cujo caminho ele no conhece, esse datagrama enviado para o roteador listado como sendo o
default gateway, esse processo continua at o datagrama atingir a sua rede de destino ou o tempo de vida
do datagrama ter se excedido o que indica que o datagrama se perdeu no meio do caminho. Em redes
grandes pode haver mais de um caminho, e o roteador o elemento responsvel por tomar a deciso de
qual caminho percorrer, para isso so montadas tabelas de roteamento para controle de rotas e
encaminhamento dos pacotes. As informaes de rotas para a propagao de pacotes podem ser
configuradas de forma esttica pelo administrador da rede ou serem coletadas atravs de processos
dinmicos executando na rede, chamados protocolos de roteamento. O gerenciamento de rotas feito
pelos roteadores, atravs do uso de protocolos, como por exemplo, o RIP (Rounting Information
Protocol), OSPF (Open Shortest Path First), IPX (Internetwork Packet Exchange) e EGRP (Enhanced
Interior Gateway Routing Protocol), que coletam informaes da rede para preencherem as tabelas de

6
Universidade Estadual de Campinas

roteamento e decidirem o melhor caminho usando dois critrios principais selecionando o caminho
mais curto ou o caminho menos congestionado. Em outras palavras, o roteador um dispositivo
responsvel por interligar redes diferentes, inclusive podendo interligar redes que possuam arquiteturas
diferentes, por exemplo, conectar uma rede Token Ring a uma rede Ethernet, uma rede Ethernet a uma
rede x-25. Nas redes locais de uma empresa, por exemplo, pode-se conectar um roteador ao swich que
interliga as redes locais Ethernet internas e por meio do roteador fazer a comunicao dessas redes com o
mundo externo. A conexo do roteador aos canais de comunicao externos da rede WAN feito por
portas com conectores RS-232, V.35, RS-449 ou G.703, dependendo do tipo de interface e da velocidade
dos respectivos canais de comunicao a qual vai se comunicar.

Figura 5 Roteadores. Fonte = http://www.baboo.com.br/tutorial/routing-information-protocol-rip/

Roteamento esttico e roteamento dinmico

Nem sempre uma rede especfica necessita da configurao de protocolos de roteamento.


Existem situaes onde as informaes de roteamento no sofrem alteraes, por exemplo, quando existe
somente uma rota possvel, o administrador do sistema normalmente monta uma tabela de roteamento
esttica manualmente. Algumas redes no tm acesso a qualquer outra rede e, portanto no necessitam de
tabela de roteamento. Dessa forma, as configuraes de roteamento mais comuns so roteamento esttico
que usado em uma rede com um nmero limitado de roteadores para outras redes, gerando uma tabela
de roteamento de forma manual pelo administrador do sistema, e pode ou no ser divulgada para outros
dispositivos de roteamento na rede. Tabelas estticas no se ajustam automaticamente a alteraes na
rede, portanto devem ser utilizadas somente onde as rotas no sofrem alteraes. Algumas vantagens do
roteamento esttico so a segurana obtida pela no divulgao de rotas que devem permanecer
escondidas; e a reduo do overhead introduzido pela troca de mensagens de roteamento na rede. J
roteamento dinmico so usados em redes com mais de uma rota possvel para o mesmo ponto, assim a
tabela de roteamento dinmico construda a partir de informaes trocadas entre protocolos de
roteamento. Os protocolos so desenvolvidos para distribuir informaes que ajustam rotas

7
Universidade Estadual de Campinas

dinamicamente para refletir alteraes nas condies da rede, podendo resolver situaes complexas
de roteamento mais rpida e eficientemente que o administrador do sistema. Protocolos de roteamento so
desenvolvidos para trocar para uma rota alternativa quando a rota primria se torna inopervel e para
decidir qual a rota preferida para um destino. Em redes onde existem vrias alternativas de rotas para
um destino devem ser utilizados protocolos de roteamento.

Cabeamento Estruturado

Atualmente a arquitetura Ethernet a mais comumente utilizada nas redes usando cabo par
tranado sem blindagem (UTP). Nessa arquitetura, h a necessidade de um dispositivo concentrador,
tipicamente um hub, para fazer a conexo entre os computadores. Em redes pequenas, o cabeamento no
um ponto que atrapalhe o dia-a-dia da empresa, j que apenas um ou dois hubs so necessrios para
interligar todos os micros. Entretanto, em redes mdias e grandes a quantidade de cabos e o
gerenciamento dessas conexes pode atrapalhar o dia-a-dia da empresa. A simples conexo de um novo
micro na rede pode significar horas e horas de trabalho (passando cabos e tentando achar uma porta livre
em um hub). a que entra o Cabeamento Estruturado. A ideia bsica do cabeamento estruturado fornece
ao ambiente de trabalho um sistema de cabeamento que facilite a instalao e remoo de equipamentos,
sem muita perda de tempo. Dessa forma, o sistema mais simples de cabeamento estruturado aquele que
prov tomadas RJ-45 para os micros da rede em vez de conectarem o hub diretamente aos micros.
Podendo haver vrios pontos de rede j preparados para receber novas mquinas. Assim, ao trocar um
micro de lugar ou na instalao de um novo micro, no haver a necessidade de se fazer o cabeamento do
micro at o hub; este cabeamento j estar feito, agilizando o dia-a-dia da empresa. A ideia do
cabeamento estruturado vai muito alem disso. Alm do uso de tomadas, o sistema de cabeamento
estruturado utiliza um concentrador de cabos chamado Patch Panel (painel concentrador e distribuidor de
cabos). Em vez de os cabos que vm das tomadas conectarem-se diretamente ao hub, eles so conectados
ao patch panel. Dessa forma, o patch panel funciona como um grande concentrador de tomadas, sendo um
sistema passivo, pois no possui nenhum circuito eletrnico. Trata-se somente de um painel contendo
conectores. Esse painel construdo com um tamanho padro, de forma que ele possa ser instalado em
um rack. O uso do patch panel facilita enormemente a manuteno de redes medis e grandes. Por
exemplo, se for necessrio trocar dispositivos, adicionar novos dispositivos (hubs e switches, por
exemplo) alterar a configurao de cabos, etc., basta trocar a conexo dos dispositivos no patch panel,
sem a necessidade de alterar os cabos que vo at os micros. Em redes grandes comum haver mais de
um local contendo patch panel. Assim, as portas dos patch panels no conectam somente os micros da
rede, mas tambm fazem a ligao entre patch panels. Para uma melhor organizao das portas no patch
panel, este possui uma pequena rea para poder rotular cada porta, isto , colocar uma etiqueta
informando onde a porta esta fisicamente instalada. Dessa forma, a essncia do cabeamento estruturado
o projeto do cabeamento da rede. O cabeamento deve ser projetado sempre pensado na futura expanso da
rede e na facilitao de manuteno. Deve-se lembrar sempre que, ao contrario de micros e de programas
que se tornam obsoletos com certa facilidade, o cabeamento de rede no algo que fica obsoleto com o
passar dos anos. Com isso, na maioria das vezes vale pena investir em montar um sistema de
cabeamento estruturado.

8
Universidade Estadual de Campinas

Figura 6 - UTP e Rack Patch Panel. Fonte = http://www.ciftelecommunication.com/patch-panel/ e


ttps://www.pinterest.com/pin/355925176772839939/

Protocolos

Os protocolos so conjuntos de regras que definem procedimentos, mtodos, regras e


convenes a serem seguidos, usados para estabelecer comunicao entre dois ou mais dispositivos
conectados a rede. Um protocolo tem o objetivo de dividir um fluxo de dados do sistema operacional, em
pequenas partes denominadas pacotes, sendo esses transmitidos pela rede atravs de mltiplos percursos,
ate chegar a maquina de destino.

Visando diminuir a complexidade dos projetos, a grande maioria das redes dividida em
camadas ou nveis, que especificam e delegam tarefas necessrias a serem executadas a cada seguimento.
Existem diversos tipos de protocolos que podem ser aplicados rede, que se diferem pela quantidade de
camadas, funes, nome entre outros utilizados para sua padronizao.

Nessa prxima sesso ser discutido sobre dois modelos de referncia utilizados em redes de
computadores, o modelo OSI e o TCP/IP que dentro de sua arquitetura, apresentam protocolos de
comunicao. Apesar de o modelo OSI ser considerado o modelo arquitetural primrio para redes de
computadores pela Organizao Internacional para Padronizao (ISO) em 1984, seus protocolos
associados ao modelo so raramente utilizados nos dias atuais, devido a sua falta de flexibilidade e
enorme complexidade. J o modelo TCP/IP foi um sucesso no apenas imposio das agncias militares
americanas, mas tambm ao fato der ter sido o primeiro protocolo a atingir a importante meta da
comunicao de dados com abrangncia mundial, devido a algumas caractersticas importantes que
tambm sero descritas.

9
Universidade Estadual de Campinas

Modelo ISO/OSI

O modelo OSI foi desenvolvido a partir de uma proposta definida pela ISO (International
Standard Organization) a fim de alcanar a padronizao internacional dos protocolos contidos em suas
diversas camadas. Intitulado Modelo de Referncia para a Interconexo de Sistemas Abertos ou RM-OSI
(Reference Model for Open Systems Interconnection), pois trata da interconexo de sistemas abertos
sendo esses sistemas que esto abertos comunicao com outros sistemas. Seus grandes objetivos do
nunca foram atingidos, em grande parte isso ocorreu enorme complexidade de desenvolver um modelo
aberto capaz de contemplar todas as possibilidades. Embora sob o ponto de vista de interligao dos
sistemas abertos tenha sido um fracasso, devido novamente sua alta complexidade, o modelo OSI foi um
passo muito importante para o desenvolvimento de novos protocolos, pois fundamentalmente criou-se a
ideia de um conjunto de normas, nomenclaturas, tcnicas para serem aplicados aos sistemas. O modelo
OSI foi criado seguindo a filosofia das arquiteturas multicamadas, sua arquitetura define 7 camadas,
sendo que cada camada corresponde a um nvel de abstrao necessrio no modelo e possui protocolos e
funes prprias e bem definidas segundo normas internacionais e visando escolher as fronteiras entre
cada camada definida de modo a minimizar o fluxo de informao nas interfaces. O grande nmero de
camadas foi pensado para que funes distintas no precisem ser colocadas na mesma camada, e serem
suficientemente pequenas para que a arquitetura no se torne difcil de controlar. O modelo consiste em
sete camadas: Fsica (camada 1), Enlace de dados (camada 2), Rede (camada 3), Transporte (camada 4),
Sesso (camada 5), Apresentao (camada 6) e Aplicao (camada 7).
A seguir, a descrio breve de cada camada.
Camada 1 - Fsica: a camada que tem como tarefa a transmisso de bits brutos (zeros e uns)
por um canal de comunicao. A transmisso realizada atravs de conexes eltricas e mecnicas
formadas por linhas de transmisso, conectores, cabos e interface dos equipamentos ligados na rede.
Devero existir garantias em relao a taxa de erros de bits transmitidos e a qualidade dos elementos que
constituem as conexes da rede, inclusive dos equipamentos. Assim existem normas que definem
requisitos eltricos, mecnicas, de sincronizao, Interfaces entre outros nos projetos.
Camada 2 - Enlace de Dados: A camada de Enlace formata os bits recebidos na camada fsica
em frames e adiciona um cabealho que contm o endereo de hardware (MAC adress) das maquinas
conectadas na rede, ela governa a troca de dados entre dois pontos na rede. Essa camada assegura que os
dados sejam transmitidos aos equipamentos de maneira confivel, pois realizada a correo de erros de
bits nessa camada, sendo requisitada a retransmisso dos bits que apresentam erros.
Camada 3 - Rede: Esta camada faz o controle da operao da sub-rede. responsvel por todo
trfego dentro da rede externa, como o roteamento dos dados entre ns da rede ate se chegar ao endereo
de destino, usando o endereo lgico dos pacotes de dados, outras funes so controle de
congestionamento e de segurana, atravs de listas de acesso, encaminhamento dos pacotes que
percorrem a rede, seleo da melhor rota, entre outras funes. Tornando possvel a comunicao de
redes diferentes.
Camada 4 - Transporte: Esta camada tem como funo garantir a comunicao entre a
aplicao de origem e destino usando comunicao ponto a ponto. Assim e realizado a segmentao e

10
Universidade Estadual de Campinas

reconstruo de fluxos de dados das camadas superiores, garantindo a entrega correta dos fragmentos
e finalizao dos circuitos lgicos estabelecidos. Essa camada responsvel pela multiplexao e
demultiplexao dos dados que sero distribudos entre os terminais da rede final, faz o tratamento de
retardo e espera de pacotes atravs do fluxo de mensagem entre o transmissor e o receptor entre outras
funes.
Camada 5 - Sesso: Basicamente, a camada de sesso faz com que os usurios de diversas
mquinas firmem uma sesso entre si, separando os dados de diferentes aplicaes, permitindo seu
gerenciamento. Nessa camada conferida a identificao de conexo entre dois sistemas, promovendo a
autenticando do usurio e controlando a sincronizao de comunicao e sua forma de transmisso
(duplex ou full-duplex). Alguns protocolos usados nessa camada so: Structured Query Language (SQL),
Apple Talk Session Protocol (ASP), entre outros.
Camada 6 - Apresentao: Essa camada responde a solicitaes de servio recebidas da camada
de aplicao fazendo a requisio das informaes camada de sesso fazendo a converso de cdigos e
formatos para serem enviadas a camada de aplicao. Ela apresenta funes que incluem a compresso e
descompresso de dados, encriptao e decriptao, alm de cuidar da segurana das informaes
transmitidas (essas funes no so exclusivas a essa camada). Alguns padres definidos para o processo
de compresso so o JPEG, MPEG, TIFF, PICT, GIF, entre outros.
Camada 7 - Aplicao: A camada de Aplicao responsvel por identificar e estabelecer a
disponibilidade da aplicao na mquina de destino e disponibilizar os recursos necessrios para a
comunicao, fazendo com que acontea a troca de informaes permitindo que ocorra a interao micro-
usurio. Nessa camada temos os os protocolos e programas de arquivos, envio de e-mails, aplicaes
HTTP (HyperText Transfer Protocol), aplicaes telnet, entre outras.

Figura 7 Modelo de referncia ISO/OSI. Fonte = http://pplware.sapo.pt/tutoriais/networking/redes-sabe-o-que-e-o-modelo-osi/

11
Universidade Estadual de Campinas

Arquitetura TCP/IP

A famlia de protocolos TCP/IP originou-se da rede ARPANET que era patrocinada pelo DoD
(ou Departamento de Defesa dos Estados Unidos). Permitia que rgos do governo e universidades se
comunicassem atravs de conexes por intermdio de linhas telefnicas dedicadas. Com o advento das
redes de rdio e satlite, problemas envolvendo protocolos comearam a ocorrer, devido ao aumento do
trafego de dados e necessidade de uma maior integrao entre as solues de redes existentes. Assim, foi
desenvolvida uma nova arquitetura de conexo uniforme entre diversas redes, denominada arquitetura
TCP/IP, nome ganho pelo uso dos principais protocolos: TCP e IP. Como requisitos, o DoD exigiu que a
nova arquitetura de rede conecta-se os meios de interconexo (hosts, roteadores e gateways) de tal forma
que mesmo que as sub-redes fossem destrudas, a rede teria de continuar operando, transmitindo as
conversaes, mediante o funcionamento das mquinas de origem e destino. O protocolo TCP/IP foi
escolhido por possuir uma arquitetura flexvel, com alta adaptabilidade a aplicaes com distintos
requisitos, substituram os antigos protocolos que a ARPANET utilizava, que no cumpriam as exigncias
requeridas pelo DoD. Assim o crescimento da ARPANET foi muito rpido e evolui at se tornar a
Internet dos dias atuais que usa como base o Modelo de Referncia ISO/OSI e a pilha de protocolos
TCP/IP. Quando um host executa a pilha TCP/IP, recebe um endereo IP e pode transmitir pacotes IP
para todas as mquinas conectadas na enorme rede Internet. Algumas das caractersticas do sucesso do
modelo TCP/IP por ser um protocolo aberto e pblico sendo completamente independente de
equipamentos e de sistemas operacionais, seu esquema de endereamento permite designar univocamente
qualquer mquina, mesmo em redes globais como a Internet, pois ele esta disponvel em quase todas as
plataformas. O protocolo TCP/IP continua sendo padronizado atravs do Requests For Comments (RFC),
que, alm da especificao formal dos protocolos, incluindo informaes importantes sobre seu uso e
funcionamento. Este modelo constitudo de 4 camadas: Redes (Inter-redes), Internet (Inter-Redes),
Transporte, Aplicao.

Figura 8 Modelo de referncia TCP/IP. Fonte de http://www.devmedia.com.br/via-de-mao-dupla-


com-websockets-revista-java-magazine-117/28281

12
Universidade Estadual de Campinas

Topologias

A topologia refere-se ao modo como dispositivos so conectados na rede atravs de um meio de


conexo fsica. A topologia de uma rede depende de vrios fatores, entre eles o projeto das operaes, da
confiabilidade e do seu custo operacional. Ao se projetar uma rede, muitos fatores devem ser
considerados, mas a topologia a ser empregada de total importncia para o bom desempenho e retorno
do investimento de uma rede. Cada topologia possui suas caractersticas, que diferem quanto ao
desenvolvimento, operao e manuteno da rede. Nas topologias fsicas so especificados como os ns
esto interconectados uns nos outros e como fluxo de informaes percorre a rede. Vrias so as formas
de interligao, embora as variaes sempre derivem de trs modelos bsicos, que so as mais
frequentemente empregadas, barramentos, anis e estrelas. A topologia em sua forma lgica tem o papel
de descrever um esquema usado pelo sistema operacional da rede, para administrar o fluxo de
informaes entre os ns rede. A maioria dos sistemas operacionais de redes utiliza-se de duas principais
topologias lgicas, a Linear e a Token Ring.

Barramento
Topologia fsica
a topologia mais fcil de instalar. Nas redes de topologia barramento cada n conectado a um
nico cabo (espinha dorsal), porm esta estrutura deve completar-se em ambas as pontas com um
conector especial chamado Terminador. O desempenho de um sistema em barra comum determinado
pelo meio de transmisso, nmero de ns conectados, controle de acesso, tipo de trfego entre outros
fatores. Isso faz da topologia barramento a mais utilizada, que, ainda, possui alto poder de expanso
utilizando repetidores. Esta rede utiliza o cabo coaxial e o padro de comunicao Ethernet. Cada n na
barra pode ouvir todas as informaes transmitidas. Esta caracterstica facilita as aplicaes com
mensagens do tipo difuso (para mltiplas estaes).
Topologia Lgica
Existe uma variedade de mecanismos para o controle de acesso ao barramento, que pode ser
centralizado ou descentralizado. A tcnica adotada para acesso rede a multiplexao no tempo. Em
controle centralizado, o direito de acesso determinado por uma estao especial da rede, o Servidor. Em
um ambiente de controle descentralizado, a responsabilidade de acesso distribuda entre todos os ns. A
vantagem de se utilizar este tipo de topologia devido a possuir um baixo custo de instalao e
manuteno, porm tem a desvantagem de se existir problemas de transmisso, difcil isolar a causa, j
que todos os ns esto conectados ao mesmo meio fsico e a rede permanece lenta em momentos em que
ela muito utilizada.

Figure 9 Topologia tipo barramento. Fonte = http://rfaelsilva.blogspot.com.br/

13
Universidade Estadual de Campinas

Anel
Topologia fsica
A topologia em anel utiliza em geral ligaes ponto-a-ponto que operam em um nico sentido de
transmisso. O sinal circula no anel at chegar ao destino.
Topologia lgica
Esta topologia lgica pouco tolervel falha e possui uma grande limitao quanto a sua
expanso pelo aumento de "retardo de transmisso" (intervalo de tempo entre o incio e chegada do sinal
ao n destino). Tem a vantagem de possibilitar fcil adio e remoo de estaes, e desvantagens por ter
um alto custo de implementao, alm de alto grau de complexidade.

Figure 10 Topologia tipo Anel. Fonte = https://weblinkinfo.wordpress.com/tag/topologia-de-redes/

Estrela
Topologia fsica
A topologia em estrela utiliza um n central (comutador ou switch) para chavear e gerenciar a
comunicao entre as estaes. esta unidade central que vai determinar a velocidade de transmisso,
como tambm converter sinais transmitidos por protocolos diferentes. Neste tipo de topologia comum
acontecer o overhead localizado, j que uma mquina acionada por vez, simulando um ponto-a-ponto.
Topologia Lgica
A topologia lgica tipo estrela comum em ambiente de rede de grande porte, ou em ambiente
de rede utilizando PBX como um dispositivo comutador central de dados. Nos ambientes LAN mais
comuns, a estrela implementada como fsica e no como uma topologia lgica. Este modelo de
topologia utiliza-se do padro de comunicao Ethernet e do padro de comunicao ArcNet, Ethernet
quando se utiliza de cabo par tranado e ArcNet quando se utiliza de cabo coaxial. Esse tipo de topologia
tem a vantagem de possibilitar o gerenciamento centralizado e fcil adio de hosts na rede conectando-se
as mesmas s portas de comunicao que estejam livres. As desvantagens seriam que o numero de hosts
que podem ser conectados a rede limitado pela quantidade de portas dos hubs ou Switchs e apresenta
alto custo de implementao, pois cada host deve ser conectado a um dispositivo central.

14
Universidade Estadual de Campinas

Figure 11 Topologia tipo Estrela. Fonte = http://www.fazerfacil.com.br/rede/topologia.htm

Classificao das Redes de Computadores


Redes de computadores so interligadas por um sistema de telecomunicaes e constituda por
um conjunto de mdulos processadores capazes de trocar informaes e compartilhar recursos entre si.
Um sistema de comunicao formado de um arranjo topolgico interligando os vrios mdulos
processadores atravs de enlaces fsicos (meios de transmisso), sendo organizado por um conjunto de
regras definidos como protocolos de comunicao.

Redes Locais
Redes Locais (LANs - Local Area Networks) so redes privadas que surgiram para permitir a
troca e o compartilhamento de informaes de diversos dispositivos perifricos, promovendo a integrao
de ambientes de trabalho, mantendo a independncia das vrias estaes de processamento utilizadas.
Foram definidas e utilizadas inicialmente em ambientes universitrios e institutos de pesquisa redes e so
amplamente utilizadas para interconectar computadores pessoais e estaes de trabalho em escritrios e
instalaes industriais. As redes locais possuem tamanho restrito de apenas alguns quilmetros de
extenso, sendo que esta limitao bastante vaga, pois s tcnicas utilizadas em redes locais no
imponham limites a essas distncias. Possuem trs caractersticas que as diferem das demais: tamanho,
tecnologia de transmisso e topologia. Tradicionalmente nas LANs os computadores (ou equipamentos)
so interconectados por cabos ou atravs de equipamentos tipo hub. Este tipo de rede por ser de curto
alcance apresenta menor taxa de erro e baixo retardo de transmisso. Essas redes possuem velocidades de
trafego que variam geralmente de 10 a 100 Mbp, atualmente existindo redes mais modernas podendo
operar em velocidades ainda mais altas, alcanando Gbps. Neste tipo de rede as topologias lgicas mais
usadas so o barramento e o anel e como topologias fsicas a rvore e a estrela. Durante a transmisso de
informaes por redes distintas interconectadas, pode ocorrer que elas se propagem no mesmo instante,
provocando conflitos na rede. Analisando estes arranjos topolgicos, possvel a criao de um
mecanismo de arbitragem para determinao de qual estao poder transmitir de forma a no existncia
de conflitos e garantindo o tempo para a transmisso de dados de cada estao em tempos diferentes.
Estes mecanismos podem ser estticos ou dinmicos e os dinmicos podem ainda ser divididos em
centralizados ou distribudos.

15
Universidade Estadual de Campinas

Figure 12 Rede LAN. Fonte = https://lucianoerodrigo.wordpress.com/lan/

Redes Metropolitanas

Uma Rede Metropolitana (MAN - Metropolitan Area Network) pode ser entendida como
aquelas que proveem a interligao das redes locais e utilizam tecnologias semelhantes. Uma MAN pode
ser privada ou publica e pode abranger um grupo de escritrios vizinhos ou uma cidade inteira. Este tipo
de rede pode transportar voz e dados, podendo inclusive ser associado rede de televiso a cabo local. A
principal razo para se tratar as redes metropolitanas como uma categoria especial que elas utilizam um
padro especial, o DQDB (Distributed Queue Dual Bus) ou IEEE 802.6 e atualmente existe uma maior
aceitao para o uso da tecnologia ATM (Asynchronous Transfer Mode).

Figure 13 Rede MAN. Fonte = http://tecredeaise.blogspot.com.br/2013/04/tipos-de-rede-relativamente-sua.html

Redes Geograficamente Distribudas

As Redes Geograficamente Distribudas (WANs - Wide Area Networks) so formadas quando as


distncias envolvidas na interligao das redes de computadores so superiores a uma regio

16
Universidade Estadual de Campinas

metropolitana, podendo ser a disperso geogrfica to grande quanto distncia entre continentes. Ela
agrupa conjuntos de sub-redes onde esto conectadas mquinas denominadas hosts que tem como
finalidade executar programas de usurios. As sub-redes tm como tarefa transportar mensagens de um
host para outro, da mesma maneira que o sistema telefnico transporta palavras da pessoa que fala para
aquela que ouve. Na maioria das redes geograficamente distribudas, a sub-rede consiste em dois
componentes distintos: linhas de transmisso e elementos de comutao. As linhas de transmisso,
tambm chamadas circuitos, canais ou troncos, transportam os bits entre as mquinas. Os elementos de
comutao so equipamentos especializados usados para conectar duas ou mais linhas de transmisso.
Na maior parte das WANs, a rede contm numerosos cabos ou linhas telefnicas, todos
conectados por um par de roteadores. Porm, se dois roteadores que no compartilham um cabo
desejarem se comunicarem eles podero faz-lo atravs de um ou mais roteadores intermedirios. Devido
aos altos custos de instalao dessas redes, em geral so estas redes so gerenciveis e de propriedade
pblica. Atualmente as velocidades empregadas nas WANs podem chegar a Gigabits/segundo.

Figure 14 - Rede WAN. Fonte = http://www.complexsystem.net/discussions/network-skills

VPN

A VPN (Virtual Private Network) trata-se de uma tecnologia para interligar dois pontos
autorizados na rede independente de sua localizao, formado um canal de comunicao usando uma
tcnica chamada "tunelamento" (tunneling), onde os pacotes de dados so transmitidos atravs de uma
rede pblica roteada (Internet) em um tnel privado que simula uma conexo ponto-a-ponto. Esses dados
devem ser protegidos visando manter a segurana, confidencialidade, integridade e autenticidade dos
dados transmitidos, no permitindo que estes sejam interceptados ou modificados. A confidencialidade
refere-se a limitar o acesso a informaes, atravs do uso de criptografia, j a integridade assegura que os
dados no sero alterados durante uma transmisso da informao, e por fim a autenticidade verifica se a
pessoa com quem se est trocando informaes sigilosas realmente quem deveria ser. O interesse
crescente das organizaes para a implementao de VPNs tambm financeiro devido utilizao da

17
Universidade Estadual de Campinas

rede pblica Internet e fcil criao e expanso dos canais de comunicao gerenciados. As VPNs so
muito utilizadas em redes corporativas, por exemplo, para conexes de filiais chamadas Extranets, ou
mesmo possibilitando o acesso seguro para trabalho remoto ou de usurios mveis usando conexes dial-
up criptogradas, para isso utiliza-se o recurso AD DS (Active Directory Domain Services) e com o NPS
(Network Policy Service), onde cria-se usurios e grupos que sero os clientes com permisso ao acesso
remoto. uma tecnologia barata e muito utilizada se comparada a outros meios para a mesma finalidade
como a linha dedicada, apresentando menores investimentos em infraestrutura extra. As principais
implementaes de VPNs incluem OpenVPN e IPsec.

Figure 15 VPN. Fonte = https://technet.microsoft.com/en-us/library/cc779919(v=ws.10).aspx

Firewall

Um firewall uma barreira inteligente entre duas redes, que controla o fluxo de dados que
entram e saem permitindo apenas o trfego autorizado, sendo que uma das redes geralmente mais segura
e outra no muito segura (por exemplo a internet). Algumas corporaes tem servidores que se encontram
externos a estrutura da rede, nesses casos o firewall deve ser colocado neste lado da rede que menos
seguro denominado de DMZ (DeMilitarized Zone) e quando usado na intranet para isolar um segmento,
essa rea chamada de sub-rede filtrada. Este trfego examinado pelo firewall que busca padres que
satisfaam algumas regras previamente estabelecidas, atravs de mecanismos de segurana que so
baseados em hardware e software em tempo real. Os firewalls fazem anlise dos dados de camada trs,
por exemplo, para conferir IP de origem e destino, camada 4 conferindo portas TCP e UDP por exemplo e
camada 7 observando os cabealhos das aplicaes. Uma caracterstica importante dos firewalls a
filtragem de pacotes, que a capacidade de descartar pacotes que no atendem a certos critrios, tambm
faz a filtragem de portas, envolvendo o bloqueio ou a liberao da passagem de pacotes com base no
endereo de porta.

18
Universidade Estadual de Campinas

Figura 16 Firewall. Fonte = http://computer.howstuffworks.com/firewall.htm

Muitos firewalls usam a filtragem dinmica de pacotes para garantir que os pacotes
encaminhados pertencem a sesses iniciadas no lado privado (rede interna corporativa). O firewall possui
uma lista dinmica de estados que contm um registro de todas as sesses de comunicaes entre estaes
de trabalho dentro e fora do firewall. Essa lista alterada sempre que uma sesso de comunicao
iniciada ou terminada. As listas dinmicas de estados permitem que um firewall filtre pacotes
dinamicamente. Na filtragem dinmica de pacotes, somente pacotes associados a sesses de
comunicaes em curso necessariamente vlidas recebem permisso para passar. Por definio um
firewall nega todo tipo de trfego e libera apenas os que so autorizados pelo administrador da rede.
Pode-se definir zona de risco como qualquer ponto da rede que pode ser diretamente acessada atravs da
Internet, ou qualquer ponto da rede interna que um atacante possa corromper sua segurana, conseguindo
roubar informaes. Tornando este ponto de acesso para que o atacante prossiga o seu ataque em outras
mquinas que esto conectados na mesma rede. Assim um firewall pode ser usado como checkpoint,
sendo este o foco para as decises referentes segurana, conectando a rede interna ao mundo externo e
limitando a exposio da rede atravs de polticas de segurana que podem ser implementadas, alm da
possibilidade de se fazer um controle do trfego e contedos de dados acessados por diferentes tipos de
usurios de acordo com permisses destes. A tabela abaixo mostra alguns recursos utilizados pelo firewall

Descrio Vantagens Desvantagens


Mtodo
Nat Traduo do endereo da rede Pode ser configurado transparentemente para No pode evitar atividades mal
(Network Address Translation) mquinas em uma LAN. intencionadas depois de usurios se
insere sub-redes IP privadas atrs Usado para proteo de muitas mquinas e conectarem a um servio fora do firewall.
de um ou um pequeno grupo servios por trs de um ou mais endereos IP
de endereos IP pblicos, externos simplifica as tarefas de
mascarando todos os pedidos para administrao.
uma fonte ao invs de vrias. A restrio de acesso do usurio de e para
uma LAN pode ser configurada abrindo
e fechando portas no firewall/gateway do
NAT.
Filtro de L cada pacote de dados que No requer nenhuma personalizao no lado No possvel filtrar pacotes para
passa por dentro e por fora de do cliente, j que todas as atividades da rede firewalls de proxy de contedo.
Pacotes
uma LAN. so filtradas no nvel do roteador ao invs do Processa pacotes na camada de protocolos,

19
Universidade Estadual de Campinas

Pode ler e processar pacotes pela nvel da aplicao. mas no pode filtrar pacotes na camada do
informao do cabealho e filtrar Como os pacotes no so transmitidos aplicativo.
o pacote baseado em conjuntos de atravs de um proxy, o desempenho da rede Arquiteturas de rede complexas podem
regras programveis mais rpido devido conexo direta do dificultar o estabelecimento de regras
implementadas pelo cliente para host remoto. de filtragem de pacotes, especialmente se
administrador do firewall. for usado com o mascaramento do IP
ou sub-redes locais e redes DMZ.
Proxy Filtram todos os pedidos de um Fornece aos administradores controle sobre Proxies so frequentemente especficos s
determinado protocolo ou tipo de quais aplicativos e protocolos funcionam aplicaes (HTTP, Telnet, etc.) ou
clientes LAN para uma mquina fora da LAN. restritos a protocolos (a maioria dos
proxy, que ento faz estes Alguns servidores proxy podem armazenar proxies funciona com servios conectados
pedidos dados frequentemente acessados no cache por TCP).
Internet representando o cliente localmente, ao invs de ter que usar a Servios de aplicao no podem rodar
local. conexo Internet para solicit-los, o que por trs de um proxy, portanto seus
Uma mquina proxy age como conveniente para reduzir o consumo de servidores de aplicaes devem usar uma
um buffer entre os usurios banda larga. forma separada de segurana de rede.
remotos Os servios proxy podem ser autenticados e Proxies podem se tornar um gargalo na
mal-intencionados e as mquinas monitorados de, permitindo um controle rede, j que todos os pedidos e
clientes de redes internas. maior do uso de recursos na rede. transmisses passam atravs de uma
mesma fonte ao invs de passar
diretamente do cliente para um servio
remoto.

Gerncia de Redes de Computadores e Telecomunicaes

Uma rede de computadores necessita ser gerenciada visando garantir a disponibilidade dos
servios suportados por ela, aumentando o desempenho, produtividade e eficincia do sistema, evitando
possveis falhas e prejuzos para a organizao em que est operando. As redes atuais so compostas por
uma grande variedade de dispositivos que devem se comunicar e compartilhar recursos, assim para
gerenciar esses sistemas e as prprias redes, fundamental a utilizao de um conjunto eficiente de
ferramentas de gerenciamento automatizadas, para a correta representao e o intercmbio das
informaes obtidas atravs da analise do trfego da rede e o status de todos os equipamentos nela
instalados. Dessa forma os sistemas de telecomunicaes precisam ser gerenciados para maximao do
desempenho da rede e identificao de melhorias que devem ser feitas para que isso ocorra,
transformando conhecimento em aes corretivas ou pr-ativas, com o objetivo de alcanar os requisitos
de desempenho operacional e de qualidade de servio, que muitas vezes esto especificados em contratos
atravs de um SLA (Service Level Agreemment). Por exemplo, ao detectar uma situao de
congestionamento em uma rede devem-se buscar alternativas para solucionar o problema atravs de aes
como aumentar os recursos da rede ou diminuir o trfego. Elementos da rede que necessitam de
monitoramento so: roteadores, centrais telefnicas, equipamentos SDH, sistema de rdio enlace, entre
outros. Existem algumas ferramentas gratuitas para monitorao da rede como o MRTG e Nagios. Em
uma rede corporativa, os grandes desafios dos gerentes e administradores destes ambientes, so de alinhar
o desempenho da rede s necessidades de negcios da corporao e minimizar o impacto de mudanas e

20
Universidade Estadual de Campinas

problema que podem ocorrer na rede como: Falhas que so normalmente causadas por operaes
incorretas ou um nmero excessivo de erros, falta de habilidade na utilizao de recursos por um usurio
ou grupo de usurios, tarefas de manuteno adio, atualizao e status dos componentes durante a
operao da rede, quedas de desempenho e interrupes nos elementos destas redes nas empresas.
Gerenciar a rede , em ltima instncia, gerenciar o negcio e, transformar as reas de tecnologia da
informao e telecomunicaes normalmente vistas como custos em unidades de negcios,
geradoras de receitas e direcionadoras da organizao.

Responsvel por dar uma viso geral do


Gerncia do negcio ou da empresa
Negcio

Responsvel pelos gerncia dos


Gerncia do
Servio servios oferecidos aos clientes ou para
outros servios oferecidos

Gerncia da Rede Responsvel pelos gerncia da rede

Coleta informao de elementos


Gerncia do Elemento da Rede gerenciados da rede individualmente, ou
seja, gerencia cada elemento da rede

Elementos da Rede Sistema agente OSI, diretamente conectado


ao gerenciador de recursos, o prprio
elemento da rede

Figura 17 - Hierarquia de gerenciamento. Fonte = http://www.teleco.com.br/tutoriais/tutorialgmredes1/pagina_4.asp

Parte Prtica

Foram discutidos conceitos bsicos sobre redes de computadores, fundamentais para o


entendimento da estrutura corporativa. Como forma de validar o aprendizado sobre topologias,
cabeamento, equipamentos entre outros utilizados em redes de computadores foi criado e configurado um
enlace de comunicao atravs do uso do software de simulao Packet Tracer Student que agrega 11
diferentes redes interligadas atravs do uso de 3 roteadores, sendo que 9 delas esto sendo usadas em
redes internas atravs de Vlans criadas nos Switchs, pois em cada um dos equipamentos foram criados 3
Vlans usando a funo mode trunk possibilitando o uso de apenas uma porta fsica para conexo do
switch e do roteador. A figura abaixo apresenta a topologia do enlace configurado identificando as redes
utilizadas e conexes entre os equipamentos. Seu funcionamento pode ser visto do lado direito na parte
inferior da figura onde foi enviada uma informao do PC2, PC8 e PC1 para o PC7, PC3 e PC9
respectivamente recebidas com sucesso. Em seguida, como forma de demonstrao apresentada as
configuraes feitas no Router1 e Switch1 que esto destacados na figura.

21
Universidade Estadual de Campinas

Figure 18 Topologia da rede criada usando o software de simulao Packet Tracer Student

Configurao do Router1

Router>enable
Router#show running-config
Building configuration...
Current configuration : 1076 bytes
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
hostname Router
ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface FastEthernet0/0
ip address 192.168.0.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.100.1 255.255.255.252
duplex auto
speed auto
!

22
Universidade Estadual de Campinas

interface FastEthernet1/0
no ip address
duplex auto
speed auto
!
interface FastEthernet1/0.10
encapsulation dot1Q 10
ip address 172.16.40.10 255.255.255.0
!
interface FastEthernet1/0.20
encapsulation dot1Q 20
ip address 172.16.50.20 255.255.255.0
!
interface FastEthernet1/0.30
encapsulation dot1Q 30
ip address 172.16.60.30 255.255.255.0
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 172.16.0.0
network 192.168.0.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

Configurao do Switch1

Switch>enable
Switch#show running-config
Building configuration...
Current configuration : 1348 bytes
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 30
switchport mode access

23
Universidade Estadual de Campinas

!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22

!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
end

24
Universidade Estadual de Campinas

Estgio

Os conhecimentos adquiridos no decorrer do curso de graduao, permite ter uma pequena viso
sobre sistemas de telecomunicaes como um todo, porm quando inserido em um seguimento especfico
no meu caso estagiando em redes, necessrio um aprofundamento visando maior entendimento sobre a
estrutura de dados e equipamentos que antes eram vistos apenas em teoria. Assim o aprendizado tcnico
essencial para que se ganhe um Know-how que permite ser um profissional diferenciado, buscando
sempre aprender, realizar e otimizar os trabalhos demandados. As minhas principais atividade do estgio
foram: Suporte na estrutura de rede corporativa, monitorao das solues de telecomunicaes do grupo
voz e dados utilizando ferramentas de gerncia como o sofwtare Spectrum, Performance Center, Network
Flow Analysis ambos da CA, e OpManager. Alm de elaborao de relatrios e configuraes bsicas das
ferramentas utilizadas e equipamentos utilizados na rede da Cisco, Huawei e Fortinet como switches,
roteadores, firewall. Durante o estgio pude adquirir experincia pessoal com a responsabilidade de
cumprir tarefas demandados dentro do prazo, buscar trocar informao com a equipe que sempre esteve
disposta a ajudar e sanar dvidas, sendo essa troca de informao indispensvel para o desenvolvimento
das atividades realizadas.

Concluso

O trabalho apresentou os conceitos bsicos sobre redes de computadores essenciais para o


entendimento da estrutura corporativa, explicitando o funcionamento de alguns equipamentos, topologias
bsicas e tipos de rede que podem compor a estrutura. Aprendi muito com a realizao deste trabalho,
pois me ajudou a ter maior entendimento sobre redes de computadores e maximizando o aprendizado na
realizao das atividades desenvolvidas durante o estgio.

Agradecimentos

Agradeo primeiramente a Deus pelo dom da vida e sabedoria, fora de vontade para buscar
conhecimentos e aprimoramentos; minha famlia pelos valores ensinados; e minha noiva que sempre
esteve ao meu lado e me ajudou a superar as dificuldades encontradas no decorrer da vida acadmica.
Agradeo a todos que contriburam de forma direta ou indireta para a realizao deste trabalho em
especial aos profissionais com que trabalhei na empresa CSC da Camargo Corra no macro de Tecnologia
e Telecomunicaes (MTT) que sempre foram solcitos nas dvidas que foram surgindo no decorrer do
trabalho e a Universidade Estadual de Campinas pelo conhecimento compartilhado.

Referncias bibliogrficas

[1] TANENBAUM, Andrew S. Organizao estruturada de computadores. 5. ed. So Paulo: Pearson


Prentice Hall, 2007.

[2] FILIPPETTI, Marco Aurlio. CCNA 4.1 Guia Completo de Estudo. Florianpolis: Visual Books,
2008.

[3] VIEIRA, Newton Jos. Introduo aos Fundamentos da Computao: linguagens e mquinas. So
Paulo/SP: Thomson, 2006.

25
Universidade Estadual de Campinas

[4] DANTAS, Mario. Tecnologias de Redes de Comunicao e Computadores. Rio de Janeiro/RJ:


Mameluco, 2008.

[5] COMER, Douglas. Interligao de Redes com TCP/IP. 5. ed. Rio de Janeiro: Editora Campus, 2006.
468 p.

[6] Specialski, Elizabeth Sueli. Gerncia de Redes de Computadores e de Telecomunicaes.

[7] SOUZA, Lindeberg Barros de. Projetos e Implementao de Redes: fundamentos, arquiteturas,
solues e planejamento. rica. So Paulo/SP, 2009.

[8] JUNIOR. Egdeo I. Uma proposta de Metodologia para Anlise de Desempenho de Redes IEEE
802.11 Combinado a Gerncia SNMP e Ferramentas de Simulao. 2003 [Dissertao de Mestrado]

[9] LIMA, Fabricio S. Gerencia de Redes de computadores. 2003 [artigo]

[10] SOARES, Luiz Fernando Gomes; LEMOS, Guido; COLCHER, Sergio. Redes de Computadores: das
LANs, MANs e WANs s redes ATM. 2 Ed. Rio de Janeiro/RJ: Campus, 1995.

[11] Odair Soares Barros. Segurana de redes locais com a implementao de VLANs O caso da
Universidade Jean Piaget de Cabo Verde. Universidade Jean Piaget de Cabo Verde, 2009.

[12] BREDARIOL, A., Aspectos de segurana em redes de computadores: IPSecurity e email Monografia
- Universidade So Francisco - Itatiba, Novembro 2001, p.6

[13] MILLER, Frank. Princpios de Redes: manual de projeto. Rio de Janeiro/RJ: LTC, 2009.

[14] GALO, M. A., HANCOCK, W. M., Comunicao entre Computadores e Tecnologias de Rede. So
Paulo: Pioneira Thomson Learning, 2003.

[15] FERREIRA, Fernando Nicolau Freitas. Segurana da Informao. Rio de Janeiro/RJ: Cincia
Moderna, 2003.

[16] FOROUZAN, Behrouz A. Comunicao de Dados e Redes de Computadores. Porto Alegre/RS:


Bookman, 2006.

[17] LYARA, Maurcio Rocha. Segurana e Auditoria em Sistemas de Informao. 1 Ed. Rio de
Janeiro/RJ: Cincia Moderna, 2008.

[18] SOUSA, Lindeberg Barros de. Projetos e Implementao de Redes: fundamentos, arquiteturas,
solues e planejamento. So Paulo/SP: rica, 2009.

26