Você está na página 1de 4

algoritmo "Problema 01 - Validao de Nota"

var
ntvalida, nota : inteiro
media: real
inicio
ntvalida:=0
enquanto ntvalida < 2 faca
leia (nota)
se (nota >=0)e (nota <=10)entao
ntvalida := (ntvalida+1)
media:=Media+nota
senao
escreval("Nota invalida")
fimse
fimenquanto
escreval("media =",media/ntvalida)
fimalgoritmo

/////////////////////////////////////////////////////////////////////
algoritmo " Problema 03 - Sequncias Crescentes"
var
x,i : inteiro
inicio
x:=1
enquanto x >=1 faca
escreval("")
leia (x)
para i de 1 ate x faca
escreva(i)
fimpara
fimenquanto
fimalgoritmo
/////////////////////////////////////////////////////////////////////
algoritmo "Problema 04 - Aumento de Salrio"
var
s: real
inicio
leia(s)
se (s >=0) e (s<=400 ) entao
escreval("Novo salario: ", s*1.15)
escreval("Reajuste ganho: ",s*0.15)
escreval("Em percentual: 15 %")
fimse
se (s >400) e (s<=800 ) entao
escreval("Novo salario: ", s*1.12)
escreval("Reajuste ganho: ",s*0.12)
escreval("Em percentual: 12 %")
fimse
se (s >800) e (s<=1200 ) entao
escreval("Novo salario: ", s*1.1)
escreval("Reajuste ganho: ",s*0.1)
escreval("Em percentual: 10 %")
fimse
se (s >1200) e (s<=2000 ) entao
escreval("Novo salario: ", s*1.07)
escreval("Reajuste ganho: ",s*0.07)
escreval("Em percentual: 7 %")
fimse
se (s >2000) entao
escreval("Novo salario: ", s*1.04)
escreval("Reajuste ganho: ",s*0.04)
escreval("Em percentual: 4 %")
fimse
fimalgoritmo
/////////////////////////////////////////////////////////////////////
algoritmo "Problema 05 - Meteoros"
var
x1,x2,y1,y2,N,M,i,x,y:inteiro
inicio
Escreva("Informe X1: ")
leia(x1)
Escreva("Informe Y1: ")
leia(y1)
Escreva("Informe X2: ")
leia(x2)
Escreva("Informe Y2: ")
leia(y2)
Escreva("Informe N: ")
LEIA(N)
para i de 1 ate N faca
leia(x)
leia(y)
se (x <= x1) e (y <=y1)entao
m:=m+1
senao
se (y <=x2) e (y <= y2)entao
m:=m+1
fimse
fimse
fimpara
escreva("Caram", m ," meteorito(s) na fazenda")
fimalgoritmo

/////////////////////////////////////////////////////////////////////
algoritmo "Problema 06 - Converso Decimal Para Binrio"
var
dec,d : inteiro
bin : caracter
inicio
escreva("informe numero a ser convertido: ")
leia(dec)
d:=dec
enquanto d > 0 faca
se(d mod 2) = 0 entao
bin:= "0" + bin
senao
bin:= "1" + bin
fimse
d:= d div 2
fimenquanto
Escreval ("Tal que representao binria de",dec," igual a: ",bin)
fimalgoritmo
/////////////////////////////////////////////////////////////////////
algoritmo "Problema 07 - Nmero Primo"
var
n,ndiv,I,cont:inteiro
inicio
leia(n)
para i de 1 ate n faca
se n mod i = 0 entao
ndiv:= ndiv+1
fimse
fimpara
se ndiv = 2 entao
escreva(n," primo")
SENAO
escreva(n," NO primo")
FIMSE
fimalgoritmo
/////////////////////////////////////////////////////////////////////
algoritmo "Problema 08 - Zerinho ou Um"
var
a,b,c,x : inteiro
inicio
leia (a)
leia (b)
leia (c)
escreval
se (a = b) e (a = c) entao
escreva("*")
senao
se (A <> B) e(A <> C) entao
escreval("A")
senao
se (B <> A) e (B <> C) entao
escreval("B")
senao
se (C <> A)e (C <> B) entao
escreval("C")
fimse
fimse
fimse
fimse
fimalgoritmo