Você está na página 1de 3

Algoritmo e estrutura de dados 06

Um ser humano pode perder todas as coisas da vida, mas se perder a f certamente
estar arruinado.

Roteiro

1. Estrutura caso
2. Exerccios

ESTRUTURA ESCOLHA...CASO

A estrutura de deciso ESCOLHA...CASO usada para testar uma condio,


numa nica expresso, que gera um resultado, ou valor de uma varivel, que se encontra
guardado num determinado contedo.

Nesta estrutura pode se ter uma ou mais condies a serem testadas e um


comando diferente associado a cada uma destas.

Sintaxe:

ESCOLHA <Expresso de escolha>


CASO condio1
Comando1
CASO condio2
Comando2
CASO condio3
Comando3
OUTROCASO
Comando A
FIMESCOLHA

Esta estrutura ocorre da seguinte forma:

Ao entrar neste tipo de estrutura ESCOLHA, a condio1 testada com a


varivel: se for VERDADEIRA, executa o comando1 e, aps seu trmino, o fluxo de
execuo continua pela primeira instruo aps o final da construo (FIMESCOLHA);
Caso a condio1 seja FALSA, a condio2 testada, e se esta for VERDADEIRA, o
comando2 executado e, ao seu trmino, a execuo continua pela instruo seguinte
ao final da construo (FIMESCOLHA). Esse mesmo raciocnio passado a todas as
condies da construo. Se por um acaso todas as condies forem avaliadas como
FALSAS, o Comando A, que corresponde ao SENO da construo executado.

EXERCCIO RESOLVIDO:

1) Por meio da estrutura de mltipla escolha faa um algoritmo para simular uma
calculadora simples de nmeros inteiros.

Resoluo:
Algoritmo calculadora
Var
X,Y: Inteiro;

Pgina 1 de 3
Algoritmo e estrutura de dados 06

Operador: Caracter;
INCIO
Escreva(Digite X:);Leia(X);
Escreva(Digite Y:);Leia(Y);
Escreva(Digite a Operao:);Leia(Operador);
ESCOLHA Operador
CASO +
Escreva(X + Y)
CASO -
Escreva(X - Y)
CASO *
Escreva(X * Y)
CASO /
Escreva(X / Y)
OUTROCASO
Escreva(Operao invlida);
FIMESCOLHA
FIMALGORITMO

EXERCCIO DE FIXAO

1) Menu principal - Faa um programa de menu que


mostra na tela, sob o ttulo de "Menu Principal", trs
opes: "1 - Fim", "2 - Cadastro" e "3 - Consulta", l
do teclado a opo desejada pelo usurio e mostra
uma mensagem confirmando a opo escolhida ou
uma mensagem de erro, se a opo for invlida.
2) Mltipla escolha 1 - Elaborar uma questo de mltipla escolha, de uma
disciplina que esteja cursando ou um tema de interesse, com um enunciado e
cinco alternativas, sendo uma correta ou incorreta. Escrever um programa que
mostra a questo na tela, pede a resposta correta e informa ao usurio se este
acertou ou errou.

3) Mltipla escolha 2 - Enriquea o programa acima da questo de mltipla


escolha, incluindo uma outra questo de outro tema. No incio do programa,
oferea ao usurio a escolha de qual questo quer responder.

4) Um determinado clube de futebol pretende classificar seus atletas em categorias


e para isto ele contratou um programador para criar um programa que executasse
esta tarefa. Para isso o clube criou uma tabela que continha a faixa etria do
atleta e sua categoria. A tabela est demonstrada abaixo:

IDADE CATEGORIA
De 05 a 10 Infantil
De 11 a 15 Juvenil
De 16 a 20 Junior

Pgina 2 de 3
Algoritmo e estrutura de dados 06

De 21 a 25 Profissional

Construa um programa que solicite o nome e a idade de um atleta e imprima a


sua categoria.

Pgina 3 de 3