Você está na página 1de 3

ATIVIDADE TELEAULA 1

Pergunta 1
Com relao ao valor lgico, avalie as expresses a seguir.
I. (2 < 3) e (5 > 1)
II. (2 * 3) < (4 / 2 + 4)
III. (5 < 4) ou (12 > 2)
IV. (no((5 * 2 + 1) > (6 * 3 8))
verdadeiro apenas as expresses

Resposta Selecionada:
c.
I e III.

Respostas:
a.
I e II.
b.
II e III.
c.
I e III.
d.
I, II e III.
e.
II, III e IV.

Feedback da resposta: RESPOSTA C

Pergunta 2
Faa o teste de mesa para o algoritmo abaixo. As entradas so 5 e 4,
respectivamente.
algoritmo testedemesa
var
Area, Base, Altura: Real
inicio
leia (Base)
leia (Altura)
Area <- (Base * Altura) / 2
escreva (A rea do triangulo com base, Base, com altura, Altura, , Area)
Fimalgoritmo
A sada na tela ser:

Resposta Selecionada:
e.
A rea do tringulo com base 5 com altura 4 10.

Respostas:
a.
A rea do tringulo com base 4 com altura 5 20.
0 em 0 pontos
b.
A rea do tringulo com base 5 com altura 4 20.
c.
A rea do tringulo com base 4 com altura 5 10.
d.
A rea do tringulo com base 5 com altura 5 20.
e.
A rea do tringulo com base 5 com altura 4 10.

Feedback da resposta: RESPOSTA E

Pergunta 3
Para desenvolver um programa, uma vez estruturado o raciocnio lgico, passamos a
utilizar simbologias dos algoritmos para representarmos esse pensamento. Na
linguagem computacional, temos trs tipos de algoritmos mais utilizados: descrio
narrativa, fluxograma e pseudocdigo ou portugol. Avalie as seguintes afirmaes.
I. Na descrio narrativa, necessrio aprender um conceito novo de escrita.
II. No fluxograma, o entendimento bem mais simples.
III. No fluxograma, no precisamos ter conhecimento de nenhum smbolo.
IV. No portugol, necessrio o conhecimento de pseudocdigo.
correto apenas o que se afirma em:

Resposta Selecionada:
b.
II e IV.

Respostas:
a.
II e III.
b.
II e IV.
c.
I, II e III.
d.
I, III e IV.
e.
I, II e IV.
Feedback da resposta: RESPOSTA B

Pergunta 4
Para se efetuar o clculo da rea de uma circunferncia, necessrio conhecer a
frmula que executa este clculo, sendo esta: A = R2 . Conseguimos criar o
programa abaixo:
algoritmo areacirculo
var
A, R: Real
inicio
leia (R)
A <- 3.1415 * R ** 2
escreva (A)
Fimalgoritmo
Podemos identificar as variveis de entrada e sada:

Resposta Selecionada:
d.
varivel de entrada R e varivel de sada A.

Respostas:
a.
varivel de entrada A e varivel de sada R.
b.
varivel de entrada PI e varivel de sada A.
c.
varivel de entrada R e varivel de sada 3.1415.
d.
varivel de entrada R e varivel de sada A.
e.
varivel de entrada A e varivel de sada 3.1415 * R ** 2.

Feedback da resposta: RESPOSTA D