Você está na página 1de 3

Gua prctica de laboratorio de Computacin

Segunda unidad: Algoritmos y Diagramas de Flujo


Prctica N08: Estructura repetitiva

Apellidos :
Seccin : 5970
Nombres :
Fecha : / / Duracin: 60 min
Docente :
Tipo de prctica: Individual ( x ) Grupal ( )

Instrucciones: Lea detenidamente cada enunciado y desarrolle lo solicitado.


Antes de iniciar la presente gua crear una carpeta en la unidad Alumno (G:) con sus apellidos, luego
guarde este archivo dentro de la misma tambin con sus apellidos. Utilizar el software PSeInt para el
diseo de los algoritmos.

Desarrolle en Pseudocdigo y Diagrama de Flujo de los siguientes ejercicios:

For (Para)

1.- Algoritmo que muestre de forma horizontal, la serie de nmeros que hay entre dos nmeros
ingresados por teclado
1.1.- En el mismo algoritmo, se debe mostrar la misma serie, pero de mltiplos de 3, cuya ltima
cifra sea ocho.
1.2.- En el mismo algoritmo, se debe mostrar la suma de los elementos de la serie.
Proceso E01
DEFINIR A,B,C,SUM,M COMO ENTERO;
ESCRIBIR "INGRESE DOS NUMEROS ENTEROS: ";
LEER A,B;
Escribir "SERIE DE ",A," HASTA ",B," DE MULT DE 3, DE ULTIMA CIFRA 8 ";
SUM<-0;
M<-0;
PARA C<-A HASTA B CON PASO 1 Hacer
Si (C MOD 3=0) Y (C MOD 10=8) Entonces
Escribir SIN SALTAR C," , ";
SUM<-SUM+C;
M<-M+1;
FinSi
FinPara
Escribir "";
ESCRIBIR "LA SUMA ES ",SUM;
ESCRIBIR "CANTIDAD DE ELEMENTOS ES ", M;
FinProceso
2.- Algoritmo que permite calcular la suma de los N primeros nmeros enteros positivos ingresados
por teclado.

3.- Disear un algoritmo que permite mostrar y sumar la siguiente serie:

Ejemplo, si ingreso N=3, debe mostrar: 5*raiz(1) + 5*raiz(2) + 5*raiz(3) + y el resultado de la suma:
20.73132

4.- Algoritmo que calcula el promedio de una lista de nmeros ingresados por teclado (Primero se
debe preguntar la cantidad de nmeros a ingresar)
5.- Algoritmo que muestre tres candidatos presidenciales (opcin 1, 2 y 3 respectivamente) y solicite
el ingreso de 10 votos. Al final debe mostrar el resultado de votos de cada candidato (si existe un
voto no vlido debe volver a solicitar)

Referencias bibliogrficas consultadas y/o enlaces recomendados


JOYANES, L. (2008). Fundamentos de Programacin. Algoritmos, estructura de datos y objetos,
4 Edicin. Madrid: McGraw-Hill.
Beekman, G., Pacheco, R. y Tbora, A. (2008). Introduccin a la computacin. Mxico: Pearson
Educacin.