Você está na página 1de 3

UNIVERSIDADE FEDERAL DO MARANHÃO – UFMA/NEAD

CURSO: LICENCIATURA EM COMPUTAÇÃO


POLO: CAXIAS
DISCIPLINA: ALGORITMOS
ALUNO: DIEGO FELIPE DO LAGO LEMOS

ALGORITMOS

CAXIAS
2017
Escreva um algoritmo em linguagem natural para realizar as etapas
necessárias para assar carnes em um churrasco.

1. COMPRAR CARNE;
2. CORTAR E TEMPERAR A CARNE;
3. PEGAR CHURRASQUEIRA E CARVÃO;
4. DESPEJEO CARVÃO NA CHURRASQUEIRA;
5. COLOQUE FOGO NO CARVÃO;
6. PEGUE UM ESPETO;
7. COLOQUE A CARNE NO ESPETO;
8. COLOQUE O ESPETO COM A CARNE SOBRE A CHURRASQUEIRA;
9. FIQUE VIRANDO O ESPETO, PARA QUE A CARNE NÃO QUEIME;
10. DEPOIS DE ASSADA, PEGUE UMA FACA E CORTE A CARNE;
11. SIRVA A CARNE;

Escreva um algoritmo para consertar um pneu furado de uma bicicleta.


Utilize a linguagem natural.

1. LEVE A BICICLETA PAARA UM LOCAL SEGURO;


2. VIRE A BICICLETA, COLOCANDO SEU GUIDON E SELA ENCOSTADO NO CHÃO;
3. PEGUE UM KIT DE CHAVES E FOLGUE AS PORCAS E TIRE A RODA COM
DEFEITO;
4. PEGUE UM JOGO DE ESPATULA E DESMONTE O PNEU;
5. JOGUE A CAMARA FURADA NO LIXO E PEGUE UMA NOVA;
6. MONTE O PNEU COM A CAMARA NOVA;
7. ENCHA O PNEU;
8. COLOQUE O PNEU NA BICICLETA;
9. PEGUE O KIT DE CHAVE E ACOCHE AS PORCAS;
10. GUARDE O KIT DE CHAVE E ESPATULA;
11. DESVIRE A BICICLETA;

Escreva um algoritmo em fluxograma e em pseudoalgoritmo que realize o


ajuste salarial sabendo que os funcionários que recebem salário de até
R$ 1.100,00 terão ajuste de 13% e os demais terão ajuste de 7%.
Algoritmo "REAJUSTE SALARIAL"

Var
salario : real

Inicio
ESCREVA ("DIGITE O VALOR DO SALÁRIO R$")
LEIA (salario)
SE salario <= 1100.00 ENTAO
ESCREVA ("O REAJUSTE SERÁ DE 13%, SALÁRIO FINAL:", salario
+(salario*13/100))
FIMSE

SE salario > 1100.00 ENTAO


ESCREVA ("O REAJUSTE SERÁ DE 07%, SALÁRIO FINAL R$",salario
+(salario*7/100))
FIMSE
Fimalgoritmo