Você está na página 1de 10

Professor: Alessandro Borges

E-mail: alessandroborgesbsb@gmail.com
Facebook: facebook.com/alessandroborgesoficial
Youtube: https://goo.gl/e9YGWi

EXCEL 2013
Fórmulas e Funções
Chegou a hora de entender como funcionam as fórmulas e as funções do
Excel. Ao término desse material, você será capaz de:

 Responder o que são fórmulas e como elas funcionam;


 Responder o que são funções e como elas funcionam;
 Entender os operadores de cálculos e suas precedências;
 Aplicar o seu conhecimento na prática.

"Computadores são inúteis, eles apenas dão respostas"

― Picasso

1. FÓRMULAS E FUNÇÕES
As fórmulas e funções são elementos fundamentais do Excel pois são eles que
permitem a realização dos cálculos.

 Fórmulas: Equações criadas pelo próprio usuário. Podemos iniciar uma


fórmula pelos sinais de igual “=”, adição “+” e subtração “-”.

=A1+A2

 Funções: Fórmulas pré-definidas no Excel que possuem um nome que as


define. Podemos iniciar uma fórmula pelos sinais de igual “=”, adição “+”,
subtração “-” e arroba “@”.

=SOMA(A1:A5)

Informática para a vida


2. OPERADORES DE CÁLCULO E PRECEDÊNCIA
Os operadores especificam o tipo de cálculo que você deseja efetuar nos
elementos de uma fórmula. Há uma ordem padrão na qual os cálculos ocorrem, mas
você pode alterar essa ordem utilizando parênteses.

2.1. TIPOS DE OPERADORES


Há quatro diferentes tipos de operadores de cálculo: aritmético, comparação,
concatenação de texto e referência.

Assista: A vídeo aula dessa apostila está disponível totalmente gratuita em:
https://goo.gl/e9YGWi.

2.1.1. OPERADORES ARITMÉTICOS


Para efetuar operações matemáticas básicas, como adição, subtração ou
multiplicação, combinar números e produzir resultados numéricos, use estes
operadores aritméticos.

OPERADOR ARITMÉTICO SIGNIFICADO EXEMPLO

+ (sinal de mais) Adição =3+3 -> 6

– (sinal de menos) Subtração =3–1 -> 2


Negação –1

* (asterisco) Multiplicação =3*3 -> 9

/ (barra) Divisão =3/3 -> 1

% (sinal de porcentagem) Porcentagem (Divide o valor por 100) =100% -> 1

^ (acento circunflexo) Exponenciação / Potenciação =3^2 -> 9

2
Informática para a vida
2.1.2. OPERADORES DE COMPARAÇÃO/ LÓGICOS
Você pode comparar dois valores, usando os operadores a seguir. Quando dois
valores são comparados usando esses operadores, o resultado será um valor lógico,
VERDADEIRO ou FALSO.

OPERADOR DE COMPARAÇÃO SIGNIFICADO EXEMPLO

= (sinal de igual) Igual a =A1=B1 -> Falso

> (sinal de maior que) Maior que =A1>B1 -> Verdadeiro

< (sinal de menor que) Menor que =A1<B1 -> Falso

>= (sinal de maior ou igual a) Maior ou igual a =A1>=A1 -> Verdadeiro

<= (sinal de menor ou igual a) Menor ou igual a =A1<=B1 -> Falso

<> (sinal de diferente de) Diferente de =A1<>B1 -> Verdadeiro

OBSERVAÇÃO: Quando houver dois operadores aritméticos sendo usados na mesma


condição e um deles for verdadeiro consideraremos a condição verdadeira.

Visite: https://www.facebook.com/groups/infoaprender
para obter os gabaritos e mais questões atualizadas.

2.1.3. OPERADOR DE CONCATENAÇÃO DE TEXTO


Use o 'E' comercial (&) para associar, ou concatenar, uma ou mais sequências de
caracteres de texto para produzir um único texto.

OPERADOR DE TEXTO SIGNIFICADO EXEMPLO

& (E comercial) Conecta, ou concatena, dois valores para ="Aula"&"Noite" -> Aula Noite
produzir um valor de texto contínuo.

3
Informática para a vida
2.1.4. OPERADORES DE REFERÊNCIA
Combine intervalos de células para cálculos com estes operadores.

OPERADOR DE SIGNIFICADO EXEMPLO


REFERÊNCIA

: (dois-pontos) Indica um intervalo de células sequências =SOMA(A1:A5) -> 15


(Conjunto sequencial), somente podendo ser
usado em funções sendo que a sua aplicação
vária conforme a função onde se encontra: Cria
uma caixa de seleção.

; (ponto-vírgula) Pode indicar um conjunto de células não =SOMA(A1;A5) -> 6


sequências (Aleatórias) e também somente pode
ser usado em funções sendo que a sua aplicação
vária conforme a função onde se encontra:
Calcula apenas células citadas na função.

. (ponto) Possui o funcionamento semelhante ao “:” dois- =SOMA(A1.A5) -> 15


pontos, sendo inclusive substituído
automaticamente por ele.

(espaço) Calcula apenas valores contidos na intersecção =SOMA(B7:D7 C6:C8) -> 30


gerada por ele.

2.2. A ORDEM DE EXECUÇÃO DE OPERAÇÕES EM FÓRMULAS


Em alguns casos, a ordem na qual o cálculo é executado pode afetar o valor
retornado da fórmula. Então é importante compreender como a ordem é
determinada e como você pode alterar a ordem para obter o resultado desejado.

2.2.1. ORDEM DE CÁLCULO


As fórmulas calculam valores segundo uma ordem específica. O sinal de igual
informa ao Excel que os caracteres a seguir constituem uma fórmula. Depois do
sinal de igual estão os elementos a serem calculados (os operandos), que são
separados por operadores de cálculo.

Assista: A vídeo aula dessa apostila está disponível totalmente gratuita em:
https://goo.gl/e9YGWi

4
Informática para a vida
2.2.2. PRECEDÊNCIA DE OPERADORES
Se você combinar vários operadores em uma única fórmula, o Excel executará as
operações na ordem mostrada na tabela a seguir. Se uma fórmula contiver
operadores com a mesma precedência — por exemplo, se uma fórmula contiver um
operador de multiplicação e divisão — o Excel avaliará os operadores da esquerda
para a direita.

PRECEDÊNCIA OPERADOR DESCRIÇÃO

1 : (Dois-pontos) Operador de Referência

2 (Espaço simples) Operador de Referência


3 ; (vírgula) Operador de Referência

4 - Operador Aritmético de Negação

5 % Operador Aritmético
6 ^ Operador Aritmético

7 * / Operadores Aritméticos de Mesma Precedência


8 + - Operadores Aritméticos de Mesma Precedência

9 & Operador de Concatenação

10 = > < Operadores de Comparação de Mesma Precedência

2.3. USO DE PARÂMETROS


Para alterar a ordem da avaliação, coloque entre parênteses a parte da fórmula a
ser calculada primeiro. Por exemplo, a fórmula a seguir retorna 11 porque o Excel
calcula a multiplicação antes da adição. A fórmula multiplica 2 por 3 e, em seguida,
soma 5 ao resultado.
=5+2*3
Por outro lado, se você usar parênteses para alterar a sintaxe, o Excel somará 5 e
2 e, em seguida, multiplicará o resultado por 3 para produzir 21.
=(5+2)*3

5
Informática para a vida
3. PRINCIPAIS FÓRMULAS
Com o objetivo didático de melhor a percepção e a utilização das fórmulas estão
disponibilizados os exemplos abaixo retirados das últimas provas com seus
possíveis resultados.

3.1. OPERADORES ARITMÉTICOS f) =A1/B1 0


1
Com base na tabela abaixo marque 10
o resultado correto para os exemplos: #DIV/0!
g) =B2:A1 2
#VALOR!
#NOME?
#DIV/0!
h) =A1+B3+C1+D2 100
80
160
0
Exemplo Resultado i) =A1^A2 100
a) =A1+B2*C1 900 6
610 12
600 20
60 j) =”a1+b2” #NOME?
b) =(A1-B2)-(C1-D2) 0 a1+a2
-20 a1+b2
-60 A1+B2
+60
c) =A1*B2/C1+D2 2,85
46,66
35
3.2. OPERADOR DE
46,00
CONCATENAÇÃO
d) =(A1+D2)*(1-10%) 45
4,5 Com base nessa outra tabela abaixo
450 marque o resultado correto para os
e) =A1XB2 #NOME? exemplos:
200
#DIV/0!
#VALOR!

6
Informática para a vida
3.3. OPERADORES DE
COMPARAÇÃO/ LÓGICOS
Com base nessa próxima tabela
abaixo marque o resultado correto
para os exemplos:

Exemplo Resultado
a) =A1&B2 30
200
1020
ERRO
b) =C1&D2 AulaNoite
Aula Noite Exemplo Resultado
Aula da Noite a) =A1<B2 VERDADEIRO
#NOME? FALSO
#NOME!
c) =C1&B2 Aula20
AulaNoite20 b) =A1=B2 VERDADEIRO
20Aula FALSO
#NOME!
Noite20
c) =A1>=10 VERDADEIRO
d) =C1+D2 #NOME?
FALSO
#VALOR!
#NOME!
30
d) =A1<>10 VERDADEIRO
AulaNoite
FALSO
e) =C1&” ”&D2 AulaNoite #NOME!
Aula&Noite
e) =C1=AULA VERDADEIRO
Aula Noite
FALSO
Aula e Noite #NOME!
f) =”2+3=”&2+3 2+3=5 f) =C1=”AULA” VERDADEIRO
2+3&2+3 FALSO
#NOME!
g) =C1=D2 VERDADEIRO
FALSO
#NOME!

7
Informática para a vida
4. PRINCIPAIS FUNÇÕES e) =SOMA(A1:B5;C1:E6) 150
0
Para que seja exercitado o #VALOR!
aprendizado sobre funções foram 130
disponibilizados os exemplos f) =MULT(A1:B2) 0
abaixo retirados das últimas provas 200
com seus possíveis resultados. #DIV/0!

4.1. OPERADORES DE g) =MOD(B1;A2) 2


REFERÊNCIA 0
20
Com base na tabela abaixo
10
marque o resultado correto para os
h) =QUOCIENTE(B1;A2) 2
exemplos:
0
20
10
i) =MÁXIMO(A1:E5) 50
150
10
#VALOR!
j) =MÍNIMO(A1:E5) 10
0
50
#VALOR!
k) =RAÍZ(A2) 3,16
Exemplo Resultado 3
a) =SOMA(A2:E5) 150
130
50
60
Assista: A vídeo aula dessa
b) =SOMA(A1:E6) 150
apostila está disponível
0
totalmente gratuita em:
#VALOR!
https://goo.gl/e9YGWi
Vazio
c) =SOMA(A1..E5) 150
50
#NOME?
d) =SOMA(A2;E5) 60
130

8
Informática para a vida
4.2. FUNÇÕES ESTATÍSTICAS Visite:
Mais uma vez colocamos uma https://www.facebook.com/
groups/infoaprender
tabela base para você avaliar se os
para obter os gabaritos e mais
resultados dos exemplos estão
questões atualizadas.
corretos:
4.3. FUNÇÃO SE
Essa função lógica retorna um
valor se uma condição for
verdadeira e um outro valor se for
falsa. Segue abaixo outra tabela
base para verificarmos essa função a
partir de exemplos e seus possíveis
resultados:
Exemplo Resultado
a) =MÉDIA(A1:B2) 20
60
b) =SOMA(A1:B2)/3 20
60
#VALOR!
c) =A2+B1+B2/3 20
40
d) =MODO(A1:C2) 10
20
e) =MODO(A1:D2) 10
Exemplo Resultad
20
a) =SE(A1<A2;”Aprovado”;”Reprovado”) Aprovado
f) =MODO(A1:B2) 0
Reprovado
10
b)=SE(A1=A2;”Aprovado”;”Reprovado”) Reprovado
#N/D
Aprovado
g) =MED(A1:D2) 40
c) =SE(A1=A2;”Azul”;”Vermelho”) Azul
30
Vermelho
20
d) =SE(A1=A2;100;200) 200
h) =MED(A1:E2) 25 100
40 e) =SE(A1=A1;SOMA(A1:B2);200) 100
20 200
f) =SE(A1=A1;”SOMA(A1:B2)”;200) 20
0

9
Informática para a vida
10 4.4. FUNÇÃO SOMASE
0
g) =SE(A1>A1;”Aprovado”;”Reprovado”) Reprovado Essa outra função lógica serve
Aprovado para somar os valores em um
h)=SE(A1>=A1;”Aprovado”;”Reprovado” Aprovado intervalo que atendam aos critérios
) Reprovado que você especificar. Segue abaixo
outra tabela base para verificarmos
essa função a partir de exemplos e
Aprovado
seus possíveis resultados:
l) =SE(SOMA(A1:A2)>=B1;”Aprovado”;
“Reprovado”) Reprovado

Preguiça
j)=SE(“Preguiça”=”Estudar”;”Aprovado”;
Estudar
”Reprovado”)
Aprovado
Reprovado

k) =SE(A3=”Estudar”;”Aprovado”; Aprovado
”Reprovado”) Estudar
Reprovado

l)=SE(SOMA(A1:A2)>=B1;”Aprovado”; Reprovado
”Reprovado”) #NOME?
#VALOR! Exemplo Resultado
Aprovado a) =SOMASE(A2:A5;"Maria";C2:C5) 35000
m)=SE(A1=A2;”Reprovado”;”Aprovado”) Reprovado
Reprovado
b)=SOMASE(B2:B5;">160000";C2:C5) 63000
#NOME?
#VALOR!
c)=SOMASE(B2:B5;300000;C2:C5) 21000
n)=SE(A1<>10;MULT(A1:B2);SOMA(A1:B 100
2)) #NOME?
d) =SOMASE(B2:B5;">"& D2;C2:C5) 49000
24000
o)=SE(B2>50;”Bom”;SE(B2=50;”Regular”; Bom
e)=SOMASE(C2:C5">160000") 90000
”Ruim”)) Regular
Ruim

"Muito obrigado!"

― Alessandro Borges

10
Informática para a vida