Você está na página 1de 7

Resumo e anotações

Título: Microsoft Office Excel Avançado


Autor: Real & Dados – Centro de qualificação profissional.
Coleção: Curso Office Mircrosoft Registered Member.

Agradecimento

Obrigado Allana Flávia Moreira do Santos pela generosidade e


paciência de emprestar seu livro por “décadas”.
Capítulo 1 – Classificação de dados, Referência absoluta e Formatação
condicional

Opções de classificação de dados

Permite a organização da planilha por qualquer coluna.

Estatística básica: Soma, média, máximo e mínimo

Fórmula para soma: =SOMA(C1:C2)


Fórmula para média: =MEDIA(C1:C2)
Fórmula para máximo: =MAXIMO(C1:C2) OU MAIOR(C1:C2;1)
Fórmula para mínimo: =MINIMO(C1:C2) OU MENOR(C1:C2;1)
*C1 e C2 são as coordenadas de qualquer células.

Referência absoluta

Utilizada sempre que deseja-se fixar numa fórmula a referência de uma coluna, linha ou
coluna e linha. Ela é identificada pelo sinal cifrão antes da letra da coluna e/ou do número da
coluna.

Formatação condicional

Permite que diferentes valores de uma faixa de células tenham diferentes formatos, com base
em um ou mais critérios.

Colar especial

Permite colar somente alguns parâmetros do que foi copiado.


Subtotal

Utilizado para totalizar planilhas além de servir como importante ferramenta de análise dos
dados. Para criar os subtotais não é necessário selecionar toda a tabela, apenas uma célula
dentro dela.

Proteção

A função Proteger Planilha evita alterações indesejadas, seja por usuários ou por vírus de
macro. É um recurso indispensável para planilhas grandes onde se deve assegurar a
integridade das fórmulas e dos próprios dados.
A função Proteger Pasta de Trabalho evita alterações indesejadas, incluindo as funções
excluir, renomear, mover ou copiar, de todas as planilhas.
A função Permitir que os Usuários Editem Intervalos permite, como o nome diz, que os
usuários editem determinados intervalos quando a planilha está protegida. Pode-se colocar
ou não uma senha de edição.

Formulário de dados

Uma caixa de diálogo que exibe os registros da lista ou base de dados. A partir desta função, é
possível cadastrar, alterar, excluir e localizar registros.
Observação: esta função não está cadastrada em nenhuma das barras de ferramentas, então,
deve-se adicioná-la (Personalizar barra de ferramentas de acesso rápido > Mais comandos >
Comandos fora da faixa de opções > Formulário).

Autofiltro

Forma rápida de localizar um subconjunto de registros que atendam a um determinado


critério. Os dados que não atendem ao critério especificado serão temporariamente
ocultados. Para ativar o autofiltro é necessário selecionar apenas uma célula dentro do banco
de dados.
Nomear área

Atribui um título a um conjunto de células. Bastante útil para criação, leitura e memorização
das fórmulas. O intervalo das células deve conter um rótulo de coluna.

Funções de banco de dados

Funções de planilha que analisam os dados armazenados em listas.


Após clicar no botão “Colar função”, escolha a categoria “Banco de dados”. Após a escolha de
uma fórmula, será aberto os “Argumentos da função”, onde existem as opções:
“Banco_dados”, “Campo” e “Critérios”. Banco_dados é a lista principal; Campo é o número
da coluna que será analisada e Critérios a lista dentro da lista principal (essa lista pode ser
também a principal).

Função lógica “SE”

Função lógica que, a partir de uma condição, retorna valores como verdadeiro ou falso.
Utilizada para fazer testes condicionais sobre valores e fórmulas.
Após clicar no botão “Colar função”, escolha a categoria “Lógica”. Após a escolha da fórmula
“SE”, será aberto os “Argumentos da função”, onde existem as opções: “Teste_lógico”,
“Valor_se_verdadeiro” e “Valor_se_falso”. Teste_lógico é a é a condição;
Valor_se_verdadeiro é o que se deve fazer quando a condição for verdadeira e
Valor_se_falso, quando for falso.
Capítulo 2 – Função SE composta

Função lógica “SE” composta


=SE(C1=”teste_lógico”;”valor_se_verdadeiro”;SE(C1=”teste_lógico”;”valor_se_verdadeiro”;[...]
;”valor_se_falso”)[...])
Utilizada para fazer testes condicionais quando existem 2 ou mais condições.
Regra geral: o número de testes é igual ao número de condições menos 1.

Função lógica alinhada


=SE(E(C1>=”teste_lógico”;C1<=”teste_lógico”);”valor_se_verdadeiro”;" valor_se_falso ")
=SE(OU(C1>=”teste_lógico”;C1<=”teste_lógico”);”valor_se_verdadeiro”;" valor_se_falso ")
Utilizada para fazer testes condicionais quando existem 2 ou mais condições em um único
teste.

Função “SOMASE”
=SOMASE(intervalo;critério;intervalo_soma)
Permite a soma de resultados com base em um critério.

Função “SOMASES”
=SOMASES(intervalo_soma;intervalo_critérios1;critérios1; intervalo_critérios2;critérios2;[...])
Permite a soma de resultados com base em um ou mais critérios.

Função “CONT.SE”
=CONT.SE(intervalo;critério)
Permite a contagem de células não-vazias que obedecem a um critério.

Função “PROCV”

Procura uma informação na tabela apresentada na vertical e insere o valor encontrado na


célula desejada.
Após clicar no botão “Colar função”, escolha a categoria “Pesquisa e Referência”. Após a
escolha da fórmula “PROCV”, será aberto os “Argumentos da função”, onde existem as
opções: “Valor_procurado”, “Matriz_tabela”, “Núm_índice_coluna” e “Procurar_intervalo”.
Valor_procurado é a informação ou célula procurada; Matriz_tabela é a tabela geral;
Núm_índice_coluna é o número da coluna que apresenta os possíveis resultados e, em
Procurar_intervalo, deve-se colocar VERDADEIRO para encontrar um valor próximo ao
digitado anteriormente e FALSO para encontrar uma correspondência exata.
Função “PROCH”

Procura uma informação na tabela apresentada na horizontal e insere o valor encontrado na


célula desejada.
Após clicar no botão “Colar função”, escolha a categoria “Pesquisa e Referência”. Após a
escolha da fórmula “PROCV”, será aberto os “Argumentos da função”, onde existem as
opções: “Valor_procurado”, “Matriz_tabela”, “Núm_índice_lin” e “Procurar_intervalo”. As
funções são análogas à função PROCV.

Validação de células

Permite a criação de restrições para a entrada de dados.

Organizar estrutura de tópicos

Exibe e oculta dados pelas colunas ou pelas linhas.

Congelar painéis

Mantém uma parte da planilha visível enquanto o restante é percorrido.

Auditoria de Fórmulas

Rastrear precedentes: indica com setas as células que são usadas na fórmula da célula atual.
Rastear dependentes: indica com setas as células que usam a célula atual em suas fórmulas.
Avaliar fórmula: abre uma caixa de diálogos que avalia cada etapa da fórmula.
Capítulo 3 – Cenários

Função “HOJE”
=HOJE()
Informa a data, mês, ano atuais.

Função “AGORA”
=AGORA()
Informa a data, mês, ano, horas e minutos atuais.

Capítulo 4 – Verificando erros em fórmulas

Significado dos diálogos de erros


CÓDIGOS SIGNIFICADO UTILIZAÇÃO
Útil para se certificar de
células que não deveriam
estar vazias. Se os dados
ainda não estiverem
#N/D Não há valor disponível.
disponíveis, utilize este
código nestas células; as
fórmulas dependentes
retornarão o valor #N/D.
O Excell não reconhece a
#NOME? ---
fórmula usada.
As áreas especificadas não se
#NULO! ---
interceptam.
Indica um problema com o
#NUM! ---
número.
O argumento ou operando é
#VALOR! ---
inválido.
A fórmula está tentando
#DIV/0! ---
fazer uma divisão por zero.