Você está na página 1de 8

Each SEA must have at least one virtual Ethernet adapter with the “Access external network” flag

(previously known as “trunk” flag) checked. This enables the SEA to provide bridging functiona
lity between the two VIO servers.

Note: SEAs has the same PVID, but will have a different priority value.

Control Channel:
An additional virtual Ethernet adapter , which belongs to a unique VLAN on the system, is used to
create the control channel between the SEAs, it must be specified in each SEA when configured in
ha_mode.

The purpose of this control channel is to communicate between the two SEA adapters to determine
when a fail over should take place

Limitation:
SEA Failover was introduced with Fixpack 7 (Virtual I/O server version 1.2), so both Virtual I/O
Servers need to be at this minimum level.

Steps:
Create the Virtual ethernet adapter with the following option on the VIOS1.
virtual adapter a unique (Port Virtual LAN ID) VLAN ID (PVID): "1"
Check the box "access external network".
Give the virtual adapter a low trunk priority. EX: "1"
mkvdev -sea ent0 -vadapter ent2 -default ent2 -defaultid 1 -attr ha_mode=auto ctl_chan=ent3

Create the Virtual ethernet adapter with the following option on the VIOS2
virtual adapter the same VLAN ID (PVID) as VIOS1. EX: "1"
Check the box "access external network".
Give the virtual adapter a higher trunk priority. EX: "2"
mkvdev -sea ent0 -vadapter ent2 -default ent2 -defaultid 1 -attr ha_mode=auto ctl_chan=ent3

Create the Virutal ethernet adapter for control channel with the following option on both VIOS1/2.
Give this new virtual adapter another unique VLAN ID (PVID) EX: "99"
Do NOT check the box "access external network".
Shutdown, Activate VIOS2 or run cfgdev from VIOS command line if created with DLPAR.

Manual SEA Failover On VIO server:


Scenario 1:
$ lsdev -type adapter
or
$ oem_setup_env
# lsdev -Cc adapter |grep ent --> Note which ent is the SEA
# entstat -d entX | grep State --> Check for the state (PRIMARY, or BACKUP)
Set ha_mode to standby on primary VIOS with chdev command:
# chdev -l entX -a ha_mode=standby
or
$ chdev -dev -attr ha_mode=standby

Reset it back to auto and the SEA should fail back to the primary VIOS:
# chdev -l entX -a ha_mode=auto
or
$ chdev -dev -attr ha_mode=auto

Scenario 2, Primary VIOS Shutdown


Reboot the primary VIOS for fail over to backup SEA adapter.
When the primary VIOS is up again, it should fail back to the primary SEA adapter.

Scenario 3, Primary VIOS Error


Deactivate primary VIOS from the HMC for fail over to backup SEA adapter.
Activate the primary VIOS for the fail back to the primary SEA adapter again.

Scenario 4, Physical Link Failure


Unplug the physical ethernet adapter cable on primary VIOS for failover to the backup VIOS.
Replug the physical ethernet adapter cable on primary VIOS for failback to the primary VIOS.

Scenario 5, Reverse Boot Sequence


Shut down both the VIO servers.
Activate the VIOS with backup SEA until the adapter becomes active.
Activate the VIOS with primary SEA. The configuration should fail back to the primary SEA.

Pre-requisite:
Make sure to check the existing vio version $ioslevel
Collect all the connected lpars to the VIO server
Take the mksysb backup of lpars and backupios, viosbr backup of vio servers.
Take note of the important output configuration files and lsmap -all output before the upgrade
start.
To get the vio upgrade package from the below site or from your nim server if you got already.
http://www14.software.ibm.com/webapp/set2/sas/f/vios/download/home.html

Implementation steps:
Copy the vio upgrade package to the /home/padmin of the VIO servers.
The upgrade package has to be placed in /home/padmin
Login as padmin mode.
$updateios -commit --> To Commit previous updates by running the updateios command.
$updateios –accept –install –dev /home/padmin/<vio package> --> To upgrade the vio version.
$shutdown -restart -->Reboot the vio server to complete the update.
$ioslevel -->Check the latest vio level has been achieved.

Important notes:
When upgrading to VIOS 2.2.0.10-FP-24
Fix Pack 24 enables Role Based Access Control (RBAC) roles and authorizations for
thepadmin user on the VIOS. Roles and authorizations are enabled immediately. If you upgrade to
VIOS 2.2.0.10-FP-24 via the updateios command, the only two commands that you can run before
the VIOS is rebooted are the shutdown and swrole commands.
$ swrole - PAdmin
$ shutdown -restart
$ license -accept

Note: The below procedure is to assume that we need to add a new virutal disk to the root volume
group on the lpar, for that we need to map a new disk from vio server to the lpar.

Hence as a aix admin i need to map a new disk from vio server to the lpar like below. There are
several methods to accomplish this task. The below procedure is one of them.

Find out the slot number of the vscsi


#lspv -> To check the disk present on the lpar
hdisk0 0006a7df4403b4a6 rootvg active

# lspath -F "name,status,parent,connection" -l hdisk0


hdisk0,Enabled,vscsi0,810000000000
hdisk0,Enabled,vscsi1,810000000000

# lscfg -l vscsi0
vscsi0 U9111.520.0000034-V10-C50-T1 Virtual SCSI Client Adapter

# lscfg -l vscsi1
vscsi1 U9111.520.0000034-V10-C51-T1 Virtual SCSI Client Adapter

U9111.520.0000034 -> model and serial number


V10 -> lpar id
C50 and C51 is client slot number of the vhost adapter

Find out the VIO server associated with the lpar using HMC
# lsrsrc IBM.ManagementServer or lsrsrc IBM.MCP
------ login to the hmc with the hscroot password

The below cmd is used to find out the vio server name and vhost info associated with the lpar
# lshwres -r virtualio --rsubtype scsi -m U9111-520-0000034 --filter lpar_ids=10 -F "slot_num,re
mote_slot_num,remote_lpar_name"

Note: we can replace “-m U9111-520-0001234” with the name of your managed system
50,50,vio_server1
51,51,vio_server2
The above output shows the client slot number, server slot number, and VIO server name.

Find out the vhost assigned for the lpar


we can find the vhost info using the slot number
#lsdev -slots|grep -i c50
output: vhost10
So the vhost10 is associated with our target lpar.

#lsmap -vadapter vhost10


SVSA Physloc Client Partition ID
--------------- -------------------------------------------- ------------------
vhost10 U9111.520.0000034-V2-C50 0x0000000a

VTD indprodfin_rootvg
Status Available
LUN 0x8100000000000000
Backing device hdisk43
Physloc L5000000000000

the slot number is the “C50” part of the U9111.520.0000034-V2-C50. So we got the correct vhost.
(we can also confirm the 0x0000000a is the hexa decimal value of the lpar id 10.
and the pvid of the backing device is same as the pvid of the disk on the lpar.)
Find out the free disk /unassigned disk on the vios which needs to be mapped.
$lspv -free
The above output will show the list of free disk which are available on the vio server and not
mapped with any vhost. or if we already talked with storage team and they provide the lun details
then we can get the disk like below.
odmget CuAt|grep -i 4386 -> The command will list out the hdisk name.
we will take hdisk20 as a free disk for instance.

Changing the attributes (reserve_policy and health check ) of the disk before mapping.

As we have a dual vio set up, we need to change the reserve policy as no_reserve. Hence the disk
is not hold by any of the vio server.

chdev -dev hdisk20 -attr reserve_policy=no_reserve


chdev -dev hdisk0 -attr hcheck_interval=60
----------------------------------------------------------------------------------------------------------------------
---------------------

Mapping the disk to the vhost

syntax: mkvdev -vdev <hdisk> -vadapter <vhost> -dev <VTD name>

mkvdev -vdev hdisk20 -vadapter vhost10 -dev indprodfin_rootvg

lsmap -vadapter vhost10


SVSA Physloc Client Partition ID
--------------- -------------------------------------------- ------------------
vhost10 U9111.520.0000034-V2-C50 0x0000000a

VTD indprodfin_rootvg
Status Available
LUN 0x8100000000000000
Backing device hdisk43
Physloc L5000000000000

VTD indprodfin_rootvg1
Status Available
LUN 0x8200000000000000
Backing device hdisk47
Physloc L3000000000000

We confirm that the disk has been mapped successfully.

Now come to lpar and scan the new disk.


----------------------------------------------------------------------------------------------------------------------
---------------------

Scanning the newly assigned disk on the lpar


#lspv
hdisk0 0006a7df4403b4a6 rootvg active

#cfgmgr --> scanning the server

#lspv
hdisk0 0006a7df4403b4a6 rootvg active
hdisk1 0006a7dfd9f11858 none

------------we got the newly added disk hdisk1


#lspath -l hdisk1
hdisk1,Enabled
hdisk1,Enabled
------------------------ confirmed that hdisk1 has a dual path.

# chdev -l hdisk1 -a hcheck_interval=20

#extendvg rootvg hdisk1

#lspv
hdisk0 0006a7df4403b4a6 rootvg active
hdisk1 0006a7dfd9f11858 rootvg active

How to find out the vhost information of the disk?

Sometimes we are in the situation to find out the VHOST information of particular hdisk. We can
easily find out using the below method.

ü First we need to find out in what VTD the hdisk is belongs to.
ü Then using VTD, we can find out the vhost info.

For example, if we want to find out the hdisk5 is part of which vhost? Now the short cut is below.
ü find out vtd which is belongs to the hdisk

$lsmap -all|grep -p hdisk5

VTD testmachine-16
Status Available
LUN 0x8700000000000000
Backing device hdisk5
Physloc U7311.D20.067DDBB-P1-C02-T1-L113

ü Now find out the vhost belongs to the VTD


syntax: lsdev -dev <VTD> -field parent
$lsdev -dev testmachine-16 -field parent

parent
vhost3

So hdisk5 is part of vhost3


To confirm:
$lsmap -vadapter vhost3
SVSA Physloc Client Partition ID
--------------- -------------------------------------------- ------------------
vhost3 U9133.55A.065040H-V22-C16 0x00000003
VTD testmachine-16
Status Available
LUN 0x8700000000000000
Backing device hdisk5

Physloc U7311.D20.067DDBB-P1-C02-T1-L113
VTD testmachine-15
Status Available
LUN 0x9200000000000000
Backing device hdisk6
Physloc U7311.D20.067DDBB-P1-C02-T1-L66

Using kdb, we can easily trace the vscsi configuration in aix. This command will save much time
when we compare with the old method to do the same.
#echo "cvai" | kdb | grep vscsi
read vscsi_scsi_ptrs OK, ptr = 0x59A03C0
vscsi0 0x000007 0x0000000000 0x0 vios1->vhost8
vscsi1 0x000007 0x0000000000 0x0 vios2->vhost8

Most of us think that we cannot execute the above command to fetch the vio server information on
AIX 5.3, thats wrong. Still we can use kdb command to get the information.
1. Simply executing the kdb command on the aix prompt
# kdb
You will receive a prompt like this:
0>

2. Load the cvscsi autoload function (note: this function is already loaded by default on AIX 6.1
systems.)
0> cvscsi
read vscsi_scsi_ptrs OK, ptr = 0x59A03C0
Autoload function /usr/lib/ras/autoload/cvscsi64.kdb was successfully executed

3. Then we can check the vscsi adapter details, using the cvai function:
0)> cvai
If you want only for a particular vscsi, we can use - cvai vscsix
Below will be the o/p:
unit_id: 0x30000001 partition_num: 0x1 partition_name: lparname
capability_level: 0x0 location_code: priv_cap: 0x1 host_capability: 0x0 host_name: vhostx
host_location:heart_beat_enabled: 0x1 sample_time: 0x1F Ping_response_time: 0x2D, Host
part_number: 0x2 : OS_type: 0x3
host part_name: VIO NAME
..........

Using the above output we can find out the 'host_part_name' for the hostname of the VIO server
serving this adapter and host_name for the associated vhost adapter.

How to find out the vhost information easily in aix?


Using the below command we can find out the vhost information very easily. We can get all the
vhost name information associated with our target lpar very easily. For that we need have the
LPAR ID in hexa decimal.

* Find the lpar id and convert into hexa decimal.


For ex: if your LPAR ID is 15, then the hexadecimal value is "f"

Using the below command we can convert decimal no to hexa-decimal.


printf "%x\n" 15 output is: "f"

* Execute the below command on the VIO server to find out the vhost info.
lsmap -all | grep vhost | grep 0x0000000f
Note: totally 6 zeros are needs to put after the "x" on the command and last two digit ("0f") is for
hexa decimal number.

Advantages of this command is, if you have 6 virtual disks on the lpar from the vios, then we will
get all the 6 virtual disks associated with the vhosts name on the VIOS..

How to find out the VHOST informaiton using VTD names?


Many ways are there to find out the vhost information. Sometimes we know the VTD name but
dont know about the VHOST information. The below commands used to find out the VHOST
information using the VTD name.
lsdev -dev <VTD_NAME> -field parent

(execute the command in the aix prompt)


/usr/ios/cli/ioscli lsdev -dev <VTD_NAME> -field parent |egrep -v parent

Você também pode gostar