Você está na página 1de 4

PRACTICA DE VoIP

1.- CONFIGURACION DEL SWITCH

CREACION DE VLANs
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 4
Switch(config-vlan)#name VOZ
Switch(config-vlan)#exit
Switch(config)#vlan 5
Switch(config-vlan)#name DATOS
Switch(config-vlan)#exit
Switch(config)#
CONFIGURACION DEL PUERTO TRUNK
Switch(config)#int f0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#exi
Switch(config-if)#exit
ASIGNACION DE LOS PUERTOS DE LAS VLANs

Switch(config)#interface range f0/2-5


Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport voice vLan 4
Switch(config-if-range)#exit
Switch(config)#interface range f0/6-10
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 5
Switch(config-if-range)#exit

2.- Configuración del router

CREACIÓN DE SUBINTERFACES
Router(config)#interface f0/0.4
Router(config-subif)#encapsulation dot1Q 4 EL NUMERO DE LA VLAN
Router(config-subif)#ip address 40.0.0.1 255.0.0.0
% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.
Router(config-subif)#exit
Router(config)#interface f0/0.5
Router(config-subif)#encapsulation dot1Q 5 EL NUMERO DE LA VLAN

Router(config-subif)#ip address 50.0.0.1 255.0.0.0


% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.
Router(config-subif)#exit
HABILITACION DE LA INTERFAZ F0/0
Router(config)#interface f0/0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to


up

%LINK-5-CHANGED: Interface FastEthernet0/0.4, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.4, changed state


to up

%LINK-5-CHANGED: Interface FastEthernet0/0.5, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.5, changed state


to up

Router(config-if)#exit

CONFIGURACIÓN DEL SERVIDOR DHCP

Router(config)#ip dhcp pool VOZ


Router(dhcp-config)#network 40.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 40.0.0.1
Router(dhcp-config)#option 150 ip 40.0.0.1
Router(dhcp-config)#exit
Router(config)#ip dhcp pool DATOS
Router(dhcp-config)#network 50.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 50.0.0.1
Router(dhcp-config)#option 150 ip 50.0.0.1
Router(dhcp-config)#exit
EXCUSION DE LAS IPs GATEWAY
Router(config)#ip dhcp excluded-address 40.0.0.1
Router(config)#ip dhcp excluded-address 50.0.0.1

CONFIGURACIÓN DEL CME (CALL MANAGER EXPRESS)


Router(config)#telephony-service
Router(config-telephony)#max-dn 5
Router(config-telephony)#max-ephones 5
Router(config-telephony)# ip source-address 40.0.0.1 port 2000
Router(config-telephony)#auto assign 1 to 5

AGREGAR TELÉFONOS (LÍNEAS DE EXTENSIONES)

Router(config)#ephone-dn 1
Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 1.1, changed
state to up

Router(config-ephone-dn)#number 2345
Router(config-ephone-dn)#exit

CONFIGURACION DE INTERFACES
Router(config)#interface serial 0/2/0
Router(config-if)#ip address 10.0.0.2 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#n shutdown
CONFIGURACION DEL PROTOCOLO RIP

Router(config)#router rip
Router(config-router)#network 40.0.0.0
Router(config-router)#network 50.0.0.0
Router(config-router)#network 10.0.0.0
Router(config-router)#exit

CONFIGURACION DEL PROTOCOLO DE VOZ


Router(config)#dial-peer voice 1 voip
Router(config-dial-peer)#destination-pattern 1...
Router(config-dial-peer)#session target ipv4:10.0.0.1