Você está na página 1de 19

LAN 20x – Cisco CCNA Routing & Switching

• Módulo 17:

NAT
Network Address Translation

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

Escalabilidade de endereçamento no IPv4

• O projeto original da Internet exigia que cada host que se conectava a ela tivesse um endereço
IP único e registrado.

• O rápido crescimento iria esgotar todos os endereços IPs até metade dos anos 1990.

• Solução de longo prazo:

 IPv6

• Solução de curto prazo:

 CIDR (Classless Interdomain Routing)


 Endereçamento Privado
 NAT (Network Address Translation)

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

CIDR (Classless Interdomain Routing)

• Definido na RFC 4632 (http://www.ietf.org/rfc/rfc4632.txt).

• Permitir faixas de endereços IPs de tamanho variável.


 Reduzir desperdicio de endereços IPs.
 Permite alocar um subconjunto de uma rede classe A, B ou C.

• Atribuição dos endereços deve ajudar no processo de agregação (sumarização).


 Reduzir o tamanho das tabelas de roteamento.

Exemplo de sumarização de rotas

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

Endereçamento Privado

 Definido na RFC 1918 (http://www.ietf.org/rfc/rfc1918.txt).

 Endereços privados são faixas de endereços IPs destinados a uso interno em uma empresa.

 São endereços IPs não registrados na Internet pública.

 Para conectar redes com endereços privados à Internet, é necessario usar o NAT.

Espaço de Endereçamento IP Privado da RFC 1918

Faixa de Endereços IP Classe Número de Redes


10.0.0.0 => 10.255.255.255 A 1
172.16.0.0 => 172.31.255.255 B 16
192.168.0.0 => 192.168.255.255 C 256

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

NAT (Network Address Translation)

• Definido na RFC 3022 (http://www.ietf.org/rfc/rfc3022.txt).

• Permite que um host que não possua um endereço IP registrado e globalmente único se comunique com
outros hosts através da Internet.

• O NAT usa um endereço IP registrado para representar o endereço privado para o resto da Internet.

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

Terminologia

• Na terminologia da Cisco, a rede da empresa que usa endereços privativos, e, sendo assim, precisa
de NAT, é a parte “interna” (ou “inside”) da rede. O lado Internet da função NAT é a parte
“externa” (ou “outside”) da rede.

 Inside Local (local interno): Um inside local é o endereço IP atribuído a um host na rede
privada da empresa.

 Inside Global (global interno): O NAT usa um endereço inside global para representar um host
interno quando o pacote é enviado para a rede externa, ou Internet.

 Outside global (global externo): Um outside global é o endereço IP atribuído a um host que fica
na rede externa, ou Internet.

 Outside Local (local externo): Quando o NAT encaminha um pacote de fora para dentro da rede,
o endereço IP que representa o host externo na forma do endereço IP destino é chamado de
endereço IP outside local.

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

Terminologia

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

NAT (Network Address Translation)

• Variações do NAT:

 NAT Estático:

 Endereços IPs são mapeados um-para-um estaticamente.

 NAT Dinâmico:

 O NAT dinâmico especifica uma faixa de endereços globais internos possíveis e define
um critério para determinar quais endereços IP locais internos devem ser traduzidos.

 Endereços IPs mapeados um-para-um dinamicamente.

 NAT Overload com PAT (Port Address Tranlation):

 Quando o PAT cria o mapeamento dinâmico, ele seleciona não apenas um endereço IP
global interno, mas também um número de porta único a ser usado com este endereço.

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

NAT Estático

• Endereços IPs mapeados um-para-um estaticamente.

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

NAT Estático - Configuração

Passo 1: Configure as interfaces que estarão na parte interna do design do NAT:


router(config)# interface ethernet0/0
router(config-if)# ip address 10.1.1.3 255.255.255.0
router(config-if)# ip nat inside

Passo 2: Configure as interfaces que estarão na parte externa do design do NAT:


router(config)# interface Serial0/0
router(config-if)# ip address 200.1.1.251 255.255.255.0
router(config-if)# ip nat outside

Passo 3: Configure os mapeamentos estáticos:

router(config)# ip nat inside source static 10.1.1.2 200.1.1.2


router(config)# ip nat outside source static tcp 90.90.90.2 80 192.168.0.2 80

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

NAT Estático – Configuração

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

NAT Dinâmico

• Endereços IPs mapeados um-para-um dinamicamente.

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

NAT Dinâmico - Configuração

Passo 1: Configure as interfaces que estarão na parte interna do design do NAT:


router(config)# interface ethernet0/0
router(config-if)# ip address 10.1.1.3 255.255.255.0
router(config-if)# ip nat inside

Passo 2: Configure as interfaces que estarão na parte externa do design do NAT:


router(config)# interface Serial0/0
router(config-if)# ip address 200.1.1.251 255.255.255.0
router(config-if)# ip nat outside

Passo 3: Configure uma ACL que identifique os pacotes chegando nas interfaces internas:

router(config)# access-list 10 permit 10.1.1.0 0.0.0.255

Passo 4: Configure o pool de endereços IP públicos e em seguida habilite o NAT dinâmico fazendo
referência à ACL e ao pool recém criado..
router(config)# ip nat pool Net200 200.1.1.1 200.1.1.2 netmask 255.255.255.252
router(config)# ip nat inside source list 10 pool Net200

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

NAT Dinâmico – Configuração

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

NAT Overload com PAT (Port Address Translation)

• Quando o PAT cria o mapeamento dinâmico, ele seleciona não apenas um endereço IP global
interno, mas também um número de porta único a ser usado com este endereço.

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

Configuração NAT Overload com PAT

Passo 1: Configure as interfaces que estarão na parte interna do design do NAT:


router(config)# interface ethernet0/0
router(config-if)# ip address 10.1.1.3 255.255.255.0
router(config-if)# ip nat inside

Passo 2: Configure as interfaces que estarão na parte externa do design do NAT:


router(config)# interface Serial0/0
router(config-if)# ip address 200.1.1.251 255.255.255.0
router(config-if)# ip nat outside

Passo 3: Configure uma ACL que identifique os pacotes chegando nas interfaces internas:

router(config)# access-list 10 permit 10.1.1.0 0.0.0.255

Passo 4: Associe a ACL com a interface externa. Adicione o termo overload ao final do comando:
router(config)# ip nat inside source list 10 interface Serial0/0 overload

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

Configuração NAT Overload com PAT

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

NAT - Verificação

• Certifique-se de que a configuração inclui o subcomando de interface ip nat inside ou ip nat outside.

• No NAT estático, certifique-se de que o comando ip nat source static apresenta o endereço IP local
interno primeiro, e o IP global interno depois.

• No NAT dinâmico, certifique-se de que a ACL esteja configurada adequadamente antes que qualquer
tradução NAT tenha ocorrido.

• Com PAT, verifique se a opção overload foi adicionada no final do comando ip nat inside source list.

• Verifique se existe alguma ACL em uma das interfaces descartando os pacotes.

• Comandos show:
 router# show ip nat translation
 router# show ip nat statistics
 router# debug ip nat

LAN 20x - Cisco CCNA Routing & Switching


17. NAT

Exercícios:

• Exercícios de Revisão 17.

• Laboratório LAN-20x Lab 17 - NAT.

LAN 20x - Cisco CCNA Routing & Switching