Você está na página 1de 1

UNICESUMAR - CENTRO UNIVERSITÁRIO CESUMAR

PRÉ-VISUALIZAÇÃO DE QUESTÕES

QUESTÃO 01 | Objetiva Código: 101994


Existem diferentes estruturas de repetição para se adequarem melhor a diferentes tipos de problemas. Na prática,
podemos realizar as mesmas repetições com as diferentes estruturas, adequando um pouco o código. Analise o código
a seguir, ele possui um erro. Leia as afirmativas e assinale a única incorreta.

1: Algoritmo conta
2:
3: Var
4: cont, n: inteiro
5:
6: Inicio
7:
8: cont := 0
9: enquanto (n <> 0) faca
10: escreva("Digite um número: ")
11: leia(n)
12: se (n >= 100) E (n <= 300) entao
13: cont := cont + 1
14: fimse
15: fimenquanto
16:
17: escreval("A quantidade de números entre 100 e 300 é: ", cont)
18:
19: Fimalgoritmo

Resposta esperada:
Como "n" é o contador de iterações, essa estrutura está preparada para a estrutura "para" ao invés de "enquanto".

A A leitura de dados da linha 11 deveria ser feita, pelo menos uma vez, antes do teste da linha 9.

B Se a linha 9 fosse trocada por "repita" e a linha 15 trocada por "ate (n=0)" o código ficaria correto.

C Para essa estrutura enquanto, se a leitura da linha 11 fosse feita antes da linha 9, ela também precisaria ser
repetida ao final do looping, logo antes da linha 15.

D O erro consiste em que o valor de "n" inicial é 0, ocasionando uma condição falsa na primeira passagem pelo
looping.

E Como "n" é o contador de iterações, essa estrutura está preparada para a estrutura "para" ao invés de
"enquanto".