Você está na página 1de 4

Av1 - Cst Anál e Desenv Sist - Lógica e Técnicas de Programação

Informações Adicionais

 Período: 17/09/2018 00:00 à 13/10/2018 23:59


 Situação: Iniciada
 Conceito:
 Protocolo: 335706554

1) Os operadores aritméticos são utilizados para realizar operações numéricas com os dados utilizados
pelo programa. Além da adição, subtração, multiplicação e divisão, pode-se utilizar por exemplo o
operador para radiciação ( ) e resto da divisão ( ). Além disso, os parênteses também possuem um
papel importante nas expressões aritméticas, pois permitem que a ordem das operações seja alterada.
Para resolver as operações aritméticas há uma hierarquia a ser seguida. Considere os operadores a seguir:

1. .

2. .

3. .

4. .
Assinale a alternativa que apresenta a ordem de prioridade correta dos operadores aritméticos.
Alternativas:

 a) 1 – 2 – 4 – 3.
 b) 4 – 2 – 1 – 3.
 c) 2 – 1 – 4 – 3. Alternativa assinalada
 d) 2 – 1 – 3 – 4.
 e) 2 – 3 – 4 – 1.

2) O fluxograma é uma forma de representar as instruções que serão executadas pelo algoritmo. Temos
um conjunto de símbolos (figuras geométricas), que representam cada ação a ser executada dentro do
algoritmo.
A respeito desses símbolos, avalie as seguintes afirmativas assinalando (V) para as verdadeiras ou (F) para
as falsas:

( ) O símbolo Terminal indica o início ou o fim de um algoritmo.


( ) O símbolo Exibição mostra o resultado de uma ação.
( ) O símbolo Processamento indica a operação realizada no algoritmo.
( ) O símbolo Decisão determina a entrada dos dados.
Agora assinale a alternativa correta.

Alternativas:

 a) V – F – F – V.
 b) V – F – F – F.
 c) V – V – F – V.
 d) F – F – V – V.
 e) V – V – V – F. Alternativa assinalada

3) O exemplo a seguir mostra a representação por linguagem natural de um problema, onde o usuário tem
que entrar com dois números e o algoritmo tem que somá-los e apresentar o resultado, conforme a
orientação a seguir:
1. Entrar com o 1o número.
2. Entrar com o 2o número.
3. Somar o 1o e o 2o número.
4. Exibir o resultado.
Sobre a linguagem natural, analise as seguintes sentenças:

I. Uma das vantagens da linguagem natural é ser escrito em Português.


II. A linguagem natural é pouco usada, pois dá oportunidade a más interpretações e imprecisões.
III. É uma descrição extensiva de um algoritmo, pois escreve-se muito para dizer pouca coisa.
IV. Na linguagem natural, há falta de confiabilidade no entendimento de um algoritmo.
Agora, assinale a alternativa que apresenta a resposta CORRETA.
Alternativas:

 a) Apenas a afirmativa III está correta.


 b) Apenas a afirmativa IV está correta.
 c) Apenas as afirmativas I, II e III estão corretas.
 d) Apenas as afirmativas I, II e IV estão corretas.
 e) As afirmativas I, II, III e IV estão corretas. Alternativa assinalada

4) Um dos problemas computacionais mais estudados é a ordenação de uma coleção de valores. A


ordenação é importante porque muitos problemas definidos sobre coleções de valores se tornam fáceis,
se os elementos da coleção estiverem ordenados.
A ordenação por seleção é um exemplo de algoritmo de ordenação.
Este algoritmo é composto pelas seguintes etapas:
1. Procura-se na parte desordenada pelo menor elemento e troca-se o menor elemento com o elemento
sob o marcador.
2. Usa-se um marcador para dividir as partes ordenada e desordenada do vetor. Atribui-se o valor 0 para o
marcador.
3. Avança-se o marcador.
4. O processo se repete até que exista apenas um elemento a partir do marcador.
Assinale a alternativa que apresenta a ordem correta das etapas do algoritmo de ordenação por seleção.

Alternativas:

 a) 1 – 2 – 3 – 4.
 b) 1 – 2 – 4 – 3.
 c) 2 – 1 – 4 – 3.
 d) 2 – 1 – 3 – 4. Alternativa assinalada
 e) 2 – 3 – 1 – 4.

5) Abaixo apresenta-se o pseudocódigo do algoritmo “teste”:

algoritmo "teste"
var
A: VETOR [1..3,1..3] DE INTEIRO
C,L,M:INTEIRO
inicio
ALEATORIO 1,50
PARA L DE 1 ATE 3 FACA
PARA C DE 1 ATE 3 FACA
LEIA(A[L,C])
SE (L=1) E (C=1) ENTAO
M<-A[L,C]
FIMSE
SE A[L,C]>M ENTAO
M<-A[L,C]
FIMSE
FIMPARA
FIMPARA
ESCREVAL("**** MATRIZ A ****")
PARA L DE 1 ATE 3 FACA
PARA C DE 1 ATE 3 FACA
ESCREVA(A[L,C]:4)
FIMPARA
ESCREVAL
FIMPARA
ESCREVAL(M)
fimalgoritmo

Sobre este algoritmo, analise as seguintes sentenças:

I. A é uma matriz cujos elementos são números inteiros gerados aleatoriamente.


II. A é uma matriz de ordem 3.
III. Ao fim de sua execução, o algoritmo imprime o menor valor da matriz.
IV. Ao fim de sua execução, o algoritmo imprime o maior valor da matriz.

Agora, assinale a alternativa que apresenta a resposta CORRETA.


Alternativas:

 a) Somente a afirmativa III está correta.


 b) As afirmativas I e II estão corretas.
 c) As afirmativas I, II e III estão corretas.
 d)As afirmativas I, II e IV estão corretas. Alternativa assinalada
 e) Todas as afirmativas estão corretas.