Você está na página 1de 4

GOVERNO DO ESTADO DO MARANHÃO

SECRETARIA DE ESTADO DE CIÊNCIA, TECNOLOGIA E INOVAÇÃO - SECTI


INSTITUTO ESTADUAL DE EDUCAÇÃO, CIÊNCIA E TECNOLOGIA DO MARANHÃO – IEMA
REITORIA DE ENSINO - DIREN
AVALIAÇÃO

UNIDADE PLENA: SÃO LUÍS


CURSO: INFORMÁTICA NOTA:___________

PROFESSOR: SILVANO DE JESUS CANTANHEDE DE OLIVEIRA ASS.: ____________


ALUNO(A):______________________________________________
TURMA: 104 DATA: ___ / 12 / 2018

INSTRUÇÕES

1. Use caneta azul ou preta, caso a resposta seja feita a lápis, a questão será anulada.
2. Caligrafia ilegível, bem desorganização, rasuras excessivas e respostas incoerentes poderão ocasionar invalidação do item.
3. Os estudantes que cometerem quaisquer atos no intuito de fraudar a avaliação serão punidos conforme regras do Regimento Interno da
Unidade e poderão obter nota zero.
4. Os celulares deverão ser desligados durante o período de realização da prova.
5. O estudante só poderá se retirar da sala após 1 hora do começo da aplicação da avaliação.
6. Ao sair da sala após o termino da sua avaliação, não faça barulho nas imediações das salas onde estão ocorrendo as provas.
7. O estudante não poderá ausentar-se da sala de aula enquanto estiver realizando a prova.

AVALIAÇÃO PERIÓDICA 4º Período – INTRODUÇÃO A ALGORITMOS

1. No que se refere a procedimentos e funções, às estruturas de controle de fluxo nas linguagens de


programação. A condição, na estrutura de repetição ENQUANTO, é testada antes de se executar o conjunto de
instruções. (1,0pt)
[ ] CERTO
[ ] ERRADO

Responda as questões 02 a 04 de acordo com o trecho de programa abaixo:


1 funcao inicio() {
2 inteiro i=0
3 enquanto (i<5) {
4 i++
5 se (i!=3) {
6 escreva (i)
7 }
8 }
9 }

2. Assinale a opção que apresenta a saída resultante da execução do algoritmo anterior. (1,0pt)
a. 12345
b. 1234
c. 1245
d. 0124
e. 3

3. Se trocarmos a linha 5 pelo comando: “se (i%2==0) {“. Qual o resultado: (1,0pt)
a. 2
b. 24
c. 135
d. 246
e. 12345
1
GOVERNO DO ESTADO DO MARANHÃO
SECRETARIA DE ESTADO DE CIÊNCIA, TECNOLOGIA E INOVAÇÃO - SECTI
INSTITUTO ESTADUAL DE EDUCAÇÃO, CIÊNCIA E TECNOLOGIA DO MARANHÃO – IEMA
REITORIA DE ENSINO - DIREN
AVALIAÇÃO

4. Se eliminarmos a linha 4, qual o resultado: (1,0pt)


a. 0
b. 0000000
c. Loop até o valor 10000000000
d. Loop infinito
e. Erro de execução

Considerando o programa abaixo, responda as questões 05 e 06:


1 funcao inicio() {
2 inteiro q, t, i, v
3 real m
4 escreva("Q: ")
5 leia(q)
6 se (q<=0){
7 escreva("\nValor de q inválido")
8 } senao {
9 t=0
10 i=1
11 enquanto (i<=q) {
12 escreva("V: ")
13 leia(v)
14 t+=v
15 i++
16 }
17 m = t/q
18 escreva("\nM: "+m)
19 }
20 }

5. Suponha que os dez primeiros valores a serem fornecidos para a leitura de v, quando solicitados, sejam na
seguinte ordem: 42, 44, 50, 44, 40, 40, 50, 50, 52, 52. Caso o valor lido para variável q tenha sido 5, o resultado
impresso ao final da execução do algoritmo será: (1,0pt)
a. Valor de q inválido.
b. M: 44,0
c. M: 52,0
d. M: 43,0
e. M: 36,0

6. Se trocarmos a linha 10 por: i = 3. E mantendo os demais dados de entrada da questão anterior, qual seria o
resultado: (1,0pt)
a. Valor de q inválido.
b. M: 27,0
c. M: 44,0
d. M: 28,0
e. M: 34,0

2
GOVERNO DO ESTADO DO MARANHÃO
SECRETARIA DE ESTADO DE CIÊNCIA, TECNOLOGIA E INOVAÇÃO - SECTI
INSTITUTO ESTADUAL DE EDUCAÇÃO, CIÊNCIA E TECNOLOGIA DO MARANHÃO – IEMA
REITORIA DE ENSINO - DIREN
AVALIAÇÃO

7. Considere o seguinte trecho de algoritmo em pseudocódigo: (1,0pt)

funcao inicio() {
inteiro vet[4]
inteiro indice, numero
indice = 0
enquanto (índice<4) {
escreva("Digite um numero dentro do limite: ")
leia(numero)
enquanto (...I...) {
escreva("Valor inválido. Digite um valor dentro do limite\n")
escreva("Digite um numero dentro do limite: ")
leia(numero)
}
vet[indice] = numero
indice++
}
para (indice = 0; indice<4; indice++) {
...II...
}
}

Para que o algoritmo acima leia quatro valores de anos de 1900 até 2017 e os apresente na tela, a lacuna:
a. II deve ser preenchida com escreva("Valor valido = ", vetor [ indice ] )
b. II deve ser preenchida com leia (vet [ indice])
c. I deve ser preenchida com numero>=1900 ou numero<=2017
d. I deve ser preenchida com numero>=1900 e numero<=2017
e. I deve ser preenchida com numero<1900 ou numero>2017

8. Considere o seguinte trecho de algoritmo em pseudocódigo: (1,0pt)

1 funcao inicio() {
2 inteiro n, i, k, j
3 para (i=0; i<n; i++) {
4 j=1
5 enquanto (j<n) {
6 j*=2
7 para (k=0;k<j;k++) {
8 escreva(“Execute”)
9 }
10 }
11 }
12 }

Assinale a opção que indica o número de vezes em que o código irá executar a linha 8 para n igual a 3.
a. 18
b. 15
c. 28
d. 48
e. 58

3
GOVERNO DO ESTADO DO MARANHÃO
SECRETARIA DE ESTADO DE CIÊNCIA, TECNOLOGIA E INOVAÇÃO - SECTI
INSTITUTO ESTADUAL DE EDUCAÇÃO, CIÊNCIA E TECNOLOGIA DO MARANHÃO – IEMA
REITORIA DE ENSINO - DIREN
AVALIAÇÃO

9. Considere o seguinte trecho de algoritmo em pseudocódigo: (1,0pt)

funcao inicio() {
inteiro x=1, y=4, z=5
enquanto (x<y) {
z = z + (y % x)
y--
x++
}
escreva(z)
}
A operação % representa o resto da divisão entre dois inteiros. Assinale a alternativa que indica o valor que
será impresso
a. 5.
b. 6.
c. 7.
d. 8.
e. 9.

10. Considere o vetor V na figura a seguir: (1,0pt)

Conteúdo 4 3 2 5 3 2 1 1
índice 0 1 2 3 4 5 6 7

Considere o algoritmo a seguir, escrito em pseudolinguagem:

funcao inicio(){
inteiro v[8]={4,3,2,5,3,2,1,1}
inteiro i, aux
para (i=0; i<6; i++) {
aux = v[i]
v[i] = aux + v[i+2]
}
v[6] = v[v[2]]
v[v[2]] = v[7]
}

Após a execução deste algoritmo, o conteúdo do vetor V, do índice 0 até 7, será:

a. 1, 2, 3, 4, 5, 6, 7, 8.
b. 4, 3, 2, 5, 3, 2, 1, 1.
c. 6, 8, 5, 7, 1, 3, 4, 1.
d. 6, 8, 5, 7, 4, 1, 3, 1.
e. 4, 5, 7, 1, 2, 3, 5, 1.