Você está na página 1de 4

ISEP - Administração de Sistemas 2007/2008 1

Temas abordados:
• Tecnologia de Redes
• Comandos CISCO IOS
• DHCP (Servidor e cliente)
• Packet Tracer

Tecnologia de Redes, Comandos Cisco IOS

Referências:

IBM Redbook : TCP/IP Tutorial and Technical Overview


http://www.redbooks.ibm.com/abstracts/gg243376.html

Internetworking Technology Handbook


http://www.cisco.com/en/US/tech/tk1330/tsd_technology_support_technical_reference_
book09186a00807594e5.html

How OSI Works


http://computer.howstuffworks.com/osi.htm/printable

How Ethernet Works


http://computer.howstuffworks.com/ethernet.htm/printable

How Routers Work


http://computer.howstuffworks.com/router.htm/printable

How LAN Switches Work


http://computer.howstuffworks.com/lan-switch.htm/printable

How Home Networking Works


http://computer.howstuffworks.com/home-network.htm/printable

Cisco IOS Command Line Interface Tutorial


http://www.cisco.com/warp/cpropub/45/tutorial.htm

Endereços IP
Classe A – 1-126 255.0.0.0
Classe B – 128-191 255.255.0.0
Classe C – 192-223 255.255.255.0

Endereços privados:

10.0.0.0 (A) 1 rede


172.16.0.0 (B) 16 redes
192.168.0.0 (C) 256 redes

Orlando Sousa e Nuno Pereira


ISEP - Administração de Sistemas 2007/2008 2

Exemplos de Equipamentos de Rede


Router – utilizado para interligar redes de computadores. Funciona na camada 3 do
modelo OSI. Encaminham pacotes entre redes. Trocam informação de uma forma
dinâmica para construir as suas tabelas de encaminhamento

Hub (Concentrador) - Liga computadores. Indicado apenas para pequenas redes, pois
as suas portas partilham o mesmo domínio de colisão. Funciona na camada 1.

Switch – Funciona na camada 2. O swith segmenta a rede, A cada porta corresponde um


segmento diferente, evitando colisões de pacotes de segmentos diferentes. Existem
switchs mais sofisticados que operam também na camada 3.

Repetidor – Funciona na camada 1. Amplifica e regenera os sinais eléctricos

Bridge – Permite ligar duas redes.

Computador

Wireless Access Point

Exemplos de dispositivos de ligação:


Ethernet (cobre)

Fast Ethernet (cobre e fibra)

Gigabit Ethernet (cobre e fibra)

Cabo Série

Modem

Placa Wireless

Exercícios:

1- Leia as apresentações “Getting Started”, “Logical Workspace”, “Configuration


Devices”, “Simulation Mode” que se encontram no menu HELPTutorials do
programa Packet Tracer

2- Faça o exercício:
CCNA1\ConceptBuilder_VariousProtocolLabs\SkillBuilder_UsingPacketTracer\Using
Packet Tracer lab handout.doc

Orlando Sousa e Nuno Pereira


ISEP - Administração de Sistemas 2007/2008 3

3- Faça o exercício:
CCNA1\SkillBuilder_PC_Config_Activity\PT PC Config Activity_Handout.doc

4- Faça o exercício:

CCNA2\SkillBuilder_InterfaceConfiguration\InterfaceConfiguration_Handout.doc

5- Faça o exercício:
CCNA2\ConceptBuilder_ICMP\CCNA2_Concept_Activity_ICMP_ Solution.doc

DHCP (Dynamic Host Configuration Protocol)

Referências:

Cisco IOS DHCP Server


http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120t/120t1
/easyip2.htm#wp4363

Características de um servidor DHCP:

• Um servidor DHCP pode estar instalado num computador com Windows ou


Linux;

• Os routers também podem funcionar como servidores DHCP.

Exemplo de configuração de um servidor DHCP no Packet Tracer com default


gateway 192.168.1.1:

Router#configure
Router(config)#ip dhcp pool teste
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.1.1
Router(dhcp-config)#exit
Router(config)#exit

Exercícios:

1- Utilize o exemplo anterior para configurar um servidor DHCP numa rede com vários
computadores. Teste a configuração.

Orlando Sousa e Nuno Pereira


ISEP - Administração de Sistemas 2007/2008 4

COMANDOS CISCO IOS destination_address destination_wildcard_mask


[protocol_information] [log]
Router# enable
Router(config)# access-list 100-199|2000-2699
Router# configure terminal
permit|deny
tcp|udp
Router(config)# interface ethernet [slot_#/]port_#
source_address source_wildcard_mask
Router(config-if)# media-type media_type
[operator source_port_#]
Router(config-if)# speed 10|100|auto
destination_address destination_wildcard_mask
Router(config-if)# [no] half-duplex
[operator destination_port_#]
[established] [log]
Router(config)# interface serial [slot_#/]port_#
Router(config-if)# clock rate rate_in_bits_per_second
operator= eq | lt | gt | neq | range
Router(config)# interface type [slot_#/]port_#
Router(config-if)# ip address IP_address subnet_mask
Router(config)# access-list 100-199|2000-2699
permit|deny icmp
Router(config)# ip host name_of_host [TCP_port_#]
source_address source_wildcard_mask
IP_address_of_host [2nd_IP_address...]
destination_address destination_wildcard_mask
[icmp_message] [log]
Router(config)# ip name-server IP_address_of_DNS_server
[2nd_server's_IP address ...]
Router(config)# ip nat inside source static
inside_local_source_IP_address
Router# show interfaces [type [slot_#/]port_#]
inside_global_source_IP_address
Router# show ip interface [type [slot_#/]port_#]
Router(config)# ip nat outside source static
Router# show ip interface brief
outside_global_destination_IP_address
Router# show hosts
outside_local_destination_IP_address
Router# show version
Router# show running-config
Router(config)# interface type [slot_#/]port_#
Router# show ip route
Router(config-if)# ip nat inside|outside
Router# show ip protocols

Router(config)# ip route destination_network_#


Router(config)# ip nat inside source
[subnet_mask]
list standard_IP_ACL_#
IP_address_of_next_hop_neighbor
pool NAT_pool_name
[administrative_distance] [permanent]
Router(config)# ip nat pool NAT_pool_name
beginning_inside_global_IP_address
Router(config)# ip route 0.0.0.0 0.0.0.0
ending_inside_global_IP_address
IP_address_of_next_hop_neighbor
netmask subnet_mask_of_addresses
[administrative_distance] [permanent]
Router(config)# ip nat inside source
Router(config)# ip classless
list standard_IP_ACL_#
pool NAT_pool_name overload
Router(config)# interface type port_#.subinterface_#
Router(config)# ip nat pool NAT_pool_name
[point|multipoint]
beginning_inside_global_IP_address
ending_inside_global_IP_address
Router(config)# interface type port_#.subinterface_#
netmask subnet_mask_of_addresses
Router(config-subif)# encapsulation isl|dot1q VLAN_#
Switch(config)# interface type slot_#/port_#
Router(config)# router name_of_the_IP_routing_protocol
Switch(config)# ip address IP_address subnet_mask
Switch(config)# ip default-gateway router's_IP_address
Router(config-router)# network IP_network_#
Switch# copy running-config startup-config
Router(config)# router rip
Switch # vlan database
Router(config-router)# version 1|2
Switch (vlan)# vtp domain VTP_domain_name
Switch (vlan)# vtp server|client|transparent
Router(config)# router eigrp autonomous_system_#
Switch (vlan)# vtp password VTP_password
Router(config-router)# network IP_network_#
Switch (vlan)# vtp pruning
Router# show ip eigrp neighbors
Switch (vlan)# abort
Router# show ip eigrp topology
Switch # show vtp status
Router# show ip eigrp traffic
Switch (config)# interface type 0/port_#
Router# debug ip eigrp
Switch (config-if)# switchport mode trunk|dynamic
desirable| dynamic auto|nonegotiate
Router(config)# access-list 1-99|1300-1999 permit|deny
source_IP_address
Switch (config-if)# switchport trunk native vlan VLAN_#
[wildcard_mask] [log]
Switch # vlan database
Switch (vlan)# vlan VLAN_# [name VLAN_name]
Router(config)# interface type [slot_#]port_#
Switch (config)# interface type 0/port_#
Router(config-if)# ip access-group ACL_# in|out
Switch (config-if)# switchport mode access
Switch (config-if)# switchport access vlan VLAN_#
Router(config)# access-list 100-199|2000-2699
10000000 11000000 11100000 11110000
permit|deny
128 192 224 240
IP_protocol
source_address source_wild$card_mask 11111000 11111100 11111110 11111111
[protocol_information] 248 252 254 255

Orlando Sousa e Nuno Pereira