Você está na página 1de 8

Centro Federal de Educação Tecnológica

Escola Técnica Federal do Rio Grande do Norte

Gerência Educacional e Tecnológica da Área de Informática


Disciplina: Linguagem de programação I - Bimestre I : Algoritmos

Exercício de Aprendizagem n 1

Objetivo: praticar os conceitos de criação de algoritmos com comandos básicos do tipo: atribuição,
declaração de variáveis e constantes e estruturas condicionais.

Escreva algoritmos:

1. Leia um número e exiba o seu sucessor.

2. Calcular a média final (CEFET/RN) dadas as notas dos 4 bimestres e produzir uma saída com a
média e a situação do aluno de acordo com o seguinte critério: média >=6, aprovado; média < 6,
reprovado.

3. Calcular a nota necessária para passar por média no 4º bimestre. Dados: notas dos 3 bimestres.

4. Calcular a quantidade de dinheiro gasta por um fumante. Dados: o número de anos que ele fuma, o nº
de cigarros fumados por dia e o preço de uma carteira.

5. Ler dois números inteiros, X e Y, e imprimir o quociente e o resto da divisão inteira entre eles.

6. Ler dois números inteiros, X e Y, e apresentar mensagem informado se o X é múltiplo de Y.

7. Fazer um algoritmo para ler dois valores reais do teclado, calcular e imprimir na tela:
a) A soma destes valores b) O produto deles c) O quociente entre eles.

8. Fazer um algoritmo para ler 03 números reais do teclado e verificar se o primeiro é maior que a soma
dos outros dois.

9. Ler um nome do teclado e verificar se é igual ao seu nome. Imprimir conforme o caso: " NOME
CORRETO " ou " NOME INCORRETO ".

10. Ler 02 números reais do teclado (A e B), verificar e imprimir qual deles é o maior, ou a mensagem
"A = B" caso sejam iguais.

11. Ler 02 números inteiros do teclado. Se o segundo for diferente de zero, calcular e imprimir o
quociente do primeiro pelo segundo. Caso contrário, imprimir a mensagem: "DIVISÃO POR
ZERO".

12. Ler três valores e determinar o maior dentre eles.

13. Ler três valores e colocá-los em ordem crescente.

14. Imprimir o menor inteiro positivo X cujo quadrado é superior a um valor L dado.

15. Ler os três coeficientes de uma equação de segundo grau e determinar suas raízes

16. Ler três valores do teclado e dizer se eles formam um triângulo. Caso afirmativo, dizer seu tipo
(equilátero, isósceles ou escaleno).

17. Ler 4 números inteiros e calcular a soma dos que forem par.
Questão 1
var
x,n:INTEIRO;
inicio
escreva ("digite um numero: ");
leia (x);
n<-x+1;
escreva ("o sucessor de ",x," é ",n);
fim;
Questão 2
Algortimo media
var
n,f:inteiro;
m:real;
inicio
escreva ("digite a primeira nota: ");
leia (n);
escreva ("digite a segunda nota: ");
leia (f);
m<-(n*2+f*3)/5;
se (m>=6) entao
escreva (m," Aprovado");
fimse;
se (6>m) e (m>=2) entao
escreva (m," Recuperação");
fimse;
se ( m < 2 ) entao
escreva (m," Reprovado");
fimse;
fim;
Questão 3
Algortimo mediatotal
var
N1,n2,n3,n4:inteiro;
Med1,medf1,medf2,medf3:real;
inicio
Escreva("digite a primeira nota: ");
Leia (n1);
Escreva("digite a segunda nota: ");
Leia(n2);
Escreva ("digite a terceira nota: ");
Leia (n3);
Escreva ("digite a quarta norta: ");
Leia(n4);
med1<-(n1*2+n2*3)/5;
medf1<-(n4*2+n2*3)/5;
medf2<-(n1*2+n2*3)/5;
medf3<-(med1+n4)/2;
se (medf1>=medf2) e (medf1>=medf3) entao;
escreva ("media final é ",medf1);
fimse;;
se (medf2>=medf1) e (medf2>=medf3) entao;
escreva ("media final é ",medf2);
fimse;
se (medf3>=medf1) e (medf3>=medf2) entao;
escreva ("media final é ",medf3);
fimse;
fim;
Questão 4
Algoritmo cigarro
var
ano,cig:inteiro;
pc,total:real;
inicio
escreva("digite o número de anos: ");
leia (ano);
escreva("digite o número de cigarros por dia: ");
leia(cig);
escreva("digite o preço da carteira: ");
leia(pc);
total<-(ano*365)*cig*(pc/20);
escreva ("o total gasto é",total);
fim;
Questão 5
Algoritmo Quorest
var
x,y:inteiro;
q,r:real;
inicio
escreva ("digite o primeiro número: ");
leia (x);
escreva ("digite o segundo número: ");
leia (y);
q<-x/y;
r<-x%y;
escreva ("o quociente e o resto da divisão dos numeros é: ",q," e ",r);
fim;
Questão 6
Algoritmo multiplos
var
X,y:inteiro;
inicio
escreva ("digite o primeiro numero: ");
leia (x);
escreva ("digite o segundo numero: ");
leia (y);
se (x%y=0) entao;
escreva (y," é multiplo de ",x);
fimse;
se(x%y<>0) então;
fim;
fimse;
fim;
Questão 7
var
x,y:inteiro;
s,p,q:real;
inicio
escreva ("digite o primeiro numero: ");
leia(x);
escreva ("digite o primeiro numero: ");
leia(y);
S<-x+y;
P<-x*y;
Q<-x/y;
escreva("soma dos numeros é: ",S,",o produto deles é: ",P,",o quociente entre os mesmo
é: ",Q);
fim;
Questão 8
Algoritmo soma
var
n1,n2,n3,soma:real;
inicio
escreva ("digite o primeiro numero");
leia (n1);
escreva ("digite o segundo numero");
leia (n2);
escreva ("digite o terceiro numero");
leia (n3);
soma<-n2+n3;
se n1>soma entao;
escreva (n1," é maior que a soma de ",n2," e ",n3);
senao;
escreva (n1," é menor que a soma de ",n2," e ",n3);
fimse;
fim;
Questão 9
Algortimo Paulo
var
nome,paulo:caracter;
inicio
escreva ("digite o meu nome: ");
leia (nome);
se (paulo=nome) entao;
escreva ("nome correto");
senao entao;
escreva ("nome incorreto");
fimse;
fim.
Questão 10
Algoritmo maior
Var
a,b:inteiro
inicio
escreva ("digite o primeiro numero: ");
leia (a);
escreva ("digite o segundo numero: ");
leia (b);
se a>b então;
escreva (a," é maior que ",b);
fimse;
se a<b então;
escreva (b,"é maio que ",a);
fimse;
se a=b então;
escreva (a,"=",b);
fimse;
fim.
Questão 11
Algoritmo div0
var
a,b:inteiro;
c:real;
inicio
escreva ("digite o primeiro numero: ");
leia (a);
escreva ("digite o segundo numero: ");
leia (b);
se (b=0) entao
escreva ("DIVISÃO POR ZERO");
fimse;
c<-a/b;
escreva ("quociente da divisão de ",a," por ",b," é ",c);
fim.
Questão 12
Algoritmo maiordentre
var
a,b,c:real;
inicio
escreva ("digite um numero: ");
leia (a);
escreva ("digite outro numero: ");
leia (b);
escreva("digite mais outro numero: ");
leia (c);
se (a<b) e (b>c) entao
escreva (b," é o maior dentro os três numeros");
fim.
Fimse;
se (a<c) e (c>b) então;
escreva (c," é o maior dentro os três numeros");
fim.
Fimse;
escreva (a," é o maior dentro os três numeros");
fim.
Questão 13
Questão 14
Questão 15
Questão 16
Algoritmo triangulo
var
a,b,c:real;
inicio
escreva ("digite o tamanho primeiro lado: ");
leia (a);
escreva ("digite o tamanho segundo lado: ");
leia (b);
escreva ("digite o tamanho terceiro lado: ");
leia (c);
se (a<b+c) e (b<a+c) e (c<a+b) então;
se (a=b) e (b=c) entao;
escreva ("triângulo equilatero");
senao;
se (a=b) ou (a=c) ou (c=b) então;
escreva ("triângulo isósceles");
senao entao;
escreva ("triângulo qualquer");
fimse;
fimse;
senao entao;
escreva ("não é triângulo");
fimse;
fim.
Questão17