Você está na página 1de 3

LOGICA DE PROGRAMACION

LOGICA DE PROGRAMACION
TALLER DE ALGORITMOS BASICOS
DOCENTE : FABIO FRANCO MARTINEZ
1. Escriba Un algoritmo que imprima el siguiente mensaje “Buenos Dias”.
2. Escriba un algoritmo que imprima el mensaje “Mi nombre es:” y el nombre
SUYO.
3. Escriba un algoritmo que imprima SU nombre, sexo, edad y estado civil.
4. Lea el nombre y la edad de una persona, e imprima tanto el nombre como la
edad.
5. Lea el nombre y la edad de una persona e imprima el nombre leido, solo si la
persona es mayor de edad.
6. Lea el nombre y la edad de una persona ; si es mayor de edad (>=18) imprima
su nombre y un mensaje “Puede Votar “, de lo contrario, imprima un mensaje
que diga: “no puede votar”.
7. Lea el nombre, la edad y el sexo (1=Femenino, 2=Masculino) de una persona e
imprima el nombre de la persona, sólo si esta es de sexo masculino y mayor de
edad ; de lo contrario imprima el nombre y edad de la persona.

Proceso Algoritmo_7

// ***********************************************************************
// Datos a Leer: Nombre de la persona, Edad y Sexo.
// ***********************************************************************
Definir nom como cadena;
definir Edad, Sexo como entero;
escribir ("NOMBRE:")
leer Nom;
escribir ("EDAD:");
leer Edad;
escribirr ("Seleccione: 1= Genero Femenino, 2= Género
Masculino:");
leer Sexo;
SI (Sexo = 2 and Edad >=18)
escribir ("NOMBRE LEIDO: ", Nom)
SINO
escribir ("NOMBRE LEIDO: " , Nom, "Edad en Años: " +
Edad)
FIN_SI

Fin_proceso

8. Lea el nombre, la edad, el sexo (1=Femenino, 2=Masculino) y el estado civil


(1=Soltero, 2=Casado, 3=Viudo, 4= Otro.) de una persona y si es una mujer

Fabiofrancomartinez.usb@gmail.com 1
LOGICA DE PROGRAMACION

menor de edad imprima el nombre y la edad de la persona leída, de lo contrario


indique que estado civil tiene esa persona (“Soltero”, “Casado”,etc)..
9. Lea el nombre, la edad, el sexo (1=Femenino, 2=Masculino) y el estado civil
(1=Soltero, 2=Casado, 3=Viudo,4= Otro) de cualquier persona. Si es una mujer
menor de edad o un hombre casado, imprima su nombre y un mensaje que diga
“Bienvenido al Tecnológico de Antioquía”. En los demás casos imprima solo el
nombre de la persona.

Proceso Algoritmo_10

// ***********************************************************************
// Datos a leer: Nombre de la persona, Edad, Sexo (1 o 2) y el
// Estado Civil (1-4)
// ***********************************************************************
definir Nom como Cadena;
definir Edad, Sexo, Estado como entero;
escribir "NOMBRE:";
leer NOm;
escribir "EDAD:";
leer Edad;
escribir "Seleccione: 1= Genero Femenino, 2= Género Masculino:";
leer Sexo;
escribir ("Estado Civil:1= Soltero, 2= Casado, 3= Viudo,
4=Otro)
Leer Estado;
SI (Sexo = 1 and Edad < 18) or (Sexo = 2 and Estado =2)
escribir ("Bienvenido al Tecnologico de Antioquia
SINO
escribir "NOMBRE LEIDO: " , Nom;
FIN_SI

Fin_proceso

10. Lea un número NRO e imprima el número y el resultado de restarle 2387.


11. Lea un número, calcule e imprima su raíz cuadrada. Si el número es negativo
imprima el número y un mensaje que diga: “tiene raíz imaginaria”.

Proceso Algoritmo_12

// *******************************
// Datos a Leer: Numero.
// *******************************
Definir Numero como entero;
escribir ("Numero:")
Fabiofrancomartinez.usb@gmail.com
leer Numero; 2
SI (Numero >=0)
escribir (“Raiz Cuadrada del Número leído: “, Numero, “ Es:
“ (Math.Sqrt(Numero));
LOGICA DE PROGRAMACION

12. Lea dos números A y B e imprima sólo los positivos.

13. Lea dos números A y B e imprima ambos números sólo si son positivos.

14. Lea dos números X y Y e imprima ambos números si por lo menos uno
de ellos es positivo.

15. Lea dos números NRO1 y NRO2 e imprima ambos números sólo si son
de diferente signo y distintos de cero .
16. Lea dos números NROUNO y NRODOS . Imprima ambos números y su
suma.
17. Lea dos números PRIMERO y SEGUNDO . Calcule la suma de los
números . Imprima los números leídos y si su suma es negativa, imprímala
también.

Fabiofrancomartinez.usb@gmail.com 3